Skip to main content

Questions tagged [thinpool]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
27 views

LVM LV path missing after wrong lvextend

I'm a bit lost after an error I made in the command lvextend. My setup: sda3 was only PV sdb added as empty disk have LV 'data' as LVM-Thin My VG is "pve" and my LV is "data" I ...
jellex's user avatar
  • 1
1 vote
1 answer
79 views

LVM Thin Pool on RAID10 + Metadata on RAID1

Given 2 SSDs and 4 HDDs with their corresponding PVs (/dev/ssd1, /dev/ssd2, /dev/hdd1 to /dev/hdd4). I know, identifiers are not correct, they are just for easier keeping track of what device I'm ...
Tux-Of-War's user avatar
1 vote
0 answers
426 views

How to repair lvm2 thin_pool?

Recently I had spun up a new vm that I was using as "tempstorage". Basically I set the size to 16tb which was the overall servers max space. I had 3 other vms up and running before this. ...
bogusT's user avatar
  • 11
3 votes
1 answer
858 views

how to snapshot thin provisioned lvm

I'm trying to create an snapshot from a thin provisioned lvm using the below command, but i get errors, is there anyone that can help me? root@ghv214:/dev/ghv214-vg# lvs LV VG Attr ...
amin hashemi's user avatar
1 vote
0 answers
974 views

LVM thin pool inactive and failed with: No data available

I am suffering in a problem due to a system crash, I am using LVM-THIN created in proxmox GUI, all lvs is inactive and the lvm seems broken and I saw it needs to fix manually in system log. After ...
StormYudi's user avatar
6 votes
1 answer
3k views

LVM type raid1 & thinpool is it possible?

We are moving an installation from mdadm raid with LVM on top to pure LVM, so we will add the original raid partitions as indendent partitions to the LVM group, something like: # lvcreate -L 240G -n ...
luison's user avatar
  • 241
1 vote
0 answers
514 views

Converting LV to thin pool: VG name mismatch

I'm trying to create a thin pool for docker as i'm changing the root location of docker and i had to delete previous thin pool. Info about situation: vgs VG #PV #LV #SN Attr VSize VFree cah ...
konpro11's user avatar
0 votes
0 answers
280 views

Shrink LVM2 Thin Volume

I would like to shrink the space required by a thin volume used as a disk for a virtual machine (Windows). Unfortunately, the underlying disk is a USB-attached SSD and therefore mounting the NTFS ...
LeoTietz's user avatar
3 votes
1 answer
3k views

Ubuntu/GlusterFS: Unable to create thinly provisioned volume from previously created pool using lvcreate

I'm testing out glusterfs, and was following this guide on creating setting up volumes. I ran into an error when trying to create a thinly provisioned volume. This is the section Create a thinly ...
Print-ABC's user avatar
2 votes
1 answer
8k views

LVM: How to recover LVM thin pool / volume after failed repair?

I would like some advise with recovering from broken LVM thin pool / volumes. The step that cause my broken LVM thin is as follows: My thin pool metadata was full (99.4%), so the pool freeze. I tried ...
Pongtawat's user avatar
3 votes
2 answers
4k views

Doubled hyphens in LVM /dev/mapper names

I created a thinpool LV using the following command: lvcreate --type thin-pool -l 100%VG -n lv-thinpool vg-test Now /dev/mapper has the following entries: vg--test-lv--thinpool vg--test-lv--...
Tom Hale's user avatar
  • 31k
3 votes
1 answer
1k views

How to perform fstrim on a loop device?

I have LVM with thin-provisioning enabled. I have two almost identical thin logical volumes with ext4 file systems that slightly differs. The first volume is used entirely for storing file system. On ...
ayvango's user avatar
  • 377
0 votes
1 answer
1k views

restore disk backup by writing only non-zero blocks

Assuming you have a disk backup in raw format sda.img and /dev/sda is initially filled with zeroes, how to skip zeroes while restoring the backup? An analog of dd should detect zero block in input ...
basin's user avatar
  • 2,061
1 vote
0 answers
2k views

Could not start docker with existing LVM thin pool option

I created an LVM thin pool to be used by Docker for storage. At the docker start time, I tell it to use the thin pool. Everything worked as expected by running docker info , I noted that it is using ...
Ijaz Ahmad's user avatar
  • 7,252