Skip to main content

Questions tagged [software-updates]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
44 views

version `XCRYPT_2.0' not found after Update Debian 10 to Debian 12

I was instructed to upgrade Debian 10 to Debian 12. After the upgrade, I noticed that the ssh.service was not working. Now I found out that no 'apt' commands work. I can't install anything. Here the ...
Szymon Tesmer's user avatar
-4 votes
0 answers
42 views

Error in software updates in Ubuntu 24.04 [duplicate]

After trying to change the mirror servers, when I want to exit this error is shown and prevents me from exiting: aslo there is a list of sources.list and aslso i use proxy update: i just try to ...
ali ataei's user avatar
2 votes
0 answers
22 views

add-app-repository fails due to connection problem (13: permission denied)

I am using the latest release version of Pop!_OS 22.04 LTS and tried to update my libre office to the latest version by adding the update information to the repository with "sudo add-apt-...
Axiom42's user avatar
  • 21
0 votes
0 answers
32 views

How to prevent the re-creation of default mkinitcpio preset file upon kernel update?

Since I’m using custom mkinitcpio presets to generate UKIs, I deleted the default preset file inside /etc/mkinitcpio.d/ that came during system installation. Unfortunately, when pacman updates the ...
Bogey Jammer's user avatar
0 votes
1 answer
22 views

Mismatched versions warning when updating Node.js/NPM in Docker

In our Dockerfile we have: FROM ghcr.io/puppeteer/puppeteer:latest AS pdf WORKDIR /puppeteer USER root # Prerequisites RUN apt-get update && apt-get install nginx -y # Update RUN npm update ...
Danny Beckett's user avatar
0 votes
0 answers
22 views

swupdate and target image size

I try to use swupdate to update my system. My swu file is pretty simple software = { ...
Alex Hoppus's user avatar
0 votes
0 answers
18 views

Should I run the KOreader AppImage as an executable or integrate it into my openSUSE Tumbleweed system?

I've downloaded the KOreader AppImage for my openSUSE Tumbleweed system, and I'm trying to decide whether I should run it directly as an executable or integrate it into my system by creating a desktop ...
Dr. P's user avatar
  • 21
0 votes
1 answer
28 views

Remaining Packages after a Failed System Update

Ubuntu Update Manager stalled on the upgrade of a package (surfshark VPN). After quite some time, I have killed the entire process and rebooted. I have removed surfshark from my system, but when ...
JF0001's user avatar
  • 101
0 votes
1 answer
181 views

NixOS rebuild fails because some directories according to NIX_PATH do not exist

When I try to rebuild NixOS, it fails because it can't find some directories according to NIX_PATH. This happens since I tried to switch to the channel nixos-unstable from 23.11 and accidentally added ...
matj1's user avatar
  • 41
7 votes
1 answer
802 views

Super-user privileges for Chromium browser

After apt-get install chromium and running it on Debian 12, ps alx | grep -e ^F -e ^5.*chromium returns: F UID PID PPID PRI NI VSZ RSS WCHAN STAT TTY TIME COMMAND 5 1000 ...
Juergen's user avatar
  • 722
-1 votes
2 answers
971 views

Ubuntu 18.04 ETS - Update Apache to 2.4.58

We are using a Ubuntu 18.04 server for a service which will be retired later this year, and will not function above this version. Whereas the ideal solution would be to upgrade the OS, due to resource ...
MOLEDesign's user avatar
-1 votes
1 answer
1k views

Error with sudo apt update. ign: 1 deb.debian.org

On my Debian Bookworm machine, packages using apt are not updated with errors Ign:1 deb.debian.org/debian bookworm Inrelease... Ign:2 security.debian.org/debian-security bookworm Inrelease... Ign:3 ...
Horiton 's user avatar
0 votes
0 answers
83 views

Linux Mint: Can I have timeshift take a snapshot automatically before updates are installed?

Because I'm paranoid, I'd like Timeshift to take a snapshot immediately before updates are automatically installed. Currently I have daily snapshots, and choose to install updates manually, but I'd ...
Das Louis's user avatar
0 votes
0 answers
75 views

The Ubuntu installation is faulty

I have installed the recommended two updates (Ubuntu) to 18.04 and since I can no longer open my writing files (LibreOffice). There is an error message BrokenCount>0 and that the package is ...
Barbara's user avatar
3 votes
2 answers
2k views

Cannot update system due to kde apps on arch

I am not able to update my system on arch. I am using Operating System: Arch Linux KDE Plasma Version: 5.27.7 KDE Frameworks Version: 5.109.0 Qt Version: 5.15.10 When I am running sudo pacman -Syu ...
FloHe's user avatar
  • 860
0 votes
1 answer
72 views

bash get output from command

I try to make a script for macOS that informs me about available software updates: result=$(softwareupdate -l) if [[ $(echo $result) = *"No new software available."* ]]; then say yes;fi But ...
Atalantia's user avatar
0 votes
1 answer
117 views

How to update programs compiled from source (from Github)?

I'm using Debian 12. I recently followed this guide (https://stopanddecrypt.medium.com/running-bitcoin-lightning-nodes-over-the-tor-network-2021-edition-489180297d5#13c5) to install some software, and ...
NVBK3's user avatar
  • 1
-1 votes
1 answer
732 views

Google Chrome got weird after last Debian 12 update

I installed Chrome on my new Lenovo Xiaoxin Pro laptop with Debian 12 KDE a month ago and all worked fine until recent update to 6.1.0-11 kernel. Browser window is now scaled up with very big top ...
Oleg Bolden's user avatar
1 vote
1 answer
129 views

Do .rpm files installed with rpm get update notices from dnf check-update?

This (longer set of instructions for ex: https://code.visualstudio.com/docs/setup/linux) shows how to get the repo installed and then goes on to dnf. This direct .rpm (https://code.visualstudio.com/...
iletras's user avatar
  • 442
0 votes
1 answer
545 views

Can't start up NetworkManager in Arch Linux: symbol loolkup error: /usr/lib/libcurl.so.4: undefined symbol: libssh2_session_set_read_timeout

Last thursday I updated my Arch Linux installtion and when I rebooted on Friday my system had multiple problems. I'm new to the Arch Linux (or Linux in general) community and don't know what things I ...
Peter's user avatar
  • 101
1 vote
1 answer
133 views

Updates on Manjaro Error message during update

I'm new to Manjaro, I have a little knowledge of Linux and I'm trying to learn more. However I had a notification from Package Manager informing me that updates were available. I then had a ...
Toby963's user avatar
  • 11
0 votes
2 answers
300 views

After a problematic software update OS boots only with SELinux disabled

I have Fedora 38. The last software update messed up my system. It became unbootable. The reason probably was in having duplicate packages. I managed to fix dnf check errors by dnf remove --duplicates ...
RCKT's user avatar
  • 11
0 votes
1 answer
2k views

Does 'apt update' also update nmap's scripts?

I'm building a Linux OVA on a VM to scan stuff with nmap. I'm using cron to keep my packages up to date: sudo apt-get update sudo apt-get upgrade sudo apt-get autoremove It's from my understanding ...
Asteck's user avatar
  • 5
0 votes
1 answer
401 views

Arch Linux can't detect drives after update without reboot

After I do updates with pacman -Syu, I always have this annoying problem that I can't connect any new USB devices (External hard drive, USB to serial etc.) to my computer until I reboot. The problem ...
anton-tchekov's user avatar
0 votes
1 answer
108 views

Zorin doesn't install Dell firmware update

Regularly, I'm notified by Zorin's Software app that a Dell firmware update is available. It's always v1.11.0 > v1.25.0. When clicking on “Install”, I'm asked to re-boot the system. After doing so, ...
Pixelcode's user avatar
  • 131
1 vote
1 answer
2k views

"Unable to lock database - Failed to synchronize databases"

I was trying to update the recommended stuff in my manjaro machine but this error occurred. I have no idea how to solve it. I was getting the error Invalid or corrupted databases so I updated the ...
Educpf's user avatar
  • 53
0 votes
1 answer
671 views

Google Chrome not updating in Deepin Linux after release update to 20.9

After release updating Deepin Linux to 20.9 and if you have previously installed Goggle Chrome you'll notice it can no longer be updated (specifically to version 112.xxx). Downloading and trying to ...
ChanganAuto's user avatar
1 vote
1 answer
885 views

RHEL - keeping a specific kernel version, possible?

I was looking to keep a specific kernel version on my machine. To prevent it from being overridden or removed without having to grow or up the # of kernels the system keeps as my only solution as ...
linuxscrub's user avatar
0 votes
1 answer
397 views

methodology [reposync?] for updating offline linux servers?

having servers that do not have an internet connection, what is the proper method for getting all necessary rpms so that a yum update does not fail because of dependency problems? Is there any other ...
ron's user avatar
  • 7,264
0 votes
1 answer
2k views

Updating PHP from 8.0.x to 8.0.28 using dnf

Will this update PHP 8.0.25 to PHP 8.0.28? dnf module reset php dnf module enable php:remi-8.0 dnf update php\*
anjanesh's user avatar
  • 103
22 votes
2 answers
26k views

Expanded Security Maintenance is not enabled on Ubuntu machine

Upon SSH'ing into my Ubuntu MATE 22.04 machine, I am greeted with: Expanded Security Maintenance for Applications is not enabled. in Welcome to Ubuntu 22.04.1 LTS (GNU/Linux 5.15.0-60-generic x86_64)...
Vlastimil Burián's user avatar
0 votes
0 answers
34 views

Errors in installation & Update [duplicate]

I have an installation of Kali VM on VirtualBox, I've always installed new programs without any problems, but I haven't been able for a few days. For example, here are the errors when I try to install ...
girvi_'s user avatar
  • 1
0 votes
0 answers
1k views

gnome-software: Could not activate remote peer

When I open gnome-software I get the following error: I've looked at the verbose output from the app, but understand nothing: $ echo '# kill existing processes'; killall gnome-software; echo '# done ...
azzid's user avatar
  • 1,000
0 votes
0 answers
885 views

Restore Void Linux Install after breaking it by updating after 18 months

I have an old Apple PowerBook on which I dual boot Void Linux and Mac OSX Leopard. I had some hardware problems around July 2021 and it took until now for me to get it fixed. When I got it working ...
Simon Baldwin's user avatar
1 vote
2 answers
173 views

How to do only low impact upgrades/fixes of packages on a Debian/apt based system? (on testing/unstable)

Initial question (please see new question below) EDIT: apparently, filtering on urgency would not be so efficient, so, please go below for amended question. This question is quite the same than this ...
Totor's user avatar
  • 20.3k
0 votes
1 answer
64 views

ChromeOS won't update

This is the error code: I'm not sure what it means or what to do. I'm on a ChromeOS laptop ---- START OF UPGRADE ---- + grep -q VERSION_CODENAME=stretch /etc/os-release + export DEBIAN_FRONTEND=...
Julia's user avatar
  • 1
0 votes
1 answer
821 views

How to prevent any kind of software from automatic check for updates?

I wanted to disable all automatic software updates so I went to gnome app Software > Update Preferences and Disabled the Automatic Updates toggle. However I still get update prompts for flatpaks. ...
rvy2649's user avatar
  • 11
1 vote
1 answer
140 views

Automated patching of packages on upstream updates

Is there a way to automatically merge custom patches to upstream packages when they update? From what I gathered so far modifying source code requires you to maintain a separate fork of packages that ...
Daniel Krajnik's user avatar
0 votes
1 answer
232 views

error during opensuse 15.4 KDE plasma update

Today, during the installation of opensuse 15.4 KDE plasma update,the following error has been reported: "the installed gio-branding-openSUSE-42.1-lp154.5.3.noarch requires 'libgio-2_0-0 = 2.70.4'...
Harlequin's user avatar
2 votes
1 answer
192 views

Fedora Server 36 - update process automatically closes user’s session

This latest Saturday and today, through VirtualBox for Fedora Server 36, as many times as I did do, was executed the sudo dnf update command, the password is written and Starts to load and show some ...
Manuel Jordan's user avatar
2 votes
1 answer
884 views

What is this update exactly designed for? (new BIOS?)

I own a rather older piece of server, Dell PowerEdge T20, with the latest BIOS version A20, link to Dell updates, screen of the update in case link goes dead in time: This morning, when SSH'd into ...
Vlastimil Burián's user avatar
0 votes
1 answer
212 views

Updating Xfce in Linux Mint beyond the standard version

I'm running Linux Mint 20 Xfce and would like to update Xfce to the latest version (beyond the version offered in the Mint repos). Is there a PPA or something for this, and is it likely to cause any ...
Sam's user avatar
  • 43
0 votes
0 answers
106 views

Is there a way to auto-update a live OS?

I'm currently using a Debian installation for a DIY router. In the interests of security, I'm wondering how I might switch to a non-persistent installation in order to defend against any persistence ...
Synthetic Ascension's user avatar
0 votes
1 answer
1k views

Why does Debian 11 apt suggest me to upgrade to the current kernel version?

I am quite new to Linux and Debian. I really like the fact that apt can be used to upgrade both software and system packages at the same time. Much better than Windows. However, I am baffled about one ...
Jupstejuho's user avatar
0 votes
2 answers
115 views

Why is Debian connecting to a CDN server in the background, automatically?

I noticed my VM with a fairly barebones Debian 11 install periodically tries to connect to debian.map.fastlydns.net on port 80. It looks like this domain is what the DNS record of http://deb.debian....
natevw's user avatar
  • 184
0 votes
1 answer
875 views

Can't install any package: "package linux-image-5.4.0-42-generic is missing final newline"?

I tried to install some package updates on my Ubuntu 20.04.5, but everything fails with: dpkg: unrecoverable fatal error, aborting: files list file for package 'linux-image-5.4.0-42-generic' is ...
Danijel's user avatar
  • 186
2 votes
1 answer
121 views

Embedded linux remote update

I build my own linux distribution using Yocto for Rpi CM4. I would like to have a possibility to update it remotely, without using Balena Etcher, just upload the built image and call some commands ...
JWZ1996's user avatar
  • 41
1 vote
0 answers
31 views

Looking for a protected update mechanism for software on a linux-based virtual machine

We use a Linux-based virtual machine with internally developed applications in a cross-organizational area with many different users. The applications and updates are not publicly available, but are ...
t7l's user avatar
  • 11
1 vote
1 answer
37 views

Do I have to lock dependencies when locking Thunar at current version?

For the purpose of this problem I have decided to lock Thunar to current version in Muon. My goal is that Thunar stays as it is and its configuration files that it owns in /usr/share/dbus-1/services/ ...
cipricus's user avatar
  • 1,629
1 vote
1 answer
568 views

Linux Mint 21 update procedures changed

Starting with Linux Mint 21 update procedures changed in a way below: Can anyone tell me how to set it up, so that it behaves normal, I mean avoid this Software application, forcing me to reboot and ...
Vlastimil Burián's user avatar

1
2 3 4 5 6