Skip to main content

Questions tagged [software-installation]

Installing software on a running system, either as binaries or from source. This is usually done using your system's package manager.

Filter by
Sorted by
Tagged with
1196 votes
9 answers
3.7m views

How to install a deb file, by dpkg -i or by apt?

I have a deb package for installation. Shall I install by dpkg -i my.deb, or by apt? Will both handle the software dependency problem well? If by apt, how can I install from the deb by apt?
Tim's user avatar
  • 103k
169 votes
4 answers
145k views

Where should a local user executable be placed (under $HOME)?

I have an executable for the perforce version control client (p4). I can't place it in /opt/local because I don't have root privileges. Is there a standard location where it needs to be placed under $...
user640378's user avatar
  • 1,983
152 votes
16 answers
59k views

Where should I put software I compile myself?

I need to compile some software on my Fedora machine. Where's the best place to put it so not to interfere with the packaged software?
theotherreceive's user avatar
127 votes
5 answers
226k views

Unable to locate package `docker-ce` on a 64bit ubuntu

I'm trying to install Docker on a Ubuntu 64 machine following the official installation guide. Sadly Ubuntu seems it is not able to locate the docker-ce package. Any idea to fix it or at least to ...
danidemi's user avatar
  • 1,553
125 votes
9 answers
303k views

How to install Python 3.6?

I'd like to install the latest Python, which is 3.6 at the time of this post. However, the repository is saying that Python 3.4.2 is the newest version. I've tried: $ sudo apt-get update $ sudo apt-...
davidtgq's user avatar
  • 1,504
123 votes
8 answers
313k views

How to install program locally without sudo privileges?

Assume I have ssh access to some Ubuntu server as user and I need some not system tools to be installed for convenience (mc, rtorrent, mcedit). I do not want to bother admins for these small programs. ...
yura's user avatar
  • 1,377
112 votes
9 answers
621k views

How to find the installation path for a software under linux?

Under linux, I launch a software by typing, e.g., fluidplot. How can I find the installation path for this software?
user5997's user avatar
  • 1,381
110 votes
5 answers
233k views

Can't Install build-essential on CentOS

When I run the command: sudo apt-get install build-essential I get the following error message: Reading Package Lists... Done Building Dependency Tree... Done E: Couldn't find package build-...
Waley Chen's user avatar
  • 1,253
110 votes
8 answers
279k views

Into which directory should I install programs in Linux?

I want to install a program in Linux and run it as a daemon. (Team Speak 3 in this case, but the question is general in nature). There is no package provided, only tarred binaries. Where in the ...
Eiver's user avatar
  • 1,255
109 votes
5 answers
238k views

Install PostgreSQL client (psql) only on CentOS

Simple question, but no resources found about this. Is there any way to install only a PostgreSQL client, the terminal-based one, psql, on a CentOS7 system, without installing the complete PostgreSQL ...
Aleksandar Stojadinovic's user avatar
105 votes
3 answers
177k views

How to install dig on CentOS?

I can't find the dig command on my new CentOS installation. I've tried dnf install dig but it say that it cannot find the package. How do I install dig on CentOS?
Mikael Dúi Bolinder's user avatar
97 votes
4 answers
21k views

Why use install rather than cp and mkdir?

I've seen in many places used install -d to create directories and install -c to copy a file. Why not use mkdir and cp? Is there an advantage in using install?
Neaţu Ovidiu Gabriel's user avatar
97 votes
4 answers
112k views

How do I install htop in mac OS X?

How do I install htop for macOS (OS X)? (The easiest and laziest path)
Ruvenss's user avatar
  • 1,071
88 votes
5 answers
104k views

No sha256sum in MacOS

I tried to use sha256sum in High Sierra; I attempted to install it with MacPorts, as: sudo port install sha256sum It did not work. What to do?
Rui F Ribeiro's user avatar
76 votes
6 answers
47k views

nvm command not available in bash script

I am trying to build a script in in which nvm and eventually node will get installed. I have installed nvm with cURL. I see the modifications in the .profile or .bashrc file (both work) and when ...
okidoki's user avatar
  • 763
67 votes
5 answers
75k views

What is the difference between building from source and using an install package?

I was wondering: when installing something, there's an easy way of double clicking an install executable file, and on the other hand, there is a way of building it from source. The latter one, ...
kwagjj's user avatar
  • 2,319
65 votes
7 answers
54k views

What is the Linux equivalent to C:\Program Files?

I understand that in Windows as well as Linux and Unix, a program|application|software can be installed in any directory. Also if packages are installed using the distribution's packaging system, it'...
Thomas's user avatar
  • 1,713
60 votes
4 answers
9k views

How do I know where to put things in linux?

Installing something in windows takes a click of a button. But every time I try to install something in linux, which is not found in APT, I get so confused. You download a zipped folder, then what? ...
Marcus Johansson's user avatar
56 votes
2 answers
177k views

Local installation of .rpms using YUM

I'm asking this question cautiously because I don't want to get this wrong. I have a program_name.rpm file saved locally on my server (CentOS 6.5). I have installed it previously just by navigating ...
TheLovelySausage's user avatar
55 votes
5 answers
105k views

How to compile and install programs from source

This is an issue that really limits my enjoyment of Linux. If the application isn't on a repository or if it doesn't have an installer script, then I really struggle where and how to install an ...
Nitrodist's user avatar
  • 735
49 votes
4 answers
39k views

How to prevent prompt that ask to restart services when installing libpq-dev

I want to install libpq-dev on my Vagrant machine. I install it with $ apt-get install -y libpq-dev During installation a prompt appears which asks if it's allowed to restart some services ...
OrangeTux's user avatar
  • 1,063
47 votes
3 answers
57k views

Install R in my own directory

How can I install a new version of R in my own directory, e.g., /local/data/project/behi.
user3925736's user avatar
46 votes
5 answers
49k views

openjdk-8-jre-headless : Depends: ca-certificates-java but it is not going to be installed

Can't install Java8 apt-get install openjdk-8-jre-headless Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean ...
Jason's user avatar
  • 1,744
46 votes
5 answers
139k views

uninstall Python installed by compiling source?

I installed Python 2.7.9 on Ubuntu 14.04 by compiling its source, by .configre, make, and make altinstall. make altinstall is because I don't want to overwrite the default Python 2.7.6. My self ...
Tim's user avatar
  • 103k
43 votes
7 answers
151k views

Couldn't find postgresql.conf & pg_hba.conf files in my postgresql installation

Following all the instructions from UNIXMEN, installed postgresql-9.4 in CentOS 6.4. Everything went well, started the service and could access pgsql screen. But when I try to configure the phpPgAdmin,...
GIRI's user avatar
  • 877
38 votes
3 answers
79k views

Installing a .deb package in home directory

Is it possible to install a .deb package completely under my home directory at debian?
free_easy's user avatar
  • 541
37 votes
5 answers
44k views

Is there any way to install Nano on CoreOS?

CoreOS does not include a package manager but my preferred text editor is nano, not vi or vim. Is there any way around this? gcc is not available so its not possible to compile from source: core@core-...
codecowboy's user avatar
  • 3,502
36 votes
10 answers
7k views

Why are programs not distributed in compiled format?

But they give instructions like cd downloaded_program ./configure make install This creates the ELF that is needed, and probably some .so files. Why not put those inside a zip file for download, ...
kitty's user avatar
  • 417
36 votes
5 answers
175k views

Install RPM file on Arch Linux?

I want to install sqldeveloper from Oracle on Arch Linux. The only Linux download option is RPM. I am not interested in using arch repositories to install sqldeveloper. I can only use what the vendor ...
Zombies's user avatar
  • 655
36 votes
4 answers
50k views

Should I put application into /usr/local or /usr/local/share?

What are the "standards" -- should I put application (not just binary, but entire distribution) to /usr/local or /usr/local/share. For example scala or weka -- it contains examples, binaries, ...
greenoldman's user avatar
  • 6,256
33 votes
5 answers
69k views

Using a file to install packages with apt-get

I find it very convenient to install packages on a new machine through package files like brewfiles, caskfiles, dockerfiles, package.json etc. Is there an alternative to this for apt-get since I ...
thibmaek's user avatar
  • 431
33 votes
5 answers
6k views

Keeping track of programs

When I install a simple program it often uses make && make install and doesn't often even have an uninstall target. If I wish to upgrade a program, is it standard protocol to assume it just ...
Will03uk's user avatar
  • 497
32 votes
3 answers
16k views

How is install different from cp? [duplicate]

How is install different from a simple copy, cp or dd? I just compiled a little utility and want to add it to /usr/sbin so it becomes available via my PATH variable. Why use one vs the other?
tarabyte's user avatar
  • 4,326
30 votes
6 answers
73k views

"showmount: command not found": how do I know what to install?

Sometimes you run a command and get a "command not found" error message. After that you try to install the package that contains that command (I think that's what happens anyway?) e.g. showmount: ...
a.smith's user avatar
  • 725
30 votes
4 answers
92k views

Arch Linux pacman error: failed retrieving file

I just installed Arch Linux today. I am trying to install elinks using pacman -S elinks And I get a long, long list of: error: failed retrieving file 'elinks-0.13-17-i686.pkg.tar.xz' from some....
The Ledge's user avatar
  • 533
30 votes
4 answers
24k views

How to make apt-get accept new config files in an unattended install of debian from Repo

I am writing a script for a unattended install of a package that is in our repo, it is a software package with one of Debian's marked config files. Is there any option that I can pass to apt-get/...
Raman's user avatar
  • 401
28 votes
4 answers
88k views

How to install VirtualBox Extension Pack to VirtualBox latest version on Linux?

How to install VirtualBox Extension Pack to VirtualBox latest version on Linux? I would also like to be able to verify extension pack has been successfully installed and and uninstall it, if I wish.
Vlastimil Burián's user avatar
28 votes
6 answers
60k views

How to install CUDA Toolkit 7/8/9 on Debian 8 (Jessie) or 9 (Stretch)?

How to install Cuda Toolkit 7.0 or 8 on Debian 8? I know that Debian 8 comes with the option to download and install CUDA Toolkit 6.0 using apt-get install nvidia-cuda-toolkit, but how do you do this ...
Greg's user avatar
  • 735
28 votes
3 answers
32k views

How can I install perldoc on Ubuntu?

Ubuntu 10.10 comes with Perl 5.10.1 pre-installed, but strangely enough perldoc isn't part of the package. $ perldoc You need to install the perl-doc package to use this program. How can I make this ...
Zaid's user avatar
  • 10.8k
26 votes
7 answers
5k views

Why no permissions like Android or iOS?

When I install a program like GIMP or LibreOffice on Linux I'm never asked about permissions. By installing a program on Ubuntu, am I explicitly giving that program full permission to read/write ...
stackinator's user avatar
25 votes
4 answers
55k views

'sudo' is not installed, I can't install it, and it asks if I am root

I just finished installing Debian 8 (Jessie) and tried to make a directory in lib/firmware, because there was a file missing (rtl8723befw.bin) in the installation, and it says mkdir: cannot create ...
M.O.'s user avatar
  • 535
25 votes
4 answers
5k views

Why updating a running Linux system is not problematic?

It's years I use Linux systems on a daily basis, and I never had major problems by updating a system when it was running, but I still wonder why this is possibile. Let me make an example. Suppose a ...
user avatar
24 votes
3 answers
72k views

How to install libtoolize as non-root user

I'm trying to install software and the autoreconf fails because libtoolize is not installed on my system. I don't have root access on this system, but I need to install libtoolize. How can I install ...
JB_User's user avatar
  • 363
24 votes
1 answer
39k views

Why did pip install a package into ~/.local/bin?

When I install this "Taurus Blazemeter 'bzt'" program with pip, it ends up being installed into ~/.local/bin folder. mkdir ~/bzt && cd ~/bzt sudo apt-get install python default-jre-...
djangofan's user avatar
  • 4,207
23 votes
5 answers
169k views

How to install tarball packages on a Debian based distribution?

I would like to know how to install .tar.bz and .tar.bz2 packages on Debian. Could anyone help me understand how to achieve that?
Zignd's user avatar
  • 3,123
23 votes
3 answers
178k views

E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution) libreoffice

Every time I try to upgrade it shows me this message sudo apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt --...
Carlos tmf's user avatar
23 votes
1 answer
61k views

How do I install non-free firmware in Debian 12 (Bookworm)?

How do I install non-free firmware using the advanced package tool (APT) in Debian 12 (bookworm)?
Константин Ван's user avatar
23 votes
3 answers
93k views

Difference between "make install" and "sudo make install"

Sometimes I encounter problems with using make install which gives me a permission denied error when writing to some folders. So instinctively I use sudo make install. Will this introduce additional ...
lokheart's user avatar
  • 463
22 votes
2 answers
20k views

Simulate the running of a "make install" -- a "dry run" or simulator utility?

Is there a generic way of running a bash script and seeing the commands that result, but not actually run the commands - i.e. a "dry run"/simulator of sorts? I have a database install script (...
Vérace's user avatar
  • 581
21 votes
5 answers
26k views

Using different versions of Python

Background: Since I develop python programs that must run on different python versions, I have installed different versions of python on my computer. I am using FC 13 so it came with python 2.6 pre-...
Alex's user avatar
  • 313

1
2 3 4 5
50