Skip to main content

Questions tagged [software-installation]

Installing software on a running system, either as binaries or from source. This is usually done using your system's package manager.

581 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
6 votes
2 answers
337 views

Installing programs on a removable drive

I am planning to install some software on removable media (which will presumably always be present in the computer, though it's possible that there could be occasions where it is absent). After doing ...
Jacob Bond's user avatar
5 votes
2 answers
5k views

GCP: Debian stuck at setting up dbus

I have been trying to install GUI, i.e. gnome and lxde, into Debian 9 stretch in google cloud computing instance. I have even increased the cpu, ram, harddisk size. However, the installation is always ...
Call Me Hi Hi's user avatar
5 votes
0 answers
9k views

How to install X window system for a minimal desktop?

On a server running CentOS 7, how to make a minimal install of the X window system? The idea is to build a very minimal desktop that the end-user will use with only one software for backups. No need ...
OuzoPower's user avatar
  • 241
4 votes
0 answers
1k views

Flatpak - Safely Relocate Sandboxed Home Directory

I would like to transparently provide a Flatpak app with a fully sandboxed ~/ directory located at an arbitrary location of my choosing. That is, I want to sandbox the entirety of ~/ such that ...
AnOccasionalCashew's user avatar
4 votes
1 answer
2k views

qmlscene could not find a Qt installation of

I'm running this in folder with main.qml qmlscene main.qml qmlscene: could not find a Qt installation of '' Then I checked qtchooser -list-versions 4 5 qt4-x86_64-linux-gnu qt4 qt5-x86_64-...
user304200's user avatar
4 votes
0 answers
1k views

How to setup networking for Linux Mint - VM when host machine uses a PAC file?

My host is a Windows 7 x64 machine. The office network uses a PAC file for the LAN settings. So, under Internet Options -> Connections -> LAN Settings, I have Use automatic configuration script with ...
Kanini's user avatar
  • 141
4 votes
2 answers
1k views

How to change the repository settings for yum installer?

I am pretty much new to Linux. I am trying to install tint2 on CentOS. When I try to install using the command yum install tint2, it gave following error checking for X11... configure: error: Package ...
ram's user avatar
  • 141
3 votes
0 answers
57 views

Manually installing most recent compilers locally on gentoo

I like to play with recent versions of compilers and tools, for example I like to compile the weekly gcc snapshot and test new c++ features or test the most recent CMake. I compile these and don't ...
Vicfred's user avatar
  • 284
3 votes
0 answers
4k views

Cannot increase maximum open files for redis

I am using ubunto 18.04, When i run redis-server on the terminal it says # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo # Redis version=4.0.9, bits=64, commit=00000000, modified=0, pid=11260, just ...
M. Habib's user avatar
  • 131
3 votes
0 answers
187 views

Is the directory /apps/ a legacy of anything?

Several times, I have seen in (quite) big projects, software installations made under /apps/ First I thought it was a fantasy, refusing FHS normalisation. https://en.wikipedia.org/wiki/...
Sandburg's user avatar
  • 357
3 votes
0 answers
2k views

Installing Mujoco from AI gym onto Windows 10(For research)

I've been trying to download and play with the Open gym software that past two days. Specifically the Mujoco which I'm planning to use for research. After some trials and tribulations actually ...
Mohammed Rashid's user avatar
3 votes
2 answers
3k views

How do I downgrade a whole group of packages with pacman?

I need an old version of qt5 for anki. (qt5-5.7) Therefore I would like to downgrade all qt5-packages (the whole group). Is there a way to do this with pacman?
linuscl's user avatar
  • 542
3 votes
0 answers
15k views

Installing libstdc++-devel on my CentOS server

rpm -qa | grep libstdc++ gives: libstdc++-4.8.3-9.el7.x86_64 However, find . -name "*libstdc++*" gives: ./usr/lib/gcc/x86_64-redhat-linux/4.8.2/32/libstdc++.a ./usr/lib/gcc/x86_64-redhat-linux/4.8....
Chani's user avatar
  • 418
3 votes
2 answers
2k views

Install userspace programs on server without root access

I would like to install some programs on my work development server because it is missing some programs I need for my day to day job. I don't have root access. What I did up to now is compiling the ...
Nicop's user avatar
  • 231
3 votes
2 answers
1k views

installing emacs with x-toolkit

I am installing Emacs 24.5.0, and I want to install it with X. I am on Fedora. the configuration script cannot find any x-toolkit. How do I find out which one is good for me, and in which folder do I ...
simona's user avatar
  • 1,011
3 votes
0 answers
1k views

getting access to the itunes store

I have minx 13 XFCE installed on both my laptop and my desktop. For purchasing music I had no problem in XP with running iTunes. In Mint however, this is more a challenge because there is no itunes ...
DutchArjo's user avatar
  • 747
3 votes
1 answer
7k views

Error building Oracle client 11g R2 on RHEL 5.5

We are trying to install oracle 11g R2 64 bit in Rhel 5.5 machine ( 64 bit ). Kernel version is 2.6.18-194.el5. We are getting the below error while installation. error in invoking target 'mkldflags ...
user44663's user avatar
3 votes
0 answers
947 views

Emacs on Minix 3?

Has anybody managed to install Emacs on Minix 3? Emacs was available on earlier versions of Minix. I am OK with an earlier version of Emacs if necessary. I don't find Zile, mg or Elle adequate and ...
haziz's user avatar
  • 2,241
3 votes
0 answers
342 views

AIX install Mercurial no root

Is is possible to install Mercurial on AIX system without root? I'm an ordinary user of our colleges IBM cluster and in there I fond no version control software. Could you show a brief guide of how ...
user6048's user avatar
  • 131
3 votes
1 answer
3k views

Hanging at "Running Transaction Test" when trying to install php-soap

I have here a CentOS 5 and I'm trying to run yum install php-soap but the installer hangs on and the last step is Running Transaction Test. I found out that NFS shares are the problem. See here or ...
testing's user avatar
  • 509
3 votes
0 answers
528 views

Uname gives unfamiliar timestamp for kernel

I'm recompiling a new kernel (adding some debugging info) on Ubuntu by doing the following: make vmlinux; make install; after this I do a reboot and select my new custom kernel from the list. ...
TotesLiotes's user avatar
3 votes
2 answers
5k views

How do I install some required libraries for a program without sudo?

I am trying to run a program on a computer running Red Hat 6.5. This results in the three following errors: "/lib64/libc.so.6: version `GLIBC_2.14' not found" "/usr/lib64/libstdc++.so.6: version `...
felix's user avatar
  • 31
2 votes
0 answers
80 views

Dyalog (APL) +RIDE issue

I am currently running a vanilla Arch machine and I wanted to try out APL. Dyalog only provides deb and rpm packages, but I saw a dyalog-bin pkgbuild in the AUR, and it seems to be pulling from the ...
homeCorn's user avatar
2 votes
0 answers
1k views

How to install QGIS on Ubuntu 22.04?

I am attempting to install QGIS on my Ubuntu 22.04. I am following these steps https://www.qgis.org/en/site/forusers/alldownloads.html#debian-ubuntu. Unfortunately I don't understand the following ...
pabstack's user avatar
2 votes
1 answer
1k views

Can't install git on Ubuntu 22.04 - unmet dependencies

I had git installed on my Ubuntu 22.04 LTS, but recently it became uninstalled somehow. git --version displays Command 'git' not found, but can be installed with: sudo apt install git. Trying to ...
Lizzy Thomas's user avatar
2 votes
1 answer
39 views

How to install Kubernetes on Ubuntu 2022LTS?

I installed docker engine using this page successfully. Now I want to add Kubernetes to it but I don't know how? In Docker-Desktop app that I was using on Windows it was as simple as check out an ...
best_of_man's user avatar
2 votes
0 answers
44 views

Installing a distro on an external hard drive without adding a bootloader to my internal drive

I want to install a distro on my external drive but do not want to add any bootloader to my internal drive. Is it possible to install it in such a way that when I plug in said external drive, it will ...
Sohrab Hamza's user avatar
2 votes
0 answers
229 views

How do I install multiple versions of a package on FreeBSD?

I currently have PostgreSQL 9.5 installed on my FreeBSD 11.4 box. I'd like to upgrade to PostgreSQL 13, and this will require a database migration. All the migration procedures I can find want to have ...
Darwin von Corax's user avatar
2 votes
0 answers
8k views

How to install webkitgtk and all its dependencies?

I wanted to install https://packages.debian.org/buster/libwebkit2gtk-4.0-dev however dependencies in the system are of lower version,hence it is not allowing me to upgrade. Is there any way to ...
ra10's user avatar
  • 21
2 votes
0 answers
348 views

I'm trying to install docker and its hangs at Setting up docker-ce (5:19.03.12~3-0~ubuntu-xenial)

I'm using this tutorial: How To Install and Use Docker on Ubuntu 16.04 | DigitalOcean to install docker, while providing sudo apt-get install -y docker-ce command, it starts downloading unpacking ...
Aditya Malviya's user avatar
2 votes
0 answers
920 views

How to install package without root?

I have no root access on a ubuntu server. I would like to install mergerfs but I can not find anyway of doing this. I have permission to install this software but the system administrator can not ...
Callum's user avatar
  • 29
2 votes
1 answer
4k views

Installing ukuu on Ubuntu 18.04

Can you help me? I'm trying to install ukuu to upgrade my kernel. I'm using this tutorial: sudo apt-add-repository -y ppa:teejee2008/ppa sudo apt-get update sudo apt-get install ukuu I'm following ...
korn's user avatar
  • 21
2 votes
0 answers
185 views

How to Install Linux OS on USB Drive and Run it On Any PC

I would like to full install Linux on USB and use it in any computer. I tried to install it from a live USB installation using gparted first to clear the partittions. After that I created an ext4 ...
Pedro R.'s user avatar
2 votes
1 answer
1k views

Command 'electrum' not found

I just installed (using sudo -H) electrum 3.3.8 on 18.04 LTS ubuntu and it looks like everything works: the results of python3 -m pip install --user Electrum-3.3.8.tar.gz[fast] are: Successfully ...
user avatar
2 votes
2 answers
3k views

Installing a .deb package locally

On a Debian system how can I extract and install a .deb package located in one folder and its dependencies located in a "pool" of other folders, using apt, dpkg and Synaptic respectively? Edit: I ...
user avatar
2 votes
0 answers
5k views

E: Unable to locate package oracle-java8-installer

I've been using the below Dockerfile to install java8. However, all of a sudden while creating the docker image it breaks with error E: Unable to locate package oracle-java8-installer E: Unable to ...
Omnipresent's user avatar
2 votes
1 answer
1k views

Incorrect virtualbox (kernel) installed for Manjaro/Arch/pacman

I did a bad virtualbox installation on 4.19.2-1-MANJARO with pacman. This is my initial install stdout: [gloom@tacos-pc etc]$ sudo pacman -S virtualbox error: could not register 'multilib' ...
gloomy.penguin's user avatar
2 votes
0 answers
301 views

Unable to find relevant linux headers

I am going through the steps to be able to use my Wacom tablet (CTL-6100WL) and I am to the point where I am installing the linux headers however this happens. (xenial)grace@localhost:~$ uname -r 3....
Grace's user avatar
  • 21
2 votes
0 answers
1k views

How to play streaming video from sites like HBO that require a Windows environment?

This query is actually a double duplicate. I initially queried several months ago, and I'm repeating this updated query in the hopes that things have changed. I recently posted a related query that ...
user2661923's user avatar
2 votes
1 answer
2k views

libreadline dependency related Error while installing an app, “seedsync”

I was trying to install Seedsync. I followed the instructions on their github Download the deb package from the latest release Install the deb package: sudo dpkg -i <deb file> ...
user3604365's user avatar
2 votes
0 answers
2k views

libstdc++.so.6: cannot open shared object file: No such file or directory

I'm trying to install this library for Ruby so I can work with FITS files, but during brew install sfitsio I encounter this error: Last 15 lines from /home/dachsroot/.cache/Homebrew/Logs/sllib/02....
OiciTrap's user avatar
  • 221
2 votes
0 answers
1k views

How can I install rexecd on Ubuntu

I tried to install rexecd executing this codes: apt-get install xinetd apt-get install rsh-server But, following the steps found on a web page, I try access to /etc/xinetd.d/rsh, /etc/xinetd.d/...
Iratzar Carrasson Bores's user avatar
2 votes
0 answers
621 views

Error (qt5-qtwebkit) trying to install notepadqq on Redhat 7.4

I am trying to install notepadqq on Redhat 7.4. To do this I run sudo yum install notepadqq However, I get the following errors, Error: Package: notepadqq-0.46.1-0.el7.centos.x86_64 (FedoraPeople-...
Austin Downey's user avatar
2 votes
0 answers
361 views

error installing oracle 11g on Ubuntu 17.04 Mate

I am trying to install Oracle 11g on my Ubuntu Mate 17.04 machine. In one of the installation steps, I am required to key in the proxy details/credentials. In our college, there is a wifi as well as ...
Upendra01's user avatar
  • 547
2 votes
0 answers
487 views

Locally built zsh can't find its own function files

Okay, so the Linux server I use at work doesn't have Zsh installed on it and I don't have root access, so I manually built and installed zsh to "$HOME/usr" (I've done this with other programs such as ...
Alexej Magura's user avatar
2 votes
0 answers
3k views

R configure file error: C compiler cannot create executables

I am trying to install R 3.3.1 on AIX 6.1 server. I am getting below error. checking whether the C compiler works... no configure: error: in `/opt/R-3.3.1': configure: error: C compiler cannot ...
rahul's user avatar
  • 21
2 votes
2 answers
3k views

missing zlib when configuring dropbear

when I ran ./configure in dropbear, it says missing zlib; however, I've already added the prefix, i.e., --prefix, to point to the correct directory for zlib, but the problem still persists. I'm ...
rainfrost's user avatar
  • 387
2 votes
0 answers
7k views

How do I successfully install GLFW on Linux Mint?

I believe I am in dependency hell. I am trying to get GLFW working. I'm on Linux Mint with Cinnamon. When I try to compile GLFW using these steps, I get the following output: $ cmake -G "Unix ...
Sunjay Varma's user avatar
2 votes
0 answers
1k views

How to install rJava Package in Linux Mint

I already have installed R, and Java in Linux Mint, to install rJava I used this command, in Rstudio- install.packages("rJava") it starts installing, but eventually it returns some errors and ...
Dwarakanath Thoppe's user avatar
2 votes
2 answers
2k views

Installing TOR on ec2 instance

As part of a research I am doing I am trying to install TOR package on a Amazon ec2 server. I have added the repo name to my repos configuration (following this tutorial: https://www.torproject.org/...
Bubble Hacker's user avatar

1
2 3 4 5
12