All Questions

Filter by
Sorted by
Tagged with
3
votes
2answers
88 views

How to install gcov-tool to RHEL?

I thought that gcov-tool is part of gcc standard package, which is true for Ubuntu. But unfortunately it's not true for RHEL. I didn't succeed to find RHEL package name to install gcov-tool. Does ...
2
votes
1answer
41 views

Transfer RPMs file with Ansible and localinstall them

I am having the following yaml ansible-playbook and want to transfer the rpms and then localinstall them on the remote machine. Until the transfer file step its working fine however on the ...
1
vote
0answers
31 views

RHEL-7.4 Linux rpm file Installation error

I tried to install rpm file in RHEL-7.4 Linux using: # rpm -i xxx.rpm /var/tmp/rpm-tmp.5WIuFR: line 9: /etc/init.d/xxx-driver: Permission denied What is this error and how to resolve it?
0
votes
0answers
41 views

Install rt-test(cyclictest) and meet some problems?

I want to measure the real-time performance of a old customized RedHat Linux (RTOS) with the rt-test tool suite, and the RT RedHat Linux is not registered with RHN, so I can not install the rt-test ...
-1
votes
1answer
106 views

Problems While Installing Git in RHEL 7.6

I am trying to install git and I get the following error though I have a valid subscription of the RHEL Client 7.6. No package git available. Error: Nothing to do I ran the following commands: [...
0
votes
1answer
2k views

How to downgrade glibc-common from 2.17-260.el7 to 2.17-222.el7

I am trying to install gcc on my RHEL 7.6 Beta workstation. At the moment, I am doing it using the command yum install gcc, but I keep receiving this error: --> Finished Dependency Resolution ...
-3
votes
1answer
343 views

How to install OS packages using yum?

I need to install below packages: gcc: gcc-c++-4.4.7-3.el6.x86_64 Flex: flex-2.5.35-8.el6.x86_64 Bison: bison-2.4.1-5.el6.x86_64 Glib: glib2-devel-2.22.5-7.el6.x86_64 & glibc-devel-2.12-1....
1
vote
2answers
340 views

Red Hat Enterprise Linux 6.9 - Cannot Find or Install RPM Python Bindings?

I am running Red Hat Enterprise Linux 6.9, and I cannot find the RPM Python bindings? I am trying to install rpm-py-installer-0.7.0 and it throws an error: RPM Python binding on system Python should ...
2
votes
2answers
2k views

How do I Install screen on RHEL 7.2

I'm having trouble trying to install screen on Red Hat Enterprise Linux Client release 7.2. I have tried: sudo yum install screen Also... sudo yum install screen.x86_64 Running... sudo yum list ...
1
vote
1answer
901 views

Red Hat 6.9 Desktop yum groupinstall Developer Tools not found? [closed]

I searched everywhere on the web for a few days, and I am still stuck... I am running Red Hat Enterprise Linux Desktop 6.9 in a virtual machine. I am using an older version because I am experimenting ...
0
votes
0answers
66 views

Cannot install GCC ld error not using custom prefix when loading lto-wrapper

I am trying to install GCC 4.9.4 in a non-standard location on Red Hat Linux using the documentation provided. https://gcc.gnu.org/install/ I do not have sudo, but I have write access to the folder /...
0
votes
1answer
154 views

install hadoop_2_6_1_0_129-hdfs

tried to install Hadoop cluster App Timeline Server Install returned error: 2018-02-26 19:31:49,406 - Installing package hadoop_2_6_1_0_129-hdfs ('/usr/bin/yum -d 0 -e 0 -y install ...
0
votes
1answer
2k views

unable to install collectd on Rhel 7

Requirement to install collectd to monitor resources. Steps done do far: yum install epel-release # this failed as pubilc key is not installed yum install --nogpgcheck epel-release # failed ...
0
votes
2answers
757 views

I receive error while installing php 7 on redhat 7

I'm trying to install php 7 with below script: yum -y install php php-mysql php-pecl-zip php-xml php-mbstring php-gd but I receive below error: Error: Package: php-7.0.26-1.el7.remi.x86_64 (remi-...
1
vote
0answers
257 views

Can not install Oracle database in Linux 7

I am trying to install Oracle database to Linux machine.I am getting error down below Could not execute auto check for display colors using command /usr/bin/xdpyinfo. Check if the DISPLAY variable is ...
2
votes
0answers
444 views

Error (qt5-qtwebkit) trying to install notepadqq on Redhat 7.4

I am trying to install notepadqq on Redhat 7.4. To do this I run sudo yum install notepadqq However, I get the following errors, Error: Package: notepadqq-0.46.1-0.el7.centos.x86_64 (FedoraPeople-...
0
votes
1answer
635 views

Stata 14 fails to start on RHEL 7.x, with “libpng12.so.0” error. How do I install libpng12?

The proprietary software Stata version 14 breaks on RHEL 7.3. Stata says: stata-se: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory So ...
4
votes
5answers
17k views

In Red Hat, how do I system install python 3.6.1 when 2.7.5 is already installed?

I have rebuilt the VM; it is an out of the box install. I just need 3.6.1 installed and available for all users without 2.7.5 interfering with it. If it's easier / possible to uninstall 2.7.5, then I'...
0
votes
1answer
69 views

Issues with installing a library

So I'm trying to download vips, and unpacked the tar.gz. I then did ./configure and make && sudo make install, and it ended with this output: libtool: link: gcc -std=gnu99 -g -O2 -o .libs/...
1
vote
1answer
303 views

Mirrors failing for RHEL 7 yum install

I have a RHEL 7 that has connectivity to the internet and no proxy in between. I can ping 8.8.8.8 I am trying to install grafana (an application for dashboards) based on official docs: http://docs....
2
votes
1answer
4k views

Install KSH on RHEL 6.5

I've been handed a RHEL 6.5 server that needs KSH installing on. That admin is not in work at the moment and we don't have a RHN subscription to download and install packages so I guess that I need ...
0
votes
2answers
244 views

How to locate installed software command in Red Hat Linux 5?

I just installed nmap. I downloaded it; saved it to my desktop; and just double clicked the rpm package. The installation was successful. Now, when I tried in bash to run nmap it did not recognise the ...
0
votes
2answers
2k views

How to install multiple versions of php on redhat

We have a legacy web application running php 5.4.10 and another application running the latest version of php ver 7.1 We would like to host both of these applications using apache on one instance of ...
1
vote
0answers
135 views

ltconfig not found

I am using RHEL 7.3 workstation version. I am trying to install Xbae -4.8.4 and I am using the script supplied by the developer to install it. However, when I try to install it, I get the following ...
2
votes
1answer
9k views

Installing nginx on redhat - error missing libpcre.so.0

I'm tring to install nginx-1.10.3-1.el6.ngx.x86_64 on redhat7 64 bit. When I run sudo rpm -Uvh http://nginx.org/packages/rhel/6/x86_64/RPMS/nginx-1.10.3-1.el6.ngx.x86_64.rpm I get this error: Error:...
0
votes
1answer
273 views

Linux + how to pick the relevant VMware tools RPM in order to install vmware tools

we have redhat version - 6 ( VM machine ) that run under VM vsphere client 5.5.0 we want to install the VM ware tools on the linux machine from this site ( vmware site ) we see many RPM that ...
3
votes
1answer
360 views

BCP neither gives results nor outputs anything when using valid statements but it does throw errors when passing invalid parameters

I have to use bcp command-line tool to export data from an SQL Server database to a file in a Red Hat server. I am (apparently) using valid statements but bcp is not producing any kind of output/...
4
votes
1answer
5k views

MySQL installed but no mysql command found

I'm trying to install MySQL 5.1.69 server community onto a RHEL 6 system (although it's outdated; I want to replicate an issue reported on this version). I installed a MySQL 5.1 PRM, downloaded from ...
2
votes
2answers
5k views

How to install specific mysql 5.6.21 version on redhat?

My requirement is Mysql 5.6.21. I tried to install Mysql but it installed 5.6.31 version. I tried following steps: $ yum repolist all | grep mysql It gives following output: mysql55-community/...
0
votes
1answer
134 views

Bash script as bin file installer

I have a package that comes in 2 parts - a bin file and digital certificate. This is to be distributed out to Linux sysadmins to install on RHEL systems in the enterprise. The bin file has various ...
2
votes
1answer
21k views

Install GCC 4.8+ on rhel x86_64 workstation 6

I want to install gcc 4.8+, preferrably 4.9 on my Red Hat Enterprise Linux Workstation release 6.7 (santiago) I have a subscription to rhn-classic. I tried installing devtoolset as given in https://...
1
vote
1answer
596 views

How do you install Ack-Grep on Red Hat Linux 6.5?

I'm not sure how to install ack-grep for redhat linux 6.5. Google only returned results on how to install it for mainly centos and ubuntu only. But what about Redhat? Why isn't there that many users ...
-1
votes
4answers
4k views

Unable to install mod_pagespeed on Apache 2.4

I have installed Apache 2.4 on the Red Hat Enterprise Linux Server release 6.7 (Santiago) by following these steps Step1 cd /etc/yum.repos.d/ wget http://repos.fedorapeople.org/repos/jkaluza/httpd24/...
0
votes
1answer
4k views

How to upgrade Vim 7.2 to 7.4 latest on Red Hat 6.6 the easiest way? [duplicate]

I'm a Vim user, and usually I just install vim via a one liner "apt-get install vim", but for red hat how can I update the 7.2 version to 7.4 with a one liner? I googled it and many places tell me to ...
26
votes
2answers
67k views

Couldn't find postgresql.conf & pg_hba.conf files in my postgresql installation

Following all the instructions from UNIXMEN, installed postgresql-9.4 in CentOS 6.4. Everything went well, started the service and could access pgsql screen. But when I try to configure the phpPgAdmin,...
0
votes
3answers
4k views

Red Hat no package realmd available

I would like to use AD authentication with a RHEL server using realmd and SSSD. I tried installing realmd using yum install realmd but I get the following message: Loaded plugins: product-id, refresh-...
0
votes
1answer
62 views

How to Install “remotely” Binary source from another path location

Suppose this I have a Bynary_Package.tar.gz When i unzipped this: zxvf Bynary_Package.tar.gz -C /path/dir/ Now, I move to cd /path/dir/Bynary_Package/ when I list this with ls -Al I have the ...
3
votes
1answer
2k views

Considering Group and User to Install Apache httpd with different Directory - CentOS 6.6

I removed user and group related to apache, (preinstalled with apache from RPM). I'm in the process of installing Apache HTTPD from binary source "tar.gz" Download httpd-2.4.12.tar.gz Extrat tar ...
-1
votes
1answer
4k views

Error: xz compression not available

I'm running redhat enterprise v6.6 64bit and am tyring to install 32bit Skype. In the process of trying to fix the dependency issue I managed to create another issue for myself. When I try and ...
1
vote
1answer
130 views

Package file without .rpm or .tar.gz… What to do?

I'm busy installing ELK package on a few RHEL6 servers, but we have two mail servers which are still RHEL5 i386 servers. So I go to https://www.elastic.co/downloads/logstash and downloaded the Linux ...
0
votes
0answers
718 views

Is there a method of installing debuginfo package without registering RHEL7?

My RHEL7 isn't registered just for test. Now I want to install python-debuginfo rpm package. But according to this, it seems that I can't install python-debuginfo rpm without registration. Is there a ...
2
votes
2answers
1k views

How do I install some required libraries for a program without sudo?

I am trying to run a program on a computer running Red Hat 6.5. This results in the three following errors: "/lib64/libc.so.6: version `GLIBC_2.14' not found" "/usr/lib64/libstdc++.so.6: version `...
1
vote
2answers
3k views

Installing MySQL on CentOS throws error that cannot find mysqld.sock

I have yum install mysql in CentOS 6.4. Now, when I use mysql command, it throws the following error: ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld....
0
votes
4answers
513 views

Cannot use “firefox” command to run latest firefox

I have download firefox version 34 from Mozilla website. Next, I extracted the tar archive, and moved it to the Desktop. Now, when I run the following command: Desktop/firefox/firefox the version ...
1
vote
0answers
99 views

unable to update HTTPD, mod_jk dependency error

While trying to update httpd in RHEL6, getting some dependency error as below: Unsatisfied dependencies for mod_jk-ap20-1.2.31-1.x86_64: httpd = 2.2.3 is needed by mod_jk-ap20-1.2.31-1.x86_64 I am ...
0
votes
1answer
1k views

Permission denied tmp dir on STIG RHEL

I am writing a program for a DISA STIG version of Red Hat Linux 6.5. I wrote a shell script to do self extracting on the program and when it self extracts put temporary files in the tmp directory that ...
1
vote
2answers
8k views

Install rcp on RHEL

I have a Linux Red Hat machine version 6.4 (64-bit). I notice that the rcp command does not exist on my machine (no rcp binary). I also searched in Google in order to find an rcp binary that will fit ...
2
votes
1answer
3k views

Trouble installing lxml with custom install location for libxml2/libxslt

I am attempting to install a python module called lxml to my account on a supercomputer running RHEL. I do NOT have root access or super user status. lxml requires the dev/devel versions of libxml2 ...
0
votes
2answers
248 views

installing own Git Server, push code after granted permission

I'm trying to install a Git Server in a RedHat 6.5 box I'm folowing this tutorials : 1,2,3, and to be honest the more I read the more things get obscure. If I'm to create a git user wich will be ...
0
votes
1answer
4k views

yum install PHP Error Summary

so I'm following this tutorial to install php5 in a red hat 6.5 box and I have only type one command and is this one below, I just wantend to install the php-gd module.(testing..) when I try this: ...