Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [rails]

The tag has no usage guidance.

0
votes
2answers
48 views

Ubuntu could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)

I'm trying to create a new user form my rails application. I already ran psql -p 5432 -h localhsot -U postgres and created a new user. Then I added the user with sudo adduser user_name and afterwards ...
2
votes
1answer
116 views

TMUX + Rails = stty: 'standard input': unable to perform all requested operations

I have a fairly large Rails project that always returns the following after every command in the Rails console: stty: 'standard input': unable to perform all requested operations This only happens ...
-1
votes
1answer
73 views

Ruby on Rails Routing Error [closed]

I am running ruby on rails on an Ubuntu Droplet and I am encountering the following error when I navigate to my domain name: Routing Error uninitialized constant HomeController Rails.root: /home/...
1
vote
1answer
83 views

`su -c` as another user doesn't work in a Rails repository

In a bash script that has plenty of commands run as another user, I've found a class of commands that don't seem to work. In a Rails repository as root: > su -c 'whoami' at at > su -c 'rake ...
1
vote
0answers
229 views

Can't install ruby on rails MacOSX

While trying to install ruby on rails with sudo gem install rails I get the following error Building native extensions. This could take a while... ERROR: Error installing rails: ERROR: Failed ...
3
votes
1answer
2k views

nginx errors with failed (13: permission denied) for socket despite socket permissions being set to 777

I've set permissions on the socket to 777 yet Nginx keeps stating that it's being denied permission to access, and yes I've restarted the server. Nginx is being started as root (not the best way but ...
0
votes
1answer
286 views

How do I get sudo to read my ~/.gemrc file?

I'm using Debian Linux, Ruby on Rails 5 on Apache with Passenger. I crated the file ~/.gemrc gem: --no-rdoc --no-ri However, I'm running the command sudo bundle install and it doesn't seem to be ...
0
votes
2answers
723 views

Error installing Ruby on Rails (Arch Linux)

I'm currently having an issue when trying to install Ruby on Rails on my Arch Linux ARM system. But it's also not just rails that won't install, it's anything I try to install using gem. Here is some ...
2
votes
0answers
134 views

How do I ungrey the “Gemfile” file so that I can open it in Atom?

I am trying to follow the Project Odin plan to install all necessary things in order to learn how to code. Idin Project has sent me to: http://installfest.railsbridge.org/installfest/...
1
vote
2answers
2k views

unable to access my rails using Public IP of my Ubuntu server in a browser

I have a Ubuntu 16.04.1 LTS (GNU/Linux 4.4.0-63-generic x86_64) server and my public IP is something like 183.xx.xxx.xx (curl -4 icanhazip.com).I have started my rails app using the command: rails s -...
0
votes
0answers
94 views

mysql.so: undefined symbol: vio_blocking

I'm trying to set up a Rails 2.2.2 installation (for an old app that I maintain) in a new Linux Mint 18 install. I've installed mysql (5.7.16-0ubuntu0.16.04.1 (Ubuntu)) and, using RVM, have installed ...
2
votes
0answers
469 views

x64_mingw not a valid platform - Rails 5

Bluehost Shared Server ruby -v 2.2.2 rails -v 5.0.0.1 gem -v 2.4.5 ~/.bashrc export HPATH=$HOME export GEM_HOME=$HPATH/ruby/gems export GEM_PATH=$GEM_HOME:/lib64/ruby/gems/1.9.3 export GEM_CACHE=$...
0
votes
2answers
3k views

Error installing nokogiri: ERROR: Failed to build gem native extensions

I can build my rails application on my mac On my Ubuntu machine when I bundle I get errors with a bunch of gems including nokogiri, version 1.6.7.2 Error installing nokogiri: ERROR: Failed to build ...
0
votes
0answers
498 views

Symbolic link not allowed apache 2.4 chiliproject

Few hours ago I upgraded ubuntu 13.10 to 14.04 LTS. I have 1 problem with chiliproject application wich running on Rails. I got error 403 when I'm trying to access my chiliproject application. In ...