Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [qtcreator]

The tag has no usage guidance.

1
vote
2answers
425 views

Is $PATH environment variable of a desktop environment different from that in a shell?

I am trying to find the .desktop file for qtcreator, so I write this: $ for p in ${XDG_DATA_DIRS//:/ }; do grep -rni 'qtcreator' $p; done And here is the most relevant lines: /usr/share/app-...
0
votes
1answer
1k views

upgrade qt 5.6 to 5.9 in centos 7

CentOS 7 ships with Qt 5.6, is there a way of upgrading to Qt 5.9?. current version. QMake version 3.0 Using Qt version 5.6.2 in /usr/lib64 I dont want to install Qt from qt.io, as I am not going ...
0
votes
1answer
470 views

Why can I run this locally and not over X?

I am trying to run qtcreator. It powers up fine on the local (Ubuntu 16.4) box, but when I try to run it over X to a Mac I get this: (qtcreator:3893): GConf-WARNING **: Client failed to connect to ...
0
votes
2answers
1k views

Qt installed in two places; wrong one takes precedence

My system is running Ubuntu 16.04 LTS. I seem to have installed Qt in two places. 4.8.7 is installed in /usr and 5.5.1 is installed in my home directory for reasons which probably seemed sensible at ...
0
votes
1answer
758 views

Using QtCreator with konsole instead of xterm

I tried to use KDE's Konsole to start console applications from QtCreator. The application works as intended, but any new instance of Konsole started during or after the execution just shows this: ...
1
vote
0answers
451 views

Qt Creator not launching in OpenSUSE

After a few years using Ubuntu, I decided to go back to OpenSUSE. I installed Qt Creator using the online installer from Qt, along with all the framework versions I wanted. Qt Creator refuses to ...
2
votes
0answers
813 views

Installing Qt Creator on Debian

I'm following this guide http://exploringbeaglebone.com/chapter11/ and I am stuck at part Click on the “Qt Versions” tab and click on “Add…” and browse to /usr/bin/ where you should see the ...
0
votes
1answer
2k views

Qt Creator crashes on startup, but it worked before

I installed the latest Qt version (5.5.1), and Qt creator worked fine, I could build programs with it. However, after I installed cmake, downloaded opencv from source, and built it, Qt creator no ...
2
votes
0answers
624 views

Can't start qtcreator

I'm trying to start qtcreator, but here is what i get: $ qtcreator libGL error: No matching fbConfigs or visuals found libGL error: failed to load driver: i965 libGL error: No matching fbConfigs or ...
2
votes
1answer
2k views

Syntax error: word unexpected (expecting “)”) when running remotely but no problem running locally

I've read plenty of discussions on various possibilities why such a thing can happen however all are about some missing library on the system where the binaries are deployed. This is not my case. I ...
2
votes
0answers
472 views

How to prevent Qt Applications from using GTK+ theme

Whenever I want to use custom QML components in my apps it makes them use GTK+ theme. How can I prevent this? Why am I asking here? Because I believe it has something to do with files like:...
1
vote
1answer
3k views

Ubuntu Qmake is not an executable

after installing new version of QtCreator in Ubuntu and tux-world@alachiq:~ > sudo apt-get install qt5-qmake build-essential g++ gcc Reading package lists... Done Building dependency tree ...
2
votes
1answer
4k views

Finding dependencies for a compiled C++ program

I wrote and compiled a C++ program using Qt Creator in Ubuntu 13.10 (32 bit). I tried to run the compiled program in a newly installed Ubuntu 13.10 (64 bit). But it is not run. I think the problem is ...
29
votes
7answers
75k views

How do I change which version of Qt is used for qmake?

I feel like there should be a simple way of doing this, but my googlefu is failing so I'd really appreciate some info on how to switch (or even permanently change) which version of Qt is used when ...
4
votes
3answers
3k views

How to find out what's wrong on all of my Qt programs?

I'm using Arch Linux (Linux 3.13), when I run qtcreator, it crashes, and the same happens for other Qt based software: $ qtcreator "Qt Warning - invalid keysym: dead_actute" Segmentation fault (core ...
1
vote
1answer
1k views

How to make Qt Creator use KDEs color scheme

I have krita-darker color scheme as my KDE color scheme, but the text area in Qt Creator is still white. How can I force Qt Creator to use KDE color scheme (like Kate)?