Questions tagged [qnap]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
16 views

Does anyone routinely rsync a linux filesystem backup (ext4 disks) to an NFS-mounted QNAP NAS?

I plan to do a production rsync backup to a QNAP, but not using the QNAP GUI methods but rather by running a cron job on the remote machine which mounts the QNAP via NFS. I'm not convinced the QNAP ...
user avatar
0 votes
0 answers
44 views

How can I see the expected and found metadata block size when calling pdata_tools, e.g. thin_dump?

How can I see the expected and found metadata block size when calling pdata_tools, e.g. thin_dump? The background to the question is that I try to recover from a too small thin pool on a QNAP NAS. [~] ...
user avatar
2 votes
0 answers
606 views

Mounting LVM partition on a RAID1 disk from a bricked QNAP NAS

I have a QNAP HS-251+ NAS with two 3TB WD Red NAS Hard Drives in RAID1 configuration. I'm quite acquainted with Linux and CLI tools, but never used mdadm or LVM so, despite knowing (now) that QNAP ...
user avatar
2 votes
1 answer
271 views

How to mount on Linux a QNAP external drive with LUKS partition

I need help to mount an external drive used on my QNAP TS-230 (latest firmware) to backup data. I set encrypted partition (LUKS) on this drive with a passphrase. I tried to mount that partition on a ...
user avatar
0 votes
0 answers
81 views

Infinite loop traversing NFS-mounted filesystem (QNAP server)

I have an NFS mount that has recently developed a problem whereby the mounted filesystem can't be traversed: find /media/photos/ runs fine for a while, then degenerates into an infinite loop over ...
user avatar
  • 379
0 votes
1 answer
207 views

Does changing an export from "no_root_squash" to "root_squash" require a remount on the client side?

Situation: a QNAP NAS is serving several directories already and I want to change the settings away from no_root_squash to root_squash. Does performing this impact anything other than user ...
user avatar
  • 3
0 votes
0 answers
55 views

How to recover Linux install on a device with no keyboard, screen or remote login?

I had Debian Jessie on a QNAP TS-210 device, which is an arm processes (kirkland architecture). It was running fine for many years, but I needed to use something which required up to date libraries, ...
user avatar
5 votes
3 answers
609 views

How to recursively set directory permissions with a find that lacks -exec?

My Qnap NAS is cursed with a find command that lacks the -exec parameter, so I have to pipe to something. The shell is: GNU bash, version 3.2.57(2)-release-(arm-unknown-linux-gnueabihf) I'm trying to ...
user avatar
-1 votes
1 answer
28 views

How to view all the list that can be viewed by update-alternatives?

Tabbing gives me ls data but i want something to be shown like x-session-manager , x-terminal-emulator and so on. How can i get list what can i set?
user avatar
0 votes
1 answer
153 views

how to upload files to a shared protected storage link using curl?

I want to upload files to a shared link (Qnap storage link) using cURL, how can I do this if i have just a password for the shared link , I do not have a username or an account. I have tried $ curl -u ...
user avatar
  • 3
1 vote
2 answers
939 views

QNAP NAS internal storage size for booting Debian

I've just downloaded version 4.3.6 of QNAP QTS operating system. It seems to contain amd64 Linux kernel 4.2.8, initrd and root filesystem, glibc 2.21, Apache 2.4.37, PHP 5.6.38, no Perl, Python 2.7....
user avatar
  • 951
0 votes
0 answers
706 views

FTP listing files (ls) with dynamic date YYYMMDD pattern

Following a previous answer I'm trying to list the files on an FTP server that match a pattern, as shown below event_date=`date +%Y%m%d` ftp -n XX.XX.XX.XX <<END_SCRIPT ls *${event_date}* ...
user avatar
  • 157
0 votes
1 answer
2k views

dhclient is not getting an lease / ip address from dhcp - but windows gets one

How could it be that I get easily an ip address with Windows 10 network manager and not with simple Linux QNAP NAS System? And not working situation. I tried to renew the ip address manually. [...
user avatar
  • 143
0 votes
1 answer
49 views

RAID 5 crash... trying to save what I can [closed]

I have a QNAP server with 8 disks. I have 2 backup/extra disks that are not in use. (I had the money an knew eventually the running ones would need replaced) The full array was across the 8 disks @6TB ...
user avatar
3 votes
2 answers
2k views

What is /dev/mapper/cachedev1?

I just got my first QNAP NAS, used to work mostly with Synology before, and I'm currently trying to figure out how the system uses LVM. Mostly out of curiosity. In my specific case, it's a 2 bay NAS ...
user avatar
  • 1,862
0 votes
1 answer
360 views

How do I connect to a QNAP [closed]

BACKGROUND DETAILS: I've inhereted a QNAP TS-459U-RP. I currently have it connected to my home router via an ethernet/rj45 cable. My computer is connected to the same router. How do I access the ...
user avatar
  • 2,531
2 votes
3 answers
201 views

Moving files to directories named after the first 6 digits in the file name

I've got thousands of raw photos (.nef) and relative settings (same filename but .xmp extension) in a single directory on a QNAP nas. My goal is to automate the creation of subdirs named like yyyy-mm ...
user avatar
5 votes
2 answers
826 views

QNAP eCryptFS Filesystem Broken Permissions

Following an issue with my QNAP device I've had to do a whole load of manual recovery of data and only getting at my encrypted data remains. It seems that QNAP use eCryptFS to do this. I've managed ...
user avatar
  • 921