Questions tagged [python3]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
17 views

Fedora 31 dnf cannot install packages

I am using Fedora 31. When I try to install something with dnf, I keep getting errors. For example, when I run sudo dnf install -y balena-etcher-electron it says: Running transaction check ...
0
votes
0answers
23 views

How to find x for y in python3?

I have this function in python: import numpy as np x = np.linspace(x_start, x_finish, 5000) y = (-np.sin(x*3e9+1.2e9) / 2 + 0.5) * (y_finish -0.6e-9 - y_start) - 4.5*y_finish max_y = max(y) min_y = ...
0
votes
1answer
26 views

How do I determine which python modules to pip-install for these imports?

I'm trying to run some scripts, with some subscripts, and each of these performs some import's. These are, overall (and dropping those with the from argument beginning with a dot): from datetime ...
0
votes
0answers
70 views

Failed to build these modules: _ctypes - when building Python 3.7

I'm trying to build Python 3.7.4 (as a non-root user on an older machine - SLES 11). After ./configureing and makeing, I get the following message: Failed to build these modules: _bz2 ...
0
votes
0answers
15 views

Can one do Libreoffice calc sripting by saving file and reload it after the file has been modified?

I have Libreoffice 6.0.7.3 and Ubuntu 18.04. Is is possible to do spreadsheet scripting as follows? When the script starts, it saves the files opened to csv files. Then some programming language like ...
0
votes
0answers
18 views

What is a recommended configuration for building Python from sources?

I'm building Python 3.7.4 from sources on an old(ish) GNU/Linux distribution. Now, I don't mind a longer compile time, but I don't want to risk stability for performance. I noticed there are all sorts ...
0
votes
0answers
7 views

How to connect to pgadmin (deployed in cloud) using psycopg2

Can anyone please help me on how to connect to pgadmin which is deployed in cloud from cloud functions? I tried to connect using psycopg2 as below (a connection file in our cloud function): import ...
0
votes
0answers
10 views

python simple web server and supporting proxy-autoconfig

I would like to publish local proxy.pac file using simple Python web server. I can start simple web server with command: python -m SimpleHTTPServer 8000 But when checking in browser http://IP:8000/...
-1
votes
0answers
20 views

linux mint python3 pip list error

There's too many python3 versions today like Anaconda, simple command line, PyPy and whatever but I'm having trouble with the command line. Where can I get help on this? pip list Package ...
0
votes
1answer
27 views

Raspberry Pi Start python script during boot

I have a Raspberry Pi which has a I2C 16x2 display screen. The screen simply say Welcome. Problem: I would like for this script to run as soon as the Raspberry Pi is turns on with power. I added ...
0
votes
1answer
18 views

How to exchange sqlite3 executable with latest version on my raspberry pi?

I needed the generated columns feature that has just been added to sqlite3 in the latest release. I managed to get it working in my python application on windows by simply replacing the relevant ...
0
votes
1answer
20 views

How to launch a python code after output files have been created [closed]

I'm trying to write my first BASH-script which is doing the following. There is some program which makes calculations and gives an output as a set of files. The program is at a cluster and is ...
1
vote
1answer
57 views

Upgrading from Python2.7.12 to Python 3.8.1 on macOS 10.15.2 Catalina in Wing IDE Shell

There are many threads online about making this upgrade. However, most people say not to remove the old Python2 - this can mess up the macOS on your system. I've thus installed Python3.8.1 (I needed ...
1
vote
0answers
22 views

Deploying flask app with apache2

I'm trying to deploy a simple hello world flask app on a linux server (Ubuntu 18.04.3). I'm logged into the linux box as bobtheuser. However, when I access the , I only see the contents "Index of/" ...
0
votes
1answer
74 views

Can CentOS 7 run without Python 2.7

Now that Python 2.7 has officially reached end of life, with no new security patches expected, there is a push at my company to delete Python 2.7 from all machines. Running CentOS 7, yum (at least) ...
1
vote
2answers
92 views

Unable to install Python3 packages on Debian based OS

I am using Kali Linux (based on Debian) and below is the output of the uname -a command Linux kali 5.3.0-kali2-amd64 #1 SMP Debian 5.3.9-3kali1 (2019-11-20) x86_64 GNU/Linux I want to install the ...
-1
votes
0answers
66 views

Terminal says that Command 'python' not found even though Python was installed

When the Terminal is started, it says that "Command 'python' not found" but Python is installed. I don't want to try installing it again not to lead to confusion in Python versions. I am using ...
0
votes
1answer
138 views

Python module 'gi' not found on Arch

I'd like to run a code that uses the gi-module. I'm not quite sure why it's not able to find the module. The python-gobject is installed and used by other Programs. I already reinstalled python-...
0
votes
1answer
185 views

No module named 'PyQt4.sip'

So, I have a .py file: from PyQt4.QtGui import * from PyQt4.QtCore import * When I'm executing it - I have this error message: Traceback (most recent call last): File "kek.py", line 1, in <...
0
votes
1answer
283 views

fern-wifi-cracker not working after latest Kali Linux update

Yesterday I tried to run fern, it asked for the latest python update so I updated Python 2.7 to Python 3.8 and then I also updated Kali since then fern is not opening. I tried uninstalling fern, I ...
0
votes
1answer
28 views

failed to find required module enchant

I am installing the OCRFeeder in Debian. To install the OCRFeeder I go to the root folder and execute the command: sudo ./configure The following error is shown in the terminal: checking python ...
0
votes
0answers
15 views

conda update --all gets stuck at hypothesis==3.38.5 in CentOS7

When I run the command $ conda update --all` It gets stuck at the following. - https://repo.continuum.io/pkgs/main/linux-64/linux-64::jupyterlab_launcher==0.10.2=py36_0 - https://repo.continuum....
1
vote
0answers
9 views

Raspbian: Reading USB port intermittently works

I have a Raspberry Pi running Linux - Raspbian. The problem is that I'm seeing odd behavior when I try to read the USB port. It gives intermittent results. Last night it worked, this morning it ...
0
votes
0answers
57 views

Virt Manager is not opening on Ubuntu 18.04

I have installed virt manager from terminal using command apt-get install virt-manager in ubuntu 18.04. It is installed successfully but when i click on VirtManager App icon it is not opening. When i ...
-4
votes
1answer
81 views

How to upgrade my python3.7.4 in kalli linux

I have two python versions in my machine python2.7 and python3.7.4. How can I upgrade my python3.7.4 to python3.8 and set its as default across all user?
1
vote
1answer
208 views

Getting error installing virtualenvwrapper and distutils

I am trying to install virtualenv but getting the below error on ubuntu bionic rock64@rockpro64:~$ pip3 install virtualenv virtualenvwrapper Traceback (most recent call last): File "/usr/bin/pip3", ...
-1
votes
2answers
47 views

Replace all backslash escape sequence-producable characters with their escaped escape sequences

EDIT: I'm very sorry, that I initially didn't make my requirements clear. I don't actually have access to the string written in a backslash-escaped way and have amended the example to make that ...
0
votes
1answer
630 views

'qt.qpa.screen: Could not connect to display' error when run python script at boot [duplicate]

I have searched this problem online but could not resolve it. Excuse my inexperience. I am trying to run a python script on startup which uses PyQt5 library to create a window. I am using a raspberry ...
0
votes
0answers
18 views

yum repo that keeps the latest build of python3?

I'm looking for a yum repository that keeps an up-to-date build of python3 for CentOS 7. I understand that I can build from source but it's too much of a hassle to keep it updated manually. Does ...
2
votes
3answers
225 views

Unable to install python3-pip on Debian 8

I want to install python3-pip but I always get errors: sudo apt-get install python3-pip The following packages have unmet dependencies: python3-pip : Depends: python3-setuptools but it is not going ...
0
votes
0answers
19 views

Can a python3 subprocess feed directly into another?

Linux Mint 18.3, python 3.5.2. Is something similar to this program possible? #!/usr/bin/env python3 import subprocess wlist = subprocess.run(['wc', '-w'], stdin=subprocess.run(['ls'],stdout=...
-3
votes
1answer
38 views

How will I write these bash commands in python [closed]

I need to write sed, cat in python ID_PSEXEC1="hello" type4="test" sed "s/^/$ID_PSEXEC1,/" psexec.csv > temp && mv temp psexec.csv cat psexec.csv > psexec_1.csv sed "s/^/$type4,/" ...
0
votes
1answer
109 views

Python Pip is broken

I just did a system update on Manjaro and my python pip is now broken. I was trying to install some stuff for some school projects. It seems to rely on a module called 'six'. Here is the error: ...
0
votes
1answer
48 views

Controlling the Keyboard and Mouse with GUI Automation - install

What is the problem here please? I try to install https://automatetheboringstuff.com/chapter18/ sudo pip3 install --user python3-xlib Traceback (most recent call last): File "/usr/bin/pip3", line 9,...
1
vote
1answer
66 views

ModuleNotFoundError: No module named 'ntp.ntpc'

I'm building package ntpsec-1.1.3+dfsg1 in buster but failed when compiling. The error is: ModuleNotFoundError: No module named 'ntp.ntpc' I saw that there are some .py files in the package need ntp....
0
votes
0answers
30 views

For loop command specifying stored name of a file (from bash to python script)

I have been using the following bash command to process files (using another python script ~/$HOME/quality_filter.py). The files come in pairs i.e. R1 ans R2 files eg. MK2_S34_L001_R1_001.fastq, ...
0
votes
2answers
422 views

Python 3.6 installation on CentOS 7

Failing to install Python 3.6 on CentOS. The error message is : Error: Package: python36-libs-3.6.8-2.el7.ius.x86_64 (ius) Requires: libcrypto.so.10(OPENSSL_1.0.2)(64bit) These library packages ...
0
votes
0answers
45 views

cannot import name main - phoebe2

How to install PHOEBE 2 (http://phoebe-project.org/install)? I have this error (numpy is installed): pip install numpy phoebe Traceback (most recent call last): File "/usr/bin/pip", line 9, in <...
0
votes
1answer
248 views

Fatal Python error: _PyMainInterpreterConfig_Read: memory allocation failed

I installed python3 on my macos using brew. Then I created virtual environment using python3 -m venv env. I have installed all my requirements in the virtualenv. Now when i try to run pytest. It gives ...
0
votes
1answer
35 views

How to setup a compute cluster in local network on top of linux

I have 3 machines in my local network running manjaro. I am running python scripts using dask, pandas, etc which max out the cpu on the first machine and I usually need to wait more than 30 min until ...
0
votes
0answers
87 views

Broken installation

I would like to compile a program: from PIL import Image import pytesseract as tes results = tes.image_to_string(Image.open('4.png')) I have an error: TesseractNotFoundError: tesseract is not ...
0
votes
0answers
288 views

How can I upgrade python3 to python3.6 or higher in xenial?

The max version of python in xenial apt repository is 3.5.1-3 $ sudo apt-get upgrade python3 Reading package lists... Done Building dependency tree Reading state information... Done python3 is ...
0
votes
1answer
180 views

Can't install Mayavi on Anaconda distribution

Ok, I am not really sure if this is the right place to post such question, so if it is not, please, tell me where it is more adequate. My problem: I just move from Ubuntu 19.04 to Manjaro 18. I have ...
1
vote
0answers
395 views

How to print terminal output to the same line using Python

I am trying to write a python script that constantly displays it's output to the terminal, but instead of printing out a new line for every output, I would like to have a fixed format where the ...
0
votes
1answer
43 views

What is the correct way of installing virtualenv for Python?

What is the correct way of installing virtualenv for Python? Should I do sudo apt-get install python3-virtualenv or pip3 install virtualenv? I'm using Ubuntu 19.04.
1
vote
0answers
114 views

How to install and run Irwin cheat detector on my PC?

I followed every thing on the document, but I am still getting errors when running it from terminal with this command python3 app.py --no-assess --no-report FileNotFoundError: [Errno 2] No such ...
-1
votes
2answers
530 views

Python 3.6 is installed two times as python3 and python3.6: can I remove one of them? How can i do it?

Ubuntu 18.04, from my terminal ~$ python3 --version Python 3.6.8 ~$ python3.6 --version Python 3.6.8 ~$ which python3 /usr/bin/python3 ~$ which python3.6 /usr/bin/python3.6 ~$ ls -la /usr/bin/...
0
votes
1answer
111 views

Python upgrade does not work

I'm trying to update from Python 3.6.8 to Python 3.7. I followed these steps: sudo apt-get install python3.7 sudo update-alternatives --install /usr/bin/python3 python3 /usr/bin/python3.6 1 sudo ...
1
vote
0answers
2k views

python: subprocess.Popen([“ssh”, fails to connect

Here are the code snippets I'm testing in python3: ssh = subprocess.Popen(["ssh", "%s" % HOST, COMMAND], shell=False, stdout=subprocess.PIPE, ...
1
vote
2answers
650 views

System service running python code exit with error code status 1

_note: the original posted question is edited and its faced has changed quite a bit! Summary: A python script using apshceduler fails to load as service with exit code staus1. Important to note that ...