Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [pkg]

For questions about pkg, the main package management tool of FreeBSD.

0
votes
1answer
58 views

Problem with pkg installation on freebsd

If I do pkg update I get: Updating FreeBSD repository catalogue... pkg: http://pkg.FreeBSD.org/freebsd:9:x86:32/latest/meta.txz: Not Found repository FreeBSD has no meta file, using default settings ...
3
votes
1answer
46 views

List Dependencies of Pending `pkg upgrade`

I wanted to update most of the stuff on my FreeBSD system, so I was going to perform a pkg upgrade. I noticed that one of the listed new packages to be installed was Wayland; I'm not interested in ...
0
votes
1answer
40 views

postinstall and postremove script not working

I am installing a package in Solaris server, my postinstallation and postremove file are kept in below path: /export/home/username/ABC/root/opt/ABC/bin I have added this path in prototype file like ...
1
vote
0answers
61 views

FreeBSD PKG Backup

As I'm finally getting around to reading through the FreeBSD Handbook, I discovered that PKG is taking daily backups of the package database (defined in periodic.conf). My questions are as follows: ...
0
votes
1answer
226 views

Change between `quarterly` and `latest` package set used by `pkg` tool in FreeBSD

The pkg tool in FreeBSD is usually set to draw upon either the quarterly or latest package set. The latest set may churn more often with updates, while the quarterly is meant to be more stable but not ...
0
votes
1answer
26 views

Is the list of packages available to install with `pkg` stored locally on FreeBSD? If so, how to update that cache?

When looking for a package to install on FreeBSD 11.2, such as the zsh shell: pkg search zsh …is the searching done against a local cache of packages information, or run over the internet against ...
5
votes
1answer
236 views

FreeBSD, bootstrapping pkg, “pkg-static: sqlite error while executing INSERT OR ROLLBACK INTO pkg_search”

I was trying to install bash on a FreeBSD 10.2 system, see How to Install bash on FreeBSD But the install failed because pkg was trying to fetch from a too-new repository. I then tried following the ...
5
votes
5answers
4k views

Solaris won't update because ddt-incorporation is using a self-signed certifcate

I'm trying to update my Solaris 11.3 x86 system. The system hasSun/Oracle software on it, including Sun Developer Studio and Sun SSH server. It does not have other software on it, and I don't have ...
5
votes
1answer
762 views

How to list installed files in FreeBSD pkg?

Is there a way to list the installed files with pkg for a certain package?
7
votes
2answers
2k views

How to install the latest version of software in FreeBSD?

The ports repository (svnweb.freebsd.org/ports/head/) shows haproxy is version 1.7.10 but pkg search haproxy gives me haproxy-1.7.9 Reliable, high performance TCP/HTTP load ...
2
votes
1answer
320 views

Can't install Golang on Solaris via pkg - release/evaluation dependency

On a new installation of Solaris 11.3 on Sparc hardware, I'm trying to install Golang but am getting the following problem: # pkg install --accept developer/golang Creating Plan (Solver setup): | pkg ...
1
vote
1answer
2k views

Installed incompatible pkg version, how to uninstall (or fix otherwise)?

While trying to upgrade a pfSense 2.2.6 to the latest version (as described here) and running pkg, I got: The package management tool is not yet installed on your system. Do you want to fetch and ...
2
votes
1answer
455 views

On FreeBSD, how to find packages depending on a specific package [duplicate]

I want to find/list/search packages depending on a specific package on FreeBSD with pkg tool. How can I do that? Something like: # pkg list dependent-upon llvm40 ???
0
votes
2answers
78 views

How does FreeBSD handle installing 2 packages which share a common dependency?

I'm working on FreeBSD 11 and already using programs with tcpdump as a dependency, which has libpcap and libsmi as dependencies. I want to also install tshark, the console version of wireshark. I'll ...
2
votes
0answers
540 views

Getting pkg data using repo URLs only (without a repo.conf file) - FreeBSD 10/11

This question is about using pkg on systems where the normal FreeBSD repos have been disabled, but may occasionally be needed. To make it concrete, I'm thinking about platforms like pfSense where the ...
2
votes
1answer
1k views

Cannot install package: kernel missing Linux support

I'm trying to install Dwarf Fortress on my MacBook Air running FreeBSD 11.0 via pkg install linux-dwarffortress. Here is some background information: root@machine0:~ # uname -a FreeBSD machine0 11.0-...
0
votes
1answer
1k views

Shared object “libarchive.so.7” not found, required by “pkg”

I'm using FreeBSD 12-CURRENT and recently I tried to update my packages with pkg. pkg update finished successfully, but pkg upgrade returned the following error: Shared object "libarchive.so.5" not ...
2
votes
1answer
283 views

How to mitigate the multiple vulnerability : remote code execution and local privilege escalation on FreeBSD 11?

By checking the state of installed package using the pkg audit -F tool on freeBSD 11 , I have found 4 vulnerability on the installed packages (installed through pkg) : samba ,OpenEXR , kdelibs and ...
3
votes
1answer
144 views

How to run pkg upgrade on FreeBSD without downloading any data?

I have a VM for FreeBSD 11-STABLE and whenever I run pkg upgrade -y on it, the thing tries to install three packages, the most notable of which is vim, then reboots without installing the packages ...
1
vote
1answer
145 views

What is the equivalent of `apt list` in FreeBSD?

I have just started using FreeBSD again after some years of staying away from *BSD based systems (with the exception of macOS). I am using FreeBSD 11.0 and 12.0. To manage packages, pkg seems rather ...
2
votes
1answer
2k views

Not able to install any FreeBSD package

I have been installing FreeBSD 12.0-CURRENT in a new desktop. I lost the wifi connection while updating the system. After that, trying to install aterm with the command: sudo pkg install aterm I ...