Questions tagged [pipewire]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
4 views

Debian switches laptop speakers to headphones, but not HDMI to headphones, can audio output be autoswitched?

When using laptop speakers, plugging-in headphones autoswitches output from speakers to headphone, and vice-versa for unplugging. When using monitor's speakers over HDMI, there's no autoswitch: Can ...
bs-'s user avatar
  • 33
0 votes
1 answer
6 views

Cannot enable sound with bb even with pasuspender

For this problem, I had trouble with getting bb to work with pipewire. Executing the command pasuspender -- env PULSE_SERVER= bb returns Failure to suspend: No such entity. How do I enable bb with ...
horsey_guy's user avatar
0 votes
1 answer
11 views

Repeated crackling sound when nothing is playing

I have installed Debian 12.5.0 (i386) on an old Sony laptop (VAIO VGN-FS742/W), using the netinst ISO. There is an issue with the audio: A repeating crackling sound when no sound is playing. That ...
Albert Patton's user avatar
0 votes
0 answers
9 views

Fix Line Out/Headphones sound echo to Microphone

I have headphones (with sep. mic and headphones) connected to Front Microphone and Headphones input. When I user this headphones as Output device then all sounds duplicates to microphone. I also ...
away228's user avatar
1 vote
0 answers
51 views

Debian/PipeWire disable bluetooth headset switching to HSP/HFP

Everytime I launch Audacity (which aggressively starts testing every possible input source), or even telegram-desktop, my headphones either switch to an HSP profile permanently (the A2DP options ...
Nick Bailuc's user avatar
1 vote
1 answer
57 views

Using OBS studio on Sway with Pipewire

I am on Debian 12 / SWAY desktop which is WLR based. I first install the "OBS Studio" version 29.0 with: ┌───┐ │ $ │ ziga > ziga--workstation > ~ └─┬─┘ /dev/pts/4 └─> sudo apt ...
71GA's user avatar
  • 1,116
0 votes
0 answers
72 views

Stream Pipewire audio to web browser with low-latency and high quality

On my Linux host where audio is managed by Pipewire, I'm playing audio files (FLAC, MP3, OGG) with various music players (e.g. VLC, mpv, mpd) which all output to the default audio device. Besides ...
Wolkenarchitekt's user avatar
1 vote
0 answers
27 views

Mapping audio output for USB sound card on Fedora with Pipewire

Setup: Creative Soundblaster X4 2 speakers + 1 sub with LFE connection Yeti USB microphone Fedora 39 Goal: Have LFE out channel working on X4 so I can have sub working without plugging into desk ...
Rig's user avatar
  • 111
0 votes
0 answers
31 views

Pipewire virtual device (audio source) combining monitoring default sound output device and default capturing device

Is it possible to create pipewire virtual audio source device which would combine (mix) sound monitoring from current default audio device (whatever it is) and default capturing device? Could you ...
vvch's user avatar
  • 101
0 votes
0 answers
20 views

Bluetooth earphones doesn't connect automatically

After Alpine installation, I paired and trusted the earphone using bluetoothctl. I have pipewire working, and pipewire-pulse installed (don't know how to check if it works). These earphones worked ...
Tala2n's user avatar
  • 1
0 votes
2 answers
619 views

No sound on fresh install of Debian 12

I have no sound on a fresh debian 12 install on a mini-pc. The PC is connected via HDMI to a TV. I've tried testing with pipewire, with alsa-only, with pipewire-pulse. I also tried testing plugging in ...
user84207's user avatar
  • 911
0 votes
1 answer
56 views

How do I stop PulseAudio from creating so many [Peak Detect] channels in pipewire/qpwgraph? (Linux Mint)

So, for some reason there are these channels called "PulseAudio Volume Control [Peak Detect]" and they pop up multiple times when opening apps and anything else that uses audio output. It is ...
linuxlife's user avatar
0 votes
0 answers
16 views

How to receive line level audio signal from a notebook jack port?

As a follow up to my reddit question I'd like to ask: How to receive audio from a jack port, if the signal is line level, but the driver processes it like if it was mic level (because this a casual ...
zaabson's user avatar
  • 33
0 votes
0 answers
104 views

Get right Pipewire object with object id

I need to know Pipewire object.serial that corresponds to a specific object. Parsing output of pw-cli list-objects is what I need, but I'm very poor with multiline regex. pw-cli list-objects gives ...
Basher's user avatar
  • 1
0 votes
0 answers
36 views

Pause audio playback when bluetooth speaker disconnects

I'm looking for a way to automatically pause audio when the Bluetooth speaker I'm playing audio on disconnects. I've seen this feature on Android, and I'd like to have it on my desktop as well. Here ...
Tim's user avatar
  • 71
2 votes
1 answer
284 views

No system sounds on KDE plasma when using pipewire

I'm running Debian 12 with pipewire installed. However the moment I remove pulseaudio and install pipewire, KDE system sounds (like volume change, critical battery alert...) no longer play. I have ...
td211's user avatar
  • 374
0 votes
0 answers
56 views

HP ProBook 450 G10 microphone not working

I have an "HP ProBook 450 15.6 inch G10 Notebook PC" running arch (using pipewire) and the microphone does not work. I tried using pavuctl and alsamixer to check if something was muted but ...
A_helpless_student's user avatar
0 votes
0 answers
462 views

Missing pipewire card/sink causing no audio?

I have an AlsaLinux 9 host with a USB audio device. The sound card device driver loads, aplay shows the device, but when I try to play audio nothing is heard. I suspect that the problem is a missing ...
TSG's user avatar
  • 1,698
0 votes
1 answer
31 views

Share audio output device between two processes

Is it possible for 2 processes, each trying to send audio to the single output device, to share (mix) the audio streams? I'm running AlmaLinux 9 and have paired back to basic ALSA only. But if needed ...
TSG's user avatar
  • 1,698
0 votes
0 answers
78 views

No audio heard, yet Linux thinks played successfully

I had audio working on my AlmaLinux 9 installation, using a USB sound card. I seemed to have changed something because I no longer hear audio (but AlmaLinux thinks its successfully playing a sound). ...
TSG's user avatar
  • 1,698
0 votes
0 answers
29 views

Fedora module-native-protocol-tcp lost on login

On Fedora 39 I have the following... cat /etc/pipewire/pipewire-pulse.conf.d/50-network-party.conf context.exec = [ { path = "pactl" args = "load-module module-native-protocol-tcp&...
paulio's user avatar
  • 101
0 votes
0 answers
504 views

Wireplumber - Simultaneous output to multiple sinks on the same sound card

I'm using Fedora 38 (6.5.6-200.fc38.x86_64 ) wireplumber: Compiled with libwireplumber 0.4.14 pipewire: Compiled with libpipewire 0.3.81 So i try to Simultaneous output to multiple sinks on the same ...
Frankstar's user avatar
  • 111
2 votes
1 answer
974 views

How to check & adjust sound volume from the command line with pipewire-pulse?

Of course I found this closely related question. However, nothing there works with this modern Fedora installation. uname -a says it's "Linux 6.4.15-200.fc38.x86_64". If it matters, here are ...
Richard T's user avatar
  • 192
0 votes
0 answers
22 views

Ubuntu base running pipewire has much louder audio than on windows dualboot

I have the opposite problem most people have with audio on Linux. Linux is at least twice as loud as windows without using any digital/soft amps. I'm not even sure how to start diagnosing this since ...
yeb's user avatar
  • 1
0 votes
0 answers
149 views

Only dummy audio device for simultaneous login session on Debian 12

I upgraded on my laptop to Debian 12 from 11. Audio works fine for the first user being logged in. If I log out with that first user, I can log in with another, and audio works fine for the newly ...
P.Péter's user avatar
  • 525
0 votes
0 answers
305 views

Can't Get Microphone on Arch Linux to Work Using Pipewire(alsamixer shows that everything is on and good)

For the past 5-6 hours I've been trying to get my microphone to work but I genuinely can't figure it out. Simply installed pipewire, pipewire-alsa, wireplumber, alsa-utils and made sure there were no ...
Ozone's user avatar
  • 1
1 vote
0 answers
304 views

VU (dB) meters for surround 5.1 (PipeWire, KDE, Debian)

I guess this is sort-of a software recommendation question, but if I post it there I think even less people will be familiar with this specific setup (5.1 surround, Debian 12, KDE and PipeWire) I ...
Nick Bailuc's user avatar
0 votes
0 answers
192 views

Simultaneous input and output on pipewire for USB-C microphone

I have an Elgato Wave 3, and I am trying to use it on Ubuntu 22.04 with PipeWire (had to replace PulseAudio because my Sony WH-1000XM5 was not able to give me high-quality audio without replacing it ...
matiaslauriti's user avatar
1 vote
1 answer
354 views

Chaining pipewire sinks for a streaming setup

Good evening! I'm trying to create a streaming setup for me and my buddies to hang out via Skype and I'm really struggling with the audio part. There are two problems : The microphone only transmits ...
Sorin Lascu's user avatar
1 vote
1 answer
97 views

How can I activate my keyboard's microphone mute light when using set-source-mute?

Give these two commands, the command for set-sink-mute turns on the muted light on my keyboard for audio pactl set-sink-mute @DEFAULT_SINK@ toggle pactl set-source-mute @DEFAULT_SOURCE@ toggle But ...
Evan Carroll's user avatar
  • 30.9k
0 votes
0 answers
64 views

Facing audio issues in pop os linux

i am facing audio issue in pop os linux that when i plug in earphones, only i am able to hear audio with noise in between some of the times and earphones mic does not work at all. But it is working ...
Bappa's user avatar
  • 1
0 votes
0 answers
73 views

Audio in the entire system freezes if one application is paused on a breakpoint

I'm making a game using SDL2. When I'm debugging it and pause on a breakpoint, the audio in all other applications (e.g. Firefox) freezes, as if infinitely replaying the last ~0.1 seconds of audio. ...
HolyBlackCat's user avatar
0 votes
0 answers
40 views

audio quality issue on fedora linux: triggered randomly or by unplugging charger during wine games

So after a recent fedora update (the ones that require a reboot) lutris wine games have been acting up lately, audio suddenly becomes 8-bit-like and super low quality, and sometimes by chance it goes ...
EsotericServers's user avatar
1 vote
0 answers
123 views

Can an audio output priority list be defined?

Is it possible to set priorities for audio output devices, such that audio will be sent to the appropriate output, depending on what’s plugged in? (That is, hot pluggable: the priority list should be ...
Xophmeister's user avatar
0 votes
0 answers
360 views

Combining 2 audio outputs

I have an app that is play music to the default audio device (which uses pipewire). When I using a second play command (pw-play) the command executes but that audio is not heard. I was hoping to ...
TSG's user avatar
  • 1,698
0 votes
1 answer
137 views

What is media-role with pw-play

I notice that the pw-play command (pipewire play audio file) accepts a media-role parameter. It's not clear what are the valid options for media role, and what impact does it have. I've search the ...
TSG's user avatar
  • 1,698
1 vote
1 answer
1k views

Pipewire-pulse: No sound, "playback open failed: Device or resource busy"

I'm running wireplumber + pipewire + pipewire-pulse and I can't get any sound out of the HDMI cable. pactl list sinks shows all my audio devices as SUSPENDED and journalctl --user -u pipewire shows a ...
cheezsteak's user avatar
0 votes
1 answer
361 views

Non-root users can't play audio with pipewire

I have an AlmaLinux 9 host which uses pipewire. Logging in as root I can play audio files no problem. But issuing the same command as any other user results in "host is down" error and no ...
TSG's user avatar
  • 1,698
3 votes
1 answer
3k views

How to set audio device profile and route with PipeWire directly?

I understand that you could select a profile for an audio device using pactl set-card-profile CARD PROFILE. But pactl is a PulseAudio utility, meaning it adds an unnecessary layer and of course it ...
Forivin's user avatar
  • 847
1 vote
0 answers
326 views

aplay with pipewire

I am running AlmaLinux 9 and have a problem playing back audio using 'aplay'. I have a service running as root, and when it tries to play the audio file I get error: aplay: main:831: audio open ...
TSG's user avatar
  • 1,698
2 votes
0 answers
202 views

What is the hierarchy of the units that audio devices consist of on PipeWire?

I'm trying to understand the audio device hierarchy for PipeWire. Looking through the output of pw-dump has given me a good idea, but I still find it very difficult to grasp the whole picture. My ...
Forivin's user avatar
  • 847
1 vote
0 answers
275 views

Tiger Lake Internal Microphone not Detected

I have problems with the microphone on my Tiger Lake laptop. I have tried to follow the guide on Arch Linux WIKI about configuring Pipewire with wireplumber, and copied the configuration files, but ...
Georgi Stoyanov's user avatar
2 votes
0 answers
610 views

How to record audio device with more than 2 channels using SoX?

I have multiple USB audio interfaces that each have 10, 18 or even 32 input channels. Mainly used to record every instrument of a band into a separate track. I record in raw wav format (s32le @48kHz) ...
Forivin's user avatar
  • 847
0 votes
0 answers
105 views

Detecting a Pipewire Virtual Sink in Java

I'm trying to set up a Virtual Sink using Pipewire which I've done successfully, however, I am having trouble detecting it in Java though other applications have no problem detecting it. I can play ...
Emmy's user avatar
  • 1
1 vote
2 answers
5k views

Bluetooth Issues with Airpods Pro 2 on Debian 12

I'm currently trying to move from Ubuntu 22.04.2 LTS to Debian 12, and everything is so much more stable and reliable here. But there is one problem: My Airpods Pro (Generation 2) don't really work. ...
User1986's user avatar
  • 121
0 votes
1 answer
1k views

Pipewire: multichannel audio using two devices

I am running a fully-updated Manjaro linux. Until recently, I had 2 Fireface 800's, which are firewire, and I used jack and ffado, which combined the two 8-channel devices into a single virtual 16-...
Christopher Brown's user avatar
0 votes
0 answers
146 views

V4L2 devices show up in in pipewire. How do I remove them?

Demonstrative image I have every video device duplicated in PipeWire due to v4l2. I cannot recall what I did years ago to make them appear. How can I remove these duplicate devices?
Managor's user avatar
  • 170
0 votes
0 answers
37 views

pactl can't unremap monitor source

Background: I have a monitor with aux in and out. When trying to use some applications I couldn't use the monitor device, so I tried remapping it to a normal pulse audio source. Unfortunately, I ...
Jesse Taube's user avatar
0 votes
1 answer
151 views

USB Headset Prevents Media Playing on Arch

I recently bought a USB headset and it has been behaving very inconsistently. Sometimes it works fine but other times, if I try to play any media, it acts as if it is buffering until I unplug the ...
Aurillium's user avatar
0 votes
0 answers
483 views

How to change between pipewire filter-chain configs when default sink is changed

If I have pipewire filter-chains set up like described here: https://gitlab.freedesktop.org/pipewire/pipewire/-/wikis/Filter-Chain, how can I automatically switch between different sets of filters ...
ipwnmice's user avatar