Questions tagged [pip]

pip is a Python package installer

Filter by
Sorted by
Tagged with
5
votes
2answers
301 views

What is the correct way to upgrade pip in stretch debian?

I have gone through some notes that it is not a good idea to do pip upgrade using sudo command. My question is if I don't give sudo I get permission errors. How can I resolve this? Also, what is the ...
0
votes
1answer
18 views

How to install git for pip - python 2.7?

My pip version is 20.0.2 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7) I can't install git. what am I missing here? $pip install git DEPRECATION: Python 2.7 reached the end of its ...
0
votes
0answers
58 views

Could not find a version that satisfies the requirement qscintilla==2.11.4

I was trying to install python packages for Mu Editor on Linux Mint when I ran into the following error: $ pip3 install qscintilla==2.11.4 Collecting qscintilla==2.11.4 Could not find a version ...
0
votes
1answer
25 views

How do I determine which python modules to pip-install for these imports?

I'm trying to run some scripts, with some subscripts, and each of these performs some import's. These are, overall (and dropping those with the from argument beginning with a dot): from datetime ...
-1
votes
0answers
19 views

linux mint python3 pip list error

There's too many python3 versions today like Anaconda, simple command line, PyPy and whatever but I'm having trouble with the command line. Where can I get help on this? pip list Package ...
2
votes
2answers
5k views

python easy_install or pip errors about sysconfig

somehow the installation of python is broken in my linux OEL 6.9. pip or easy_install are broken and I cannot do anything. i get the same error on both sides: # easy_install Traceback (most ...
0
votes
1answer
3k views

Python3.6's Pip Checking wrong Python Version

I've recently upgraded to use Python 3.6 on Ubuntu 16.04. Now I have Python 2.7, 3.5, and 3.6 all on the same system. I've had pip (defaults to v2.7), and pip3 (defaults to v3.5), and I then ...
1
vote
3answers
8k views

python-pip : ImportError: cannot import name main

I am using Debian 9.5 Stretch release. I am having import error while using pip. When I try using pip it says: However I can use python: I have two versions of python installed: 2.7 and 3.5 Output ...
0
votes
2answers
967 views

pip not working and apt cannot reinstall python using kali 2019.4 on vmware

I installed kali 2019.4 from kali.org on a vmware machine. However, pip does not seem to be installed and I can't find the answer on how to install it. Note: I am forwarded to the internet by a proxy. ...
0
votes
0answers
21 views

Running Python in Hue Shell

Does anyone know how to troubleshoot the error "No package pip34 available"? I'm just following what my professor did in class. I know the commands are right and that pip34 exists. I'm not sure why I ...
0
votes
1answer
4k views

pip not working after installing another python version

My CentOS 6.5 machine already had Python 2.6 installed in it. Now I just installed Python 2.7. But now, pip is not working. Whenever I run any pip command, it shows following error- File "/usr/bin/...
0
votes
1answer
788 views

pip - fatal error: leveldb/db.h: No such file or directory

The usual answer to this is that I am missing leveldb from my system, however the python3-leveldb libleveldb-dev packages includede in Debian 9 are for python3.5 but I am using python3.7 I compiled ...
0
votes
1answer
966 views

Error while Installing Kivy with pip on GalliumOS

I'm installing Kivy on my laptop running GalliumOS and when I do pip install kivy It gives me all of this stuff. I'm new to Linux and Python so I have no idea what any of this really means. ...
1
vote
1answer
1k views

certbot and awscli require different versions of botocore

I have a small script that generates new Let's Encrypt certificates whenever they are due for renewal and then imports the new certificates to our AWS account so that we can use them to sign ...
5
votes
4answers
8k views

pip upgrade messed up python installation

I'm trying to install a python application I wrote on a freshly created Ubuntu 16.4 virtual instance. I need to install a number of python packages that I previously installed on my own PC. ...
0
votes
1answer
106 views

Python Pip is broken

I just did a system update on Manjaro and my python pip is now broken. I was trying to install some stuff for some school projects. It seems to rely on a module called 'six'. Here is the error: ...
0
votes
1answer
73 views

Manjaro: Permissions issues on new SSD after crash and restore

My SSD died. All my projects were stored on HDD ( and worked smoothly without any issues), so I just bought another SSD and installed the new OS (Manjaro, the old one was Fedora, if it matters). ...
11
votes
3answers
72k views

How do I correct the path for pip?

I'm trying to get pip to point to a different install rather than the default. It is currently pointing to /usr/bin/pip, but I want it to point to /usr/local/bin/pip. I believe I have the path set ...
0
votes
1answer
1k views

Installing Packages in PyCharm

I'm using Mint Cinnamon (very new) and tryign to get some packages in PyCharm. When I use the package installer for Numpy or Pandas I get the error message: collect2: error: ld returned 1 exit status ...
1
vote
0answers
36 views

install pip and setuptools on remote machines

we want to install pip on all remote machines on each remote machine we have ls -ltr -rwxr-xr-x 1 root root 855608 Oct 7 01:39 setuptools-41.4.0.zip -rwxr-xr-x 1 root root 1140573 Oct 20 07:23 ...
1
vote
1answer
310 views

how to install pip without network or internet

I am using the following way to install pip on redhat 7.5 version I download the pkg - pip-8.1.2-py2.py3-none-any.whl to the machine without network and I instal it python /root/pip-8.1.2-py2.py3-...
0
votes
1answer
25 views

how to download specific pip version on linux redhat

we can download the latest pip as curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py % Total % Received % Xferd Average Speed Time Time Time Current ...
0
votes
1answer
22 views

How can I get “pip show” to show the date and time when module was installed?

how to know when module for example requests was installed - in date and hour and min for example pip show show only the following details without time pip show requests --- Metadata-Version: 1.1 ...
38
votes
5answers
33k views

Recommended way of installing python packages on Arch

What's the recommended way of installing python packages on Arch? Searching for them on the AUR and installing them from there (or create a PKGBUILD file to make a package yourself) or using pip? I ...
0
votes
1answer
35 views

How can I install an apt-get/pip package for use by a particular Python version?

OS Linux Mint 18.3. Based on Ubuntu Xenial. This gives "Python 3.5.2" as its installed version. I learnt the hard way that it's not good to try and upgrade Python in a Ubuntu OS as apparently it's ...
1
vote
0answers
47 views

I would like to install pip packages on a Linux CentOS without internet access

I have a Linux CentOS without internet access and I need to install some python packages. My pc runs Windows 8.1 Can I download the .whl files and send them with WinSCP ? From where can I download ...
0
votes
0answers
24 views

Compile a python package to another target

Is it possible to "compile" a python package (with pip or installing by source with python setup.py install or something) and then transfer the resulting binary to another machine (in this case, an ...
0
votes
0answers
21 views

Unable to instal PIP or Virtualenv

I get the following error messages when trying to install PIP in my CMD Prompt. C:\cicdbuzz>pip-v 'pip-v' is not recognized as an internal or external command, operable program or batch file. and ...
0
votes
0answers
215 views

Ubuntu 16: pip3 installs to Python2 instead of Python3

Having issues linking pip to python 3.7. Both pip and pip3 been installed but linking to Python 2.7. I have tried to reinstall Python3 and then pip, but no progress. I get the following message: ...
4
votes
2answers
573 views

Why does pip3 install in ~/.local on Debian?

I'm testing Debian 10 in a VM to check if i can use it for my stream servers (headless minimal netinstall). Why does pip3 install, e.g supervisor, in ~/.local? I did read the release notes but ...
-4
votes
1answer
885 views

Writing a Python Script which uses pyWin32 in Kali Linux

I'm trying to make a Python script which runs in windows, but because of reasons I have to write it in Kali Linux. Since it doen't exist on Linux, I can't add the additional libraries I need. Should ...
1
vote
0answers
107 views

parallel-ssh not appears in any path after pip installation

we installed the parallel-ssh but after pip successfully installation the command parallel-ssh not appears in any path where we are wrong? locate parallel-ssh which parallel-ssh /usr/bin/which: ...
4
votes
1answer
3k views

AttributeError: module 'lib' has no attribute 'X509_up_ref'

No matter what module I try to install via pip3 install I always get the same error : AttributeError: module 'lib' has no attribute 'X509_up_ref' Have no idea how to solve this one. Anyone had this ...
-2
votes
1answer
660 views

Issue using pip3 to install “face_recognition”, packages do not match hashes

When I give command pip3 install face_recognition in the raspberry pi terminal, It shows this error: THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the ...
1
vote
2answers
571 views

Installing qutip package in python3.7 gives errors

I'm running Linux Mint 19.1 with Python 3.7.3 and am trying to install the qutip package. I've got the following installed so the dependencies should be fulfilled: NumPy-1.16.4 SciPy-1.3.0 Maplotlib-...
67
votes
6answers
126k views

zipimport.ZipImportError: can't decompress data; zlib not available

On RHEL 6.6, I installed Python 3.5.1 from source. I am trying to install pip3 via get-pip.py, but I get Traceback (most recent call last): File "get-pip.py", line 19177, in <module> ...
6
votes
2answers
9k views

How to install python pip without Internet connection?

My python is 2.7.5, -bash-4.2$ python --version Python 2.7.5 By default it doesn't have python pip. My Linux is Redhat ERHL 7.3. -bash-4.2$ cat /etc/redhat-release Red Hat Enterprise Linux ...
2
votes
2answers
3k views

pip install gives “TypeError: 'int' object is not iterable ”

In Debian Stretch, when I try to install the python package python-constraint via pip install python-constraint I get the following error; Exception: Traceback (most recent call last): File "/usr/...
1
vote
1answer
4k views

Arch:pip: ImportError: cannot import name 'requests'

Some of my python packages installed with pip had conflicts with another package I tried installing using pacman. So I decided to uninstall all the packages installed with pip. I made a requirements....
0
votes
1answer
192 views

Installing matplotlib

$ pip3 install matplotlib Requirement already satisfied: matplotlib in /home/vorac/.local/lib/python3.7/site-packages (3.0.3) Requirement already satisfied: cycler>=0.10 in /home/vorac/.local/lib/...
0
votes
1answer
372 views

Unable to install PIP on Linux

I am trying to install pip on my Linux environment, but it is not installing properly. Python version - 2.6.6 When I try to install pip using the following command, python setup.py install ...
1
vote
1answer
3k views

pip install opencv-python gives error on Raspbian

I'm using a Raspberry Pi 3 B+ with Raspbian installed. When I run pip install opencv-python I get the following message: Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple ...
0
votes
0answers
19 views

Occurred an error when trying too install packages for python

When I tying to install some package with pip for python in raspbian I occurred an erros as showes in picture http://uupload.ir/files/vasg_20190428_135436.jpg
7
votes
1answer
9k views

Why did pip install a package into ~/.local/bin?

When I install this "Taurus Blazemeter 'bzt'" program with pip, it ends up being installed into ~/.local/bin folder. mkdir ~/bzt && cd ~/bzt sudo apt-get install python default-jre-...
-2
votes
1answer
89 views

Woes installing PIL

I get this error when I try to run my program. Traceback (most recent call last): File "green.py", line 11, in from PIL import Image ImportError: No module named PIL I already tried "pip ...
0
votes
0answers
223 views

After updating pip gives an error

I want to install # pip install certbot-dns-rfc2136 #pip install --upgrade pip You are using pip version 7.1.0, however version 19.0.3 is available. You should consider upgrading via the 'pip install ...
0
votes
2answers
828 views

How Troubleshoot Failed Installation of pywfdb from pip?

Condition: unable to troubleshoot failed installation of the library/module pywfdb from pip Differential conditions: failed dependenciens of pywfdb Exclude: upstart/systemd design bugs with runit in ...
2
votes
0answers
441 views

Switch pip from /usr/local/bin/pip to /usr/bin/pip

I m forcefully started pip from /usr/local/bin/pip by executing sudo python3 -m pip install -U pip command. Now I want to use pip from /usr/bin/pip to achieve this, I have rename the pip as /usr/...
0
votes
0answers
189 views

Local Python Repository Packet Installation

I have a rhel server which I use as yum repository for my other servers. Now I need it to serve python packages as well. I found an anaconda repository to download packages: https://repo.continuum.io/...
1
vote
1answer
679 views

Problem with pip package installation in virtualenv environment

After creating python virtual environment virtualenv -p python3 venv and activating it source venv/bin/activate, i am trying to install python packages using pip command-> pip install Flask which ...