Questions tagged [php7]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
0answers
15 views

How check apache & php-fpm config is appropriate (not too high or too low)

I will have an event with 3k users on an app (php base). I launch several instances in the cloud and install LAMP on it.[to make load test and choose on for the event] On Ubuntu 18 I enable mpm_event ...
0
votes
0answers
10 views

Use multiple PHP-FPM versions using FastCGI on same Debian/Apache server

I would like to use multiple PHP-FPM versions using FastCGI on same Debian/Apache server. Using: Debian v9.12, Apache v2.4.25, php5.6-fpm, php7.4-fpm, libapache2-mod-fcgid v1:2.3.9-1+b1, libapache2-...
0
votes
1answer
33 views

Ondrej repo on Ubuntu 18.04

I'm following a guide for loading PHP 7.4 on Ubuntu 18.04 from the Ondrej Surý repo and noticed the CAVEAT about apache2 and nginx from the 1. If you are using php-gearman, you need to add ppa:ondrej/...
0
votes
1answer
89 views

connect mssql database on Centos 8 using php 7.4

I cannot figure out the way to connect MSSQL 2014 database on centos 8 using PhP 7.4. I found GitHub link and downloaded CentOS8-7.4.tar and extracted the php_sqlsrv_72_ts.so and php_pdo_sqlsrv_72_ts....
1
vote
1answer
22 views

Older php versions are getting auto installed

I use Sury for Debian 10. Somehow I noticed, it's trying to install older versions and new versions. Is their any way, I can do something so that, apt-get update or apt-get dist-upgrade, doesn't ...
0
votes
1answer
34 views

Google Chrome scrolling suddenly stopped on my website

I have a website that was working OK until this weekend. Today I noticed that a number of browsers lost the ability to scroll the content vertically. The only modifications done to the server or the ...
0
votes
0answers
24 views

PHP Zip module doesn't load

I use PHP 7.4 and Nginx 1.16.1 and i want to enable php-zip in my server because a wordpress plugin required it: I installed zip module (php-pecl-zip-1.19.1-1.el7.remi.7.4.x86_64). If i type php --...
0
votes
1answer
783 views

Problem with installing PHP 7.4 on Ubuntu 14.04 LTS

I'm on Ubuntu 14.04 and PHP 7.0. I need to update PHP to PHP 7.4. I added ppa:ondrej/php repository. Still, it says Unable to locate package php7.4 when trying to update PHP. $ sudo add-apt-repository ...
0
votes
0answers
30 views

How to have .html files pass through the PHP preprocessor?

I would like to configure an Apache webserver 2.4.37 to hide the fact that it is serving PHP files. For this, I renamed all .php files to .html and inserted the following directive: AddType ...
0
votes
1answer
79 views

Try to install php 73 but it installs php 74

I had php 7.4.10 in my centos 7 server but I want to downgrade to php 7.3 I uninstalled the php 7.4 and tried this code. wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm ...
0
votes
0answers
41 views

Why do I get `OpenSSL support => disabled` even after uncommenting `extension=openssl` in php.ini?

If I execute php -i | grep "openssl" then I get OpenSSL support => disabled (install ext/openssl) even though I uncommented the line extension=openssl in the loaded configuration file (...
0
votes
1answer
508 views

How to make Apache use PHP 7.3 on server upgraded to Debian 10?

I am upgrading a server from Debian 9 (stretch) to Debian 10 (buster), and am aware (and intend) that this results in PHP being upgraded from PHP 7.0 to PHP 7.3. php -v does indeed show that PHP 7.3 ...
0
votes
1answer
45 views

Why a PHP module is not loaded into PHP?

Showing my case how to debug the problem, that a PHP module is not loaded into PHP. I use OpenSUSE v42.2 Linux OS, with Apache webserver, PHP v7.1, Mysql. Because it does not provide PHP v7.1 I need, ...
0
votes
1answer
25 views

What is the cause of the bad performance of NGINX / PHP which host only 1 Wordpress website

I spawned a LXC container on our (Proxmox) hypervisor (we run multiple containers on it without any performance issue). I installed NGINX and PHP7.4 on it and host (currently) only 1 Wordpress website....
0
votes
1answer
45 views

fastcgi php nginx errorlog messed up

I have a strange problem, the errorlog of my nginx server is somehow messed up: PHP errors seem to be all written in one line and repeating itself recursively. This way the llog grows a few GB within ...
1
vote
0answers
25 views

Install PHP in Linux Mint 19.1

I am new in Linux Mint. I installed Linux Mint 19.1. Now I would like to install PHP7.2 in Linux Mint. I found a way in this tutorial and another way in this tutorial. I got another way in this ...
0
votes
0answers
303 views

Http requests hanging on new CentOS 7 + apache install. TTFB of 30 secs

we've just migrated from CentOS 6.5 with PHP 5.3 to CentOS 7.7 with PHP 7.0 and are getting strange behaviors with some http requests Most of the time, pages & resources load super fast, and some ...
0
votes
0answers
108 views

Debian Stretch + Apache 2.4 + PHP 5.6 + PHP 7.0 and virtual hosts

I have a little Debian 9 server with Apache 2.4 installed. I need it to serve my home with a Nextcloud service, which requires PHP7.0. Then I also need to get it to serve a rather old service (http://...
0
votes
1answer
771 views

Package Dependency when Upgrading to PHP7

Not sure if this is a correct place to post. I have recently upgraded to PHP 7 on one of our webservers, however, when I do the same for another webserver, I get the below dependency error. The ...
0
votes
1answer
553 views

RHEL 8 AppStream does not contain PHP 7.1?

I have a fresh RHEL 8 system. I thought I could install PHP 7.1 via the Software Collections. But this package is not available. Repository list: $ sudo dnf repolist Updating Subscription ...
1
vote
1answer
142 views

Install php 7.X (for new wiki) alongside php 5.3 (for old wiki) on CentOS 6

I would like to replace the ancient Mediawiki (version 1.21.2,l PHP version 5.3.3, MySQL 5.1.73) used by my company with a brand new Mediawiki site running the latest version (requires php 7.0.13 or ...
0
votes
0answers
90 views

Nginx php-fpm optimization in centos 7

My server setup uses cloud azure VMSS. I have an issue when testing 200 users' requests that produce error 502 and non-HTTP response message connection timed out connect. Already followed some ...
0
votes
1answer
639 views

Showing “Cannot create SSL client. SSL is not enabled in this build” when connecting to Cosmos DB (MongoDB API)

I am facing the error "Cannot create SSL client. SSL is not enabled in this build" when connecting to CosmosDB using the MongoDB API. My PHP configuration suggests SSL support is included in my ...
-2
votes
1answer
5k views

Unable to install php 7 in ubuntu 14.04

Commands I have tried : sudo add-apt-repository ppa:ondrej/php sudo apt-get update sudo apt-get install php7.0 Getting error as Reading package lists... Done Building dependency tree ...
1
vote
2answers
646 views

php curl not getting installed on Debian 8 [duplicate]

I am using linux debian 8. I have webmin/virtualmin installed and 1 domain is running over the server. Php version is 7.1. But, i can not run curl on my server. i tried to install curl but it throws ...
0
votes
1answer
138 views

Running Drupal's drush cron jobs with a newer PHP version from Software Collections

How do you run Drupal's drush cron jobs when your server has a newer PHP version installed from Software Collections? The server is running Scientific Linux 7, which comes with PHP 5.4, but we need, ...
0
votes
1answer
532 views

Init script not picking up environment variable set in /etc/environment?

What is the right way to set a global environment variable, such that it is picked up all processes, including those started via init.d (service <service> start), on Ubuntu? Details: I first ...
2
votes
3answers
6k views

Installation conflicts with httpd on Amazon Linux AMI

When installing 'yum install -y php70 mysql56-server php70-mysqlnd' on an Amazon Linux AMI server, I'm receiving these conflicts: Error: httpd24-tools conflicts with httpd-tools-2.2.34-1.16.amzn1....
0
votes
1answer
75 views

How to connect PHP 5.6 to SQL db after compilation

I installed PHP 5.6 from source on Debian server 9 server. The OpenSSL version in Debian 9 is too new for PHP 5.6, so I had to compile an older version in /opt/openssl to use it with PHP 5.6. ( ...
1
vote
1answer
6k views

PHP Not Loaded on CentOS 7/Apache

I've installed PHP 7.2.11 on my CentOS 7 VPS along with Apache; however, I can't seem to load the PHP module into Apache so that my server can serve PHP content. Right now, if I go to a URL that ...
1
vote
1answer
4k views

Can't find php-zip extension for php 7.1 on CentOS 7

I am attempting to install Magento 2.2.5 on a new CentOS 7 server with PHP 7.1. I can't seem to find how to install and/or enable the php-zip extension. The issue I'm trying to resolve is this (via ...
1
vote
1answer
1k views

Does Apache2 auto install when installing PHP 7.2?

Anyone else experiencing this issue? When I installed PHP 7.2, it somehow auto installed Apache2 with it. This is a fresh Ubuntu 16.04 with only nginx installed on it to serve static files. add-apt-...
3
votes
0answers
2k views

Apache mod-security gives “Loaded PCRE do not match with compiled!”

I've got a webserver installed with Apache and PHP with mod-security. The problem is that mod-security seems to be incompatible with the PHP installation. I get the following result in the apache ...
2
votes
3answers
5k views

Installing php7 on alpine: missing libcrypto and libssl

I tried to setup a LEMP stack over Alpine GNU/Linux Distribution running on a VM WITHOUT docker. Then I tried to install the php7-mysqli over via community repositories with: sudo apk add php7-...
1
vote
2answers
3k views

Debian 9.4: cannot install php7.2-curl

Trying to install php7.2-curl library from a well-known repository deb.sury.org on Debian 9.4. But it gives the error: The following packages have unmet dependencies: php7.2-curl : Depends: libcurl4 ...
0
votes
1answer
3k views

How to run script as php user

I have a script which is called from php using the shell_exec command on a server running Ubuntu. The script runs properly when called from the command line via ssh, but not when called from php. I'...
0
votes
0answers
1k views

Unable to install PHPMyAdmin with PHP 7.1

I previously installed php56 in aws but i had to update to 7.1. When I do, I couldn't install phpmyadmin anymore. I tried to search on the net but all are said to remove php5.6 then to install 7.1. It ...
2
votes
1answer
5k views

How to make my system centos 7 use primarily ipv4 if it's available

I have CentOS 7 running on an AWS machine. I recently enabled IPv6, and everything was working fine – except for the fact that PHP connection requests (also curl from command line) always prefer to ...
1
vote
1answer
180 views

lag starting php 7.1.13 on CentOS 7.4.1708. how to fix?

PHP 7.1.13 on CentOS 7.4.1708 Inexplicable lag (2 to 10 seconds) just invoking php, even with empty script or just to get version info. I have never seen this before on any system and I'm not sure ...
1
vote
3answers
2k views

Yum install php v5.4 packages while I have installed php 7

I have installed PHP version 7 on my centOs. Now I got an error says: undefined function mb_internal_encoding() So I decided to install php-mbstring (using yum install php-mbstring) but I face the ...
2
votes
1answer
6k views

Services timed out at boot but could start manually what could be the problem?

I've installed apche2 and php7.1-fpm recently and added them to boot with systemctl enable apache2 systemctl enable php7.1-fpm After rebooting the system systemctl status shows the following: sudo ...
0
votes
1answer
3k views

how to install php7.0-mbstring in debian 9.3

I can't install php7.0-mbstring: The following packages have unmet dependencies: php7.0-mbstring : Depends: php7.0-common (= 7.0.19-1) but 7.0.20-1~dotdeb+8.2 is to be installed E: Unable to ...
1
vote
2answers
1k views

I receive error while installing php 7 on redhat 7

I'm trying to install php 7 with below script: yum -y install php php-mysql php-pecl-zip php-xml php-mbstring php-gd but I receive below error: Error: Package: php-7.0.26-1.el7.remi.x86_64 (remi-...
0
votes
0answers
772 views

Can't install php7 and phpmyadmin in centos 6.9 - adding repository failed

I was trying to install php7 and phpmyadmin in centos 6.9. I have added epel-release and remi-release repository for centos 6 wget https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch....
0
votes
2answers
807 views

How can you restore the php ini files and .so files to their original configuration

I'm wokrking on upgrading my VM to PHP7 and I've run into a few issues such as: PHP Warning: PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/pdo.so' - /usr/lib64/php/modules/pdo....
0
votes
1answer
855 views

cli php.ini and web phpinfo() not pointed

li php.ini and web phpinfo() not pointed After setting up LAMP in centos I tried php -i | grep "Loaded Configuration File" Loaded Configuration File => /usr/local/lib/php.ini But on web <?...
0
votes
1answer
97 views

How to send a request to Pgpool2 server from php script?

Actualy i'm trying to create a postgres replication system using pgpool2 and docker containers, I created 2 containers running postgres and another container for pgpool2, so when I tried to connect to ...
2
votes
1answer
3k views

How to replace Php7 install from dotdeb with php7 from Stretch

I used PHP7 from the dotdeb packages for my install of Debian 8 Jessie. Now, I want to upgrade to Debian 9 Stretch (which has php7) and I want my Php7 package to be from Stretch and no more from ...
0
votes
1answer
1k views

PHP include file to all directory files by default

I have a config.php file which I want to include to all php files in the directory. Is there a way to include a file by default (hence I won't need to write require 'config.php' in all files)? Nginx
2
votes
1answer
2k views

PHP-FPM7 SIGSEGV - core dumped

I'm having some issues with just a single site that keeps segfaulting php-fpm7. Can't seem to pinpoint the exact moment when this occurs, i browse around on the site and wait and after a while when ...