Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

All Questions

Tagged with
1
vote
1answer
126 views

Install custom perl modules

I have build an RPM from a proprietary software collection in a CentOS 7 environment but the build process required executing some Perl modules (.pm files) found within the source itself. When I ...
0
votes
1answer
182 views

Cannot install URI::_foreign

Well I'm trying to install URI::_foreign on my server (I have root access) I get the following errors: CPAN: Storable loaded ok (v2.20) Going to read '/root/.cpan/Metadata' Database was generated on ...
0
votes
1answer
610 views

nginx fails with following error: nginx: [alert] perl_parse() failed: 2

I have nginx version 1.10.2 running on a CentOS 7 box. When I try to start the service I am getting the following error: Aug 15 16:08:50 user.mylabserver.com nginx[2704]: Can't locate nginx.pm in @...
0
votes
1answer
43 views

What is this unlink script action doing and under what conditions?

I'm debugging someone else's script and am confused by this: my $LOG = "/var/log/installfoo.log"; my $APPDIR = "/usr/share/foodir" my $RUN_ONCE = "$APPDIR/runonce"; # check for script if (-x $...
0
votes
1answer
59 views

Cannot locate RHN/DB.pm in @INC

I am trying to install spacewalk on CentOS 7 however i receive "Cannot locate RHN/DB.pm in @INC" error. It says compilation was aborted in spacewalk-setup line 33 which is "use RHN::DB ();". I tried ...
1
vote
0answers
890 views

How do I fix this broken CPAN and Perl installation

My Perl and cpan installation is broken. The perl version is shown below and this command executes and runs fine. >perl -v This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-...
-1
votes
1answer
741 views

snmptt cannot load PERL module

CentOS 7 I cannot move forward with starting snmptt. I use it to translate traps into nagios. I have been poking around with my system and this issue occured after I make uninstalled extra net-snmp ...
0
votes
2answers
459 views

Centos 7 - perl : Fails to install Crypt::OpenSSL::EC through cpan

Trying to install Crypt::OpenSSL::EC using cpan go the following result: $ cpan install Crypt::OpenSSL::EC Reading '/home/vafbuild/.cpan/Metadata' Database was generated on Mon, 05 Dec 2016 10:41:...
0
votes
1answer
407 views

Building autoconf-2.69 without root access on Centos 7 machine

I am using a Centos 7 machine, and I don't have root access. For this reason I have to compile everything locally, and hold them under my .local/ directory. I need to compile autoconf, and I compile ...
0
votes
1answer
358 views

perl(Inline) module is needed

I decided to view the contents of buffers cache using the tool called fincore while trying to install I have been getting the error as warning: fincore-1.9-1.el6.rf.x86_64.rpm: Header V3 DSA/SHA1 ...
1
vote
1answer
689 views

SSH into another VM via Perl / Sh script failing. Works manually

I want to run a Perl CGI script (a_web_page.cgi) from my dev box .1.20 that runs a bash script from the same folder (host_script.sh). This script then runs a SSH command to another server 1.10 that ...
1
vote
1answer
291 views

No 'Makefile' created KAMENSKY/Text-Bidi-2.11.tar.gz

I am trying to install following perl module via cpan on centos 6.x but unfortunately getting error. Please advise to solve. Text::Bidi Version: 0.03 Usage: Label batch PDF CPAN /usr/bin/cpan ...
0
votes
1answer
990 views

lwp-request Fails After Upgrade to Centos 7

I have a bash script that runs well on centos 6, which has an lwp-request in it. I upgraded my system to Centos 7, and the request fails to run: # lwp-request -E https://localhost/admin/startup GET ...
1
vote
1answer
673 views

Assp won't start

I tried to install ASSP (Anti-Spam SMTP Proxy Server),but when I try to start it I get the following: $ perl assp.pl Perl version 5.012003 (5.12.3) is at least recommended to run ASSP 2.4.3 (14313) ...
2
votes
2answers
3k views

how to install Padre in linux(CentOS)?

How to install Padre IDE tool in Linux(Centos) for Perl scripting language?
1
vote
1answer
126 views

foomatic-configure producing weird perl warnings

I am using CentOS 6.4 and trying to use the 'foomatic-configure' for print information and am receiving some weird errors: Perl: v5.10.1 foomatic: foomatic-4.0.4-1.el6_1.1.i686 Command line: ...
4
votes
5answers
8k views

fixing cpan by resetting it

So I ran into a simple little problem. I wasn't connected to the internet and started cpan. It started to configure for the first time and then when I realised a few seconds later that the internet ...
1
vote
1answer
389 views

Perl dependency issue

I've installed CentOS 6.3 (i386) recently. It has two perl binary /usr/bin/perl (v5.10.1) /usr/local/appx/perl/bin/perl (v5.8.8) My question: Is it possible to install some other funtinonality to ...