Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange
The results are in! See what nearly 90,000 developers picked as their most loved, dreaded, and desired coding languages and more in the 2019 Developer Survey.

Questions tagged [package-management]

tools for installing and maintaining software packages

4
votes
2answers
435 views

Creating a Debian package repository for distributing multiple versions of a custom deb package

We are building an application, which will be packaged into a DEB package. We would like to be able to install and (in the future) update this application on a number of Linux servers with minimal ...
1
vote
3answers
10k views

Unmet dependencies when trying to build chromium browser on Ubuntu 14.04

I am trying to install the necessary dependencies for building Chromium on Ubuntu 14.04, and I am facing the following message: The following packages have unmet dependencies: g++-4.8-multilib : ...
35
votes
4answers
183k views

How to install the latest Python version on Debian separately or upgrade?

I'm still new to Linux, so I'm still trying to understand where executables and their libraries are and how to install packages, so I have Debian Wheezy 7.3 which has these Python versions: Python 2....
1
vote
1answer
2k views

Mint 17.2 Synaptic Package Manager

I recently installed Mint 17.2 (Rafalea) on a HP-255 G1 laptop. It was one of the smoothest installs I have ever done. However I have found a major issue with the Synaptic Package Manager. Whilst it ...
-1
votes
2answers
3k views

Install a package manager on a terramaster NAS

I got this NAS and while it has a decent amount of features, I was hoping i could extend them a bit. It's running a dual core Celeron with 2gb of ram. I tried to find the Linux distro, but it seems ...
-2
votes
1answer
215 views

Dependency problems Linux Debian undetectable broken packages

I am just trying to do an upgrade (sudo apt upgrade), but it fails with error E: Broken Packages. Doing dpkg -l | grep broken and dpkg -l | grep held returned nothing. My sources.list looks as follows:...
4
votes
1answer
457 views

Using symbolic links and git to manage build versions

In general I follow the following workflow when I build any program (e.g. emacs, tmux, etc.) /home/opt/[name of the program]/builds/[version]/ bin lib share For example for a program like tmux I ...
-1
votes
0answers
10 views

Why can I run “emerge --ask” multiple times simultaneously

I recently installed gentoo and I'm installing chromium. This package takes hell long compiling, so I tried to emerge another package at the same time: xfce4-meta. I'm surprised portage led me emerge ...
3
votes
6answers
12k views

How to remove all software

How can I remove all software installed on my Linux distribution? I'm using Debian: $ uname -a Linux debian 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux I want to go back to the original ...
25
votes
9answers
27k views

How to apply updates on OpenBSD, NetBSD, and FreeBSD?

I'm using OpenBSD for quite a while now. All I do, however is go from one release to the next, always just doing an update. I configured the system so it works as my router and firewall, and it works ...
0
votes
0answers
21 views

python pip/pip3 defaults to --user behavior

I recently used pip install --user foo once and even though I did some other stuff, I can't imagine that any other command causes my pip install to use ~/.local/lib/python2.7/site-packages/ directory ...
1
vote
1answer
24 views

Debian/dpkg handle group id collision

In my network there is a special user group with the ID 101. Unfortunatelly, Debian wants to use the ID 101 for the group systemd-journal. Since it exists only locally, I assigned systemd-journal the ...
0
votes
1answer
68 views

Debian sources errors

When I try to update my packages on my Chromebook (with Linux installed on it) I do this: sudo apt-get update, and it gives me this error: Ign:1 https://deb.debian.org/debian stretch InRelease Ign:2 ...
0
votes
3answers
50 views

Linux/Debian dpkg & administrator errors

So today I ran into a bunch of errors while using the sudo command on my Chromebook with Linux installed. For example when I try to remove my Google Chrome beta application, I tried this: sudo apt-...
0
votes
0answers
9 views

How to list all packages marked as 'group'

The dnf command is able to mark packages as install, remove or group [1]. To list all packages marked as install, the command dnf repoquery --userinstalled [2] can be used. My question is: Is there a ...
3
votes
1answer
29 views

How to mark a base package as not user installed while avoiding dnf autoremove?

On a freshly installed Fedora system, base packages such as sudo are not counted as user installed, i.e. dnf repoquery --userinstalled | grep sudo comes back empty. At the same time, these packages ...
2
votes
1answer
3k views

Arch Linux installation (dual-booting with UEFI Windows)

I've tried VirtualBox, I've even given some unorthodox installation ways a go, like using Architect or Arch-Anywhere, but eventually found the vanilla ISO image to be much better and far more up to ...
0
votes
1answer
96 views

Problem due to incorrect libstdc++6

When I do sudo apt-get -f install I am getting Preparing to unpack .../libstdc++6_8.1.0-5ubuntu1~14.04_amd64.deb ... Unpacking libstdc++6:amd64 (8.1.0-5ubuntu1~14.04) over (5.4.0-6ubuntu1~16.04.10) .....
0
votes
1answer
24 views

How can i remove ImageMagick 7 completely from ubuntu 18.04?

I have to remove ImageMagick 7 completely from my system. I have a rails app which requires ImageMagick 6. I have tried the following commands to remove but nothing works. 'sudo apt remove --purge ...
-1
votes
1answer
19 views

Manjaro 18 (Arch) Installing Packages Outside Repository

So I recently switched to Manjaro. I am having an issue with installing MegaSync from mega.nz. When I download their package for Arch it gives me a .tar.xz file. I'm not familiar with .xz but it's an ...
0
votes
1answer
29 views

What exactly does it mean for packages to be conflicting?

I installed a package and pacman spit out a message like this: looking for conflicting packages... :: packageX and packageY are in conflict. Remove packageY? [y/N] I already managed to install the ...
7
votes
1answer
9k views

Can I disable unattended Debian package updates?

Does Debian have some sort of automated package update process? I'm using it on a set of fanless PCs and noted that one had become very slow recently. On inspection the network LED showed lots of ...
46
votes
3answers
65k views

Can I rollback an apt-get upgrade if something goes wrong?

Is there a way, before starting an aptitude upgrade or apt-get upgrade, to set up something so that you can "easily" rollback your system to the "apt" state it was before the actual upgrade, if ...
0
votes
2answers
35 views

NixOS - how is environment.systemPackages implemented

I've started using NixOS. As far as I understand Nix is a purpose built functional language to avoid side-effects. All packages are part of a giant attribute set but as everything is lazily evaluated ...
1
vote
4answers
99 views

Is there a way to delete all files/directories created by program?

A program I installed splattered files and directories in different places. I'm having to manually remove these files and directories. I know you can delete files and directories created by a user ...
0
votes
1answer
3k views

How to install gtk3 in CentOS?

I have gtk2 installed on my ec2 machine instance. In order to install the latest google-chrome/mozilla-firefox version, it requires libgtk3 to be installed in the machine Will there be any ...
3
votes
1answer
64 views

Unable to update glibc to the latest version

We use Katello/Satellite 6 to manage our repos/pkgs and subscribe our servers to it. In the Katello Web UI it says that glibc-2.12-1.212.el6.x86_64 and glibc-common-2.12-1.212.el6.x86_64 is an ...
2
votes
0answers
33 views

How do I use xbps with an authenticated proxy?

How do I use xbps with an authenticated proxy? what configuration do I have to do? I'm looking for an example because I've tried configuring the environment variable and nothing, I'm almost buying a ...
2
votes
1answer
685 views

Have pacmatic wrap yay wrap powerpill wrap pacman

I have a few preferences in regards to managing packages on Manjaro / Arch: pacmatic adds safety features when installing packages yay provides a consistent interface to both the official and AUR ...
0
votes
1answer
214 views

Deploying a package through puppet from URL

How can i install a package through puppet by using the URL of the .tar.gz of the package on centos 6 client. Is there any native support in puppet without installing anything extra on the puppet ...
4
votes
3answers
2k views

Uninstall dig command in centos 6?

I've realized that for some commands like wget and dig, we need to use the command yum to install them before we can use them. Doing some research the dig command doesn't come installed for security ...
0
votes
1answer
223 views

How to minimize the unnecessary files installed by package dependencies?

I'm trying to install packages with having as little files from their dependencies as possible, since system size is important to me. For example, when wanting to install a package, I could install ...
3
votes
1answer
105 views

Is it possible to disable ability to install from yum repos that may include dependencies?

Rather new to yum so excuse if I don't word something correctly. We're trying to use only in-house RPMs, so is it possible to enable users to be able to install only from our repo(s), without ...
3
votes
3answers
9k views

AUR and pacman GUI frontend for Arch

Do you know any good GUI for pacman and arch? Where I could view packages installed and possible to install? And of course do anything as in pacman.
0
votes
1answer
421 views

Installing ia32 Libs Need to Downgrade Packages

I've been trying to install ia32 libs for ADB and fastboot through apt-get but I get a message stating I have held broken packages. So I have tried Aptitude and instead Aptitude keeps telling me that ...
2
votes
1answer
2k views

How to install lsb_release in opensuse 13.2?

I want to know the command through which I can install lsb_release in opensuse 13.2 while using OpenSUSE 13.2 through a terminal.
2
votes
1answer
3k views

How to install php7.2 on Debian?

I have a problem in the installation of php. I have tested a lot of solution but without success. I'm using debian 8 server. Here is the error in french (sorry) In English this error speak about ...
0
votes
0answers
25 views

Anaconda Repository

I have a rhel server which I use as yum repository for my other servers. Now I need it to serve python packages as well. I found an anaconda repository to download packages: https://repo.continuum.io/...
0
votes
1answer
34 views

dnf not working properly on non fedora machine

I have installed dnf package on custom linux distribution(non fedora). dnf can able to pull and install the .rpm packages from the configured repository. I could not able to remove the packages via ...
1
vote
1answer
907 views

Where can I get the “kernel-default-debuginfo” package for SLES 11?

I'm using SLES 11 SP2 x86_64 and I want to install kernel-default-debuginfo package. But, I couldn't find it anywhere on the Novel website. Where can I find the mentioned package?
8
votes
2answers
980 views

What does the '@' mean in front of the repo name in `dnf list`?

When I want to list installed packages, I do it usually in one of two ways. The old fashioned way is using rpm -qa | grep <whatever I look for>, and that's that. But recently I wanted a more ...
1
vote
3answers
2k views

How to upgrade openssl 1.0.1 in debian

TL;DR: I'm trying to install a package that needs libssl 1.0.2 or greater but can't: # dpkg -i my_package_name_3.0.1.8_amd64.deb Selecting previously unselected package my_package_name. (Reading ...
0
votes
1answer
44 views

How can I install elementaryOS's terminal “pantheon-terminal” on Linux Mint?

I am trying to install elementaryOS (Juno)'s terminal emulator on Mint 19 Tessa. I checked the instruction at the git hub site https://github.com/elementary/terminal, and I installed all dependencies ...
0
votes
3answers
890 views

get notification when Red Hat releases update/patch for $PACKAGE

I wish to get email notifications when RedHat releases an update/patch for only certain packages. # rpm -qa | grep maria mariadb-5.5.41-2.el7_0.x86_64 mariadb-galera-common-5.5.41-2.el7ost.x86_64 ...
1
vote
1answer
28 views

Confusion on apt-cache policy: same origin but different versions?

Background: I have a Debian container that installs libapache2-mod-php and is running PHP 7.2 server. It has been set up half a year ago and is running fine. Problem: This week I've been trying to ...
1
vote
0answers
97 views

`apt update` results in consistent “Failed to Fetch” errors for different apt sources

After a recent update from Bionic-based Pop OS! 18.04 to Cosmic-based Pop OS! 18.10, executing apt update always results in Failed to Fetch .... Temporary failure resolving errors for few sites. ...
-4
votes
1answer
38 views

How can I install a package in a Docker Ubuntu container?

I use the default downloaded Ubuntu Docker image. I want to find the network interfaces and IP addresses in its container, so I would like to install the package containing ifconfig, but why do I fail?...
2
votes
1answer
56 views

RHEL/CentOS - How can I find all rpm packages which depends on a particular package?

Linux distribution: Red Hat Enterprise Linux Server release 6.10 (Santiago) Context: I need to uninstall all old versions of Java in my server. I have the list of java paths, example: /usr/lib/jvm/...
-2
votes
2answers
36 views

How do I get a list of all existing Debian source packages of all architectures online?

I need some online service that gives me all existing source packages in Debian. A source package is something like this: https://packages.debian.org/source/stretch/wireshark It contains several ...
0
votes
1answer
39 views

Error Installing Emacs25 Package on Ubuntu 16.04

I am trying to install Emacs25 package on Ubuntu 16.04 alongside Emacs 24 and Emacs-snapshot (currently Emacs 27.0.50). I ran the following commands sudo add-apt-repository ppa:kelleyk/emacs sudo ...