Questions tagged [octave]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
28 views

GNU Octave: fplot exponent problem

I use GNU Octave 4.4.1 (x86_64-pc-linux-gnu on Arch Linux), and I have problem with fplot function. I would like to know why fplot(@(x) 1/(1+25*x.^2),[-1,1]) Have a different result of fplot(@(x) (...
-1
votes
1answer
297 views

Trying to install Image package on Octave 4.4.1

I am using the following version of linux. e130167@instance-1:~$ lsb_release -a No LSB modules are available. Distributor ID: Debian Description: Debian GNU/Linux 9.6 (stretch) Release: 9.6 ...
3
votes
1answer
577 views

How to install octave 4.2.0 on my machine?

How can I install octave 4.2.0 or latest ? I have tried https://askubuntu.com/questions/945517/installing-latest-version-of-gnu-octave-when-i-have-already-installed-other-vers does not give flathub ...
-2
votes
2answers
548 views

what's problem with this octave installation?

$ sudo apt-get install octave Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have ...
0
votes
1answer
358 views

Why is octave package not showing up in apt search?

I'm using 'termux'(android terminal emulator ). I've recently installed Ubuntu inside it in a 'proot' environment. When I searched for octave package using 'apt search octave' , I can't find any ...
1
vote
0answers
53 views

Use sed to fix weird symbols on tex file generated by publish function from miscellaneous Octave package

I have an Octave code that among other things outputs: (x - 5)⋅(x - 4)⋅(x - 3)⋅(x - 2) ─────────────────────────────── 24 When using publish function from Octave miscellaneous ...
0
votes
1answer
99 views

Not able to update octave

As per Wiki page of GNU software octave latest version is 4.2.1 (Released in february 2017). I am using fedora 25 and the octave in my system is version 4.0.3 . I tried upgrading it to the latest ...
1
vote
1answer
5k views

pkg install -forge general bash: pkg: command not found

I'm running Debian stretch and want to be able to run my MATLAB code, using the GNU Octave packages. I type this into terminal pkg install -forge general and it gives me this error bash: pkg: ...
1
vote
2answers
319 views

Function System() using Octave

I have done a shortcut to open LTSpice simulator on terminal, to open the program typing "ltspice", I used the alias command and the path of the program and saved to bashrc. It's working pretty good ...
1
vote
0answers
1k views

Octave GUI doesn't launch on Ubuntu 16.04

I have installed Octave using the following commands: sudo apt-add-repository ppa:octave/stable sudo apt-get update sudo apt-get install octave Typing octave --no-gui in the shell launches Octave ...
1
vote
0answers
201 views

Compiling Octave: how to add a new item to the include directories for Qt?

Situation My distro is Ubuntu 14.04. I am installing Octave 4.2.1. I have a shell script doing this for me using GNU make. Octave is in search of Qt libraries. I wish to use the Qt5 5.8 binaries ...
2
votes
1answer
567 views

GNU Octave compilation fails with libinterp/.libs/liboctinterp.so: undefined reference to `Magick::*

Context My uname -rv is 4.4.0-64-generic #85~14.04.1-Ubuntu SMP Mon Feb 20 12:10:54 UTC 2017 --- My compiler is GNU gcc 6.3.0 --- I am compiling GNU Octave from source. I have been trying to compile ...
1
vote
0answers
91 views

How to configure 'readline' such that GNU/Octave's 'input' command can browse its history

In this script: #!/usr/bin/octave --line-editing a = input("command: ", "s"); a = input("command: ", "s"); during the second input, if you press the up arrow, it should show the command entered in ...
12
votes
7answers
17k views

Error running Octave in Ubuntu 16.04

I just followed the answer in: How to install Octave without GUI in Ubuntu 16.04? to install octave in ubuntu 16.04 and apparently it worked fine. Running octave-cli in terminal apparently works But ...
2
votes
1answer
2k views

Run GNU Octave script on multiple cores

I am computing Monte-Carlo simulations using GNU Octave 4.0.0 on my 4-core PC. The simulation takes almost 4 hours to compute the script for 50,000 times (specific to my problem), which is a lot of ...
8
votes
3answers
32k views

How to install Octave without GUI in Ubuntu 16.04?

I am really angry. Just installed the new ubuntu and run apt-get install octave. I got tons of crap installed (like Java, some QT libraries, and other pollution). How can I install Octave in Ubuntu ...
3
votes
2answers
652 views

Compiling Octave 4 with OpenGL .. X11 configure script linking error

I want compile Octave 4 with OpenGL/GUI support but don't know which packages to install on RHEL/CentOS system. I only get warning: configure: WARNING: OpenGL libs (GL and GLU) not found -- disabling ...
1
vote
0answers
38 views

How do I use octave to find the numerical solutions to a system of non-linear equations?

I have the following set of equations: acos(x/250)=t acos(w/300)=u asin(y/250)=u asin(z/300)=t w-x=150 z-y=150 How do I solve this system of non-linear equations using octave? The only documentation ...
0
votes
1answer
1k views

How to install Octave in Scientific Linux 6.5?

I am following the installation instruction for Scientific Linux on Ocatve website: # wget http://url/to/latest/epel-release-6-7.noarch.rpm # yum localinstall epel-release-6-7.noarch.rpm Then I type ...
1
vote
0answers
2k views

Octave - warning: unable to open X11 DISPLAY

My setup is as follows: Octave 3.6.4 Mac OS X Mavericks 2009 Macbook Pro I'm trying to run Octave in Terminal, with gnuplot. I'm trying to plot matrices in a graph, as part of an online Coursera ...
5
votes
2answers
16k views

Resolve missing package dependencies when trying to install octave

I am trying to install the octave software package on a RHEL 6 Workstation. I have installed the epel-release 6.5 package to enable the EPEL package repository. When I try to install the octave using ...
0
votes
1answer
148 views

Why does octave give different results for 9 ^ 1/2 and 9 ^ 0.5?

Lately I've been trying to brush up on the math I should have learned in high school. (I didn't pay much attention.) Regarding this, college entrance exams and Octave make a great pair. This morning ...
3
votes
1answer
2k views

Octave package installation: “couldn't create installation directory”

I am trying to install the statistics package (1.0.10) for Octave (3.2.4), which requires the miscellaneous package. When installing the miscellaneous package (1.0.11) I receive the following error: ...