Questions tagged [npm]

node package manager is a package manager for node.js

Filter by
Sorted by
Tagged with
0 votes
0 answers
29 views

PAM configuration pop up when running apt install npm (node)

Also asked this question here: https://serverfault.com/questions/1120767/pam-configuration-pop-up-when-running-apt-install-node Running Ubuntu 22.04 on a VPS; behavior persists on newly installed OS. ...
0 votes
2 answers
104 views

Installing nodejs in ubuntu via the downloaded file from nodejs website

I have downloaded the nodejs repository from nodejs website and I want to install it via node file in bin directory and I want to install it with gdebi or software installer app but the errors are: ...
1 vote
0 answers
51 views

Symlink npm to pnpm

My understanding is that pnpm is designed to be a drop-in replacement for npm. However, I'm not sure if this is true for all cases. Is it safe to just delete npm and symlink in pnpm or will that break ...
0 votes
0 answers
204 views

Read string from file and pass to command, keeping dollar sign intact

Consider a string stored in a file, which I need to read and pass to a Node script via NPM. But the string in the file contains a $, and is being interpreted as a variable and is replaced before being ...
  • 243
1 vote
0 answers
261 views

Figuring out which user is best to start pm2

I'm about to deploy a highly secure production server, which is running an nginx reverse proxy, which points to the backend server on nodeJS. When a user starts the server by typing in the "pm2 ...
1 vote
1 answer
286 views

bash/zsh hook - Add to PATH only if no matching file found

I am looking for a bash/zsh hook, that is invoked when a command is not found. Say I run some arbitrary executable: xyz foo --bar say that bash/zsh cannot find the executable. is there a way to ...
1 vote
0 answers
242 views

Make npm work in tails

The latest tails comes with nodejs v10.24.0. Trying to get tails to run a newer node has been unsuccessful even after running script from deb.nodesource.com/setup_14x which said buster was unsupported....
0 votes
1 answer
226 views

Facing an error while installing npm for neovim coc

I have installed coc.nvim and am now installing the dependencies. To do this I need to install npm. The command I'm using to install npm is sudo apt-get install npm. However, I get this error when ...
0 votes
0 answers
113 views

Running script at dockerfile for node image

I'm trying to run script file at dockerfile to node project. That script is adding themes repos to the core project - where the dockefile is built and running- . But when trying to run the dockerfile ...
0 votes
0 answers
88 views

Why is cronjob stoping the script execution after 60 seconds?

0 8 * * * /usr/local/bin/npm --prefix /root/myscript run start > /root/logs I can see at the log file that this script STARTS execution at 8am. Although, if the script does exceed more than 60 ...
0 votes
1 answer
507 views

Arch Linux Manjaro: npm start not detecting chrome and returning ENOENT error

I am using Manjaro and have downloaded google-chrome-stable from the AUR package. Even though google chrome is set as a default browser, npm start still defaults to opening firefox, after I deleted ...
  • 101
0 votes
1 answer
186 views

authentication for npm install during PuTTY ssh?

I'm connected via PuTTY ssh to a Linux Server (so it's not supposed to have a GUI). when I npm install something, due to some intranet network configuration, the http request is redirected as follows ...
  • 125
0 votes
0 answers
122 views

Npm won't install SOCKET.io due to Node version?

I need to install socket.io for my node program. So, whenever I try to install socket.io by running the following commandline instruction, it says node version needs to be greater than or equal to 10 ...
  • 133
0 votes
2 answers
153 views

installation of npm

I was trying to install npm.. └─$ sudo apt-get install npm I got ...
1 vote
0 answers
131 views

tar.unpack untar error while installing angular in Linux vm

I am installing Angular in Linux VM (3.10.0.1062) using command npm install @angular/cli@10.0.5 from Putty terminal, getting below error [host@machinename /]$ npm install @angular/cli@10.0.5 npm WARN ...
0 votes
2 answers
472 views

NPM: Unmet dependencies on Debian 9.13 Stretch

I'm trying to install NPM on a Google Cloud Platform Debian Instance running Debian 9.13 Stretch. However, if I try to use $ sudo apt install npm I get the following message Reading package lists... ...
  • 101
0 votes
1 answer
304 views

Can't run any serverless commands without error

Not sure if I've tagged this question correctly, but... I installed the serverless framework and went through a tutorial to deploy an app. All good. Then I changed into my actual project's directory ...
0 votes
0 answers
110 views

Ubuntu server NodeJS app exited due to lack of memory (npm err 137). Memory leak or lack of memory on server?

I am hosting a NodeJS app on a Ubuntu server. The server has 512 MB of RAM and is pretty basic since I am the only user of the app. Recently, the app ended exited with the following errors: npm ERR! ...
2 votes
1 answer
548 views

Unable to run npm install with version specification

I am trying to run a simple npm install with zsh terminal. npm install --save-dev @typescript-eslint/eslint-plugin@^4.0.0 zsh: no matches found: @typescript-eslint/eslint-plugin@^4.0.0 It appears ...
  • 123
0 votes
2 answers
30k views

lsof command not found in VS Code terminal

I am trying to start up my application with npm start, however I get the following errors: rm: cannot remove 'dist/': Device or resource busy When I try to run an lsof I get the error message: bash: ...
  • 467
3 votes
1 answer
2k views

How to install npm on my debian stretch?

nodejs installed on my debian stretch. nodejs -v v4.8.2 With same way ,i want to install npm. sudo aptitude install -f npm The following NEW packages will be installed: libjs-inherits{a} node-...
  • 361
0 votes
2 answers
260 views

shell script relative position from the file

I have almost no idea about shell scripts or commands in linux I have a project named projectx projectX happens to be in users/hardik/desktop/projectx I have created a shell script start.sh. This is ...
0 votes
0 answers
634 views

How do I remove unnecessary versions of node in Centos

I am trying to learn how to use node.js in centos 8 I have installed node.js and npm, and using npm I have installed inherits and n I have been following tutorials on different websites and have been ...
  • 169
0 votes
1 answer
62 views

After debian upgrade, npm is not working

I upgraded from Debian 9 to 10, and Emacs from 25 to 26.1. Then, npm was NOT working and missing but node was there. Then, re-installed npm using: $ sudo apt-get install npm npm succesfully ...
  • 33
0 votes
1 answer
528 views

NodeJS React Systemd Service not working

I am trying to set up a systemd service for a simple react application. This application is hosted in /home/myuser/test. Both npm and node are in the PATH and hard linked to /usr/bin. All the files ...
0 votes
1 answer
317 views

Getting error when installing bufferutil npm package

I've a problem install my application on my server. Locally everything works fine. The versions of node and npm are the same but I'm still getting this error during my install on the server: 91 ...
  • 203
1 vote
1 answer
120 views

Installed btlejuice package and can't seem to be able to uninstall it

I'm using Kali Linux 2020.1 and installed the btlejuice package yesterday via the command npm install -g btlejuice. Now I'm trying to remove it but when typing dpkg --list I can't see it in there. How ...
user avatar
6 votes
1 answer
243 views

When debian bugfix will appear on my system?

On my Debian 10 I've ran into same problem with npm as many people before: npm does not support Node.js v10.15.2 Searching for the fix I've found that the bug was fixed in debian: https://bugs....
  • 163
0 votes
1 answer
187 views

Vue.js on Debian 9 installation woes

I'm trying to install Vue.js on my Debian 9 OS and I'm getting this error message: Illegal instruction] - rollbackFailedOptional: verb npm-session 1fd93108cdc88b2 when I do this command: npm install ...
2 votes
1 answer
457 views

Deb build-dependencies in custom locations

I have a debian package with npm build dependency, e.g, the control file contains the line: Build-Depends: debhelper (>= 11), npm Building this package works fine if I have installed nodejs using ...
1 vote
0 answers
116 views

npm autocomplete broken if prefixed by double dash (--)

I notice this when using a command that accepts additional args after a double-dash, for example: npm test -- spec/blah-spec.js In a raw, clean, ZSH v5.3 install, tab-completion works properly: npm ...
1 vote
1 answer
9k views

EACCES: permission denied when using sudo

I'm trying to install a node package using NPM, but it just gives a permission error. I could install packages without any issues yesterday, but for some reason it has stopped working. asgeir@...
0 votes
1 answer
4k views

yum install npm fails with failure: repodata/repomd.xml from pgdg10

I am trying to install the npm through yum install npm command but it fails every time with the below log: epel/x86_64/metalink | 6.0 kB 00:00 google-...
2 votes
1 answer
1k views

How does one set up CodiMD as a personal wiki?

CodiMD is great for collaborative work, but I would like to use it for personal notes on my laptop (Ubuntu 18.04), configured so that it works without an internet connection and uses as few resources ...
0 votes
1 answer
279 views

Remove .gitignored folders and `node_modules` and `vendor` folders whilst I rsync them

On my GNU/Linux machine I want to backup a list of files specified in a text file names rsyncFolders.txt the idea is to keep the files I want and to exclude unwanted ones to backup. In these folders ...
1 vote
0 answers
3k views

npm : Depends: node-gyp (>= 3.6.2~) but it is not going to be installed

I did the following steps: git clone https://github.com/nibtehaz/NORTH-app.git curl -sL https://deb.nodesource.com/setup_10.x | sudo -E bash - sudo apt-get install -y nodejs npm install # which ...
3 votes
1 answer
823 views

Is there a way to package npm dependencies into a .deb package for offline deployment?

I've created a very simple debian .deb package that deploys my node-red project to the correct directory structure on a target machine. I also have a number of python/debian dependencies, which I've ...
  • 31
1 vote
1 answer
539 views

Durring npm install: fs.js... binding.copyFile... Unknown system error -122

I'm getting the following when installing @sentry/cli@1.39.1 in a fresh node_modules (existing project). Needed for @sentry/webpack-plugin. Is there any way I can find out more about this "unknown ...
1 vote
1 answer
525 views

Can not install npm

I want to make an smart mirror, before I decide to buy a Raspberry pi I want to preview it on my old computer. I installed Raspberry pi (desktop version from homepage of Raspberry). Everything was ...
  • 33
0 votes
1 answer
9k views

JSON on the command line with jq in Jenkins

I used jq -r '.version' package.json command to filter the version from package.json file using the terminal. Can we use jq command in Jenkins shell without locally installing it?
  • 191
0 votes
1 answer
2k views

Why is process not exiting and how to get it to exit

I have a server I want to run (on one HTTP port), and then another script (which runs (temporarily) on another port). I'm using a pipe in order to let these run concurrently, and brackets to group ...
2 votes
2 answers
4k views

How to update npm to latest version on Fedora

I've try to run this: sudo npm install npm@latest -g to test npm audit, but this command failed, I've got error: npm ERR! path /usr/lib/node_modules/npm/node_modules/fs-write-stream-atomic npm ERR! ...
  • 9,172
4 votes
2 answers
3k views

nodejs deb package seems to miss npm

I did on Debian testing sudo apt install nodejs but I'm missing npm. $ node -v v8.11.2 $ npm -v bash: npm: command not found What did I miss?
1 vote
1 answer
1k views

connect to server with netcat and receive *multiple* files with one request/connection

Say I have an http or tcp server running, which serves tarballs (.tgz files). Is there some way I can receive files individually so I can do something like this: nc localhost 5000 | how can I read ...
0 votes
0 answers
704 views

Use sudo to preserve ownership of created files (do not be owned by root but by user)

My question is simple but I couldn't find answers I need to use sudo npm install but I need the files installed to have my user's ownership, not root's. For example: sudo touch a will give me a file ...
0 votes
1 answer
3k views

Arch - Installing truffle via npm - npm ERR! write after end [closed]

I'm trying to install truffle, an ethereum development framework, via npm, running sudo npm i -D -g truffle. Unfortunately I'm getting the following error: npm ERR! code ERR_STREAM_WRITE_AFTER_END ...
  • 693
1 vote
2 answers
343 views

NPM fail on Debian 9

I'm trying to install jquery on Debian 9 and it fails. I have installed other packages using npm with no problem. When I execute npm install jquery, I get this error: npm WARN enoent ENOENT: no such ...
0 votes
1 answer
4k views

Why removing npm means removing nodejs as well on CentOS?

I'm trying to remove npm (EPEL repository), but yum wants me to remove nodejs as well. It's nodejs that is npm's dependency. Not the other way around. nodejs can live without npm just fine. Am I ...
  • 3,073
0 votes
0 answers
581 views

serverless update check failed error

I want to intsall serverless on my kali linux . In order to proceed for serverless installalation we need node js install , which i have already done . root@gpunk:~# npm --version 3.10.10 root@gpunk:~...
4 votes
2 answers
3k views

Trying to install debian package npm, makes apt-get to remove libssl-dev

:~/$ uname -a Linux hostname 4.9.0-4-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.51-1 (2017-09-28) x86_64 GNU/Linux I think that I have a clear dependency tree without broken packages. :~/$ sudo apt-get ...
  • 330