All Questions

Tagged with
1
vote
2answers
1k views

Error installing mysql-server on Debian 9 Stretch (dependency problems)

Using Debian 9.5, fresh install. I want to install mysql-server, but I run into dependency problems. sudo apt-get install mysql-server Reading package lists... Done Building dependency tree Reading ...
5
votes
1answer
1k views

Cannot install phpmyadmin

I cannod install phpmyadmin. The installation process fails with the following error. I can normally log in to the mysql database. What should I do? Normally I would expect "(using password: Yes)". ...
3
votes
5answers
22k views

error processing package mysql-community-server during apt-get upgrade

How can I solve this problem? root@ip-*******:/# apt-get upgrade Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... Done ...
2
votes
0answers
2k views

“You have held broken packages” when trying to update mysql

I'm tryng to update my mysql (currently at version 5.6) to 5.7 on my Debian 8, however I get this error when I'm reaching the last step. cat /etc/apt/sources.list gives the following: deb http://...
0
votes
1answer
685 views

Where is the BASEDIR for MySQL installed with APT on Ubuntu?

According to the MySQL document, 2.10.1 Initializing the Data Directory: Change location into the top-level directory of your MySQL installation, represented here by BASEDIR: shell> cd ...
1
vote
1answer
1k views

apt-get keeps trying to install package that's already installed

I'm using Bash for Windows and I had some troubles getting MySQL to work at some point. Now it's working fine, however it looks like there are some remnant of the installation process in apt-get. ...
0
votes
2answers
3k views

SQL install in Debian Jessie 8.0 failling: “Unable to locate package mysql” but sourcers.list is already configured.

I'm using Debian 8.0 Jessie and trying to install mysql. My /etc/apt/sources.list is ok but I don't have enough reputation points to post the configurations once only two links are allowed, but with ...
1
vote
2answers
1k views

upgrade mariadb 10.0.29+maria-1~jessie failed [closed]

using debian 8 with mariadb repository, apt-get dist-upgrade command failed for Mariadb Packages. Lecture des listes de paquets... Fait Construction de l'arbre des dépendances Lecture des ...
0
votes
1answer
882 views

MySQL install aborts with error

I'm trying to install MySQL on Raspbian Jessie. This has worked smoothly on another machine with an identical setup; however, on the second one, I can't get it to work. During package configuration, ...
2
votes
1answer
4k views

broken packages when installing mysql 5.6 using apt-get [closed]

I am trying to install mySql 5.6 on my Linux machine. I tried >apt-get install mysql-server-5.6 but I am getting the following error: mysql-server-5.6 : Depends: mysql-common (>= 5.6.22-1~)...
0
votes
1answer
694 views

Trouble opening phpmyadmin login page from the browser

I followed this link to install LAMP server on my Ubuntu 16.04 OS. In the steps given, I have skipped the installation of MariaDB (I went with mysql instead). Also, there was an error while installing ...
2
votes
0answers
54 views

apt-get commands won't return

I am working on a Raspberry Pi running Raspbian, and I think I'm having a problem with my apt-get. The problem originated with a MySQL server I was running. The server stopped seemingly at random, ...
0
votes
1answer
2k views

Upgrading mysql caused broken packages

I have Debian Jessie, and MySQL 5.6 from the MySQL Debian repository. This installation installes an apt sources.list.d entry that after sudo apt-get install mysql-community-server, it asks whether I ...
2
votes
3answers
10k views

How to install a newer version of MySQL workbench than is available in my distro's repos

I am trying to install a version of MySQL workbench that is NEWER than what is available to me through the regular debian repos. I started by adding testing, unstable and experimental repos, but even ...
2
votes
1answer
3k views

mysql-server-5.5 unmet dependencies each time running apt-get

Each time I run "sudo apt-get install package-name", the following error happened, even if I tried to install other packages other than mysql ones: You might want to run 'apt-get -f install' to ...
5
votes
2answers
5k views

Apt-get hangs on “Setting up mysql-server-5.5 (5.5.44-0+deb8u1)”

I'm on Debian 8 (stable) (Linux zenbook 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) x86_64 GNU/Linux) and tried to apt-get update && apt-get upgrade yesterday. There was an ...
1
vote
1answer
2k views

Debian - problems updating mysql 5.6

I just tried to update my dev database that runs on debian 7.8. Unfortunately it's now giving me the folllowing error: ... W: Failed to fetch http://repo.mysql.com/apt/debian/dists/wheezy/Release ...
2
votes
4answers
12k views

Cannot install mysql-server-5.5/the following packages have unmet dependencies [closed]

I'm using Ubuntu 14.04. I tried entering mysql with the following command: mysql -u root -p and I got the following message: The program mysql can be found on the following packages: mysql-client-...
12
votes
3answers
41k views

How can I upgrade MySQL in Debian using apt-get?

I'm using the Turnkey Linux virtual machine. The version of Debian in there is apparently on the "Wheezy" upgrade path (if that's what you call it). I'm not completely comfortable with Linux, as you ...
0
votes
3answers
22k views

Where Is MySQL installed on My Machine?

What is going on, everybody? Recently I have installed MySQL server on my Debian machine using Advanced Packaging Tool, and I am curious where it is installed and how I can find all the source files ...
1
vote
1answer
883 views

Uninstall MySQL server without removing or breaking any client functionality

I have an Ubuntu webserver which once used a local database, but we migrated it and now the database is stored remotely on a separate server accessed from many different places. The webserver runs ...
0
votes
2answers
178 views

phpmyadmin is listing my server version and client version as being different

In a continuation of this question, I have purged the 5.1 client via sudo apt-get purge mysql-client-core-5.1. I have reinstalled the 5.5 client - sudo apt-get --reinstall install mysql-client-5.5 ...
1
vote
1answer
321 views

Mint 12 - Error updating MySQL (mysql-client-core-5.1)

I have MySQL 5.5 installed via packages.dotdeb.org. When trying to update 5.1, which is also installed, I get the following error: E: /var/cache/apt/archives/mysql-client-core-5.1_5.1.66-0ubuntu0....
1
vote
1answer
282 views

How to purge package in debian without affecting other packages?

I had mysql-server-5.1 installed, then upgraded to mysql-server-5.5 and now upgraded to percona server (package percona-server-server-5.5). So now I have 2 mysql-server packages removed, but not ...
3
votes
1answer
5k views

How to enable an federated storage engine in the Debian MySQL package?

How would I enable an extra (in this case FEDERATED) storage engine in the mysql-server-5.1 package from Debian? I've installed mysql-server-5.1 via apt-get. But the SHOW ENGINES shows that federated ...
13
votes
2answers
34k views

How can I completely reinstall mysql?

I had to reboot in the middle of a large data import. I only have one mysql database, which has now been corrupted. How can I completely remove mysql and reinstall it? I've tried apt-get purge mysql-...
2
votes
1answer
2k views

Install MySQL from Bash Script

I'm coding a bash script to automate the process of deploying VPS servers but I'm having some trouble while trying to install MySQL from either aptitude/apt-get or yum, this is what I have so far: if ...