Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [libraries]

A library is a collection of functionality that programs can use. They can be dynamically loaded by a program, or they may be compiled into the program.

0
votes
0answers
254 views

Where do I get libc-2.17.so from for an Arm71 (32bit) linux machine

Trying to run command on an arm based version of Linux it complains: [root@N100 chromaprint-fpcalc-1.4-linux-armhf]# ./fpcalc ./fpcalc: /lib/libc.so.6: version `GLIBC_2.17' not found (required by ...
7
votes
1answer
16k views

What is the default value of LD_LIBRARY_PATH? [duplicate]

In my case, it seems as if LD_LIBRARY_PATH is set to the empty string. But all standard system tools still work fine, so I guess the dynamic linker checks for that case and uses some default for ...
1
vote
1answer
173 views

problem on zlib

I'm trying to install a package (named FIESTA). When I run make, I get a error message "zlib.h is required". I'm pretty sure that zlib1g is installed, and zlib.h can be found in /usr/include. How ...
1
vote
1answer
2k views

OBS Studio CMAKE unable to find FFmpeg?

I am trying to install OBS Studio on Debian 8. I tried to follow the official install guide for OBS Studio, but when I try to run cmake -DUNIX_STRUCTURE=1 DCMAKE_INSTALL_PREFIX=/usr .. I get the ...
0
votes
0answers
4k views

/usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found

I recently enabled libgl1-mesa-glx instead of libgl1-mesa-swx11. Now a couple of programs (like waterfox) refuse to run because they throw this error: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: ...
1
vote
0answers
158 views

Use different freetype libraries for GTK+ and Qt applications

For Fedora, there is a version of the freetype library in RPM Fusion which has patented sub-pixel rendering enabled. I would like to use the default version of freetype for KDE/Qt applications and the ...
1
vote
1answer
33 views

git - extract some files into shared 'lib'

There were some similar projects (projA and projB), which was developed separately and had similar files in it. No VCS was used. After time, some 'library' (let's call it lib directory) same for both ...
5
votes
2answers
4k views

configure: error: libcurl >= 7.28.0 library and headers are required with support for https

Hi I met an issue when I tried to configure for R installation. Basically, I tried to follow my previous installation process, (For some reason, I need to reinstall the same R in CentOS6 instead of ...
1
vote
1answer
5k views

How to link OpenSSL library in macOS using gcc?

I have OpenSSL installed through the Homebrew package manager. I have found the library and header files I need. The headers are: /usr/local/Cellar/openssl/1.0.2h_1/include/openssl /usr/local/...
1
vote
2answers
8k views

“ /lib64/libc.so.6: version `GLIBC_2.7' not found” Error when installation of R package

I met a problem when trying to install a R package called "GenomicFeatures", Error in dyn.load(file, DLLpath = DLLpath, ...) : unable to load shared object '$HOME/.R325/lib64/R/library/RCurl/libs/...
1
vote
1answer
267 views

libandroid-shmem showing invalid ELF header in chrooted linux

I have chrooted Debian in android marshmallow (snapdragon 650 [64bit]). I installed iceweasel in chrooted debian. But it showed this error :: (firefox:16210): Gdk-WARNING **: shmget failed: error ...
3
votes
1answer
2k views

bin/ld: cannot find -l<nameOfTheLibrary> install BigARTM - CentOS v7

I am trying to install BigARTM according to this tutorial on Centos 7. But I am getting this error: /bin/ld: cannot find -lboost_thread-mt /bin/ld: cannot find -lboost_program_options-mt /bin/ld: ...
-1
votes
2answers
51 views

Mounted /lib on logical volume - Can't run anything now

I'm working on a server which works with logical volumes. The root partition was full, basically because of a large /lib directory. I wanted to set this /lib to a logical partition, as I did already ...
1
vote
1answer
3k views

How to fix error: “symbol lookup error: /usr/local/lib/libQt5DBus.so.5: undefined symbol”?

I was using GNS3 network simulator fine for a while & then after few days When I start GNS3 Network Simulator, it is giving out following error, not sure what caused this. $ sudo gns3 GNS3 GUI ...
5
votes
2answers
556 views

How to list RPM packages that depend on a specific library?

I would like to determine which RPM packages on my Fedora 25 system depend on the libraries libLLVM-3.8.so and libclang-3.8.so. How do I?
-1
votes
1answer
558 views

libgstapp-1.0.so.0 is not an ELF file

I recently installed Ubuntu 16.10. This was a clean install, not an upgrade. I'm not sure what I did, but when I use apt to install packages, at the end, the following error are printed: Processing ...
4
votes
4answers
656 views

How to check if its safe to delete a library?

I found a library on my system and I don't think it is used anywhere. So for tidyness' sake I would delete it, but I want to make sure that I don't break anything. Specifically it's about libgme0. I ...
2
votes
2answers
638 views

What is the advantage of archiving C object files in a static library (.a file)?

I mean, as opposed to just linking to individual modules/object files. Why are groups of modules archived together? Doesn't it make the executable 1. larger, and 2. less secure (i.e. more vulnerable ...
2
votes
1answer
478 views

DNS Resolve in php chroot

I created a script which creates a chroot and sets up php-fpm and apache2 to make the site work. In my script I'm copying all required lib(s) to my chroot lib(s) dir(s) using this: fileArray=$(ldd /...
0
votes
0answers
266 views

Error in installation of older version of openssl

I am trying to compile openssl 0.9.6 (I know very old version) from source on ubuntu 16.04 LTS. I did following ./configure shared --openssldir=/home/segnate/dev/openssl make make ...
1
vote
2answers
705 views

./Telegram:error while loading shared libraries

Does anyone know this error? tar -x -v -f tsetup.0.10.19.tar.xz telegram/ telegram/updater telegram/telegram cd Telegram ./Telegram ./Telegram:error while loading shared libraries: libX11-xcb.so.1:...
1
vote
1answer
579 views

Not getting libglib2.0-dev (updated libraries) even after upgrading from Ubuntu 14.04 to 16.06

I wanted to compile and install something-for-reddit from git. As I went with ./configure.ac it showed below error. ./configure: line 5088: GLIB_GSETTINGS: command not found ./configure: line 5089: ...
2
votes
2answers
4k views

Problem with libx11.so.6: undefined symbol: xcb_wait_for_reply64

I have a problem with a one-day-old arch system. I accidentally moved /usr/lib/libX11.so.6 out of /usr/lib and then put it back. But now, I cannot launch Android Studio because of this: /usr/lib/jvm/...
1
vote
0answers
293 views

How do i Get SPI to work on allwinner A20 with kernel 4.4

I have configured the DTS file as required, am building my system using buildroot. find attached configuration file for buildroot and the configured DTS file. Up-to this point i can see the spidev ...
1
vote
1answer
2k views

Can't install glibc and glibc-common cause they need each other

I am working on RHEL 7.2 and I want to install LibXp.so.6 and LibXmu.so.6, but I have problem with glibc-common-2.17-105.el7.x86_64.rpm and glibc-2.17-105.el7.i686.rpm because they need each other. [...
-2
votes
1answer
308 views

Compile new boost library on linux with ancient kernel

I try to compile the newest boost library (1.62.0) on a Linux system with kernel version 2.6.18-92.1.13.el5 (from uname -r), and 2016 intel c++ compiler using gcc 6.1.0. The new intel c++ compiler ...
1
vote
1answer
58 views

How to know whether command is available in my linux distribution

We are shipping some drivers for some linux for our usb products. And in our driver code to make it distribution independent we have to dynamically get the distribution name and find whether there are ...
0
votes
1answer
1k views

Not able to install Netlink Protocol Library Suite (libnl3)?

I was trying to install newer version of Aircrack-ng so I downloaded it from the official site and tried to install it, but it gave the following error: /bin/sh: 1: pkg-config: not found /bin/sh: 1: ...
0
votes
1answer
94 views

python3 lib installed but no binary?

Default installation of dist Ubuntu 16.04 has /usr/lib/python3 installed but nothing inside of /usr/bin nor /usr/local/bin. Why would they include a lib folder with python3 and python2 without ...
2
votes
1answer
275 views

How can I separate directories to different partitions when installing OpenSUSE Leap (and other Linux distros)?

I have a Lenovo 80Q0001NUS laptop that uses a 128 GB SSD and a 1 TB HDD. Both drives now use GPT, and I need to use both Windows and Linux (OpenSUSE) via dual boot. I have my drives partitioned in ...
1
vote
1answer
429 views

libglui.so.2: cannot open shared object file

I am trying to run a executable box 2d game machine file. I am getting the following error : while loading shared libraries: libglui.so.2: cannot open shared object file: No such file ...
2
votes
1answer
305 views

How to get the shared librarys in order to make omxplayer work?

So basically I am trying to make omxplayer work on my raspberry PI 2 model B running on fedora arm 23, I downloaded the last .deb package for omx player and unpacked it and am actually trying to get ...
1
vote
1answer
304 views

Is it possible to use LD_LIBRARY_PATH to specify location of system libraries in Ubuntu

I have a 32-bit application which is developed and runs in Ubuntu 14.04. I tried running the application in Ubuntu12.04 and obviously it failed due to dependency issues. My question is, is it possible ...
1
vote
1answer
529 views

python Import requests error [closed]

So I keep getting this error everytime I try to run my python script. import requests ImportError: No module named requests I have checked all the answers to this issue in other previous questions ...
0
votes
1answer
71 views

trouble with R packages on linux

Why do I have to almost always install libraries and can't install an R package directly as on Windows? When installing a package named Hyfo, I have to install the libraries of three different ...
2
votes
1answer
662 views

Updated Flash on Firefox for Linux

Using the freshplayer wrapper one can use Chrome's flash player on Firefox and Firefox based browsers. The reason being that Adobe's flash is outdated. For Ubuntu 16.04 and 15.10. And possibly ...
1
vote
0answers
64 views

“Divinity: Original sin” game tries to load outdated libicuuc library

The game is Divinity: Original sin I was missing a few of the libraries it needs to run, one of which was libicuuc.so.54. I tried to update libicuuc but the version installed was .55, and the game ...
2
votes
1answer
6k views

How to change the path of shared libraries shown by ldd?

I am trying to make the postgis extension work on my system and it always spits out "$libdir/postgis2.2" no such file or directory error. For my curiosity I executed "ldd postgis-2.2.so" and it spits ...
1
vote
1answer
5k views

Permission denied on some shared libraries

First of all, I hope this is the right site to be posting this to. I get these errors when logging in as another user (ignatius): catch22bbs:~/Desktop # su ignatius ls: error while loading shared ...
0
votes
1answer
303 views

How can I compile an old PHP version and dependencies on debian 8? (PHP 5.1.0 in this case)

I'd like to install a very old PHP version on debian 8. Namely PHP 5.1.0. I will not use this in production, it is just for testing purposes. However, if I try to compile it I run into problems with ...
1
vote
1answer
661 views

How to fix missing libraries?

Just tried to uninstall bitcoind and install bitcoin-qt but now it says error while loading shared libraries : libminiupnpc.so.16 cannot open shared object file : no such file or directory pacman ...
1
vote
1answer
44 views

How strong is the promise that .so.x.y.z will exist?

I have an application that requires OpenCV 2.4.11 to link, so in my make file I ensure I use the following linker flag pattern: -l:libopencv_core.so.2.4.11 How robust is this assumption? My ...
3
votes
1answer
6k views

What is the purpose of libimf.so?

I am running Ubuntu 14.04 and am having various issues with libimf.so (see my questions on Ask Ubuntu: 1, 2). While waiting to sort those issues out, I am trying to figure out what libimf.so is ...
2
votes
2answers
488 views

“make” doesn't find an installed library

I am attempting to use make to compile purple-facebook, a plugin for pidgin. It requires json-glib, which I have installed, but whenever I attempt to compile, it returns fatal error: json-glib/json-...
1
vote
0answers
172 views

How to compile efivar 0.24?

I am having trouble compiling efivar 0.24 and have already searched on StackExchange for an answer I found one close How to compile efivar? but it didn't exactly solve my problem. make V=1 -j1 I get ...
1
vote
1answer
71 views

Deploy personal programs and scripts

I have a git project containing useful programs and scripts. Hierarchy looks like this: $ git clone https://github.com/myaccount/myutils.git $ tree myutils . ├── bash │ ├── do-this.sh │ ├── do-...
1
vote
1answer
292 views

How to use local shared library while compiling the FOSS project?

I want to compile guile on shared hosting but when I run ./configure I've got error: configure: error: GNU MP 4.1 or greater not found, see README so I've downloaded GMP and tried to install it ...
0
votes
1answer
71 views

Can I edit library with text editor?

I want to edit python library in Visual Studio Code. I dont know how to do it and editing in another folder and then sudo cp edited_file library_path is annoying. I tried something like sudo ./Visual\...
4
votes
1answer
2k views

ld cannot find -lgfortran

I'm trying to compile Knut (a maths program) on Arch Linux with CMake and I'm getting the following error: /usr/bin/ld: cannot find -lgfortran /usr/bin/ld: cannot find -lquadmath collect2: error: ld ...
1
vote
0answers
74 views

/etc/sysctl.conf abstraction for custom usage

Is there an abstraction model for configuration files like /etc/sysctl.conf ? I find it great for a few reasons, it's humanly readable, has nestable namespaces, hierachy of settings instead of one-...