Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [libraries]

A library is a collection of functionality that programs can use. They can be dynamically loaded by a program, or they may be compiled into the program.

2
votes
2answers
9k views

Install libjpeg.so.8 to CentOS 6.6

I need install libjpeg.so.8 to CentOS 6.6 but i do not understand how to do... I have installed libjpeg-turbo libjpeg-turbo-devel but libjpeg.so.8 there is not
3
votes
1answer
1k views

Arch Linux - make: error while loading shared libraries: libunistring

I keep getting this same error when trying to install various packages: make: error while loading shared libraries: libunistring.so.0: cannot open shared object file: No such file or directory It's ...
1
vote
1answer
96 views

Install both 32-bit and 64-bit versions of libgoogle-perftools-dev

I am on Debian Stretch and need google-perftools to profile some programs of mine. My machine is 64-bit; I build the programs for both 64 and 32-bit (using gcc -m32). I want to be able to profile both....
0
votes
0answers
109 views

Uninstall Netcdf and HDF libraries from Ubuntu

I have installed certain packages like ZLIB, HDF, and NETCDF for some model simulation purposes. Now, i have to redo some steps while configuring these packages (ZLIB, HDF, NETCDF), which means i need ...
3
votes
1answer
40 views

List all 32 Bit packages on a Gentoo System

How can I get a list of all installed 32 Bit packages on a Gentoo Linux system?
1
vote
1answer
3k views

How to fix error: “symbol lookup error: /usr/local/lib/libQt5DBus.so.5: undefined symbol”?

I was using GNS3 network simulator fine for a while & then after few days When I start GNS3 Network Simulator, it is giving out following error, not sure what caused this. $ sudo gns3 GNS3 GUI ...
1
vote
0answers
37 views

cannot find libarary error

I am trying to install a software "W" which requires some non standard packages like "XYZ". I am installing XYZ as instructed in the related site using the following commands ./configure -C make ...
0
votes
0answers
22 views

Problem finding required libraries on ubuntu 16.04

I have used the following command sudo apt-get install coinor-cbc and get the following result coinor-cbc is already the newest version However, when I am building a package which require some non-...
25
votes
4answers
3k views

How to execute library commands from the shell?

I wanted to simply calculate the length of a string (that is hash value). So, I opened terminal and did this: $ apropos length that returned me with a bunch of commands/functions having (3) or (3ssl)...
2
votes
2answers
2k views

How to use libraries installed with a package manager in GNU/Linux

I installed a library(for example lzma-dev) using a package manager(for example apt-get for Debian or Ubuntu). How can I use it? Where can I find the libs and headers? How about sos(dynamic libraries)?...
1
vote
2answers
82 views

Which is the “standard” configuration parser library used in Linux?

A very simple question, but very difficult to find. In an Linux application I don't want to use "my own" configuration parser, but use the one which (should be?) is already available. Simple to keep ...
1
vote
2answers
4k views

using ldconfig and ld.so.conf versus LD_LIBRARY_PATH

I often build various libraries from source code to play with, such as gmp-6.1.2, mpfr-4.0.1, and gcc-7.x. In doing so, I prefer to use --prefix=/usr/local/gcc-7.2.0 so I know exactly where it is ...
1
vote
1answer
669 views

Steam won't start on Arch Linux - possibly libGL error (nvidia)

Whenever I try to launch Steam I get the "Steam upgrading" loading screen for a split second and then every Steam process dies. When I run steam, steam-runtime or steam-native in terminal I get ...
1
vote
0answers
592 views

mod_rewrite: undefined symbol: lstat error

I compiled the mod rewrite for apache (version 1.3.0) however, when I try to run the server I have this error about mod_rewrite: Syntax error on line 27 of /home/myuser/apache/etc/httpd.conf: Cannot ...
2
votes
1answer
1k views

How to make a library linkable with g++ -l argument

How can I make a shared library which is in /usr/lib/some-path linkable with the g++ -l argument when compiling? As far as I know, to do what I want, I need to chmod 0755 the library .so file, create ...
2
votes
0answers
32 views

Upgrading Python3 Without Breaking Access to lib Folder

Upgrading Python3 package is always a big pain for me. Every time I upgrade from one version, e.g. 3.7.0, to another, e.g. 3.7.1, my python script loses access to my /usr/local/lib/python3.7/site-...
0
votes
0answers
560 views

Install libstdc++ 4.9.x from source but compiled with glibc 2.14

I am on a Red Hat Enterprise Linux Server release 6.6 (Santiago) Linux version 2.6.32-696.20.1.el6.x86_64 (mockbuild@x86-042.build.eng.bos.redhat.com) (gcc version 4.4.7 20120313 (Red Hat 4.4.7-18)...
3
votes
3answers
1k views

Set LD_LIBRARY_PATH correctly

I am using Docker with image of Ubuntu 16.04. I am using this docker to run: Import C++ classes in python with the help of boost.python Import matlab's python package in python with the help Matlab ...
1
vote
1answer
51 views

Building QuantLib on Amazon Linux

I am trying to get QuantLib version 1.13 running on Amazon Linux. I found some .rpm files at https://pkgs.org/download/QuantLib, although there is an up to date .rpm for Fedora, there isn't one for ...
1
vote
2answers
2k views

ERROR: Failed to build gem native extension on Arch (postgresql)

I can't install gem pg on Arch due to the error: Gem::Ext::BuildError: ERROR: Failed to build gem native extension. /home/alex/.rvm/rubies/ruby-2.1.1/bin/ruby extconf.rb checking for pg_config.....
48
votes
7answers
106k views

How to find out the dynamic libraries executables loads when run?

I want to find out the list of dynamic libraries a binary loads when run (With their full paths). I am using CentOS 6.0. How to do this?
5
votes
4answers
18k views

/usr/bin/ld: cannot find -lcrypt (rhel 6 )

System info [root@xilinx busybox-1.22.1]# uname -r 2.6.32-71.el6.x86_64 Following errors come when I make busybox on rhel 6: /usr/bin/ld: cannot find -lcrypt collect2: ld returned 1 exit status ...
0
votes
1answer
31 views

Tricky issue with stata and libpng

I use stata 14 in Linux mint 19.3. For some reason stata has a problem with the libpng included in Linux mint 19. To fix that, I followed a fix that installs an older version of libpng (see here) to ...
3
votes
2answers
1k views

Invoking a script with ld-linux.so?

I just downloaded a tar file that is supposed to include everything required to run a program that we can call some_binary. I extracted it's contents, and I see the following: A binary (let's call it ...
3
votes
1answer
2k views

Installing flash player for Firefox

I would like to install Flash player for Firefox on Linux. I downloaded the .tar.gz, and there are some compiled shared libraries. I am not sure how to make them work, and I am looking for a hint. ...
2
votes
2answers
4k views

Problem with libx11.so.6: undefined symbol: xcb_wait_for_reply64

I have a problem with a one-day-old arch system. I accidentally moved /usr/lib/libX11.so.6 out of /usr/lib and then put it back. But now, I cannot launch Android Studio because of this: /usr/lib/jvm/...
0
votes
1answer
27 views

Rebuild from src.rpm using new version

This is a follow up to my previous question regarding Building QuantLib on Amazon Linux. I followed the instructions in the answer posted by MLu: Download the source RPM (QuantLib-1.4-7.el7.src.rpm) ...
0
votes
1answer
87 views

The same curl binary shows different version of openssl on 2 different servers

so I have built curl (possibly incorrectly) on debian 9 x64, and after curl -V command I can see that it uses the new version: OpenSSL/1.1.0f After that, I copied the very same library into ...
1
vote
2answers
2k views

Google Chrome starts but fails to open https websites: “This site can’t be reached”

These were Chrome's error messages on the command line: ATTENTION: default value of option force_s3tc_enable overridden by environment. [11850:11915:0210/111421.109731:ERROR:bus.cc(394)] ...
0
votes
1answer
55 views

Weird problem with CUDA installation

I am experiencing a rather unusual problem with my CUDA installation on Linux Mint 18.3. After a clean reboot, running deviceQuery as a standard user: optirun ./deviceQuery returns FAIL, but if I do: ...
2
votes
3answers
845 views

Why does linux not allow multiple versions in the central repository?

It seems to me that a lot of the problems using Linux is because of mismatched dependencies. Specifically that you can't install two versions of a library. So if program A requires "lib1.2" and ...
3
votes
2answers
962 views

Package installation and dependencies - how to prevent installation of existing libraries?

I'm a relatively new Ubuntu server user, so I'm learning as I go. I have an issue with a software package I'm installing (QGIS) which has several dependencies one of them being gdal library. ...
0
votes
1answer
191 views

How to run programs with ld-linux.so?

The dynamic linker can be run either indirectly by running some dynamically linked program or shared object (in which case no command-line options to the dynamic linker can be passed and, in the ELF ...
1
vote
1answer
746 views

Unable to extend desktop with USB display adapter and libdlo

Anyone familiar with using libdlo for DisplayLink's USB display adapters? I've followed the instruction steps from README file of libdlo Install a compatible libusb version (0.13) $ ./configure ...
3
votes
1answer
2k views

bin/ld: cannot find -l<nameOfTheLibrary> install BigARTM - CentOS v7

I am trying to install BigARTM according to this tutorial on Centos 7. But I am getting this error: /bin/ld: cannot find -lboost_thread-mt /bin/ld: cannot find -lboost_program_options-mt /bin/ld: ...
3
votes
1answer
7k views

Yum says dependency “ libltdl.so.3” is required, but it's already installed?

I have spent a few hours trying to get ImageMagick installed. I finally got an old version uninstalled, but am struggling to get the newest version installed. When I run the following command: yum --...
0
votes
2answers
257 views

Cannot compile, missing libncurses5-dev

When I try make menuconfig I get this Install ncurses (ncurses-devel or libncurses-dev When I try to install it Package libncurses5-dev is not available, but is referred to by another package. ...
3
votes
1answer
258 views

Satisfying lib dependency

I have a program (which I will call foo here) compiled for x64 (my current arch). When I try to run it, it goes: ./foo: error while loading shared libraries: libgmp.so.3: cannot open shared object ...
2
votes
1answer
329 views

Is it possible to use multiple branch of the same library to make multiple sofware which require different version of this Library work?

I was wondering if it's possible to have multiple instances of a library in Linux. Example : Software A need the 1.0, 1.1 or 1.2 branch or older of Library X to work Software B need the 1.4 branch ...
9
votes
4answers
12k views

Stereo “tone-generator” for linux?

Is there something like a stereo (separate left-and right-channel) tone-generator for Linux? Where you can set volume and tone/pitch for each channel, and preferably also set the wave-form (sine, ...
1
vote
0answers
46 views

Undefined symbols : how do I figure dependency resolution?

I am trying to figure out how to handle the lack of dependency resolution in Slackware. I installed Gnumeric from slackware.pkgs.org, but it won't run with a number of ** (gnumeric:10645): ...
4
votes
3answers
542 views

Centos 7, I thought “yum install ___” was supposed to get all the dependencies, too?

I'm trying to get back into *nix again after many years away, and I'm running into a few headaches that I'm hoping you can help me with. I want to install Trillian onto my CentOS 7 box. I went to ...
1
vote
0answers
352 views

Cannot install libgstreamer-0.10 [duplicate]

I' using Debian 9 Cannot install libgstreamer-0.10.so I tried sudo apt-get install libgstreamer0.10-0 Reading package lists... Done Building dependency tree Reading state information... Done ...
0
votes
0answers
88 views

install vips library in openbsd

On OpenBSD, I need to install sharp, which require the vips library. When I use a prebaked vips tarball, <stephane@bandersnatch.22decembre.eu:/usr/local/src/libvips/vips-8.7.0> ./configure ...
2
votes
1answer
20 views

Installing dev libraries locally

I need to install libpng-dev locally on a system where I do not have sudo access This is required to compile a C application. What is the best way to proceed with this? Can this be installed from ...
-2
votes
1answer
152 views

How to verify that the installation of Apache Server works?

Debian 9.5 Apache HTTP Server 2.4.34 (httpd) After installing Apache from the official page with sudo make install, I want to check that the installation works starting the server: $ sudo /usr/local/...
1
vote
2answers
4k views

How to install libprotobuf?

By mistake i have deleted these libraries. I couldn't find a right way to reinstall it. /usr/lib/x86_64-linux-gnu/libprotobuf.so.8 /usr/lib/x86_64-linux-gnu/libprotobuf-c.so.0 To fix it, i tried to ...
1
vote
1answer
267 views

libandroid-shmem showing invalid ELF header in chrooted linux

I have chrooted Debian in android marshmallow (snapdragon 650 [64bit]). I installed iceweasel in chrooted debian. But it showed this error :: (firefox:16210): Gdk-WARNING **: shmget failed: error ...
0
votes
0answers
95 views

Use uClibc for single package

I'm having some issues using busybox and dns lookups. I found a claim that this a glibc problem. I'm on gentoo. I would like to compile busybox against uClibc, without replacing glibc on the system. ...
30
votes
3answers
118k views

Viewing Linux Library / Executable version info

In Windows, EXE and DLL have version info, including at least the following fields: file version product version internal name product name copyright In Linux Library / Executable: Which fields ...