Questions tagged [glibc]

glibc is GNU's implementation of the Standard C library.

4
votes
1answer
866 views

Debian: How to resolve relocation error?

I am running Debian 7.1. I tried to apt-get install -f, and messed up. All command line returns ln: relocation error: /lib/arm-linux-gnueabihf/libc.so.6: symbol _dl_find_dso_for_object, version ...
3
votes
1answer
654 views

How to make my ELF run with both new and old version of glibc?

When I'm compiling my elf, it is "best practice" to make it link against the oldest version of glibc I can, so it will work both on new and old versions of glibc. i.e. if I use realpath, which in ...
2
votes
1answer
145 views

Redhat and Centos servers glibc errors

Please forgive if I am not wording this correctly and my current lack of information, but I am losing my mind trying to figure this out and I am not currently behind the servers in question. I have ...
2
votes
1answer
1k views

How to install glibc version that corresponds to GCC 4.4 on RHEL5

We have a program with executables built on RHEL6 using GCC4.4 and we need to run it on RHEL5.5. But RHEL5.5, by default does not have the necessary version of glibc. Has anyone faced such an issue ...
2
votes
1answer
808 views

LFS 7.5 - Glibc-2.19 compile errors at section 6.9, are they fatal to my LFS build?

I am using a host Ubuntu 14.04 system, and I am currently going through the Linux From Scratch guide here. At section 6.9, http://www.linuxfromscratch.org/lfs/view/stable/chapter06/glibc.html, after ...
2
votes
1answer
876 views

Eglibc cannot compile suffix of object files while trying to cross compile

I'm currently making my way through Trac's CLFS book. When trying to configure the 32-bit version of EGLIBC-2.15, using the options: BUILD_CC="gcc" CC="${CLFS_TARGET}-gcc ${BUILD32}" \ AR="${...
1
vote
1answer
6k views

GLIBCXX_3.4.21 in CentOS

I have created c++ application in Ubuntu machine. I have copied binary to Centos machine. Got error: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.21' not found I have installed packages I thought ...
1
vote
1answer
2k views

Problems running glibc 2.14 on RHEL6

I am trying to run the latest version of the Android SDK on an RHEL6 box. I am getting errors that I need GLIBC 2.14. So I installed GLIBC 2.14 in /opt/glibc-2.14. I have set the LD_LIBRARY_PATH=/...
1
vote
1answer
2k views

How to fix ld-linux-x86-64.so.2 CRC mismatch?

Not sure how I came to getting this problem but for some reason ld-linux-x86-64.so.2 is reporting a CRC mismatch and it's effecting a program that I cannot open which results in a segfault. the ...
1
vote
1answer
228 views

Need general guide on how to build Linux Stream (LiS) under RedHat 6.2

Day 1 I have hit into some error, and the build simply fail, saying that there is some conflict. Thus I believe a .o file cannot be made and then result fatal error during linking, anyone have steps ...
0
votes
1answer
269 views

Update the glibc package Error

I was asked to fix the vulnerabilities for RHEL 7: GLIBC(RHSA-2018:3092). Based on the output given by Nessus. Remote package installed : glibc-2.17-222.el7 Should be : glibc-2.17-260....
0
votes
1answer
2k views

How to downgrade glibc-common from 2.17-260.el7 to 2.17-222.el7

I am trying to install gcc on my RHEL 7.6 Beta workstation. At the moment, I am doing it using the command yum install gcc, but I keep receiving this error: --> Finished Dependency Resolution ...
0
votes
1answer
188 views

Which distro has glibc 2.2.5 installed default?

I want to know which 64 bit distro has glibc 2.2.5 installed default. I found that debian 3 woody has that version.But I cannot download it. Please suggest how to do and where can I download ISO.
0
votes
1answer
349 views

Why could a call to `getaddrinfo()` fail with `EAI_SYSTEM` and errno set to `EBUSY` (“Device or resource busy”)?

I'm seeing this error when running apt update in containers, if that is useful information. apt spits out: System error resolving 'archive.ubuntu.com:80' - getaddrinfo (16: Device or resource busy) ...
0
votes
1answer
2k views

LD_LIBRARY_PATH not working - centos

I try to set new location for Glibc but LD_LIBRARY_PATH not working. I followed the first answer here: How to update glibc to 2.14 in CentOS 6.5 And when I run the script at the end: [taviad@...
0
votes
1answer
541 views

AMD Catalyst 15.302 Build Failure on Ubuntu Server 14.04.05

I'm trying to install the proprietary drivers for my Radeon R9 Fury graphics card. The files are fglrx_15.302, etc., and I'm getting them from here at AMD Drivers: I'm installing on Ubuntu Server 14....
0
votes
1answer
790 views

Running C++11 library with older libc

I have written a shared library using C++11 features, compiled with gcc 4.8, libc 2.18, which needs to be run on a client's CentOS 6 machine, which has gcc 4.4.7, libc 2.12. There are some symbols in ...
0
votes
1answer
272 views

Constraints on gcc / glibc versions between build and run

Probably a basic question but I did not manage to find a clear answer to it: Let's say I am compiling a code (with some parts in C) on a build server and run it on a different server. The build ...
0
votes
1answer
45 views

How can I check whether my cross-compilation of a dynamic library has been done correctly?

I used my arm toolchain to compile the glibc library, I have already deployed this on the target device (linux) with no issues. How can I be sure that my compilation and deployment is done correctly ...
0
votes
1answer
688 views

RedHat Glibc - multiple packages

Before I jump into the issue, I am using RedHat 6.5 and have no access to the internet to download yum updates due to environment restrictions. All I have in this case is the CD ROM (RHEL 6.5) to ...
4
votes
0answers
363 views

GNOME shell periodically crashing

I'm on a laptop running Arch Linux. As of a series of updates applied this morning, I've had some issues with GNOME crashing, and being reloaded, forcing me to log in again -- and while my tmux ...
4
votes
0answers
182 views

Highest version of glibc working on actual 386 hardware

I need to build a working minimal Linux environment that will run on ACTUAL 386 class hardware. I know that I have to use kernel <3.8, which is not a problem. The issue is with glibc, as it seems ...
2
votes
0answers
457 views

Is it possible to recover from corrupted libc on Redhat?

I have created the following unfortunate situation. While trying to resolve this error when running a binary : /lib64/libc.so.6 : version 'GLIBC_2.15' not found Looking further I found that libc....
2
votes
0answers
227 views

How to deal with “scriptlet failure in rpm package glibc” during upgrade to Fedora 24?

Actual message (from photo, not recorded in dnf system-upgrade log -1): Upgrading : glibc-2.23.1-18.fc24.x86_64 28/4874 warning: %trigger(cronie-1.4.12-1.fc21.x86_64) scriptlet failed, exit status ...
2
votes
0answers
1k views

GLIBC not loading even after source compilation

While I am installing chef , I am getting below error. [root@centos Tools]# chef-server-ctl reconfigure /opt/opscode/embedded/bin/ruby: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /...
2
votes
0answers
683 views

How to remove a broken installation of glibc

I just attempted to install glibc version 2.19 to my computer as follows: 1) I cloned the glibc git repo with $ cd ~ $ git clone git://sourceware.org/git/glibc.git 2) I checked out version 2.19 ...
2
votes
0answers
5k views

../lib/libc.so.6: version `GLIBC_2.12' not found

I'm running a debian wheezy (7.8) box and I just ran into a problem with an application that needs `GLIBC_2.12'. The glibc-linking seems confusing to me. Maybe someone can enlighten me? The program ...
2
votes
0answers
508 views

Determine libc version used to create static library

I am seeing symbol referencing errors with the static libraries I am using (available with OpenSPARC processor). I have glibc 2.15 on my system. How do I determine the version of glibc used to create ...
2
votes
0answers
262 views

How to install libc6 from unstable repository on Debian?

This is my server: Linux nn15.project.org 3.2.0-4-amd64 #1 SMP Debian 3.2.46-1 x86_64 GNU/Linux Debian GNU/Linux 7.1 (wheezy) Release: 7.1 I have sudo permissions. How can I install libc6 from ...
1
vote
0answers
103 views

Making a CentOS 6.x installation compatible with Xilinx ISE 14.7

I would like to run version 14.7 of Xilinx ISE, which is a closed-source software. When it originally came out in 2013, it was supposed to be running on RHEL 6, so I think using CentOS 6.x should be ...
1
vote
0answers
179 views

How to install glib2.14 in centos along with existing glib in centos 6.7

I wont able to run my electron app in centos 6.7 which says, G_LIB2.14 and G_LIB2.15 not found... i gone through many sites since which says updating glib was not a good method will affect other UI ...
1
vote
0answers
197 views

upgrading GNU libc (Debian Sid)

I'm running Debian/Sid/x86-64 on my desktop (mostly for development tasks). Current kernel is Debian 4.12.13 I'm quite interested by the latest features of GNU libc 2.26 The current libc on my ...
1
vote
0answers
160 views

How to add variables to getconf?

According to the getconf man page: NAME getconf — get configuration values SYNOPSIS getconf [−v specification] system_var ... DESCRIPTION In the first synopsis form, ...
1
vote
0answers
886 views

Installation of glibc in my directory

Hi for the reason here, I would like to install glibc in my own directory. I tried to follow the "HOWTO" here wget http://ftp.gnu.org/gnu/libc/glibc-2.7.tar.gz tar xzvf glibc-2.7.tar.gz wget https:/...
1
vote
0answers
756 views

Applications reporting “Illegal instruction” after upgrading glibc

Background Info: Linux OS: Stripped down, minimalistic and very customized (no apt-get, yum, etc) Linux Kernel: 2.6.19.1 Current glibc version: 2.3.6 Target glibc version: 2.6.1 Issue: ...
1
vote
0answers
1k views

yum update glibc - ERROR with rpm_check_debug vs depsolve:

I want to update my system with yum update but I get only errors starting with these two lines: Running rpm_check_debug ERROR with rpm_check_debug vs depsolve: Then, I tried only to update the ...
1
vote
0answers
365 views

Ubuntu unzip error: sysmalloc assertion failed

I'm trying to unzip a multipart zip file (that I had originally zipped in Windows using WinRAR). The file consists of 4 parts: me.zip and me.z01, me.z02, me.z03 and me.z04. The command I'm using to ...
1
vote
0answers
3k views

Broken System due to upgrading libc6

I am using Kali, and I tried to upgrade libc6, because it comes with a lower version than I need. After downloading the latest package from the debian repo (https://packages.debian.org/sid/amd64/libc6/...
1
vote
0answers
777 views

OpenEmbedded: root account doesn't exist!

I'm using the current OpenEmbedded system from: http://git.openembedded.org/openembedded-core/tree/ (For what it's worth, I'm also pulling in layers from http://git.openembedded.org/meta-openembedded/...
0
votes
0answers
14 views

install glibc to specific folder with gcc in specific folder

There is no answer in installation-of-glibc-in-my-directory OS: x86_64. cat /etc/redhat-release Red Hat Enterprise Linux Server release 6.3 (Santiago) Things I want to do: installing glibc-2.23....
0
votes
0answers
30 views

What is “arm-linux-gnueabihf/ld-2.24.so”?

When i $ file /bin/bash on my raspberry, it says interpreter arm-linux-gnueabihf/ld-2.24.so Is it an "ELF shared object" or a "binary program as Dynamic linker"?
0
votes
0answers
32 views

Browsers recomendations that work without “modern” glibc and libstdc++

Recently a website that I use was modified, and with that, I can no longer bid on an auction I participate in. I use an Firefox 30, a Firefox 45 and a Palemoon 27.9.4, but neither works anymore. To ...
0
votes
0answers
117 views

Cross Compiling GCC - 'glibc' on windows for linux platform

I am trying to cross compile the gcc for linux - i686-elf platform from windows PC. As per the toolchain steps, I have successfully compiled: binutils using /binutils-x.y.z/configure --target=$TARGET ...
0
votes
0answers
249 views

locale & locale-gen: command not found, probably a problem with GCC? - void linux

I have a problem with my system - void linux. At first I have found that one app wasnt working correctly. When I tried to edit the Flameshot configuration by right-clicking on its icon and clicking "...
0
votes
0answers
68 views

building glibc 2.16 from source throws error

I am trying to build glibc-2.16.0 from source following these steps. The configure step worked fine but when I run make it results in an error /tmp/ccZNttGz.s: Error: `_obstack@GLIBC_2.2.5' can't be ...
0
votes
0answers
54 views

How to check if `libc`, `font` and `terminal` all agree on Unicode version?

In my case, when I open certain files in tmux such as this file, and have multiple panes, the characters overflow the pane's boundaries. Nicholas Marriott suggested that the libc, font and terminal ...
0
votes
0answers
287 views

does software requiring newer version of glibc = Operating System update?

I am trying to test a newer version of a software package and get this error message when trying to launch Error: unsupported version of GNU C Library (glibc) minimum supported version : 2.12 ...
0
votes
0answers
753 views

Building glibc doesn't produce 64 bit libc.so.6

I'm trying to build glibc with a 64bit version of libc.so.6 since a library I'm trying to use wants glibc_2.14+ but it isn't provided because the system I'm running on I don't have root access and the ...
0
votes
0answers
851 views

How to manually upgrade libc6?

I have a live linux distro, taken from this article. My working linux is Ubuntu 14 x64 where I build the live distro. I need to add an application to distro, so I copied executable to bin folder, ...
0
votes
0answers
451 views

SIGSEV on lots of GUI-software on arch linux. Seems to be glibc related

On my arch linux install, I can't open firefox, evolution, geary, midori and other software. All CLI-stuff I've tried works flawlessly, and also google-chrome-unstable, vlc and others. When ran in gdb ...