All Questions

Tagged with
Filter by
Sorted by
Tagged with
0
votes
1answer
17 views

Error building Docker container images on CentOS 7

I'm trying to build a CentOS 7 Docker container from a minimal template as below FROM centos:AUTO_SELECT_VERSION RUN yum -y install yum-plugin-ovl \ && yum -y install lsof perl file tar ...
3
votes
1answer
293 views

Unable to update glibc to the latest version

We use Katello/Satellite 6 to manage our repos/pkgs and subscribe our servers to it. In the Katello Web UI it says that glibc-2.12-1.212.el6.x86_64 and glibc-common-2.12-1.212.el6.x86_64 is an ...
0
votes
1answer
244 views

I want to update the glibc version from 2.17-222.el7.x86_64 to 2.17-260.el7

I want to update the glibc version from 2.17-222.el7.x86_64 to 2.17-260.el7. Will there be any effect ? IS 2.17-260.el7 compatible to centos 7.2 as all my machines are in centos 7.2 only.
-1
votes
1answer
703 views

GLIBCXX_3.4.20 not found

My issue is: Failed (/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by plugins) I have installed g++ (GCC) 4.9.1 20140922 (Red Hat 4.9.1-10) and centos version 6.10 (64 bit)
0
votes
1answer
810 views

Glibc requirement update for Dropbox

Dropbox recently updated their glibc requirement to version 2.19. Centos 7 has version 2.17. It seems not to be a good idea to replace glibc manually. Is there any other workaround?
1
vote
0answers
111 views

Making a CentOS 6.x installation compatible with Xilinx ISE 14.7

I would like to run version 14.7 of Xilinx ISE, which is a closed-source software. When it originally came out in 2013, it was supposed to be running on RHEL 6, so I think using CentOS 6.x should be ...
1
vote
1answer
89 views

How can I install a present-day version of glibc on CentOS 5, without disturbing any existing software?

I would like to run present-day versions of git, python, curl, and other common programs on a machine that is permanently stuck on CentOS 5. I have been able to walk the compiler version up far enough ...
1
vote
0answers
183 views

How to install glib2.14 in centos along with existing glib in centos 6.7

I wont able to run my electron app in centos 6.7 which says, G_LIB2.14 and G_LIB2.15 not found... i gone through many sites since which says updating glib was not a good method will affect other UI ...
1
vote
1answer
6k views

GLIBCXX_3.4.21 in CentOS

I have created c++ application in Ubuntu machine. I have copied binary to Centos machine. Got error: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.21' not found I have installed packages I thought ...
0
votes
2answers
791 views

Unable to run yum update

Trying to run yum update, and yum update google-chrome-stable but receiving this error. I am actually trying to install mssql tools, and I think it requires me to do this? Anyway I need to be able ...
1
vote
1answer
3k views

Installing Tensorflow on CentOS 6.9 (GCC, GLIBC, and binutils problem)

I have been having a tremendous trouble installing Tensorflow on CentOS 6.9. I tried to follow the instruction installing Tensorflow on CentOS using Anaconda3 (naturally for Python 3, Python 3.5.3 ...
6
votes
1answer
5k views

Rpmdb checksum is invalid - Trying to install gcc in a CentOS 7.2 docker image

So I'm trying to create a Docker image that contains gcc. I'm running the command RUN yum -y install gcc within my Dockerfile. It downloads the package until it finally fails trying to install a ...
0
votes
2answers
651 views

CentOS 6 glibc Update issue

my centOS version is centos-release-6-6.el6.centos.12.2.x86_64 I have executed the following commands to extract and install glibc-2.15 tar zxvf glibc-2.14.tar.gz cd glibc-2.14 mkdir build cd build ...
0
votes
1answer
941 views

create new locale on centos 6

Last Night there was power failure and the system was shutdown. When system was stated in morning, PostgreSQL db server could not start. While looking at the pgstartup.log file, following lines were ...
0
votes
1answer
2k views

LD_LIBRARY_PATH not working - centos

I try to set new location for Glibc but LD_LIBRARY_PATH not working. I followed the first answer here: How to update glibc to 2.14 in CentOS 6.5 And when I run the script at the end: [taviad@...
-1
votes
1answer
176 views

Compiling Firefox 50 under GLibc 2.12

I've successfully been able to configure the latest Firefox (source) without errors. All the required dependencies are in place (i.e. GCC 4.9.2 via devtoolset-3, Python 2.7, Yasm, libffi 3.2.1, and on)...
4
votes
1answer
1k views

CentOS 7: enabling blowfish hashes for password authentication

In our organization, we are distributing pre-hashed password values for a number of local accounts. Currently, these accounts' passwords are hashed using Blowfish ($2a$[...]) or Blowfish-8-bit ($2y$[.....
2
votes
1answer
147 views

Redhat and Centos servers glibc errors

Please forgive if I am not wording this correctly and my current lack of information, but I am losing my mind trying to figure this out and I am not currently behind the servers in question. I have ...
0
votes
1answer
1k views

Updating glibc to 2.21 on CentOS

I need to install MySQL 5.6 on a CentOS box. I found what seemed to be a simple tutorial, but the first command (sudo yum install my-sql-community-server) resulted in this group of errors: I ran yum ...
2
votes
1answer
12k views

can not install mysql-server on centos 6.7 32bit . Error: need rpm?

when I try to install mysql-server on centos with this command: yum install mysql-server server replies: Loaded plugins: fastestmirror, security Setting up Install Process Loading mirror speeds ...
1
vote
0answers
1k views

yum update glibc - ERROR with rpm_check_debug vs depsolve:

I want to update my system with yum update but I get only errors starting with these two lines: Running rpm_check_debug ERROR with rpm_check_debug vs depsolve: Then, I tried only to update the ...
6
votes
3answers
20k views

Yum says a package is installed, and not installed, and it's blocking other packages from being installed

I am trying to install a new package (glibc-static), and I get the following error ---> Package nss-softokn-freebl.i686 0:3.14.3-18.el6_6 will be installed --> Finished Dependency Resolution ...
2
votes
2answers
114 views

Ghost vulnerability - recompile C/C++ programs?

I've CentOS 6.0 server with glibc-2.12-1.7.el6.x86_64 running many open source services and some of my own C programs. To fix ghost vulnerability, I need to update it to glibc-2.12-1.149.el6_6.5. ...
4
votes
2answers
8k views

Cannot update glibc on CentOS 7

I have CentOS 7 installed. I want to install the APR package for Apache, and I'm told I cannot install it because it requires at least glibc.2.14 while I have glibc.2.12 installed. I have downloaded ...
44
votes
3answers
143k views

How to update glibc to 2.14 in CentOS 6.5

I want to install Android NDK on my CentOS 6.5 machine. But when I ran the program, it says it needs glibc 2.14 to be able to run. My CentOS 6.5 only has Glibc 2.12 installed. So I tried to update ...
9
votes
2answers
10k views

No 32 development library error after install glibc-devel.i686

I am trying to install gcc 4.9.0 on centOS 6. During ./configure there is an error coming up: /usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.4.7/libgcc_s.so when searching for -...
0
votes
1answer
6k views

Centos 6.5 iconv 2.5 glibc

I'm using Centos 6.5 x64 for developing purposes. I need to install iconv 2.5 but could not find how. Centos 6.5 glibc version is 2.12 On Centos 5.9 glibc version is 2.5 Why newer Centos uses older ...
2
votes
2answers
16k views

CentOS yum install gcc error: glibc-common conflicts with glibc

I met a problem with installing gcc on my CentOS. Outputs of my command sudo yum install gcc: Loaded plugins: fastestmirror Loading mirror speeds from cached hostfile * addons: centos.ustc.edu.cn *...
3
votes
2answers
4k views

llvm and clang on CentOS 5 without root permissions?

I am trying to have llvm and clang on a centOS 5 without root permissions. I tried to do it downloading llvm and clang src packages and trying the ususal configure, make and make install steps as ...
4
votes
1answer
2k views

CentOS 4.8 and glibc 2.5

How would I go about installing glibc 2.5 on CentOS 4.8? I know CentOS 4.8 has been EOL'd, which is all good and well. However, the environment that I am working in is using this version, and will ...
0
votes
2answers
758 views

Unable to install Mono 2.6 on CentOS

I have an application that breaks on mono 2.10, so I'm trying to install an older mono instead. I found an RPM and tried to install it, but it won't install (I believe) because the glibc and gcc ...