Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [gem]

The tag has no usage guidance.

0
votes
0answers
8 views

Bundler issues upon terminal startup

Whenever I start my terminal, it gives me this output right from the get-go: Traceback (most recent call last): 2: from /usr/local/bin/fusuma:23:in `<main>' 1: from /usr/lib/ruby/2.5.0/...
1
vote
1answer
1k views

gem install bundler, bundle not working

So this is a bit weird. Gem works fine. When I go to gem install bundler, the system outputs the following: Successfully installed bundler-1.16.2 1 gem installed When I check to see what gems ...
1
vote
0answers
229 views

Can't install ruby on rails MacOSX

While trying to install ruby on rails with sudo gem install rails I get the following error Building native extensions. This could take a while... ERROR: Error installing rails: ERROR: Failed ...
0
votes
1answer
286 views

How do I get sudo to read my ~/.gemrc file?

I'm using Debian Linux, Ruby on Rails 5 on Apache with Passenger. I crated the file ~/.gemrc gem: --no-rdoc --no-ri However, I'm running the command sudo bundle install and it doesn't seem to be ...
0
votes
1answer
264 views

openSUSE Leap 42.3: Cannot install Jekyll due to dependency issues

I'm trying to install Jekyll on my Linode server running openSUSE Leap 42.3, but Zypper gives me this error: # zypper install ruby2.1-rubygem-jekyll Loading repository data... Reading installed ...
3
votes
1answer
1k views

Gem install producing “OpenSSL” error

For at least a week now i have been trying to install Bettercap on my Raspberry PI using gem but whenever i type in: sudo gem install bettercap i receive an error message that says ERROR: While ...
1
vote
1answer
36 views

How to start gem ffaker in Debian?

I install ffaker but cannot find it in my PATH masi@masi:~$ sudo gem install ffaker Fetching: ffaker-2.6.0.gem (100%) Successfully installed ffaker-2.6.0 Parsing documentation for ffaker-2.6.0 ...
1
vote
1answer
153 views

How can I use ruby gem commands like bundler when ruby is installed by nix package manager?

I'm new to nix package manager. After installing nix into Ubuntu 16.04 LTS(Japanese translated version), I installed ruby with nix-env command. Then I did gem install bundler. That seemed to work ...
0
votes
1answer
735 views

Ruby version issues

I have been practising setting up a production environment with puppet, and now I'm setting up everything to accommodate HTTP requests with Apache. Since Puppet runs on Ruby, I also need Passenger ...
2
votes
0answers
469 views

x64_mingw not a valid platform - Rails 5

Bluehost Shared Server ruby -v 2.2.2 rails -v 5.0.0.1 gem -v 2.4.5 ~/.bashrc export HPATH=$HOME export GEM_HOME=$HPATH/ruby/gems export GEM_PATH=$GEM_HOME:/lib64/ruby/gems/1.9.3 export GEM_CACHE=$...
0
votes
2answers
1k views

Is there a way to use this command without having to type 'y' all the time?

I am trying to remove all ruby gems before uninstalling ruby. The command I am using is: sudo gem uninstall --all to achieve this. However, I have to type y continually to remove things. Is ...
0
votes
2answers
2k views

Ruby gems not recognized in bash script

I have built a node.js app that listens for webhooks. Currently it is used to build a jekyll website. I have configured it on my server and jekyll build works perfectly when I run it in the root of ...
4
votes
0answers
971 views

How to install a Ruby gem on Arch Linux using Puppet?

I've got the following: class travis_linter { include shell package { 'travis-lint': ensure => latest, provider => gem, } } When I try to test it, however, I get the following ...
2
votes
1answer
1k views

mysql2 gem build error when installing redmine

when i tried installing redmine with bundle install --without development test I received this build error: Fetching gem metadata from https://rubygems.org/......... Resolving dependencies...............
0
votes
2answers
604 views

Installing Jekyll on Elementary OS using gem

When I try to install Jekyll on Elementary OS Luna with the command sudo gem install jekyll --no-rdoc --no-ri I get the following error. -- rbconfig (LoadError) from /usr/lib/ruby/vendor_ruby/1.8/...
8
votes
2answers
10k views

How to specify a higher ruby version for installing a gem?

I install a ruby package. $ sudo gem install pdfbeads ERROR: Error installing pdfbeads: nokogiri requires Ruby version >= 1.9.2. says that it needs ruby version greater than 1.9.1. My ruby ...