Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [gcc]

Questions regarding GNU Compiler Collection Suite.

4
votes
0answers
96 views

Compile a library aiming to reduce size as much as possible

I have to 'squeeze' all the needed code to run ldaps on an embedded system. So the 3 MiB of lybcrypto and almost 700KiB of libssl are way too much. I'm now experimenting on ldapsearch because reading ...
3
votes
0answers
191 views

Using a NFS for gcc, Apache, PHP, MySQL, glibc

I have 7 SLES VM. I am compiling always the newest version of gcc and all dependencies. Apache and all dependencies. PHP and all dependencies. MySQL and all dependencies. glibc and all dependencies. ...
3
votes
0answers
3k views

Cross Compiling Openssl for MIPS

I've been trying to cross compile Ncat for the MIPS architecture (big endian), and I really need SSL support, so I first must compile OpenSSL. I downloaded the latest version from Github and ...
3
votes
0answers
362 views

Remove package with yum but leave libraries in place?

During setup on a specific set of servers, I need gcc-c++ installed to compile some of the software I am setting up. After install is complete I need to remove the compiler for security reasons. ...
3
votes
0answers
4k views

Custom GCC installation - how should I set my environment variables?

After some pains I was finally able to build me a gcc 4.9.3 (I don't have root on the machine I'm working on, and Fedora 22 doesn't package gcc 4.9 anyway). And it even works, i.e. using it to compile ...
3
votes
0answers
2k views

-fstack-protector-strong not supported by compiler gcc 4.8.3

On Fedora 20, I need to install a linux driver for a particular PCI express serial port card which is given by the manufaturer. In order to do this, I have to compile the source code of the driver. ...
3
votes
0answers
1k views

Compile parameters for MIPS based codesourcery toolchain?

I installed codesourcery cross compile toolchain for mips32 architecture on my WIN 7 machince. I want to first compile a simple 'factorial' binary for my router which is based on MIPS32. From little ...
2
votes
0answers
457 views

While compiling 32 bit binary on 64 bit Linux (ubuntu 14.04) getting wrong ELF class error “wrong ELF class: ELFCLASS64”

I have 64 bit Ubuntu 16.04 installed on my system. For some reasons i have to change root directory to a directory which is nothing but a replica of a different system with the required libraries ...
2
votes
0answers
2k views

How to install GCC 4.9 or GCC 5 on Debian Stretch?

To build an old program for use in my Debian GNU/Linux box I need either GCC 4.9 or GCC 5. GCC 6+ will not work without changing the sources (that, for several reasons, I cannot change). So I want to ...
2
votes
0answers
671 views

GCC 5+ on CentOS 6.8

I was wondering how to get GCC 5+ on CentOS 6.8 and use it as the default compiler. I have seen several answers to this, but all of them point to binaries that are no longer hosted on the internet. I ...
2
votes
0answers
280 views

Automatically generating makefiles for a different compiler from an existing makefile

I am looking for a tool which can generate makefile for Sun CC compiler from an existing makefile , which is actually written for GCC compiler.Is there any tool which does the same? I tried by setting ...
2
votes
0answers
255 views

LFS 7.10 - why am I getting an error when using make command for expect-5.45

I am trying to compile expect-5.45 for LFS everything works until I use the make command, below is the output of using the make command: gcc -DPACKAGE_NAME=\"expect\" -DPACKAGE_TARNAME=\"expect\" -...
2
votes
0answers
917 views

Errors cross-compiling with distcc

I'm currently attempting a build of the Raspbian kernel using both a cross-compiler (for the Raspberry Pi 2's ARM processor) and distcc, based on the instructions posted at the Raspberry Pi website. I ...
2
votes
0answers
191 views

What is the effect of ACLs/umask on the permissions of the executable file generated by gcc?

I have been wondering how gcc determines the resulting file permissions of the executable file being generated. To gain some insight, I considered a minimalistic program test.c #include <fcntl.h&...
2
votes
0answers
112 views

Does make sense using exotic bootstrap in GCC?

Has anyone any evidence that currently GCC is bootstrapped in non trivial ways to detect bugs for certain features and architectures? Or at least point to some documentation where I can find wich real ...
2
votes
0answers
86 views

GCC configure error

When I'm trying to install GCC for SLED 11 SP3, the terminal show me this error: configure: error: cannot compute suffix of object files: cannot compile. Before to intall GCC, I installed the GMP (4....
2
votes
0answers
58 views

GNU toolchains against GCC SVN?

Is there anything like CodeSourcery which provides prebuilt binaries for arm toolchains built against gcc-svn. http://elinux.org/Toolchains#Prebuilt_toolchains Otherwise, a working instruction for ...
1
vote
0answers
26 views

How to determine the runtime dependencies of gcc-arm-none-eabi?

Background There is a GCC bug that affects Cortex M0 architecture which seems to be introduced in v5.4.1 (...and seems to be fixed in the trunk, however, we aren't interested in this option ATM). ...
1
vote
0answers
55 views

gcc 8.2.0 build fails on LFS v8.3

While building all packages in order every single one of them has succeeded but gcc 8.2.0 build fails. Below is the build error on executing make: msgfmt: error while loading shared libraries: ...
1
vote
0answers
69 views

How to safely reconfigure gcc on my Linux system?

I am trying to install a program (github.com/zhenglz/dockingML) on CentOS 6.10 and at the end of the installation, it gave an error saying that Glibc-2.14 is necessary. I upgraded the current Glibc ...
1
vote
0answers
163 views

How do I install newer or older versions of GCC on Devuan/Debian?

Some distributions come with package sets for different versions of GCC, which you can easily install in parallel; others do not. Specifically, in Devuan ASCII / Debian Stretch, there only seem to be ...
1
vote
0answers
268 views

gcc-config: could not run/locate 'avr-gcc-ar'

I'm trying to build an arduino sketch, but it fails with error: "/usr/bin/avr-gcc-ar" rcs "/tmp/arduino_build_191139/core/core.a" "/tmp/arduino_build_191139/core/wiring_pulse.S.o" gcc-config: ...
1
vote
0answers
568 views

g++46: error trying to exec 'cc1plus': execvp: No such file or directory

I'm on FreeBSD 9.2. The gcc version is 4.2. My project needs c++11 so I install gcc 4.6 and in Codeblocks I change the build option to support c++11 and in toolchain section I write g++46 and gcc46. ...
1
vote
0answers
269 views

How to update Solaris assembler after updating to GCC 5?

This is related to Where is GCC-5 after installing it on Solaris 11? We got GCC 5 installed thanks to @DanekDuvall. We started a round of Solaris testing... Testing on Solaris with GCC 5 is revealing ...
1
vote
0answers
243 views

Changing system wide GCC compilation options such as -DFORTIFY_SOURCE, PIE and stack_protector

This is my first StackExchange question ever, and if it is in the wrong place (UNIX and Linux vs. somewhere like Software Engineering?) please point me right! A very long time ago, I built a system ...
1
vote
0answers
421 views

Undefined references to 'get_rome_version' and 'rome_download' when compiling 'btusb_probe' in SM-G360T kernel

When I try to compile the kernel for the Samsung SM-G360T / SM-G360T1, I get identical issues for two different source repositories of the kernel. Kernels I am using: https://github.com/MSM8916-...
1
vote
0answers
109 views

Compiling g++ from source results in broken standard library. error: ‘::realloc’ has not been declared

I need to run on Amazon Linux but I need a recent g++. I compiled g++ 5.3.0 from source following the instructions here. The compilation ran for 13 hours on an EC2 instance and finished successfully. ...
1
vote
0answers
45 views

Error with installation of HDF-EOS5 augmentation tool: Cannot find -lGtcp

I am trying to compile the HDF-EOS5 augmentation tool. However, when I run: ./configure --with-hdfeos5=/HDF-EOS5-path/ I get the error: checking for inv_init in -lGctp... no configure: error: ...
1
vote
0answers
534 views

Host CFLAGS for cross-build of GCC

I want to build Rockbox from source for MIPS targets. According their the wiki I need a tool chain with binutils v2.17 and GCC v4.1.2 for the mipsel-elf target with CFLAGS="-U_FORTIFY_SOURCE -fgnu89-...
1
vote
0answers
451 views

MPICC with different versions of GCC

I need to use MPICH with different versions of GCC. Is it possible to change GCC without having to recompile MPI? Example I'd like to do something like this: mpicc --compiler=/usr/bin/gcc-5 Is it ...
1
vote
0answers
879 views

Installation of glibc in my directory

Hi for the reason here, I would like to install glibc in my own directory. I tried to follow the "HOWTO" here wget http://ftp.gnu.org/gnu/libc/glibc-2.7.tar.gz tar xzvf glibc-2.7.tar.gz wget https:/...
1
vote
0answers
90 views

Move compiler to a different system

Is it possible to move a compiler that is installed on one system (aarch64 5.4 on Ubuntu 16.04) onto another system off of a home directory? I want to do this because I need to run this compiler on a ...
1
vote
0answers
339 views

Problems compiling Python 3.6.0+ in Qubes OS Debian

I've tried to compile Python 3.6.0 and the lastest CPython from sources in a Debian Template inside Qubes OS (gcc 4.9.2). I've managed to do it, but looking the configure output in details, I've ...
1
vote
0answers
1k views

Qubes OS - Update a Template Kernel

I'm trying to update the kernel in the Debian Template of Qubes OS, following the official documentations, but it seems I'm missing something or doing something wrong. I'm using gcc 6.3.0. Qubes ...
1
vote
0answers
773 views

configure failed because of See `config.log' for more details

I am trying to compile Tcl, but I got the following error: ~/apps/tcl8.6.6/unix> ./configure --prefix=$HOME/.local/Tcl checking whether to use symlinks for manpages... no checking whether to ...
1
vote
0answers
195 views

How to build GTK2 on the Mac OS X EI Captain?

I tried to build GTK2 to Mac OS X EI Captain from source code. But by the environment variable (INCLUDE?), an error occurred and I failed to build. Please help me by advices? Doesn't someone have the ...
1
vote
0answers
134 views

Build errors on a copied operating system in a chroot

I'm in a bit of an interesting situation. In an attempt to have root access on my school's physics network computers, I ended up creating a chroot environment, using fakeroot and fakechroot. As every ...
1
vote
0answers
329 views

Prune yum of stale installed packages/duplicate gcc packages after manual install

I'm in a weird situation, and maybe I've messed something up and just need to hit the reset button and re-install CentOS. Off a fresh install of CentOS7.1 the other day, I noticed the latest version ...
1
vote
0answers
514 views

Error building and compiling GCC 5.2.0 from scratch on Vortex86DX

In order to upgrade a VortexDX86 custom linux with a gcc 3.2.3 compiler, I´m trying to built the GCC 5.2.0 compiler to support the latest C++ 11 standard. I have downloaded its source code from gcc....
1
vote
0answers
426 views

How do I change the version of GCC that I'm using? Why does GCC still seem to work despite bash telling me the gcc command was not found?

I was trying to follow this tutorial for an introduction to bare metal programming in C on a raspberry pi. One of the first things it recommends is to install the gcc 4.7 toolchain instead of what I ...
1
vote
0answers
496 views

How to change CFLAGS for autogen.sh

I am relatively new to Linux. I was trying to rebuild MDM display manager for Linux mint from url https://github.com/linuxmint/mdm. In the documentation it is said that you should use ./autogen.sh ...
1
vote
0answers
748 views

How can I install gcc-4.2 g++-4.2 on Linux Mint 17 with gcc-4.8 already installed?

I need an older version of gcc (specifically 4.2) alongside current gcc (4.8) on Linux Mint 17. Default Mint repositories can't find needed package: sudo aptitude install gcc-4.2 No candidate version ...
1
vote
0answers
1k views

How to change CFLAGS option -march from native to corei7?

Is it possible to change the CFLAGS -march=native to -march=corei7? Would I have to recompile the whole system once this change is made? I would like to setup distcc and I read that march cannot be ...
1
vote
0answers
1k views

Building HDF5 with GCC 4.7 and OpenMPI

I am trying to install hdf5 with GCC 4.7 from binary, because I do not have root permissions, using following script on a machine using CentOS release 5.6(AMD64bit): module purge module unload ...
1
vote
0answers
1k views

Install gcc into x86_64-linux-gnu

I'm trying to compile and install gcc-4.9.0 on my Debian system, and in particular I want the new version to overwrite an old version of libstdc++.so.6 in /usr/lib/x86_64-linux-gnu that came as ...
1
vote
0answers
217 views

how to install gcc4.8 in netbsd 6.1.3?

I did a "make install" for lang/gcc48 in pkgsrc. It did built ok. However, when I do gcc --versions, the default gcc 4.5.3 is displayed. What steps do I need to do after the build?
1
vote
0answers
1k views

Problem with configure - cannot find -lgcc_s

I want install Argos 0.5 to Debian 3.12.6-2 (2013-12-29) x86_64 GNU/Linux. I had to install gcc 3.4 because Argos call for it. Now I have gcc 3.4 and gcc 4.8.2-2 too. Problem is that ./configure ...
1
vote
0answers
165 views

Stanford's StanfordCPPLib on Linux

I'm using SUSE Linux 13.1 and self studying Stanford's CS 106B course. Here I have found the following zip file, cs106b-hw2-ngrams-starter-files.zip, and downloaded. Now questions This libs are for ...
1
vote
0answers
346 views

How to install gcc 4-8 on #! Waldorf 64-bit?

I would like to install and use g++ 4-8 compiler. It supports various C++11 features, and I am willing to look into them and use them. Also, as I came here from Windows, my previous files also used C++...
1
vote
0answers
836 views

Error cross compiling linux kernel using buildroot

I am trying to build a kernel bt in cross compiling the kernel when I ran following command make CROSS_COMPILE=i686-linux- ARCH=x86 I got the following error: UCLIB_EXTRA_CFLAGS="" \ ...