Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [gcc]

Questions regarding GNU Compiler Collection Suite.

0
votes
1answer
509 views

Issue with upgrading GCC 'missing requires of libgcc_s.so.1'

I upgraded my GCC from 4.4.7 to 4.8.2. So I removed GCC 4.4.7 by using: rpm -e --nodeps gcc-c++-4.4.7....... libgcc-4.4.7....... gcc-4.4.7........ Then I manually installed 4.8.2: ./configure ...
1
vote
0answers
90 views

Move compiler to a different system

Is it possible to move a compiler that is installed on one system (aarch64 5.4 on Ubuntu 16.04) onto another system off of a home directory? I want to do this because I need to run this compiler on a ...
1
vote
0answers
339 views

Problems compiling Python 3.6.0+ in Qubes OS Debian

I've tried to compile Python 3.6.0 and the lastest CPython from sources in a Debian Template inside Qubes OS (gcc 4.9.2). I've managed to do it, but looking the configure output in details, I've ...
1
vote
0answers
1k views

Qubes OS - Update a Template Kernel

I'm trying to update the kernel in the Debian Template of Qubes OS, following the official documentations, but it seems I'm missing something or doing something wrong. I'm using gcc 6.3.0. Qubes ...
0
votes
1answer
1k views

gcc cannot do ./configure apache

I tried to install apache on solaris. While I did know I can do this by pkg install apache-ver, this doesn't allow me to install to custom directory. CC='/usr/bin/gcc' ./configure --prefix=/opt/app/...
4
votes
1answer
2k views

bin/ld: cannot find -l<nameOfTheLibrary> install BigARTM - CentOS v7

I am trying to install BigARTM according to this tutorial on Centos 7. But I am getting this error: /bin/ld: cannot find -lboost_thread-mt /bin/ld: cannot find -lboost_program_options-mt /bin/ld: ...
8
votes
3answers
3k views

Where is GCC-5 after installing it on Solaris 11?

Please forgive my ignorance... I only use Solaris for testing C/C++ libraries I have an interest in. I'm not a Solaris admin or Solaris user. I installed GCC-5 on Solaris 11.3, x86 because I needed a ...
1
vote
1answer
872 views

how can I install gcc 4.8 or higher on wheezy?

I want to compile a library that need gcc 4.8 or higher. how can I install it on wheezy (32bit)? # apt-get install gcc-4.8 Reading package lists... Done Building dependency tree Reading state ...
2
votes
0answers
280 views

Automatically generating makefiles for a different compiler from an existing makefile

I am looking for a tool which can generate makefile for Sun CC compiler from an existing makefile , which is actually written for GCC compiler.Is there any tool which does the same? I tried by setting ...
2
votes
1answer
82 views

Debian 8 Synaptic issue

I have a Debian 8 installed with its GCC4.8, and need to install GCC6, too. Using Synaptic, if I select GCC6 from the list of installable packages, I get a message of this kind: Mark additional ...
1
vote
3answers
2k views

How to handle error compiling GCC 4.7.0 using GCC 6.2.1

I'm using Arch linux and I need GCC 4.7.0 for a class. I only have GCC 6.2.1 installed on my system currently. I followed all the install instructions correctly but I still yield this error after ...
0
votes
1answer
148 views

Compilation and build using make

Currently when I go invoke make I see the following being executed cc x.c -o x What I would like to see is the following cc -ggdb3 -O0 -std=c99 -Wall -Werror x.c -l<lib> -lm -o x or maybe ...
1
vote
2answers
215 views

Why LFS and CLFS change the path used to find the dynamic linker?

Both LFS and CLFS apply patches to the GCC source before building. The CLFS patches are a bit more involved than the LFS patches, but what they have in common is the changing of the path used to find ...
0
votes
0answers
885 views

install older version of gcc - debian sid

I have Debian testing. My version of gcc is : gcc (Debian 6.2.1-5) 6.2.1 20161124 I would like to install the version 4.7 of gcc but any attempts fail. I added deb http //ftp.fr.debian.org/debian/...
0
votes
1answer
736 views

compile one file of linux kernel

I want to compile one of linux kernel source files (/net/rds/recv.c) for this, call gcc like below : gcc version 5.4.0 20160609 (Ubuntu 5.4.0-6ubuntu1~16.04.4) cc1 -E -quiet -nostdinc -v -...
41
votes
1answer
4k views

How does this Makefile makes C program without even specifying a compiler?

I was using a Makefile from the book "Advanced Linux Programming (2001)" [code]. It was strange for me to see that GNU make does compile the code correctly, without even specifying a compiler in the ...
1
vote
1answer
969 views

How to get the REAL gcc (not the one that is hashed to clang) in MacOS?

I am trying to compile a program that uses the OpenSSL library. I had a problem where it couldn't find the header files. I fixed this problem by adding the option -I /usr/local/opt/openssl/include ...
2
votes
1answer
1k views

-fstack-protector-strong available but compiler is broken while compiling kernel using gcc

I have looked around for this specific error however I did not find it, instead I found errors that are similar such as 'not supported by compiler'. I am trying to compile Kernel version 4.8.8, i ...
0
votes
2answers
433 views

/proc/version show a gcc version, but I can't find the binary

A Linux computer at my university does not have gcc, that is to say, when typing gcc in command prompt it gives: /bin/sh: gcc: not found I was not able to find it with whereis, and locate gives me ...
1
vote
1answer
294 views

Debian Realtek RTL7832BS driver

I recently installed Linux Debian on my Lark Ultimate 7i WIN tablet, that was originally running windows, but Windows was so much laggy on this device. I succesfully installed Debian with LXDE, that ...
2
votes
1answer
730 views

Checkinstall fail installing gnu gcc 6.2.0

I try to install from source GCC 6.2.0 with checkinstall but it fails. I run configure and make, all seems fine, but when I try checkinstall I have this error: ranlib: could not create temporary ...
0
votes
1answer
252 views

What consequences may arise from using an alternate GCC version to compile the kernel? [closed]

Related to: Cannot compile kernel: error, kernel does not support PIC mode I also just had this issue, instead of patching; I configured alternates with a different gcc version, jumped from v4 to ...
-2
votes
1answer
220 views

Unable to update GCC version [closed]

In order to update gcc version in my debian pc. I am following this answer but it didn't work for me. ┌─[shravan40@ChangeStreet] - [/etc/apt/sources.list.d] - [Mon Oct 24, 13:27] └─[$] <> cat ...
1
vote
2answers
186 views

Where to find the source tarball for libgfortran3?

I've been using the multithreaded linear algebra package jblas on Chrome OS, which is called from some Java code. When attempting matrix multiplication via mmul, the following error is thrown: ...
0
votes
1answer
94 views

inverse translation from fortran90 (or gfortran) into ratfor90?

I have most likely a silly question, and asking perhaps a wrong forum, but don't know where to go. OK, I work with gfortran via ratfor90 (it is a nice little preprocessor for gfortran and fortran90, ...
3
votes
1answer
251 views

Using *Autotools*, how do I save the compiler listing on a file by file basis?

Please understand I'm using Autotools / Automake / Autoconf, and I can not use redirection because it needs to be applied command by command in the make file generated by autotools. I need a way for ...
0
votes
1answer
1k views

Can't update GCC version from 4.9.2 to 5.4 or 6.2? [duplicate]

I am trying to update gcc version in debian pc, but no luck yet. I have followed the instruction given in this answer and changed the last command to apt-get install gcc-5.4 g++-5.4 but it seems no ...
0
votes
1answer
212 views

Why does GCC stop working?

I've followed this tutorial which shows how you can enable the GCC compiler on ChromeOS, which uses the following commands below. sudo /usr/share/vboot/bin/make_dev_ssd.sh --...
1
vote
1answer
407 views

Is it ok to use gcc to compile userspace binaries on FreeBSD 10?

I know that recently FreeBSD 10 dumped gcc in favour of clang due to licensing reasons (Ref). I wanted to understand if this restriction to use clang is limited only to kernel compilation. Can I use ...
0
votes
1answer
278 views

How to get gcc-4.7 to /usr/bin/gcc-4.7 as second gcc in Debian Jessie?

I would like to keep my gcc 4.9 but let Matlab use gcc 4.7 because Stable Debian does not support 4.7, as observed in the thread Debian Jessie: Why gcc-4.7 conflicts with gcc-4.8? I do the following ...
2
votes
0answers
255 views

LFS 7.10 - why am I getting an error when using make command for expect-5.45

I am trying to compile expect-5.45 for LFS everything works until I use the make command, below is the output of using the make command: gcc -DPACKAGE_NAME=\"expect\" -DPACKAGE_TARNAME=\"expect\" -...
0
votes
1answer
755 views

Gdb pretty printer is not working in Ubuntu 16.04

I have debugged C++ codes using gdb in Ubuntu 14.04. When I pass a stl container to the print command, it used to print the contents of the container. But then I upgraded to Ubuntu 16.04 LTS a week ...
4
votes
1answer
924 views

How can I cross-compile standard libraries?

I'm trying to set up a cross-compiler for ARM. I followed this tutorial and I'm at the point now where I can run the cross compiler and get: arm-unknown-eabi-gcc (GCC) 4.8.4 Copyright (C) 2013 Free ...
1
vote
2answers
2k views

error starting vmware workstation 12 on kali linux [closed]

When I try to run vmware workstation 12, I'm greeted with the following message. I've tried the following: pointing the location to /usr/bin/gcc apt-get install libglib2.0-0 apt-get install build-...
-1
votes
1answer
644 views

C compiler while installing GCC!

I have a virtual machine running RHEL7. I am trying to install GCC from source following https://gcc.gnu.org/wiki/InstallingGCC I am unable to do yum groupinstall "Development Tools" or yum ...
3
votes
6answers
20k views

VMware kernel module: a compatible version of gcc was not found

When running the VMware kernel module updater, I get the following message: A compatible version of gcc was not found. How can I setup GCC to compile the VMware kernel module?
1
vote
0answers
773 views

configure failed because of See `config.log' for more details

I am trying to compile Tcl, but I got the following error: ~/apps/tcl8.6.6/unix> ./configure --prefix=$HOME/.local/Tcl checking whether to use symlinks for manpages... no checking whether to ...
0
votes
1answer
2k views

How can I build my shared library (.so) so that symbols from a different shared library are also included? [closed]

My shared library libnew.so uses some symbols form an already built third-party shared library libold.so. I would like to build an executable binary file that should be only linked against libnew.so. ...
1
vote
1answer
258 views

building from source code fails

I'm trying to build some software from scratch on a full installation of Slackware64 14.2. I follow the instructions in readme ./autogen.sh # only needed if building from git repo CFLAGS="-march=...
2
votes
1answer
2k views

How to Resolve undefined reference to 'RAND_egd'

Debian 8 Jessie, OpenSSL version 1.1.0, cURL version: 7.50.2 I am trying to build curl on a Linux Debian system. All stages go well up until trying to build with make command. The linking stage fails ...
0
votes
2answers
4k views

Installing GeForce drivers to Kali [duplicate]

I'm currently trying to install GeForce drivers for Kali Linux, but it isn't going so smooth. I have a GTX 285 and when I try the apt-get method for drivers I'm told that my card is no longer ...
1
vote
1answer
3k views

How to install gcc 4.9 arm cross compiler on debian stretch

Debian "stretch" has built-in cross compilers for gcc versions 5 and 6, but apparently only includes the native architecture in its gcc-4.x packages. Unfortunately I need to compile software that ...
0
votes
1answer
271 views

How to get a particular gcc version on debian armhf?

I need gcc 4.9.3 installed on my armhf debian box. But the version in the jessie repositories are 4.9.2 and the version in stretch is 5. How can i get a particular version through the repositories?
5
votes
2answers
14k views

Install another gcc version

I'm trying to compile NVIDIA CUDA on a Fedora 24 Workstation. I'm using CUDA version 7.5 and when I try to compile it I get this method: gcc versions later than 4.9 are not supported! I have ...
0
votes
1answer
787 views

Running C++11 library with older libc

I have written a shared library using C++11 features, compiled with gcc 4.8, libc 2.18, which needs to be run on a client's CentOS 6 machine, which has gcc 4.4.7, libc 2.12. There are some symbols in ...
0
votes
1answer
272 views

Constraints on gcc / glibc versions between build and run

Probably a basic question but I did not manage to find a clear answer to it: Let's say I am compiling a code (with some parts in C) on a build server and run it on a different server. The build ...
0
votes
1answer
1k views

Force linker to find stdc++ library in non-standard directory

I've read a lot of guidance that says the LD_LIBRARY_PATH is searched before anything else, but one of my .so libraries is linking with libtdc++.so.6 in /usr/lib64. ldd mylib.so: ... libstdc++.so.6 =&...
-1
votes
2answers
1k views

GCC 4.8 compilation error: cannot find the system header directory

I'm trying to compile GCC 4.8.3. I have read the documentation carefully but I'm still unable to cross compile it for 64bit system. I have also gone through this guide. But my requirement is to build ...
1
vote
1answer
934 views

What is -J n Option for in GCC?

I have a final exam next week, and in the exercise paper which is given us to study, there is a gcc option that I could not find on gcc manual page. It is something like that gcc -J 4 program.c -o ...
6
votes
1answer
2k views

Why can't I fetch the gcc-doc package on Debian?

When I was testing some code snippets from Stack Overflow, I realized that I haven't any man-pages for GCC on my Debian System. But when I try to get them from Debian's repositories it outputs E: ...