Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [gcc]

Questions regarding GNU Compiler Collection Suite.

-1
votes
1answer
13 views

GCC .lib file format not recognized by shell script

I am trying to run a shell script for gcc arm, but while running the script I get this error File format not recognized The end of the script, line 70 is the last one: include $(...
1
vote
0answers
69 views

Shell script cannot find file [duplicate]

I am trying to install a gcc-arm version but run into trouble while trying to run the setup shell script. Following step 2 in the prerequisites I downloaded GNU ARM embedded toolchain v4.9-2015q3. ...
0
votes
1answer
1k views

Force linker to find stdc++ library in non-standard directory

I've read a lot of guidance that says the LD_LIBRARY_PATH is searched before anything else, but one of my .so libraries is linking with libtdc++.so.6 in /usr/lib64. ldd mylib.so: ... libstdc++.so.6 =&...
0
votes
0answers
26 views

Installing GCC 4.7.0 fails at make command

I'm attempting to install GCC 4.7.0 in Linux Mint (based off of Ubuntu 18.04). I get past the first step of configuring it. However when I run make -j5, I get the following errors: make[2]: Leaving ...
1
vote
2answers
1k views

How to use afl-fuzz (American Fuzzy Lop) with openssl

I am trying to use afl-fuzz with openssl in Ubuntu. A normal usage of afl-fuzz would be: afl-gcc test.c //-- this will produce a.out mkdir testcases echo "Test case here." > testcases/case1 afl-...
0
votes
0answers
23 views

How does my application in Linux know how to find libraries in the common places [duplicate]

When I compile a simple C program for Linux, how does it automatically know where to find the standard C libraries when I run it? Take the simple Hello World program for example which uses printf to ...
1
vote
1answer
26 views

What packages the man pages for GCC on Debian 10 Buster / Testing?

I just installed build-essential, which installed gcc-8 but the man pages seem to be unavailable. $ man gcc No manual entry for gcc See 'man 7 undocumented' for help when manual pages are not ...
1
vote
0answers
26 views

How to determine the runtime dependencies of gcc-arm-none-eabi?

Background There is a GCC bug that affects Cortex M0 architecture which seems to be introduced in v5.4.1 (...and seems to be fixed in the trunk, however, we aren't interested in this option ATM). ...
0
votes
0answers
17 views

Compiling module crc32_intel_glue fails

I have two CentOS hosts and want to install the kernel module crc32_intel_glue.  I don't find it in the official repo, so I tried to build it from source, and failed. I downloaded crc32c-intel_glue.c ...
3
votes
6answers
20k views

VMware kernel module: a compatible version of gcc was not found

When running the VMware kernel module updater, I get the following message: A compatible version of gcc was not found. How can I setup GCC to compile the VMware kernel module?
8
votes
3answers
3k views

Where is GCC-5 after installing it on Solaris 11?

Please forgive my ignorance... I only use Solaris for testing C/C++ libraries I have an interest in. I'm not a Solaris admin or Solaris user. I installed GCC-5 on Solaris 11.3, x86 because I needed a ...
1
vote
1answer
2k views

gcc compiles gcc with errors 'template with C linkage' and 'template specialization with C linkage'

I am working with Ubuntu 14.04 LTS. This already ships a packaged gcc 4.8.4 but I wanted to have a later version of gcc. Using the existing version 4.8.4, I built version 4.9.4 from the source code ...
2
votes
1answer
33 views

What the branch machine op-code means (X86 architecture)?

I have a simple c code which is compiled and then the text code extracted using objdump utility. here is the dump file (A piece of dumped file): 0804841b <main>: 804841b: 8d 4c 24 04 ...
2
votes
2answers
2k views

How do I disable g++ displaying notes for errors?

When compiling, errors are often accompanied by a lengthy series of notes (cyan). Is there a g++ flag to disable this, only showing the error itself?
1
vote
1answer
5k views

GLIBCXX_3.4.21 in CentOS

I have created c++ application in Ubuntu machine. I have copied binary to Centos machine. Got error: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.21' not found I have installed packages I thought ...
0
votes
0answers
17 views

Debian nvidia-cuda-* packages conflict with gcc-6

I'm trying to compile a CUDA program on a Google Cloud VM running Debian Stretch. CUDA does not seem to officially supported on Debian but I was able to to install nvcc by installing the nvidia-cuda-...
2
votes
1answer
2k views

How to Resolve undefined reference to 'RAND_egd'

Debian 8 Jessie, OpenSSL version 1.1.0, cURL version: 7.50.2 I am trying to build curl on a Linux Debian system. All stages go well up until trying to build with make command. The linking stage fails ...
2
votes
3answers
6k views

How can we install devtoolset-4.0 on CentOS 6.7

I tried to install devtoolset-4.0 to use g++ version 5.x via sudo yum install devtoolset-4 However, I got No package devtoolset-4 available. Is there any way to get to that?
3
votes
1answer
5k views

Installing GCC on SLES 12

I'm having trouble installing gcc on a new SLES 12 box. The goal here is actually to get R Shiny running, but when I try to install any packages I get the below error: sudo su - -c "R -e \"install....
3
votes
1answer
3k views

Gcc configuration error

I am trying to build GNU toolchain for OpenRISC by following the guide given at http://openrisc.net/toolchain-build.html#_stage_1_gcc on Fedora Virtual Box Image. I am getting error saying Configure:...
-1
votes
2answers
1k views

GCC 4.8 compilation error: cannot find the system header directory

I'm trying to compile GCC 4.8.3. I have read the documentation carefully but I'm still unable to cross compile it for 64bit system. I have also gone through this guide. But my requirement is to build ...
2
votes
2answers
3k views

Multiple gcc and linking between them

I'm running centOS 6.3 which comes with gcc 4.4.6 and I installed gcc 4.6.3 using these instructions. But when I type gcc -v it still says gcc 4.4 is the version I'm using. The newer version is under ...
4
votes
2answers
842 views

What is the difference between “LSB executable” (ET_EXEC) and “LSB shared object” (ET_DYN)?

With two files, one compiled and linked with gcc and the other manually with nasm and ld I get ELF 32-bit LSB shared object ... ELF 32-bit LSB executable ... What's the difference between these two ...
0
votes
0answers
71 views

Why am I receiving make errors when trying to compile GCC?

I am currently working on Linux From Scratch part 5.5: http://www.linuxfromscratch.org/lfs/view/stable/chapter05/gcc-pass1.html Although i have followed everything exactly correctly to this point, I ...
3
votes
1answer
3k views

I'm trying to compile alsa-driver-RTv5.18 but get date-time error for gcc 4.9.2

/home/user/Downloads/Rt-Linux-HDaudio-5.18/alsa-driver-RTv5.18/alsa/acore/info.c:1065:22: error: macro "__DATE__" might prevent reproducible builds [-Werror=date-time] "Compiled on " __DATE__ " for ...
0
votes
2answers
287 views

How to create and use dynamic and static libraries in linux (c programming)? [closed]

How I can create and use dynamic and static libraries? Can anyone explain here in an easy way of how to create and use dynamic and static libraries in c and static vs dynamic libraries? And also ...
0
votes
2answers
2k views

gcc: fail sanity check error, I suppose due to cxx USE flag missed

Recently I've done emerge -e world and then found that gcc was compiled without cxx flag. Now I can't compile any C++ package due to configure: error: C++ preprocessor "/lib/cpp" fails sanity check ...
3
votes
3answers
2k views

6.7 Linux headers `make mrproper` fails in lfs 7.5

I'm building lfs-7.5. When I run make mrproper in chapter 6.7, it says: make: gcc: command not found and on running bash /tools/bin/gcc, it says: bash: /tools/bin/gcc: no such file or ...
3
votes
1answer
7k views

Linker error: /usr/bin/ld: cannot find -lgcc_s

I am trying to compile symlinks (tar.gz-file), which is a very small tool with one line for compilation: gcc -Wall -Wstrict-prototypes -O2 -N -s -o symlinks symlinks.c which gives the error .... ...
5
votes
2answers
7k views

using ldconfig and ld.so.conf versus LD_LIBRARY_PATH

I often build various libraries from source code to play with, such as gmp-6.1.2, mpfr-4.0.1, and gcc-7.x. In doing so, I prefer to use --prefix=/usr/local/gcc-7.2.0 so I know exactly where it is ...
0
votes
1answer
68 views

How to cross compile older version of GCC under Debian?

I'm trying to build an older version of GCC toolchain for ARM under x86 because there is a bug with GCC > v5 for Cortex-M0. I'm following the combination of the following instructions: https://...
0
votes
1answer
73 views

Check which library compiled in linux

I want to compile a C file with gcc, to embedded arm that is running Gnu/Linux . How can I known which function/header files that I need to compile statically, and which dynamically?(I don't want to ...
2
votes
2answers
7k views

Linking issues with libjpeg

I have a game I'm writing which recently required libjpeg. I wrote some code using libjpeg on some-other-machine and it worked as expected. I pulled the code to this machine and tried compiling and ...
8
votes
3answers
37k views

How to install latest stable release of GCC in Linux Mint?

I want to install the latest version of GCC (GNU compiler collection) in Linux Mint 17.3. Currently g++ --version returns 4.8.4, whereas the latest stable release is 5.3.
1
vote
1answer
968 views

How to get the REAL gcc (not the one that is hashed to clang) in MacOS?

I am trying to compile a program that uses the OpenSSL library. I had a problem where it couldn't find the header files. I fixed this problem by adding the option -I /usr/local/opt/openssl/include ...
20
votes
4answers
45k views

How to install GCC 5 on debian jessie 8.1

I tried many solutions to install update for my gcc compiler on debian server. None of them worked. I need the compiler update to use new features of c++11, as this provides a stable libcxx11 ABI, and ...
3
votes
1answer
183 views

Maintaining a single binary across Debian distributions

We are currently migrating our system from Debian 6 to 8. The agenda is to try to maintain a single binary across OS platforms (x86 based) However, I tried running a Debian 8–compiled binary in ...
0
votes
1answer
70 views

How to suppress all warnings being treated as errors for format-truncation

I am trying to build my source using gcc 8.3.0 root@eqx-sjc-engine2-staging:/usr/local/src# gcc --version gcc (Debian 8.3.0-2) 8.3.0 Copyright (C) 2018 Free Software Foundation, Inc. This is free ...
2
votes
1answer
2k views

What is the fastest way to install GCC on Wind River 3.02?

I really do not want to just blindly install rpm after rpm of dependencies I think I might need... I know that this version of Linux is based off of Fedora 11. I am currently trying to install yum ...
3
votes
1answer
3k views

Centos 7 gcc 8 installation

GCC 8 is out for a white and I would like to test on CentOS 7, but no devtoolset-8 yet in yum. I found https://cbs.centos.org/koji/packageinfo?packageID=7198 but this is cbs; Can I have it as a ...
0
votes
0answers
32 views

Browsers recomendations that work without “modern” glibc and libstdc++

Recently a website that I use was modified, and with that, I can no longer bid on an auction I participate in. I use an Firefox 30, a Firefox 45 and a Palemoon 27.9.4, but neither works anymore. To ...
2
votes
1answer
55 views

How to install .net Mono on Solaris 11 (source code compile)?

I downloaded the last mono tar to Solaris 11 I install the required packages: # pkg install autoconf # pkg install automake # pkg install libtool # pkg install gcc When I tried to configure mono 5....
0
votes
2answers
902 views

Compile mex files for spm12 in Matlab r2012a student version

in 2012 I bought a student version of Matlab (r2012a, 32bit) which I have now installed on my Ubuntu 14.04.2 LTS. This far, everything works. However, I would like to install SPM12 (a software used ...
1
vote
2answers
996 views

Cross-Compiling kernel can't find gcc

I am cross compiling the Raspbian kernel since it will take about 12 hours for the Pi to do (Raspberry Pi 1). I have the build tools for ARM and the kernel in two separate folders in /home/gray/...
3
votes
1answer
2k views

Upgrading GCC on Debian Wheezy to support C++ 11 features

We are currently working with Kontron servers on which we've installed Debian 7.x systems. I began to develop applications using C++ 11 features. But it's not officially supported by the version of ...
0
votes
0answers
111 views

Fail to initialize plugin stackleak_plugin.so

I'm on Fedora 28, Kernel 4.20.14-100.fc28.x86_64 and trying to get a working dual-screen on a D6000 Dell docking Station. For now I have the following error while trying to restart the displaylink ...
0
votes
1answer
39 views

What are the criteria for including a language in gcc? [closed]

According to man gcc, gcc supports the following languages, which you can choose from with the -x flag: c c-header cpp-output c++ c++-header c++-cpp-output objective-c objective-c-header ...
0
votes
1answer
1k views

musl-gcc not working

I have linux installed in armv6 android phone in chrooted environment. I have installed musl-libc from source for building static binary for android. Here are the commands, I ran for building & ...
3
votes
1answer
4k views

Trouble with opkg package manager in Angstrom embedded linux on Colibri module ARM v7 processor

I am working on a Colibri module having Angstrom linux installed in it! The processor is ARM v7. I am having trouble updating the softwares installed in the system. Whenever I tried the command opkg ...
1
vote
0answers
748 views

How can I install gcc-4.2 g++-4.2 on Linux Mint 17 with gcc-4.8 already installed?

I need an older version of gcc (specifically 4.2) alongside current gcc (4.8) on Linux Mint 17. Default Mint repositories can't find needed package: sudo aptitude install gcc-4.2 No candidate version ...