All Questions

0
votes
1answer
252 views

Solaris 11.3 - Unable to install system/header

I'm (unsuccessfully) trying to get GCC installed on Solaris 11.3 but am running into a lot of issues. My current issue is that I'm unable to install the package "pkg://solaris/system/header". ...
3
votes
1answer
452 views

How to install php7 on solaris 10 with OpenSSL 1.0.1

I am trying to install php7 on Solaris 10. OpenSSL 1.0.1 was installed from https://www.opencsw.org/packages/libssl1_0_0/ To check for the installed ssl I did pkginfo -i | grep -i "ssl" and I ...
0
votes
0answers
64 views

Cannot install GCC ld error not using custom prefix when loading lto-wrapper

I am trying to install GCC 4.9.4 in a non-standard location on Red Hat Linux using the documentation provided. https://gcc.gnu.org/install/ I do not have sudo, but I have write access to the folder /...
2
votes
1answer
8k views

gcc - error: no acceptable C compiler found in $PATH

I am trying to install GCC from source. I am following the instructions on the wiki at https://gcc.gnu.org/wiki/InstallingGCC and also on this question on SO. I am running into issues on the ...
4
votes
4answers
4k views

How to install multiple version of GCC (GCC-3.3) on Ubuntu 16?

I am not familiar with Ubuntu and I want to install old version (3.3) of gcc to compile some code. When I tried with sudo apt-get install gcc-3.3 it's not installing. ~$ sudo apt-get install gcc-3....
0
votes
1answer
427 views

I installed and run gcc but dpkg says : package gcc is not installed, why?

I downloaded and installed gcc-4.9 (using the basic ./configure make make install). I can compile code and everything works fine. But dpkg -s gcc claims thats gcc is not installed. However, dpkg -s ...
0
votes
2answers
419 views

Best way to have “alternate” gcc environment on Mint 18.1

Under Mint 18.1, is there a HowTo or info on how (or info that I can't/shouldn't) install a separate GCC toolchain for my own C++ noodling? I don't want to break anything in the regular system, so ...
1
vote
0answers
91 views

Move compiler to a different system

Is it possible to move a compiler that is installed on one system (aarch64 5.4 on Ubuntu 16.04) onto another system off of a home directory? I want to do this because I need to run this compiler on a ...
0
votes
0answers
398 views

Build location-independent GCC binaries

I have some problems with GCC. I want a portable version of GCC because the PC I use for programming cannot be connected to Internet due to some driver issues. So, I read an article on how to compile ...
2
votes
1answer
20k views

Install GCC 4.8+ on rhel x86_64 workstation 6

I want to install gcc 4.8+, preferrably 4.9 on my Red Hat Enterprise Linux Workstation release 6.7 (santiago) I have a subscription to rhn-classic. I tried installing devtoolset as given in https://...
2
votes
2answers
781 views

installing virtualbox apt-get wants to download gcc-4.8 --> replacing gcc-4.9?

I'm trying to install virtuabox on Debian 8.3 using the contrib repos. When I use apt-get install virtualbox it wants to install gcc-4.8, but I already have gcc version 4.9.2 installed. What am I ...
4
votes
1answer
12k views

C compiler cannot create executables exit 77

I am using a RedHat linux environment where I do not have root permissions (I am on a paid server account). Every time I try to run "./configure" on a new package that I am trying to set up and ...
1
vote
0answers
517 views

Error building and compiling GCC 5.2.0 from scratch on Vortex86DX

In order to upgrade a VortexDX86 custom linux with a gcc 3.2.3 compiler, I´m trying to built the GCC 5.2.0 compiler to support the latest C++ 11 standard. I have downloaded its source code from gcc....
0
votes
0answers
485 views

custom gcc install include files

I have a custom installation of g++ 4.8.1 in my home directory. However the include files in that installation have no extensions! (except for tgmath.h, fenv.h, complex.h, and cxxabi.h) Thus even if ...
3
votes
1answer
2k views

Install gcc4.9 on openSuse 13.1

I need to download and install g++4.9 in order to work with regex in c++11 for a school project. I downloaded the source but it seems it does not work .. I searched for the rpm and 1-ClickInstall and ...
0
votes
0answers
417 views

Installing gcc offline on a Debian based distro

I installed Kubuntu 14.10 and it doesn't come with gcc compiler. Since I currently don't have Internet access on my laptop, I got the offline version (a tar.gz file) from a friend but I don't know how ...
8
votes
2answers
1k views

Why is this Python package trying to use a non-existent gcc?

I'm trying to install PyCrypto for Python 3 on Solaris. Whether I do it via "python3 setup.py install" or "pip3 install pycrypto", I run into the same problem: a call is made to a gcc which does not ...
3
votes
1answer
4k views

Why can yum still not update GCC 4.9.0?

GCC 4.9.0 has been released since April 22. However, I can still not update it through the following command: $yum update gcc Why does the yum repository lag so much behind gcc.gnu.org?
11
votes
5answers
63k views

install latest gcc on rhel 6 x86_64

I have an RHEL 6 server with gcc version 4.4.7. I wanted to update the gcc version (I think the current one is 4.8). Yum update doesn't work. Also, SO answers for a similar question on CentOS does not ...
0
votes
1answer
2k views

Solaris 11 pkg repository update fails

I want to install gcc in my solaris 11 working in virtualbox, I tried pkg install gcc-45 but I am getting : pkg: 0/1 catalogs successfully updated: Unable to contact valid package ...
0
votes
1answer
6k views

Installing php phalcon extension

I am unable to install phalcon php extension by folowing these steps. I use 64-bit Linux Mint 14 Nadia. http://docs.phalconphp.com/en/latest/reference/install.html#linux-solaris-mac For the ...
0
votes
0answers
497 views

How to install cpp in RHEL 6.3?

I want to install gcc in RHEL 6.3, but it has cpp dependencies. So I go to cpp rpm download page, but it has no rpm for 6.3 version: Is there any other way to install cpp in RHEL 6.3?
2
votes
1answer
6k views

Installing GCC 4.6.3 on Fedora 18

I am trying to install GCC 4.6.3 on Fedora 18. I was following the instructions provided by Lars Rohrbach. When I run make, I get the error /usr/include/gnu/stubs.h:7:27: fatal error: gnu/stubs-32....
0
votes
1answer
1k views

Install GCC at a custom location without machine prefix

When installing GCC, libraries, header files and some executables are placed in directories similar to /usr/lib/gcc/i686-pc-linux-gnu/4.5.4/ and /usr/libexec/gcc/i686-pc-linux-gnu/4.5.4/. I'm ...
3
votes
1answer
9k views

Install gcc 4.7.2 on Debian squeeze 64x

I want to use gcc 4.7.2 on my Debian squeeze 64x I followed instructions in this thread: Get newest gcc for debian?, but I'm getting an error, I tried several apt-get install commands I will settle ...
2
votes
1answer
861 views

Being not admin user how to install local GCC instead of provided?

So I came into my classrom Debian is installed, and gcc 4.1. I want to install (compile from sources is an option - I have time..) for my self GCC 4.7 and adress it in bash as gcc anywhere. Is such ...
2
votes
1answer
2k views

Extracting / Installing a TAR file

When I extract a tar file using this command: tar xvzf gcc-4.7.1.tar.gz (This is the directory the tar file is in: cd /u/test/GCC-4.7.1/) The files were extracted but they are in /dev/... (see below ...
1
vote
2answers
7k views

Install older version of GLibc on RHEL

I'm trying to install GCC 4.4 on RHEL6: sudo rpm -ivh /mnt/dvd/Packages/gcc-4.4.3-1.el6.x86_64.rpm. But the problem is that is depends on glibc and glibc-common libraries. When I try to install them ...
4
votes
1answer
1k views

Install Compiler, GCC, in SCO

I am having difficulty trying to install the GCC compiler in SCO, but can't get it to work. I have used an FTP to transfer some files (.tar.gz) to /u/test/installgnu/ and I extracted the files, but ...
7
votes
2answers
16k views

Get newest gcc for debian?

I can't build my apps on gcc since I use various c++0x features. I'm on Debian 6 (Lenny) and after upgrade/updating I have gcc version 4.4.5-8. I'm unsure which version is required but mingw 4.6.2 ...
1
vote
1answer
1k views

Configurations needed to be done post GCC compilation and installation

I have compiled the latest GCC 4.7.0, on my Linux Mint 12, using gcc 4.6.1 (default). Compiler compiled successfully, steps followed ./configure make make install Binaries of gcc-4.7.0 are in /usr/...
4
votes
1answer
13k views

Installing GCC 4.5 on Fedora 16

The default GCC package available in the Fedora 16 repositories is gcc-4.6. I need to install gcc-4.5 on my system. I downloaded the packages from the kijo repository, but when I try to install them ...
2
votes
1answer
2k views

What is the fastest way to install GCC on Wind River 3.02?

I really do not want to just blindly install rpm after rpm of dependencies I think I might need... I know that this version of Linux is based off of Fedora 11. I am currently trying to install yum ...
4
votes
3answers
5k views

How to set the default gcc version for only one user?

I share a server (Ubuntu 11.04) with other people and I am the only one who has to use gcc 4-4 for my code, the rest is using 4.5. I already installed gcc 4.4 but how do I make it the default for me, ...
2
votes
1answer
8k views

Install GCC on OpenSUSE 11.4

I installed OpenSUSE 11.4 but I noticed that it don't have gcc… How I can install it?
11
votes
1answer
13k views

Install g++ when having gcc (C only) — RH6

I have a RHEL 6 machine, which came with gcc but without g++. The gcc version is 4.4.4 20100726 (this is what I got from gcc --version). How can I get g++ working? Currently, the shell just returns "...