Skip to main content
Share Your Experience: Take the 2024 Developer Survey

Questions tagged [fpm]

Use this tag for questions specific to the FPM ("Effing Package Management") utility. If you have a general question about package management, please use the `package-management` tag instead.

Filter by
Sorted by
Tagged with
1 vote
0 answers
53 views

503 Service Unavailable after 60 seconds Apache Symfony (in certain features only)

I currently face an issue in a Symfony 3.4 application, in one of its features which loads history of some data (a lot of data actually which dates from 2017). When trying to access the history ...
mblackroot's user avatar
0 votes
0 answers
661 views

Start nginx without host container being available

For local development, I have a suite of 5 sites. Each site runs in its own php-fpm container. All sites are served by a single nginx container, which contains .conf files for all the sites. They ...
amacrobert's user avatar
2 votes
0 answers
127 views

PHP-FPM + Apache2 security

My question is almost identical to Luis Machuca's from 2 years ago (Apache + php-fpm: Proper permissions for per-pool, per-user projects?), but with some additional conditions. I have also configured ...
MrL's user avatar
  • 21
0 votes
1 answer
286 views

fpm .deb package docker dependencies

I created a simple .deb package with fpm. The package is very basic and it simply runs a docker-compose file (see my other question here for package description). I tried to specify that the package ...
cccnrc's user avatar
  • 255
0 votes
0 answers
214 views

Can not access PHP-FPM site

Using OpenSUSE v15.2, Apache. Installed PHP-FPM with zypper. Followed instructions on this site: https://en.opensuse.org/SDB:Apache_FastCGI_and_PHP-FPM_configuration I restarted Apache and PHP-FPM. ...
klor's user avatar
  • 414
0 votes
1 answer
1k views

Why a PHP module is not loaded into PHP?

Showing my case how to debug the problem, that a PHP module is not loaded into PHP. I use OpenSUSE v42.2 Linux OS, with Apache webserver, PHP v7.1, Mysql. Because it does not provide PHP v7.1 I need, ...
klor's user avatar
  • 414
-1 votes
1 answer
89 views

Going from a binary RPM to an OBS signed rpm?

I have a RPM that I'm currently building with FPM, fpm --verbose \ -s dir \ -t rpm \ --directories /opt/myprod --name myprod --rpm-summary "My Prod" --version $(git describe --abbrev=0 --...
Evan Carroll's user avatar
  • 31.3k
4 votes
1 answer
3k views

fpm: rpm: /usr/bin/rpmsign: No such file or directory

When I run fpm with --rpm-sign I get the following error, rpm: /usr/bin/rpmsign: No such file or directory I am using CentOS
Evan Carroll's user avatar
  • 31.3k
1 vote
1 answer
332 views

Changing manifest values in RPM built with FPM

I'm using the delightfully–named Effing Package Manager (FPM) to build RPMs and DEBs for a project. After publishing the generated RPM with createrepo, I noted the following lines in the generated ...
Ruben Schade's user avatar
0 votes
1 answer
3k views

How to define the user and group for directories inside and RPM using FPM?

RPMs have been built using FPM. When the --rpm-user and --rpm-group parameters are used the %defattr(-,user,group,-) attribute is part of the %files, but not part of the %directory section. How to ...
JavaRocky's user avatar
  • 101