Questions tagged [error-handling]

Use this tag for questions on how to handle errors generated in shell scripts.

40 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4
votes
1answer
3k views

fontconfig warning: “/etc/fonts/fonts.conf”, line 100: unknown “element blank”

Getting this error on my vps server: fontconfig warning: "/etc/fonts/fonts.conf", line 100: unknown element "blank" This is the file: https://pastebin.com/VqcSgJ9x How to fix it?
4
votes
0answers
344 views

Distinguish between error and “success” in scanimage-batch

I'm running a little script with the scanimage batch-command on a remote server and would like to know if and how the scan has been done the batch. Therefore the script requires a proper "error"-...
3
votes
0answers
3k views

Wifi too much “Invalid misc”, how to fix it?

Here are some outputs: root@debian:/home/love# iwconfig wlan0 wlan0 IEEE 802.11bgn ESSID:"SITI_Broadband-06E6-G" Mode:Managed Frequency:2.412 GHz Access Point: FC:4A:E9:4B:06:E8 ...
3
votes
1answer
2k views

How to get non-zero exit code from Puppet when configuration cannot be applied?

I've tried the following Puppet configuration to disable the root password: class users { user { 'root': password => '*', } } But after applying it with no warnings or error messages I ...
2
votes
1answer
103 views

Script error handling: need to report segfault in script run by ssh

I wrote a cron job, which uses ssh to run a script on a server. I just tried running the script, and now I am unhappy. client# ssh server.local /usr/local/bin/script client# server# /usr/local/bin/...
2
votes
0answers
461 views

libtool: error: relink 'libpocketsphinx.la' with the above command before installing it

When I trying to install pocketsphinx by make install command(after ./autogen.sh , ./configure, make commands) , I get this error message: libtool: error: relink 'libpocketsphinx.la' with the above ...
2
votes
3answers
689 views

Error cleanup for shell scripts

What's the best way to include error cleanup logic for shell scripts? Specifically, I have a script that does something like this: mount a x mount b y setup_thing mount c z do_something umount z ...
2
votes
0answers
653 views

Error calling EVIOCSKEYCODE

I used journalctl -p 3 -xb and got this error message -- Logs begin at Thu 2016-06-23 22:48:08 AST, end at Sat 2016-06-25 13:15:23 AST. -- Jun 25 09:31:35 Almoullim systemd-udevd[268]: Error calling ...
2
votes
1answer
324 views

crossplatformui error in Mint 11

Whenever I try to install something in my system it generally installs but shows some error related to "crossplatformui". I don't know what it is and how to remove it. I am printing here a sample ...
1
vote
0answers
692 views

Error adding symbols: DSO missing from command line while compiling Ogre Meshy

Yes I read many questions for ex. this and this and this and this but nothing works for me. So basicaly Im trying to compile Ogre Meshy but Im getting an error [100%] Linking CXX executable bin/...
1
vote
0answers
988 views

Yum not found on Centos 7 “ No module named yum”

I recently installed CentOS 7 but have run into an issue with yum. I get the following error: There was a problem importing one of the Python modules required to run yum. The error leading to this ...
1
vote
0answers
233 views

I am getting this errror when trying to install the newest version of Python 3. Any ideas on how to fix it?

checking build system type... x86_64-pc-linux-gnu checking host system type... x86_64-pc-linux-gnu checking for python3.7... no checking for python3... python3 checking for --enable-universalsdk... no ...
1
vote
0answers
53 views

Scribbleton doesn't run on Linux Mint 19

I am trying to install and run Scribbleton on Linux Mint 19, but when I do ./run_scribbleton.sh nothing happens. Talking to the support, they asked me to modify the run_scribbleton.sh script to print ...
1
vote
0answers
82 views

Why does trying to open a sub-shell in a for loop give a syntax error at done?

If I execute this bash script: #!/bin/bash j=0 for(( i=1;i<(j);i++ )) do echo j done I get: ./test: line 6: syntax error near unexpected token `newline' ./test: line 6: `done' I know that the ...
1
vote
0answers
2k views

the 'grub-efi-amd64-signed' package failed to install into /target/

I am trying to install Ubuntu 18.04 but I get this error at the end of installation process! I tried to create a partition with ext4 for \boot. also ext1 but non of them worked. Also I tried to ...
1
vote
1answer
26 views

djvulibre-3.5.27 Build Error

I am currently on Linux Mint 18.3. I downloaded the package from the Djvulibre website. Here is my error: make[2]: Entering directory '/home/amucs/Downloads/djvulibre-3.5.27/desktopfiles' PNG ...
1
vote
1answer
654 views

How to avoid error-message during the execution of a bash script?

I need to write a bash-script which will find all files with name string.h on the computer and copy them to some folder. My code is here: #!/bin/bash sudo find / -type f -name "string.h" -exec cp {} ...
1
vote
0answers
48 views

STDERR redirection without intermediate file

Here is a toy shell script: #!/bin/bash set -e misspelled_command exec > run_$( date +%Y%m%d ).log 2>&1 echo "Logging" exit If I submit with nohup bash raise_errors.sh > /dev/null 2&...
1
vote
1answer
2k views

/sbin/ldconfig.real: /usr/local/lib is not a known library type

I was following this instruction on this site to installing tesseract: https://github.com/tesseract-ocr/tesseract/wiki/Compiling git clone https://github.com/tesseract-ocr/tesseract.git cd tesseract ....
1
vote
0answers
1k views

Mint 17.3: Your session has lasted less than 10 seconds

yesterday I executed 'sudo apt-get update && apt-get upgrade' and today I get the following error after the login Your session has lasted less than 10 seconds... syndaemon: no process found /...
1
vote
0answers
2k views

Repeated error : #error “Only <glib.h> can be included directly.”

I have a research on author attribution compression distance. And I should use "Complearn" ,which is a compression program, in my work. But in the beginning I have problem in installing this program. ...
1
vote
0answers
887 views

error: implicit declaration of function ‘rt_dev_socket’

The developer says: http://comments.gmane.org/gmane.linux.real-time.rtnet.user/2546 Now how can I tell the Makefile to look for headers in /usr/local/rtnet/include respectively ...
0
votes
0answers
47 views

Failed to run bash script remotely Too many )'s

After some research: Script to ssh and run a command doesn't work Multiple commands in sshpass Make a shell script execute commands in telnet or programs I've come up with a script that logs ...
0
votes
0answers
45 views

EDUP WIFI instllation in Reaspberry pi error

I need to install the Wifi dongle into my raspberry zero for connecting to my home wifi modem, based on solving my previous question vi this link: https://raspberrypi.stackexchange.com/questions/...
0
votes
0answers
20 views

Bluetooth file transfer PC-to-Android fails

on sending a file from a debian machine to an android device over bluetooth using the blueman-sendto command it finishes with an error: _on_properties_changed (usr/lib/python3/dist-packages/blueman/...
0
votes
1answer
953 views

E: Unable to locate package nvidia-graphics-drivers-418

My OS is Deepin 15.10. My GPU is NVIDIA Quadro 3000M. I want to play games on Linux. Steam has a program called Proton which enables this. Proton requires nvidia-418 or higher to work properly, so I ...
0
votes
3answers
85 views

Linux/Debian dpkg & administrator errors

So today I ran into a bunch of errors while using the sudo command on my Chromebook with Linux installed. For example when I try to remove my Google Chrome beta application, I tried this: sudo apt-...
0
votes
0answers
320 views

how to make a Input/Output Error example?

I'm working on a simple game console for raspberry pi, and I want to handle some common errors like segmentation fault, arithmetic exception and input/output error (since there maybe some guys using ...
0
votes
0answers
33 views

How can i check for errors of the nemo file manager?

Are there any terminal commands one can use to check if the nemo file manager (linux mint 19.1 cinnamon) is working properly? Asking, since i tend to get some error messages every now and then, ...
0
votes
1answer
106 views

get an error typeset: not found when i launch my script by crontab?

I use this portion of code to set default values in my config on my script.sh # Copyright (c) 2015 # Licence MIT ( http://choosealicense.com/licenses/mit/ ). #!/bin/sh typeset -A config # init ...
0
votes
2answers
318 views

How to make systemd not hang (unresponsive system), but provide emergency shell?

I am not very familiar with systemd. The answer I seek with this question is: How is it possible to make systemd react to problems with "dropping the user into an emergency shell of sorts", instead ...
0
votes
0answers
68 views

How to filter out warning messages from yum?

I have installed via yum some packages as follows: $ yum install ambari-agent During installation there are a lot of warnings (see below). Is it possible to block these warnings but see only the ...
0
votes
0answers
1k views

E: Unable to locate package libboost / libxerces E: Package 'libzeroc-ice-java' has no installation candidate

I am trying to install RebeccaAIML dependecies as it says here: https://github.com/codeanticode/chatbots-library/wiki/Linux-installation-of-RebeccaAIML , by this command: apt-get install libboost ...
0
votes
2answers
3k views

Will this damage my PC? GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pci=noaer pci=nomsi”

When I tried to install my Ubuntu 16.04.2 I faced with no screen problem! and PCI_bus errors! after many searching and trying only this modifications on /etc/default/grub solved my problem: ...
0
votes
0answers
1k views

collect2: error: ld returned 1 exit status Makefile:107: recipe for target ‘binary’ failed make: *** [binary] Error 1

I am trying to compile ChatScript V7.55 on Ubuntu 16.04 but I got this error message: collect2: error: ld returned 1 exit status Makefile:107: recipe for target ‘binary’ failed make: *** [binary] ...
0
votes
0answers
516 views

Error opening audio device (null) for capture: Connection refused FATAL: “continuous.c”, line 245: Failed to open audio device

I am trying to install pocketsphinx on my ARM-based board(nanopi-m1), and use Ubuntu-Core 16.04 on it. But when I try to test pocketsphinx with this command: pocketsphinx_continuous -inmic yes I get ...
0
votes
1answer
98 views

Error Update package ubuntu server

Hello i have this error when launch apt-get update command on my ubuntu server : how can i solve this? W: Impossibile scaricare alcuni file di indice: saranno ignorati o verranno usati quelli ...
0
votes
1answer
158 views

Trouble installing Deco-IDE on Ubuntu 16.04 - .sh file keeps throwing a postscript ngrok error

Ive been trying to install Deco-IDE on Ubuntu 16.04 linux through this hack I found on github but I keep getting an error seen in the image below after the lines: cd ../../Desktop npm install I ...
-2
votes
1answer
379 views

Issue using pip3 to install “face_recognition”, packages do not match hashes

When I give command pip3 install face_recognition in the raspberry pi terminal, It shows this error: THESE PACKAGES DO NOT MATCH THE HASHES FROM THE REQUIREMENTS FILE. If you have updated the ...
-2
votes
1answer
741 views

Error installing anything on Kali 2.0

I changed from 32bit to 64bit and i cant install anything. As soon as i installed the OS i used apt-get update and apt-get upgrade. Now everything i try to install i get the following error. Reading ...