Questions tagged [emerge]

emerge is the definitive command-line interface to the Portage system. It is primarily used for installing packages, and can automatically handle any dependencies that the desired package has. There are at least three distributions which widely use this tool: Calculate, Funtoo and Gentoo Linux.

Filter by
Sorted by
Tagged with
0 votes
1 answer
38 views

media-libs/libogg package won't install because lack of certificate

Intro/Context - https://ibb.co/8jkBNLy. What I am trying to do: I want to install kde-plasma desktop enviroment, on my gentoo machine that works only in text mode now. emerge --ask kde-plasma/plasma-...
0 votes
0 answers
100 views

How to install PFL (e-file) on Gentoo (in Docker)

I can't seem to figure out how to install pfl in order to get the e-file command. It was mentioned here that the pfl package would install the e-file command. So started a Gentoo Docker container and ...
  • 697
1 vote
2 answers
157 views

Gentoo invalid profile

So. Been going at the gentoo install without proper instructions until very recently. After emerge-webrsync stage of the install a message pops up saying "your current profile is invalid". ...
1 vote
2 answers
259 views

Is it safe to install packages with multiple instances of emerge running at the same time?

I'm currently installing Gentoo by following the Handbook. I ran emerge -uDN @world after changing USE flags and it's taking hours, but I would like to continue with the next step. Is it fine to ...
  • 179
0 votes
2 answers
202 views

How can I run many emerge jobs in paralell?

When I install many packages at once, I use emerge --jobs=8 firefox vim. This will install the packages, but it won't run everything in paralel. For example, it will wait compile rust before compiling ...
0 votes
1 answer
146 views

emerge cannot prevent installing as it cannot find the package name

Gentoo emerge cannot find name of package In attempt to prevent the installation of dev-python/setuptools-53.0.0 failed emerge: error: Invalid Atom(s) in --exclude parameter: 'dev-python/setuptools-53....
's user avatar
1 vote
3 answers
2k views

How to force a package to use a Python version in Gentoo?

I would like to use only one Python3 version for all my packages in a Gentoo system. So I looked for the installed versions and found out that three versions are installed: 3.6, 3.7 and 3.8. I would ...
  • 747
0 votes
1 answer
856 views

There are no ebuilds to satisfy

So, I want to install the vimb browser from a Gentoo overlay called 'booboo'. I added the overlay with layman and ran emerge vimb. This is what I get: emerge: there are no ebuilds to satisfy ">...
0 votes
1 answer
459 views

Command not found: eselect

I am using Gentoo (for the first time, actually). I am trying to set up package management. I discovered that I have to set up portage (emerge). While doing so, I had to run emerge --sync. That gave ...
1 vote
0 answers
201 views

Emerge (Gentoo) reports package as being installed and not installed

I am trying to upgrade a Gentoo installation from end 2018 to the current version (March 2020). I am following the instructions given here. I have a host installation which contains an up-to-date (...
  • 747
1 vote
0 answers
170 views

Removing a single dependency via USE flag in Gentoo

I have a system whose sound is currently pulseaudio-{dis,en}abled, and I'm trying to remove pulseaudio. I first ran a emerge --update --newuse --deep @world and that worked fine. Then I added "-...
  • 111
1 vote
1 answer
1k views

How to set CPU_FLAGS_X86 during Gentoo Stage 3 Install From Minimal without cpuid2cpuflags

I'm attempting my first Gentoo install, I'm relatively well versed in Linux but haven't done a ground up install before like this. I'm installing from Minimal and trying to set my CPU_FLAGS_X86 and ...
2 votes
2 answers
1k views

download packages for offline gentoo update

I have a machine with gentoo that does not have internet access but I want to install a few packages on it. I do not have another machine with gentoo, how does one download packages for it? google ...
  • 145
1 vote
1 answer
2k views

How to force emerge to install a newer version of a package?

I'm using Gentoo and needing to install a newer version of gcc, available in the official Gentoo package repo. I want to do the equivalent of apt-get install gcc=8.0.3-r1 but cannot figure out how. ...
  • 113
1 vote
0 answers
218 views

Can't install dev-util/meson-0.49.2::gentoo, with emerge, can't install any other package from the list

I am installing gentoo and now I am installing the packages with: (chroot)ubuntu /boot # emerge --ask --newuse --deep --verbose sys-boot/grub:2 os- prober and dev-util/meson-0.49.2::gentoo ...
0 votes
1 answer
641 views

Gentoo is missing X bitmapped fonts Helvetica, Times, Georgia

I'm installing Gentoo for the first time and I've noticed that all bitmapped X fonts except Misc are missing. For instance, I type xlsfonts | grep -i helvetica and it is not there, nor is times, ...
  • 1
1 vote
1 answer
1k views

Gentoo Linux - "emake" failed: No rule to make target '3'. Stop

I am trying to install Gentoo, where, according to the Handbook, says to update the world set. I get this (truncated for character limit): pqueue.h => ../../include/openssl/pqueue.h make[2]: ...
1 vote
1 answer
893 views

Having Troubles Installing Ninja on Gentoo

I am trying to install ninja (as a prequisite for YouCompleteMe for vim) and I get error. Here is the summary of my =dev-util/ninja-1.8.2::gentoo Portage 2.3.31 (python 3.5.5-final-0, default/...
  • 111
2 votes
1 answer
5k views

emerge /etc/portage/make.profile is not a symlink during Gentoo installation?

I cannot run emerge-webrsync because it says that snapshots are not found. Nor can I execute mirrorselect, since I get command not found. Finally, I tried to run: $ emerge --ask app-portage/...
0 votes
1 answer
132 views

emerge install package with flag which not in ruby_targets

$ emerge --info | grep ruby ..... RUBY_TARGETS="ruby23" ...... And I run emerge with --newuse and --deep, it will ask me to add use flag with ruby22. These packages are not in @system. These ...
  • 248
2 votes
1 answer
2k views

Dependency conflict while upgrading Gentoo

When I tried to upgrade my Gentoo system, I had got following errors: WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict: sys-libs/zlib:0 (sys-libs/zlib-1.2.11-...
's user avatar
2 votes
0 answers
525 views

Failed to emerge dev-libs/boost-1.63.0 (incompatible properties)

I am trying to install gentoo (genkernel) and I have boost as dependency. I got this error in log file: What is the problem? b2 --user-config=/var/tmp/portage/dev-libs/boost-1.63.0/work/...
  • 21
0 votes
1 answer
354 views

Why /etc/portage/package.use lines do not work installing Openshot?

On Funtoo Linux I has no sense how to solve requirements. I added lines but again and again I cannot run openshot installation # tail -n 5 /etc/portage/package.use >=x11-libs/libXcursor-1.1.14 ...
  • 1
1 vote
1 answer
1k views

Failed to emerge dev-libs/boost-1.65.0

I've got a following error while installing dev-libs/boost-1.65.0: >>> Install boost-1.65.0 into /var/tmp/portage/dev-libs/boost-1.65.0/image/ category dev-libs * abi_x86_64.amd64: running ...
's user avatar
1 vote
1 answer
492 views

Failed to emerge net-fs/samba-4.7.0-r1

I'm trying to update Gentoo to unstable. I executed emerge @preserved-rebuild because virtualbox-guest-additions install fails. emerge @preserved-rebuild stopped and threw error while Samba compiling. ...
's user avatar
1 vote
1 answer
191 views

Gentoo failed to emerge sys-devel/prelink-20130503

I'm trying to install app-emulation/wine Gentoo package using command: sudo WINE_COMMIT="wine-2.0-rc5" STAGING_COMMIT="v2.0-rc5" emerge -av '=app-emulation/wine-9999' but compilation of sys-devel/...
's user avatar
1 vote
0 answers
82 views

Funtoo: define for emerge to use certain version in futher world update

Funtoo has no libxklavier-5.4 that is required by latest xfc4-xkb-plugin-0.8.1 # emerge xfce4-xkb-plugin Calculating dependencies... done! emerge: there are no ebuilds to satisfy ">=x11-libs/...
  • 61
1 vote
2 answers
310 views

How to work around a error in an eclass file located in a Gentoo overlay?

(cross-posting from the Gentoo forum) I try editing the .eclass file in order to correct the error, but it seems my edits are being defeated by a cache somewhere. The initial error occurs when I run ...
7 votes
3 answers
2k views

How do you print a list of all upgradeable packages in Gentoo

doing emerge -avuDN --with-bdeps y --keep-going @world takes a whole lot of time and often fails. Is there a way to print a list of all upgrade-able packages in a Gentoo system?
  • 497
1 vote
1 answer
1k views

When Gentoo emerge world fails, it starts again from the beginning. Why?

I've been using gentoo for about 10 years. I love the distro. But there is some thing that's been really needling me, and i've never got to the bottom of it, so I thought it might be worth asking in ...
  • 205
0 votes
2 answers
3k views

Gentoo: cannot install sys-kernel/gentoo-sources-4.4.6, no error message

I am trying to install Gentoo on an old laptop following the online handbook. I got as far as installing the kernel sources (see here): the installation with emerge --ask sys-kernel/gentoo-sources ...
  • 747
1 vote
1 answer
3k views

How to install custom source from git using my package manager in Gentoo?

I would like to install custom source from a git repository, but using my package manager (emerge for portage). Background I have installed Gentoo using EFI using Sakaki's tutorial, so I have ...
  • 209
0 votes
1 answer
143 views

Manual emerge package zlib

How can I install/emerge a package manual in gentoo? I cannot download this package (ZLIB), because it gets blocked by our IT-Firewall (invalid decompression table). They scan each http/ftp request ...
  • 103
4 votes
2 answers
772 views

emerge scheduled 2 versions of the same package (dev-lang/perl-5.20 vs. perl-5.22) to build - causing conflicts

I'm trying to update all my packages, so I ran: emerge -aUDU --with-bdeps=y --verbose-conflicts @world and I found a few package conflicts. Interestingly enough though, is that it has scheduled two ...
  • 141
2 votes
1 answer
774 views

How do I get Portage to always select to install and upgrade to the latest available version of selected software?

I would like to get Portage to always install the latest available version of selected software (i.e., software specified when running emerge, along with all relevant dependencies that also need to be ...
  • 3,343
2 votes
1 answer
2k views

An issue that use Emerge to install package

I'm not too much experienced within Gentoo portage, When I tried to install Nodejs # emerge --ask monit nginx nodejs into my gentoo and i get an error message like: [ebuild N ] net-libs/...
  • 313
3 votes
2 answers
1k views

Gentoo won't update Chromium due to conflict with libxml, icu USE flag is globally set on make.conf, qt-webkit is not part of the conflict

I am running Gentoo Hardened using kernel version 4.1.7-hardened-r1. When I first set up my system I was able to emerge Chromium without a hitch. However, I recently issued emerge --sync followed by a ...
  • 1,298
5 votes
2 answers
4k views

How do I apply multiple profiles at once on Gentoo?

I am installing KDE on a Gentoo Linux Hardened system. The official Gentoo wiki says the recommended way is to apply the KDE desktop profile, issue emerge -NDu --with-bdeps=y @world, and then install ...
  • 1,298
3 votes
2 answers
1k views

Fatal mistake: Uninstalled sys-devel/binutils - emerge don't work anymore

I cleaned up my system 3 weeks ago and made a fatal mistake. Well, I don't really know why, but I uninstalled sys-devel/binutils. After I recognized the mistake I tried re-emerge, but it doesn't work....
  • 133
1 vote
1 answer
130 views

How to download nouveau source in selected directory with Portage?

I would like to download Nouveau source code. There is an x11-drivers/xf86-video-nouveau ebuild, but I don't want to install it(downloading is okay though). Let's say that I want to install it into ~/...
  • 6,616
4 votes
1 answer
930 views

How to stop emerge showing "unnecessary" blockages

I am usually updating my ~amd64 Gentoo system using emerge -avNuD --backtrack=100 @world. I do however often get the following type of blockages. sys-libs/ncurses:5 (sys-libs/ncurses-6.0:5/6::...
  • 315
0 votes
1 answer
330 views

Can't install MySQL client libraries on Gentoo

I'm new in Gentoo. I'm trying get the mysql2 gem installed. But it's stuck. I found out that I need MySQL client libraries. I tried: emerge dev-db/mysql:minimal * IMPORTANT: 2 news items need ...
  • 131
0 votes
1 answer
644 views

Using package.env for phase hooks

Following this answer I've set up a simple file /etc/portage/env/echo.conf: post_pkg_postinst() { echo "updating $P to $PV" } with the line sys-apps/util-linux echo.conf in /etc/portage/...
  • 245
4 votes
2 answers
2k views

What does "WHIRLPOOL size ;-)" mean?

Often when installing or upgrading packages the following appears in the log: * ….tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ... What does this mean and what does the emoticon signify? ;-)
's user avatar
2 votes
1 answer
2k views

Python now thinks arguments are files: Broken emerge, pip, livestreamer and most tools using Python

For these commands (in both bash and fish): sudo emerge eix emerge eix I get this error: usage: emerge [-h] [--version] [input [input ...]] emerge: error: argument input: can't open 'eix': [Errno 2]...
  • 223
4 votes
1 answer
2k views

Why does Chromium use so much disk space on Gentoo Linux?

I have chosen Gentoo for my Linux distribution. I installed it in VirtualBox for practice purposes only, so I just gave it 10GB of disk space. Yesterday when I tried to emerge the Chromium package, it ...
  • 85
0 votes
1 answer
619 views

Gentoo CPU_FLAGS_X86 doesn't work

I havn't updated my system for few months and found i have to add new option to my make.conf. Ok, so now i have CPU_FLAGS_X86="aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" ...
  • 101
0 votes
1 answer
90 views

Flag change log in gentoo

I was wondering if there is any tool that shows changed flags of recently emerged packages? I missed to use --ask -v while using emerge and I lost the verbose details. I have checked the /var/log/...
  • 287
7 votes
2 answers
6k views

Installl a specific version of a portage overlay package

I need to install an older version of x11-libs/bamf package , as you can see below there are different versions available I want to install 0.5.0[2], but it always go to 9999 version using "emerge ...
  • 287
1 vote
1 answer
2k views

How to remove set from portage

I was dealing with a lot of blocks of Qt5. [blocks B ] <dev-qt/qtgui-4.8.6:4 ("<dev-qt/qtgui-4.8.6:4" is blocking dev-qt/qtchooser-0_p20150102) [blocks B ] <dev-qt/qtsql-4.8.6:4 ("...
  • 870