Questions tagged [dnf]

DNF(Dandified Yum) is the next upcoming major version of Yum, a package manager for RPM-based Linux distributions. It roughly maintains CLI compatibility with Yum and defines strict API for extensions and plugins.

Filter by
Sorted by
Tagged with
0 votes
1 answer
101 views

'sudo dnf update' package conflicts on Fedorda Rawhide 37

Below is my output from trying to update my packages using dnf update. I'm new to the rawhide community. I'm not sure if this is an error on the package maintainers end and it will resolve itself? I ...
user avatar
0 votes
2 answers
24 views

How to list installed packages with their summary using `dnf`?

I can list installed packages on my Fedora with: dnf list installed When searching for packages, I'd use something like: dnf search terminal dnf will proceed to list available packages similar to ...
user avatar
  • 10.5k
0 votes
0 answers
13 views

How could I prevent conflicting packages and broken dependencies with DNF in Fedora?

I've made a normal update on a broken WiFi spot (I don't know if it's linked but it's the only time it happened to me) and now I have some broken dependencies in Fedora 36. DNF seems to try to install ...
user avatar
  • 253
0 votes
0 answers
12 views

dnf upgrade sequence of actions

What exactly does dnf upgrade <package> do? Am I right that it: Removes the old package, if higher version is available (is it similar to dnf remove <package>?) Installs the new version (...
user avatar
  • 1,471
0 votes
0 answers
41 views

Yum/dnf error (35) when using https connections on CentOS Stream 9

BLUF: Can someone help me set yum and/or dnf to prefer TLS 1.3 when connecting to https sites? Situation: fresh installation of CentOS Stream 9 (CentOS-Stream-9-20220718.0-x86_64-dvd1.iso) on ...
user avatar
-2 votes
1 answer
23 views

Why does dnf consider a package with a lower version number than the installed one an update?

On Fedora 36 I have installed package wine-7.2-1.fc36.x86_64 from repo fedora. If I run "dnf upgrade" it wants to install version 7.12-1.fc36.x86_64 from repo updates. Also the operation is ...
user avatar
  • 139
0 votes
0 answers
76 views

How to handle dependency problem during dnf update?

I use sudo dnf update and after downloading I get the error [SKIPPED] glibc-devel-2.34-34.fc35.i686.rpm: Already downloaded ... Transaktionsüberprüfung wird ausgeführt Fehler: Konflikt zwischen ...
user avatar
  • 101
0 votes
0 answers
62 views

broken dnf while updating fedora 34 to 35

I'm using fedora 34. Update to 35 returns error After some search with google, the issue is reported to be a broken dnf. Tried to solve issue with no success. error messages: Traceback (most recent ...
user avatar
  • 1
0 votes
1 answer
37 views

yum: install local RPMs and all local dependencies

I have my locally generated rpm packages (the main package and its dependencies) located in my home directory. The spec file defined dependencies. I'd like to install it with a single yum or dnf ...
user avatar
  • 1,471
1 vote
0 answers
673 views

CentOS 8.5.2111 with EPEL repository: Upgrading Ansible via dnf fails

I've installed ansible-2.9.27-1.el8.noarch on a CentOS Linux release 8.5.2111 machine. For this I've enabled the "epel-release" repo using "dnf install epel-release". When I try to ...
user avatar
2 votes
0 answers
207 views

CentOS 8 stream module conflicts installing package

I'm trying to install the redhat-lsb package. This will allow me to gather additional facts when running ansible against this target machine. When I attempt to install redhat-lsb I get the following ...
user avatar
-3 votes
1 answer
58 views

What is the relation/difference between "Package Manager" or "Package Management"?

I read in many tutorials about apt and dnf and others where the "Package Manager" and "Package Management" terms are used - but just being curious: What is the relation/difference ...
user avatar
3 votes
3 answers
322 views

Remove all dnf modules currently installed

I have a CentOS 8.0 system with quite a few modules installed I don't want. I want to get rid of them to force an upgrade to CentOS 9.0, which I know is not officially supported but it is not actually ...
user avatar
  • 1,810
1 vote
1 answer
53 views

How to install syslinux-efi64 on Centos 8

In order to Create bootable syslinux USB on UEFI with Centos 8, I need some files from the syslinux-efi64 package. The centos.org site says that such a package exists, but yum/dnf fails to install it: ...
user avatar
  • 407
1 vote
1 answer
90 views

Fedora Offline-Upgrade shutdown instead of reboot from CLI

Before turning off my Laptop (which runs Fedora 36) I like to run sudo dnf offline-upgrade download -y && sudo dnf offline-upgrade reboot || sudo shutdown now So that all pending updates get ...
user avatar
  • 13
3 votes
1 answer
205 views

What does this yum package version mean?

On Rocky Linux: $ sudo yum list squid Available Packages squid.x86_64 7:4.15-3.module+el8.6.0+842+aea5c28d What does the 7: and the .module ... part of the version string mean? I can see the ...
user avatar
  • 172
0 votes
1 answer
44 views

rpm database lost, how to proceed?

I completely lost the rpm directory under /var/lib with no way to recover it. (I know what I should have done...) I have made a new one (rpm --initdb) but of course rpm and yum no longer know what's ...
user avatar
0 votes
1 answer
89 views

Does dnf work with all the latest data installed/updated got through yum?

Through Virtual Box was installed Fedora Workstation 36. It for experimental purposes. About package/repository management there are two options yum and dnf where the latter is preferred over the ...
user avatar
0 votes
1 answer
20 views

Where to find pstreams-devel package for Rocky Linux 8 (EPEL)?

It seems there is no pstreams-devel package in Rocky Linux 8. I was wondering why it has not been included and if there is a way to get it from some extra repository? The last reference to it that I ...
user avatar
  • 300
3 votes
1 answer
382 views

What is the link between g++ and gcc-c++ in Fedora's DNF repositories?

On Fedora 35: # dnf install g++ Last metadata expiration check: 0:07:14 ago on Fri May 6 09:44:09 2022. Package gcc-c++-11.3.1-2.fc35.x86_64 is already installed. Dependencies resolved. Nothing to ...
user avatar
0 votes
0 answers
28 views

dnf cannot find bashdb on fedora 34 arm version

I'm running arm version of fedora 34 using parallels on a m1 Mac mini. However, when I tried sudo dnf install bashdb, it complains the package is not found. I also tried to download the tar files and ...
user avatar
  • 1
1 vote
1 answer
1k views

Fedora transaction test error on dnf update: file "conflicts"

I am trying to update Fedora using sudo dnf update. It lists the packages to be updated, downloads them, but then fails with this message: Running transaction check Transaction check succeeded. ...
user avatar
  • 11
0 votes
0 answers
292 views

What's the best way to upgrade Go to 1.18 on Alma Linux?

I need to upgrade the version of Go on my Alma Linux 8 box from the installed version 1.16 to the latest 1.18. There are several tutorials on how to install, but I haven’t found any for upgrade ...
user avatar
  • 103
0 votes
1 answer
67 views

Fedora stuck on running scriplet: systemd-libs

I used the dnf update command and after some time this happened. It's been like this for half an hour. Not only that, but I can't move my mouse, press any buttons, open something else, the computer is ...
user avatar
  • 1
0 votes
1 answer
267 views

I need help with an Alma Linux error with dnf: "There are no enabled repositories..."

I have a new install of Alma Linux 8 and I'm having a problem figuring out how to be able to install packages. When I run dnf, I get: Error: There are no enabled repositories in "/etc/yum.repos.d&...
user avatar
  • 103
2 votes
0 answers
142 views

Configure dnf to use DNS-over-HTTPS (DoH) without using systemd-resolved

Is there a way to configure dnf to use DNS-over-HTTPS (DoH) without using systemd-resolved or a proxy (i.e. dnscrypt-proxy)? I dont like have local servers running on desktops (even on loop back ...
user avatar
1 vote
1 answer
371 views

How to tell "dnf search" to list only matches in the pacakge name (or name and summary), but not only in the summary?

On RHEL/CentOS the package manager dnf can search for strings in the names and summaries of packages. How can I tell it to list only matches in the name (or in name and summary), but not in the ...
user avatar
  • 335
1 vote
1 answer
311 views

How to mark packages as manually installed with DNF

I'm looking for the equivalent of running apt install with a package that came pre-installed on the system or was automatically installed as a dependency of another package. apt then simply marks that ...
user avatar
2 votes
1 answer
2k views

Conflicting requests after update to CentOS 9 Stream from 8

I have a CentOS 8 system that I have decided to upgrade to CentOS 9 and this is not offically supported. I did however find some directions on doing this a few pages into a Google search on Github. ...
user avatar
  • 1,810
1 vote
0 answers
147 views

How to install php 8 to aarch64 oracle linux?

Since official Oracle Linux only support up to 7.4 and Remi repo also doesn't support aarch64 , how to install PHP 8 to aarch64 oracle Linux?
user avatar
0 votes
1 answer
262 views

Setting up DNF on Yocto

I am using PetaLinux (or Yocto) as my systems OS. I built the image and have dnf as my package manager. However, when I try to install something, I get the error message: Error: There are no enabled ...
user avatar
  • 101
0 votes
2 answers
146 views

Install Yum/Dnf in a Virtualenv

I've created a Virtualenv (with python3.6) and want to install yum/dnf package in that environment. Is there any way to do that? As import dnf or import yum giving me error in that environment -> ...
user avatar
  • 13
0 votes
0 answers
32 views

Installed app does not show up on the gnome dashboard

I was messing with flatpak and dnf ( removing and installing and testing qutebrowser) and now i can't add qutebrowser to my favorites( im using gnome) and i cant find it as an app but i can run it ...
user avatar
0 votes
1 answer
53 views

setarch i686 with builddep on fedora 35 can't find repositories

Want to install 32-bit build dependencies on Fedora 35, but fails, should this be possible? Is there a way to resolve it? [root@fedora etc]# setarch i686 dnf builddep wine-devel enabling fedora-source ...
user avatar
0 votes
0 answers
99 views

Duplicate GPG key CentOS 8

If I run dnf check I get the following message: centos-gpg-keys-1:8-2.el8.noarch is a duplicate with centos-gpg-keys-1:8-3.el8.noarch How do I get rid of centos-gpg-keys-1:8-2.el8.noarch, I've found ...
user avatar
0 votes
1 answer
98 views

How do you download a RPM by name and version, using Python or terminal?

I need to download .rpm files for particular packages by specifying the package name and version. Such as "libX11-1.5.99.902". I've been looking online to find a way to query & download ....
user avatar
0 votes
1 answer
196 views

Running dnf update on Fedora returns conflicts for MongoDB

I'd appreciate some advice resolving the following conflict with MongoDB install on my Fedora Workstation. I've added MongoDB as a custom repo and get the following output in the terminal when running ...
user avatar
0 votes
0 answers
39 views

VS Code Download Error

I am using Centos and I get this error message on trying to download the vs code for linux. I have tried updating the system but still no progress.Please help. Total download size: 108 M Installed ...
user avatar
  • 37
0 votes
1 answer
141 views

How to remove commands installed through the "command-not-found" prompt

On Fedora 35, if I type in a command that is not installed, like mu, then I get a prompt that offers to install it for me, i.e. mu bash: mu: command not found... Install package 'maildir-utils' to ...
user avatar
0 votes
1 answer
147 views

Updating packages on CentOS via dnf module list using https?

I have a new Centos 8 installation and am trying to use dnf to install the packages I need. Company rules (and common sense, honestly) is that any outgoing traffic needs to be done over HTTPS. However ...
user avatar
  • 123
3 votes
1 answer
1k views

Errors during downloading metadata for repository 'epel'

What specific syntax must be changed in the cloud-init startup script excerpt below in order to handle the error message shown below by retrying something else until it correctly works without ...
user avatar
  • 5,153
2 votes
1 answer
449 views

Dnf/Yum repository install on AIX 7.1 ImportError: 0509-022/0509-150 libcrypto

I am trying to create a Yum/Dnf Repository for an offline AIX 7.1 and I've downloaded all the repos by using the reposync on a linux machine that was connected to the internet. I've installed the Dnf ...
user avatar
0 votes
1 answer
65 views

Does sudo dnf install dnf-plugins-core -y affect all users?

I'm a newbie to Fedora and a novice at Linux in general, but I just want to know whether I have to run that command in every different user account: I have three, a root user, and two others for some ...
user avatar
  • 1
2 votes
3 answers
2k views

Can't install Certbot for Apache on CentOS Stream 9 (python3-certbot)

On Centos Stream 9, when I try to install certbot (sudo yum install certbot) into the server it returns: Error: Problem: package certbot-1.22.0-1.el8.noarch requires python3-certbot = 1.22.0-1.el8, ...
user avatar
0 votes
0 answers
51 views

DNF system-upgrade reboot does not trigger upgrade (Fedora 33 to 34)

Trying to upgrade from Fedora 33 to F34, following the Fedora docs and the upgrade does not start after reboot or even after a shutdown and fresh start. I've repeated the process more than four times, ...
user avatar
  • 1
0 votes
1 answer
326 views

How to easily remove old kernels with DNF under Mageia?

As installonly_limit 3 in etc/yum/yum.conf and in etc/dnf/dnf.conf didn't seem to have any effect under Mageia even by running dnf autoremove, I tried to run dnf remove $(dnf repoquery --installonly --...
user avatar
  • 101
1 vote
2 answers
1k views

nothing provides selinux-policy-base >= 3.14.3-80.el8_5.2

I am trying to install snap on my rhel 8.4 machine and it throws the following error Error: Problem: package snapd-2.54.1-1.el8.x86_64 requires snapd-selinux = 2.54.1-1.el8, but none of the ...
user avatar
-3 votes
1 answer
272 views

yum errors with 404

I am running RHEL 7.6 on virtualbox and have been trying to install dnf using yum. yum install dnf errors with the following: Not only this, other commands like yum check-update, yum list etc also ...
user avatar
0 votes
1 answer
88 views

created by dnf config-manager from https://brave-browser-rpm-release.s3.brave.com/x86_64/ Fedora

Whenever I try to install or update any package it starts to update the brave browser created by dnf config-manager from https://brave-browser-rpm-release.s3.brave.com/x86_64/ I just removed the ...
user avatar
0 votes
1 answer
159 views

Find why a specific package is installed in a big chain of dnf dependencies

I'm trying to do a 'dnf update' and getting a bunch of errors like: Problem 2: cannot install both libinput-1.16.3-2.el8.x86_64 and libinput-1.16.3-1.el8.x86_64 - package libinput-devel-1.16.3-1....
user avatar

1
2 3 4 5
7