All Questions

7 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
4
votes
0answers
2k views

Cryptsetup hanging after passphrase entered

I am currently looking to recover some data for a friend from an internal HDD removed from a laptop that they had encrypted using LUKS. They can't really tell me much more else as somebody else ...
2
votes
1answer
1k views

Proper manual OS setup on LUKS encrypted drive with non-aes algorithm on yum-based distro (CentOS)

I'm trying to achieve LUKS-encrypted CentOS 7 install with separate /boot partition and lvm on EFI-friendly motherboard. I've done partitioning fresh CentOS install from old CentOS(installed from GUI)...
1
vote
0answers
400 views

Moving encrypted partition from passphrase to random keyfile?

I have a fresh install of Debian using sda2_crypt as swap. When I set it up I used a passphrase, but I would like to move to a random keyfile instead so that it won't prompt to unlock at every boot. ...
1
vote
0answers
356 views

Is multiple ecryptfs encryption possible?

Is multiple ecryptfs encryption possible? How to encrypt a folder called level2 with ecryptfs that is inside a ecryptfs mounted folder called level1? level1 and level2 folder are organized as # ...
0
votes
0answers
43 views

Is there a way to do one-time pads(OTP) with Linux cryptsetup(dm-crypt)?

It looks like losetup with cryptoloop did it and there was a dm-xor module for a very old kernel, but can't find anything modern. I'm wading through a ton of obsolete losetup documents. Something ...
0
votes
0answers
21 views

dm_crypt mount on login takes 90 seconds

I'm trying to configure automounting encrypted home on login with user password=encryption password. I'm using archlinux + kde + sddm + crypsetup (dm_crypt). Following archlinux article I did as ...
0
votes
0answers
438 views

Grub-install error: disk 'crpytouuid/<uuid>' not found

I followed fdiblen's guide on Arch Linux Installation with a Fully encrypted disk and Btrfs filesystem that uses cryptsetup. I'm at the bootloader stage where I'm trying to grub-install with these ...