Questions tagged [debian]

Questions specific to the Debian official distribution (stable, testing, or unstable); if you are using a derivative of Debian (e.g. Mint, Ubuntu, Kali, etc), then use that distribution’s tag instead.

Filter by
Sorted by
Tagged with
362 votes
18 answers

How do I set my DNS when resolv.conf is being overwritten?

Most of the info I see online says to edit /etc/resolv.conf, but any changes I make there just get overridden. $ cat /etc/resolv.conf # Dynamic resolv.conf(5) file for glibc resolver(3) generated by ...
Seán Hayes's user avatar
  • 4,521
339 votes
5 answers

What's the story behind Super Cow Powers?

As we know, apt-get has Super Cow Powers and aptitude does not: $ apt-get --help | grep -i cow This APT has Super Cow Powers. $ aptitude --help | grep -i cow ...
derobert's user avatar
  • 108k
280 votes
10 answers

What is the real difference between "apt-get" and "aptitude"? (How about "wajig"?)

I know that both apt-get and aptitude are command line package management interfaces on Debian derived Linux, with different options, but I'm still somewhat confused. Under the hood, aren't they ...
Kevin Cantu's user avatar
  • 3,774
260 votes
4 answers

How to enable diffie-hellman-group1-sha1 key exchange on Debian 8.0?

I am unable to ssh to a server that asks for a diffie-hellman-group1-sha1 key exchange method: ssh Unable to negotiate with port 22: no matching key exchange method ...'s user avatar
243 votes
3 answers

Why is 'ls' suddenly wrapping items with spaces in single quotes?

I just noticed that on one of my machines (running Debian Sid) whenever I type ls any file name with spaces has single quotes surrounding it. I immediately checked my aliases, only to find them intact....
Wyatt Ward's user avatar
  • 3,962
207 votes
5 answers

Failed to fetch jessie backports repository

I'm using a docker image as a base for my own development that adds the jessie backports repository in its Dockerfile and uses that to install a dependency. This image uses the following command to ...
user12345's user avatar
  • 2,013
177 votes
1 answer

How to apt-delete-repository? [duplicate]

I would like to run the reverse of this command to remove the non-compatible repository in Debian 8.1 sudo add-apt-repository -y ppa:nemh/systemback where the command add-apt-repository is in the ...
Léo Léopold Hertz 준영's user avatar
173 votes
10 answers

"no public key available" on apt-get update

When performing apt-get update, I get the following error: root@ADS3-Debian6:/home/aluno# apt-get update Atingido squeeze Release.gpg Ign squeeze/...
That Brazilian Guy's user avatar
163 votes
4 answers

-bash: sudo: command not found

I am trying to deploy django app. When I print apt-get update I see W: Unable to read /etc/apt/apt.conf.d/ - DirectoryExists (13: Permission denied) W: Unable to read /etc/apt/sources.list.d/ - ...
user2950593's user avatar
  • 1,797
160 votes
6 answers

How can I communicate with a Unix domain socket via the shell on Debian Squeeze?

I’m running a Debian Squeeze web server. I’ve installed memcached on it, and configured memcached to listen on a Unix domain socket (at /tmp/memcached.sock), as it only needs to receive messages from ...
Paul D. Waite's user avatar
158 votes
4 answers

How to add repository from shell in Debian?

In Ubuntu one can add a repository via following command - sudo add-apt-repository ppa:yannubuntu/boot-repair As Ubuntu is based on Debian code base, I was expecting that the same would work in ...
Kshitiz Sharma's user avatar
136 votes
12 answers

List packages on an apt based system by installation date

How can I list installed packages by installation date? I need to do this on debian/ubuntu. Answers for other distributions would be nice as well. I installed a lot of stuff to compile a certain ...
Elazar Leibovich's user avatar
133 votes
3 answers

gpg: keyserver receive failed: No dirmngr

While trying to receive keys in my Debian Stretch server, I get this error: sudo apt-key adv --keyserver hkp:// --recv-keys 3FA7E0328081BFF6A14DA29AA6A19B38D3D831EF Executing: /...
Hunter.S.Thompson's user avatar
131 votes
4 answers

How to update Linux "locate" cache

How can I update the cache / index of locate? I installed new packages and the files are clearly not yet indexed. So which command do I have to commit, in order for the indexer to trigger? I'm ...'s user avatar
126 votes
9 answers

How to install Python 3.6?

I'd like to install the latest Python, which is 3.6 at the time of this post. However, the repository is saying that Python 3.4.2 is the newest version. I've tried: $ sudo apt-get update $ sudo apt-...
davidtgq's user avatar
  • 1,494
123 votes
7 answers

Error when trying to connect to bluetooth speaker: `org.bluez.Error.Failed`

I'm running Debian Jessie 8.2. I have a bluetooth USB dongle connected to my machine. I run sudo bluetoothctl -a then do the following: [NEW] Controller 5C:F3:70:6B:57:60 debian [default] Agent ...
Username's user avatar
  • 801
113 votes
6 answers

List of available services

Is there any command that would show all the available services in my wheezy Debian based OS? I know that in order to see all the running services you can use service --status-all.
Dragos Rizescu's user avatar
112 votes
3 answers

What's the difference between /usr/lib/systemd/system and /etc/systemd/system?

Before all the unit files were in /etc/systemd/system/ but now some are showing up in /usr/lib/systemd/system (<- on CentOS, or /lib/systemd/system <- on Debian/Ubuntu), what is the difference ...
therealssj's user avatar
  • 1,251
108 votes
4 answers

How do I know which version of Debian I'm running?

In a tutorial, I'm prompted "If you are running Squeeze, follow these instructions..." and "If you are running Wheezy, follow these other instructions..." When I run uname, I get the following ...
IQAndreas's user avatar
  • 10.2k
107 votes
5 answers

Possible missing firmware /lib/firmware/i915/* for module i915

I am getting these warnings every time I update my initramfs image(-s) with update-initramfs on my Dell PowerEdge T20 server running GNU/Linux Debian Buster 10.0. Is there a fix? W: Possible missing ...
Vlastimil Burián's user avatar
105 votes
5 answers

Installing a .deb package on Arch - Is it possible?

The problem is simple - I have a .deb package and I want to install it on my Arch Linux. Is this possible? If yes, how?
BKC's user avatar
  • 1,153
95 votes
6 answers

How to COMPLETELY turn off system beep sounds forever for good for real

I use Nautilus to explore my files. I use a Debian-based OS with KDE Plasma 5. I use the keyboard a lot. When I press the key up when navigating files, if I'm already at the extremity of the list of ...
Guillaume Chevalier's user avatar
95 votes
4 answers

Purpose and typical usage of /etc/rc.local

The header looks like this: #!/bin/sh -e # # rc.local - executed at the end of each multiuser runlevel # # Make sure that the script will "exit 0" on success or any other # value on error. What is ...
Emanuel Berg's user avatar
  • 6,763
94 votes
5 answers

Problem of Can't set locale; make sure $LC_* and $LANG are correct!

When I always try to install new package I get this message: Can't set locale; make sure $LC_* and $LANG are correct! perl: warning: Setting locale failed. perl: warning: Please check that your ...
Ismail Sensei's user avatar
91 votes
5 answers

Set systemd service to execute after fstab mount

I'm working on a systemd .service script that is supposed to start after a CIFS network location is mounted via /etc/fstab to /mnt/ on boot-up. The script waits for an OpenVPN dependency script to ...
P A N's user avatar
  • 1,671
91 votes
5 answers

apt-get fails: The method driver /usr/lib/apt/methods/https could not be found

I tried to update my OS Debian jessie using the terminal and i get an error : “E: The method driver /usr/lib/apt/methods/https could not be found.” error? My sources.list : deb http://httpredir....
GAD3R's user avatar
  • 63.6k
91 votes
4 answers

How do I change the default text editor in the Debian (squeeze) distro

"Joe's own editor" does not come naturally to me. How do I change to using nano or vim? I've tried export EDITOR=nano but it doesn't seem to be respected. I'd like visudo to respect this as well.
wmarbut's user avatar
  • 1,011
91 votes
14 answers

How to unload kernel module 'nvidia-drm'?

I'm trying to install the most up-to-date NVIDIA driver in Debian Stretch. I've downloaded from here, but when I try to do sudo sh ./ as ...
Rodrigo's user avatar
  • 1,732
90 votes
13 answers

Tab completion errors: bash: cannot create temp file for here-document: No space left on device

When using the tab bar, I keep getting this error: bash: cannot create temp file for here-document: No space left on device" Any ideas? I have been doing some research, and many people talk about ...
lucasrodesg's user avatar
  • 1,002
89 votes
1 answer

Easy command line method to determine specific ARM architecture string?

I'm trying to write a script which will determine actions based on the architecture of the machine. I already use uname -m to gather the architecture line, however I do not know how many ARM ...
Thomas Ward's user avatar
  • 2,610
88 votes
6 answers

Why do iptables rules disappear when restarting my Debian system?

I add this rule: sudo iptables -t nat -A OUTPUT -d a.b.c.d -p tcp \ --dport 1723 -j DNAT --to-destination a.b.c.d:10000 When restart computer rules are deleted. Why? What I can do to make the ...
Jhonathan's user avatar
  • 3,535
88 votes
4 answers

What does adduser do that useradd doesn't?

In addition to the more widespread useradd, Debian based systems also contain an additional adduser command which provides a higher level interface for adding users and some related tasks. There are ...
Graeme's user avatar
  • 33.7k
86 votes
3 answers

How do services in Debian work, and how can I manage them?

In Windows I have the services manager, where I see all system services, that can be started through Windows itself, I set up the user it uses, the rights management is in there, and I can pass ...
Erdinc Ay's user avatar
  • 1,000
83 votes
7 answers

What directories do I need to back up?

What are the directories one should back up, in order to have a backup of all user-generated files? From a vanilla debian install, I can do enough apt to get the packages that I want. So if I don't ...
user394's user avatar
  • 14.2k
78 votes
3 answers

How do I run 32-bit programs on a 64-bit Debian/Ubuntu?

I have a 64-bit (amd64 a.k.a. x86_64) Debian or Ubuntu installation. I need to run 32-bit (i386/i686) programs occasionally, or to compile programs for a 32-bit system. How can I do this with a ...
Gilles 'SO- stop being evil''s user avatar
78 votes
2 answers

Debian: The repository does not have a Release file

Whenever trying to install some programs from source, or specifically running apt update, I receive this message: E: The repository ' stretch/updates Release' does not ...
user avatar
77 votes
3 answers

OpenSSH: How to end a match block

I'm using a Match block in OpenSSH's /etc/ssh/sshd_config (on debian) to restrict some users to SFTP: # my stuff Match group sftponly X11Forwarding no AllowTcpForwarding no ForceCommand ...
mreithub's user avatar
  • 3,543
77 votes
3 answers

Can I rollback an apt-get upgrade if something goes wrong?

Is there a way, before starting an aptitude upgrade or apt-get upgrade, to set up something so that you can "easily" rollback your system to the "apt" state it was before the actual upgrade, if ...
Totor's user avatar
  • 19.4k
75 votes
6 answers

How to safely turn off swap permanently and reclaim the space? (on Debian Jessie)

I installed Debian Jessie with default partitioning on my SSD drive. My current disk partitioning looks like this: As I have 16GB of RAM, I assume I don't need swap. But since I have other disk ...
Vlastimil Burián's user avatar
74 votes
11 answers

Backspace, Tab not working in terminal (using ssh)

When I ssh into another machine with Debian with my account(with sudo permissions), my backspace key generates some awkward symbols on pressing. Also Tab & del keys don't work too. On the other ...
gopi1410's user avatar
  • 849
74 votes
3 answers

Using ip addr instead of ifconfig reports "RTNETLINK answers: File exists" on Debian

I have a Debian system working as a wireless router with eth0 and wlan0. Now I added an additional network manually on eth1 with ifconfig: alix:~# ifconfig eth1 netmask alix:...
ceving's user avatar
  • 3,461
71 votes
7 answers

Crontab never running while in /etc/cron.d

Here's what I did on Debian Jessie: install cron via apt-get install cron put a backup_crontab file in /etc/cron.d/ However the task is never running. Here are some outputs: /# crontab -l no ...
Jivan's user avatar
  • 849
70 votes
4 answers

Full-upgrade to Debian testing fails due to libc6-dev : Breaks: libgcc-8-dev

I've just switched to bullseye (see sources below) deb testing main contrib non-free deb-src testing main contrib non-free deb http://deb....'s user avatar
69 votes
5 answers

Where in Apache 2 do you set the ServerName directive globally?

NOTE: This is related to my question: "Apache 2.4 won't reload, any problem with my configuration?". I'm trying to test a local site, locally. As I understand Apache 2 (and perhaps Apache as well) ...
shirish's user avatar
  • 12k
68 votes
4 answers

Cannot update APT list: "repository no longer has a Release file"

I cannot run apt-get update as I encounter the following error: # apt-get update Hit:1 testing InRelease Ign:2 testing/...
giusti's user avatar
  • 1,797
68 votes
1 answer

dmesg: read kernel buffer failed: Permission denied

Since recently Debian has changed the default behavior for dmesg and I cannot use it simply from my local user. % dmesg dmesg: read kernel buffer failed: Operation not permitted Same goes for: % ...
malat's user avatar
  • 2,708
67 votes
6 answers

Moving /var, /home to separate partition

I am attempting to move some folders (such as /var and /home) to a separate partition after reading this guide: 3.2.1 Choose an intelligent partition scheme I was able to move one folder ...
toffee.beanns's user avatar
67 votes
3 answers

How to undo sudo add-apt-repository?

I ran sudo add-apt-repository ppa:noobslab/indicators to install my-weather-indicator but it requires GTK3 and I don't want to proceed further. So I'd like to undo that command. I've checked my /etc/...
Sigur's user avatar
  • 2,411
66 votes
3 answers

wkhtmltopdf - QXcbConnection: Could not connect to display

How to run wkhtmltopdf headless?! Installation on Debian Whezzy apt-get install wkhtmltopdf Command wkhtmltopdf --title "$SUBJECT" -q $SOURCEFILE $OUTPUTFILE Error QXcbConnection: Could not ...
clarkk's user avatar
  • 1,747
64 votes
12 answers

gpg: keyserver receive failed: Server indicated a failure

This error has arise when I add gns repository and try to use this command: #sudo apt-key adv --keyserver --recv-keys F88F6D313016330404F710FC9A2FD067A2E3EF7B the error is: gpg:...
Govinda Chaulagain's user avatar

2 3 4 5