Questions tagged [configure]

A Configure script is an executable script designed to aid in developing a program to be run on a wide number of different computers.

Filter by
Sorted by
Tagged with
0 votes
2 answers
46 views

checking whether the C compiler works... no

I'm trying to build Linux From Scratch (LFS) I'm just following this books https://www.linuxfromscratch.org/lfs/view/stable/chapter08/eudev.html I have this error after I run ./configure in eudev ...
user avatar
0 votes
0 answers
11 views

./configure error for wxPython

I'm trying to install wxPython on AlmaLinux 8.5 Python 3.8(.8) is installed and works The version I need for wxPython is 4.1.1 so I run this command : sudo pip install wxpython==4.1.1 The installation ...
user avatar
  • 1
0 votes
2 answers
19 views

How to install libcurl from git clone source (has configure.ac but is missing ./configure)

I'm trying to install libcurl from source, but it's missing the configure executable, so I can't run ./configure. How do I generate it? Here is my attempt: time git clone https://github.com/curl/curl....
user avatar
-2 votes
1 answer
55 views

configure midnight commander build

In short: there's no configure executable file in mc repo. Coming from this thread How do I *completely* disable the Ctrl-O shortcut in Midnight Commander? where it became obvious the only way to ...
user avatar
  • 63
5 votes
1 answer
167 views

How to get the build procedure for a Debian package?

I want to build a version of some software that is more recent than the one that is currently available as a stable release Debian package. To do this, however, other than using a more recent version ...
user avatar
  • 12.7k
0 votes
1 answer
128 views

configure: error: Found libffi but could not link and compile with it

When i run configure it tells me that it cannot link to libffi and compile with it. This is weird as it is already installed and I don't know what I am supposed to do since all needed packages are ...
user avatar
0 votes
1 answer
41 views

c cannot create executables configure script

Executed command: bash configure \ --enable-option-checking=fatal \ --build=x86_64-unknown-linux-gnu \ --host=i686-linux-android \ --target=i686-linux-android \ --disable-warnings-as-errors \ --enable-...
user avatar
0 votes
0 answers
47 views

How can we append CFLAGS when doing ./configure

I got a configure script file that originally will create some CFLAGS when doing ./configure. I am wondering how can we append some other CFLAGS when doing ./configure without changing the original ...
user avatar
0 votes
0 answers
28 views

Passing parameters to configure to try to avoid "undefined reference" errors

I am trying to compile wine with the following command: CPPFLAGS="-I/media/34GB/Arquivos-de-Programas-Linux-32bit/xorg/X11-1.4.4/include/ -I/media/34GB/Arquivos-de-Programas-Linux/xorg//Xorgproto-...
user avatar
3 votes
2 answers
181 views

How to put multiple -I, -L and -l flags in ./configure?

I am trying to build using ./configure. I have Three include directories -I/path1/include -I/path2/include -I/path3/include Two link directories -L/path1/lib -L/path2/lib Two -l flag options -...
user avatar
  • 35
-2 votes
1 answer
494 views

When i start sudo apt update this appears ubuntu 21.04

Hit:1 (https://)dl.google.com/linux/chrome/deb stable InRelease Hit:2 (https://)dl.winehq.org/wine-builds/ubuntu hirsute InRelease Hit:...
user avatar
1 vote
1 answer
75 views

How to understand this output of apt-get unmet dependencies - X: Breaks: Y (< version) but Z is to be installed

I'm getting the following error when trying to install libnm-gtk-dev, but I'm having trouble understanding it: The following packages have unmet dependencies: gir1.2-nm-1.0 : Breaks: gir1.2-...
user avatar
  • 177
0 votes
1 answer
65 views

Looped when trying to install `network-manager-sstp` dependencies as hinted by `./configure` output:

I am trying to install network-manager-sstp, but I get looped trying to install the dependencies. ./configure output oscillates between telling me I'm missing two distinct dependencies (libnma and ...
user avatar
  • 177
1 vote
0 answers
183 views

Why would one M1 machine need architecture-specific options for building from source and other M1 machines not?

I have tool version managers in the Ruby and react-native worlds that (underneath the layers of abstraction) end up building software like Ruby from source using a fairly mundane: ./configure ./make ./...
user avatar
0 votes
1 answer
94 views

Override makefile precious variable

configure.ac has precious variables[1], which are supposed to be subbed-in when calling configure, e.g. configuring the location of the system Lua interpreter as a precious variable[2]: configure.ac: ...
user avatar
  • 101
0 votes
2 answers
44 views

Forcing overrides when configuring a compile (e.g. CXXFLAGS, etc.)

I wonder how one could force, for some real example: CFLAGS='-O2 -march=native' CXXFLAGS='-O2 -march=native' CC='gcc-10' CPP='gcc-10 -E' CXX='g++-10' when running the configure script in my case for ...
user avatar
2 votes
1 answer
51 views

How do I profile a real world application?

I run Debian 10 and since two weeks or so the PDF reader Atril (a fork of Evince) takes 25 seconds to start. Previously it started almost instantly. Now I'm trying to find out what causes the delay. I ...
user avatar
1 vote
1 answer
85 views

How can you change ./configure to use a specific binary over /usr/bin?

Running macOS Catalina 10.15.6. My question is more related to compilation with GNU tools, so it may be more suited for a different SE site — I'll be happy to close and ask somewhere else if that's ...
user avatar
0 votes
1 answer
2k views

libsocketcan ./configure: No such file or directory

I want to install libsocketcan from source on my raspberry pi. I already installed libsocketcan on my Ubunutu VM successfully by following the instructions of the INSTALL file. Unfortunately the first ...
user avatar
  • 11
0 votes
1 answer
43 views

Know what flags were used with configure script after compiling

Let's say I'm compiling some application (codebase in C, using gcc as default compiler, git cloned from github...) and doing ./configure --flags1 --flags2 ... And after compiling finish, i want to ...
user avatar
1 vote
1 answer
365 views

install xorg server

I have this problem when installing xorg-server. (Installation from source) configure: error: Package requirements (glproto >= 1.4.17 gl >= 9.2.0) were not met: No package 'gl' found ...
user avatar
1 vote
1 answer
294 views

How to build only one program in binutils

Since there are many programs that are not related to my interests, I'd like to build a specific program in GNU binutils on Ubuntu. Program means that one binary file (e.g., ar, objcopy) for example, ...
user avatar
  • 11
1 vote
0 answers
201 views

phpinfo still shows old PHP version after installing new version from source

I downloaded PHP 7.3.18 from php.net. Then I configured it, maked it and installed it from source. If I execute php -v then I get PHP 7.3.18 (cli) (built: Jun 17 2020 12:55:46) ( NTS ) Copyright (c) ...
user avatar
  • 1,708
2 votes
1 answer
2k views

Unable to create Xorg.conf

I opened a terminal and ran Xorg -configure, then I received error. _XSERVTransSocketUNIXCreateListener: ...SocketCreateListener() failed _XSERVTransMakeAllCOTSServerListeners: server already ...
user avatar
1 vote
1 answer
527 views

./Configure error installing xDebug - wrong php version

I am trying to install xDebug for php7.2 but keep receiving the following error when i execute ./configure to generate the make file: checking Check for supported PHP versions... configure: error: ...
user avatar
  • 11
0 votes
2 answers
893 views

Passing CFLAGS to configure via bash variable

Just when I think I know how the shell works fairly, something comes along and stumps me. The following commands were executed on GNU bash, version 3.2.25. I have several ./configure scripts that all ...
user avatar
  • 111
1 vote
1 answer
520 views

How to install owping tool?

I would like to install owping, however I am not able to configure and compile sources. I have installed autoconf. Instructions to install owping I have downloaded and unpacked sources of master ...
user avatar
  • 115
1 vote
2 answers
2k views

Passing configure option to rpmbuild?

To build a piece of software I normally do rpmbuild -ta slurm*.tar.bz2 However I now need to configure the software with the option --with-pmix=/home/user/git/pmix/install/2.1 Is this possible ...
user avatar
  • 123
0 votes
1 answer
369 views

failed to find required module enchant

I am installing the OCRFeeder in Debian. To install the OCRFeeder I go to the root folder and execute the command: sudo ./configure The following error is shown in the terminal: checking python ...
user avatar
  • 343
0 votes
0 answers
115 views

bind9 build from source : how to set install/config directory

I have built and installed bind from source (https://github.com/isc-projects/bind9). This has installed to /usr/local/sbin and is expecting configuration files to be in /usr/local/etc. I have copied ...
user avatar
0 votes
1 answer
39 views

set network on GNU/Linux Mint

I am migrating to Linux, but I only have experience with Windows. So, I'm afraid I'll run into many difficulties. In Windows in my workenvironment I configure the following things: IPv4 address ...
user avatar
2 votes
1 answer
2k views

libtool installed but not found by buildconf

I'm trying to cross-compile Apache httpd for ARM. Here what I did: $ sudo apt install libtool $ git clone https://github.com/apache/httpd.git $ cd httpd $ svn co http://svn.apache.org/repos/asf/apr/...
user avatar
  • 557
1 vote
1 answer
424 views

Installing psiphon on Debian 10 gives make: *** [Makefile:129: authfd.o] Error 1

I am trying to install psiphon on Debian 10 based on instructions here https://github.com/thispc/psiphon then ./configure came across error configure: error: *** zlib.h missing - please install first ...
user avatar
0 votes
0 answers
101 views

building glibc for old kernel

I configured build with this command and built it using make Now I'm trying to create deb package with this settings but i failed with this error FATAL : kernel too old how can i do it?
user avatar
1 vote
0 answers
127 views

Is 8-bit PCRE with no UTF-8/16/32 Suitable for Compiling Apache?

I'm compiling Apache from source, so installing PCRE in order to do that. When I ./configure PCRE I get: Build 8 bit pcre library ........ : yes Build 16 bit pcre library ....... : no Build 32 bit ...
user avatar
1 vote
1 answer
23 views

libSDL not recognized in installer

I'm trying to install Rejoystick for my system (Latest version of GalliumOS), and when I run ./configure (What README says to do) it spits out the error that I don't have libSDL. But running sudo ...
user avatar
2 votes
0 answers
119 views

Difficulty with configuring paths before compiling

I'm running MacOS Mojave 10.14.2 with Homebrew and MacPorts installed; I'm attempting to install the dsniff suite via the command line, and I installed Xcode's command line tools for this purpose--I ...
user avatar
  • 21
0 votes
1 answer
193 views

Necessary package for compiling libX11

I am currently trying to compile libX11 version 1.0.0 and during the configure process this error message shows up: checking for BIGREQS... configure: error: Package requirements (bigreqsproto) ...
user avatar
2 votes
1 answer
298 views

How I can preconfigure the write mode of drive cache?

journalctl -p err gives [sdX] Assuming drive cache: write through for each of my hard drives, where X is from a to f. These are normal hard drives, Ubuntu runs under VMWare. How I can preconfigure the ...
user avatar
1 vote
1 answer
320 views

Auto Refresh qpdfview

I am writing documents in latex that I compile to produce a pdf file opened with qpdfview (with the --unique option). Once compiled after a modification on the tex .document, I would like qpdfview to ...
user avatar
  • 300
0 votes
1 answer
109 views

Initialize AIDE in Slackware 14.2

I have succesfully installed AIDE in my slackware installation. I want to initialiaze using the command below : aide --init But since I dont have the aide.conf file yet, I could not start the ...
user avatar
  • 143
1 vote
1 answer
82 views

install peacock, during ./configure missing libraries, but they are actually

During ./configure I obtained this error: configure: error: Library requirements (libgnomeui-2.0 >= 2.2.0 libbonoboui-2.0 >= 2.2.0 libglade-2.0 >= 2.0.1 gtksourceview-1.0 >= 0.5.0) not ...
user avatar
1 vote
1 answer
920 views

Build OpenSSH client only

I'm trying to build OpenSSH 7.9p1 from source, but I can't find a way to delete (or not include), for instance, ssh-agent, ssh-keygen, scp, sftp, sshd, etc. – of course, assuming none of those are ...
user avatar
  • 865
3 votes
2 answers
2k views

`openocd` configure script cannot find `libusb`

I'm installing OpenOCD on my Debian stretch system. When I run ./configure it reports it cannot find libusb. ... checking for LIBUSB1... no configure: WARNING: libusb-1.x not found, trying legacy ...
user avatar
  • 851
1 vote
1 answer
776 views

ERROR: checking the archiver (false) interface... unknown

While I was installing pcre2-10.21 on Solars 10 (SunOS 5.10 Generic_147440-01 sun4u sparc SUNW,SPARC-Enterprise) the ./configure command led to the above error. checking the archiver (false) ...
user avatar
  • 133
0 votes
1 answer
826 views

usr/bin/ld: cannot find -lCbc

I'm trying to use make, it returns these errors and simmilar ones : usr/bin/ld: cannot find -lCbc usr/bin/ld: cannot find -lCgl I have already found similar issues, and tried a great deal of them. ...
user avatar
  • 23
0 votes
1 answer
292 views

lalsuite pycbc won't install - Ubuntu

I'm working through these instructions https://pycbc.org/pycbc/latest/html/install_lalsuite.html for installing pycbc which I need for my research, and I have some issues. Just under half way down ...
user avatar
0 votes
1 answer
537 views

Configure: error: Package requirements (libcanberra-gtk3 >= 0.10) were not met [but libcanberra-gtk3 v. 0.30 is installed]

I'm trying to build a package (mate-power-manager) and hit this error during ./autogen.sh: checking for CANBERRA... no configure: error: Package requirements (libcanberra-gtk3 >= 0.10) were not ...
user avatar
  • 383
1 vote
0 answers
86 views

Cairos's configure output: Is it enough for Firefox?

I intend to compile Firefox from the source. For that, I do need to compile GTK. And for that, I do need to compile Cairo. After solving some of Cairo's dependencies, I was able to run the configure ...
user avatar
6 votes
3 answers
1k views

Refer to the manual of configure

I follows an instruction to install shtool Download and extract wget ftp://ftp.gnu.org/gnu/shtool/shtool-2.0.8.tar.gz tar -zxvf shtool-2.0.8.tar.gz Build the library $ ./configure $ make I ...
user avatar
  • 2,291