Questions tagged [checkpoint]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers

Criu restore fails when invoked trough the pycriu API

I have a Python application which manages the execution, checkpointing and restoring of a bunch of binaries, trough a GRPC interface. I am experiencing a strange problem - restoring a binary fails ...
  • 1
0 votes
0 answers

Checkpoint mobile vpn

I am using a VPN provided by my university. I connected to the VPN on ubuntu 22.04.1 using but the problem that I am facing is that the traffic is not being ...
0 votes
0 answers

SSL Network Extender on Fedora 35

I have some troubles with SNX on Fedora 35. I've installed libX11, libstdc++ and pam, but I get ./ line 71: /usr/bin/snx: No such file or directory. How to setup SNX properly? Or maybe ...
0 votes
1 answer

How to connect to Checkpoint VPN with Passport using snx on linux / Ubuntu?

my client company just modified their Checkpoint VPN to integrate with ISAM Passport now. This ruins all of us Linux user since we can not connect via snx anymore. Could someone please help us how to ...
8 votes
2 answers

SNX: Connection aborted

My ultimate goal is to download files from an FTP server, which is behind a CheckPoint VPN in a server running ubuntu 16.04, which I only have access through ssh. I followed the steps described in ...
  • 223
0 votes
2 answers

criu: hello-world not working

I wanted to play around with criu, a project for checkpointing/restoring linux processes. For that I am playing around with the hello-world of criu, which is checkpointing and restoring a simple loop. ...
1 vote
3 answers

Using Checkpoint VPN SSL Network Extender CLI with certificate

I'm trying to use the command line tool from Checkpoint to set up an SSL Network Extender VPN using a certificate (P12) rather than a password. I tried the solution mentioned in getting Checkpoint ...
3 votes
3 answers

SNX VPN Ububuntu 18.XX

Anyone running SNX on Ubuntu 18.04 or 18.10 ? I am using build 800008061 with Firefox which should be a latest version AFAIK. Problem is that snx can not handle systemd-resolved -> dns nameservers ...
  • 151
6 votes
1 answer

Linux Checkpoint SNX tool configuration issues

I tried a solution mentioned in the question: getting Checkpoint VPN SSL Network Extender working in command line (the accepted answer), but for some reason I'm getting an authentication failed error. ...
3 votes
0 answers

How to connect to CheckPoint VPN on Ubuntu 18.04LTS? [duplicate]

I need to connect to Checkpoint VPN (using login & pass authentication method). For Windows I'm able to connect, using their client, CheckPoint Endpoint Connect. But i was not able to find the ...
  • 251
21 votes
2 answers

getting Checkpoint VPN SSL Network Extender working in the command line

The official Checkpoint out command line tool from CheckPoint, for setting up a SSL Network Extender VPN is not longer working from the Linux command line. It is also no longer actively supported by ...
6 votes
4 answers

VPN SSL Network Extender in Firefox

I need to connect from a Debian Stretch amd64 VM to a CheckPoint corporate VPN. I am using it from the customer point of view, and do not know much technical details about the server side. I am ...
0 votes
1 answer

CRIU for non-root users

CRIU doesn't support in non-root user environment, to my knowledge. Does anyone have got a patch for this? -a Linux enthusiastic.
5 votes
1 answer

Check Point - Connect under Linux - snx + OTP

We have a Check Point Mobile appliance at work and the Linux client is horrible, I can connect but for that I need: Old unsupported Oracle Java installed and enabled in the browser Plenty of 32-bit ...
  • 1,206