Skip to main content

Questions tagged [busybox-init]

The implementation of init that comes with BusyBox

Filter by
Sorted by
Tagged with
0 votes
1 answer
398 views

How to set console for auto login in inittab of busybox?

I am working on an embedded Linux system (kernel-5.10.24) with busybox as init. The kernel log is disabled in serial console without setting console= in kernel command line. So is the logs from init ...
wangt13's user avatar
  • 443
1 vote
0 answers
1k views

How to start and manage a process in busybox inittab, and rcS as early as possible?

I am working on an embedded Linux system where busybox is being used as init. I have 2 requirements on running my application. My application needs to start as early as possible; It needs to be ...
wangt13's user avatar
  • 443
1 vote
0 answers
51 views

syslogd not ouputting year information

I updated busybox to 1.35.0 and had the same settings as earlier but for some reasons the syslogd is not outputting year in the timestamp information. Prior to this I was using busybox 1.19.3 and it ...
m4n07's user avatar
  • 191
3 votes
4 answers
178 views

Protect against vanishing output redirection targets

I have a daemon running on an embedded Linux device with its output redirected to the serial console: my_daemon > /dev/ttyS0 But now if a user exits the shell running on the serial interface then ...
phk's user avatar
  • 5,983
0 votes
1 answer
520 views

Get time after boot

When Linux is booting there are timestamps which time something was loaded etc, so I think that information about boot start time must be available. Is there a way to run in any moment command or ...
IzZy's user avatar
  • 135
1 vote
1 answer
543 views

Can the Busybox init start a process as unprivileged user

I have a tiny, tiny system comprised of Busybox, an executable application and its dependent libraries ONLY. I am using the Busybox /etc/inittab to start the application as an unprivileged user: ::...
starfry's user avatar
  • 7,520
1 vote
1 answer
604 views

OpenWRT BusyBox init does not create /etc/init.d/rcS

I'm building an OpenWRT image (Chaos Calmer) that needs BusyBox to be configured to use init. So, in the busybox configuration, I enter the Init Utilities menu, then enable init, as well as support ...
maldata's user avatar
  • 155
0 votes
1 answer
228 views

Busybox init, Kivy python application appears to block execution of ifup

I am experimenting with Buildroot, trying to create a minimal system to optimise cold boot time into a Python application (Kivy GUI). I chose to use Busybox init process because this is supposed to be ...
user362397's user avatar
0 votes
1 answer
6k views

Ubuntu 18.10 boots into initramfs busy shell [closed]

I am getting booted into the initramfs shell directly in ubuntu 18.10 I have tried the exit command which leads to the manual fsck is required on /dev/sda2 When I enter fsck /dev/sda2 the shell ...
user79267's user avatar
1 vote
0 answers
236 views

What is needed to make a busybox init boot to a shell on an arm device/phone?

I compiled busybox with arm-linux-gnueabihf for and Cortex-A/armv7-a arm device/phone. When I run the binary on android it works well. I decided to modify the android boot image. In the boot image ...
Bret Joseph's user avatar
1 vote
0 answers
2k views

File not found when running a simple busybox system

I'm running Linux 4.1 and booting into a simple busybox environment. Busybox and shadow packages have been built as static and installed in my rootFS. Busybox is used for the /sbin/init and shadow's ...
dangeroushobo's user avatar
0 votes
0 answers
488 views

System V - Respawn service but don't launch at boot

I'm trying to have a System V service relaunched on exit. EDIT: Should have precised that I'm using busybox init system instead of classic systemV I found that It could be done using /etc/inittab ...
Arkaik's user avatar
  • 1,168
0 votes
1 answer
792 views

Opening raw UBI partition for writing on Linux if it's mounted and used by init

I need to update a raw UBI partition with a new UBIFS image from Linux userspace with superuser rights, however I'm getting EBUSY (Device or resource busy) error whenever I'm trying to open my ...
gsnoff's user avatar
  • 3
2 votes
1 answer
2k views

busysbox reboot doesn't work from init script

We have Beaglebone black based custom board with 256MB RAM and 4GB eMMC. We upgraded from Linux-3.12 to Linux-4.4 and busybox-1.20.2 to busybox-1.26.2. Now in busybox-1.26.2 we are seeing and issue ...
ART's user avatar
  • 1,141
5 votes
2 answers
4k views

How can I get /bin/login to not timeout

In my /etc/inittab I am using the following line: ttyS0::respawn:/bin/login This gives me a login prompt if I want to connect to the serial port. But it keeps echoing this: [hostname] login: Login ...
Dakkaron's user avatar
  • 2,057
9 votes
1 answer
20k views

How to login automatically without typing the root username or password in Buildroot BusyBox init?

If I do: git clone git://git.buildroot.net/buildroot cd buildroot git checkout 2016.05 make qemu_x86_defconfig make BR2_JLEVEL=2 qemu-system-x86_64 -M pc -kernel output/images/bzImage -drive file=...
Ciro Santilli OurBigBook.com's user avatar
6 votes
1 answer
10k views

Set environment variable (TZ) for all startup scripts and inittab

I'm working on an embedded Linux system and looking for a way to set the time zone for all processes. The question is: Is there any possibility to set the TZ environment variable at boot time (init ...
Klaus's user avatar
  • 63