Questions tagged [boot]

Bootloader issues: what happens before the operating system itself starts.

1,286 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
8 votes
1 answer
5k views

Linux Tablet: Is there a way to enter a password with onscreen keyboard to unlock a LUKS crypto device during bootup?

I just installed Linux (Ubuntu, but it does not really matter) on an x86-based tablet. I also encrypted a partition which is mounted during bootup. Of course, one usually needs to enter the password ...
  • 7,966
7 votes
0 answers
3k views

Setting the EFI Framebuffer's Resolution during boot

I've got a MSI WD-60 laptop running Gentoo. It has one of those 3840x2160 screens so I've had to setup Gnome/Firefox/IntellJ to double their DPI for anything to be readable. It all works fine except ...
  • 810
6 votes
0 answers
9k views

Issue while booting Kubuntu on VirtualBox: drm vmw_host_log vmwgfx error failed to send log

I have installed Kubbuntu as guest one virtualbox on Windows 10 and now when I want to boot it take a long time showing this message: [drm:vmw_host_log [vmwgfx]] ERROR Failed to send log What is ...
  • 379
6 votes
1 answer
3k views

Grub won't boot from GPT RAID (gave up waiting for root device)

I'm having problems with booting a Debian 8 system on which I migrated the root partition from a single hard drive to a RAID1 (mdraid). On every boot, I get the following grub error: Gave up waiting ...
  • 190
6 votes
1 answer
4k views

Linux Mint GUI stays black after login

Suddenly this happens: When I boot my noteback linux mint boots to the login screen. Then after I logged in the mouse cursor is visible centered on a black background. And thats where nothing more ...
  • 476
5 votes
2 answers
558 views

Can't boot FreeBSD on a P133 laptop

Recently, I've setup a FreeBSD 11 on a 6GB PATA 2.5" hard drive using a PATA/SATA>USB adapter and qemu on my main Arch Linux computer. FreeBSD boots OK in qemu, but when moved to my Dell Latitude XPi (...
  • 150
5 votes
0 answers
9k views

Black screen after booting in UEFI installation of Arch Linux

My laptop is Asus K53SV, you can find its specification here. I tried to install Arch Linux with UEFI boot method, and I stuck at a black screen after press Arch Linux archiso x86_64 UEFI CD. Firstly, ...
5 votes
0 answers
2k views

How do I add modules, binaries or scripts to initramfs in RHEL distributions?

I have an initramfs script I developed for Debian distributions that required some extra binaries to be loaded into the image. I'm now trying to port this to RHEL distributions and I'm struggling. To ...
  • 181
5 votes
1 answer
4k views

Make an SD card to boot the distribution image created with Yocto

I have managed to build images for my own compiled Linux kernel source code using Yocto. Yocto has produced image files according to: http://www.crashcourse.ca/wiki/index.php/...
  • 205
5 votes
0 answers
11k views

Is there a solution for when a system hangs on "switching to clocksource tsc" anyway?

Ok so this is exactly what I did yesterday, and what I have tried to solve the problem so far. The distribution is Ubuntu Server 12.04. What I have done just before the error appeared I added a new ...
5 votes
1 answer
1k views

Manually copying MBR from one drive to the other GPT drive and configuring GRUB results in booting failure

I run CentOS 6.4. I have SSD 300GB for system files and RAID10 8TB for storage + backup. SSD system drive is partitioned as follows: fdisk -l /dev/sdb Disk /dev/sdb: 300.1 GB, 300069052416 bytes 255 ...
  • 363
4 votes
0 answers
6k views

What is the the solution for the error"Platform MSFT0101:00: failed to claim resource 1?

I have been trying to install debian 8 to my laptop yet i could not because i am getting errors like "Platform MSFT0101:00: failed to claim resource 1" and uncompression error.
4 votes
0 answers
2k views

Force Arch boot to specific GPU

Arch Linux - kernel 4.13.12-1 (x64) Bootloader - Grub 2 Window Manager: I3-wm. Gpus: AMD 570 (Passthrough), 1080Ti(Passthrough), 1050TI (Host) Misc: Dual-Monitor I have three GPUs in my machine, ...
4 votes
0 answers
3k views

how to add a custom GRUB2 menuentry to a submenu?

My GRUB2 initial boot screen was like LMDE 2 Cinnamon 64-bit Advanced options for LMDE 2 Cinnamon 64-bit Windows Recovery Environment (loader) (on /dev/sda1) Windows 7 (loader) (on /dev/sda2) Note ...
  • 1,225
4 votes
0 answers
2k views

Ubuntu boot freezes after GRUB (blank screen), but works after warm reboot from Windows

I have a peculiar situation concerning the boot process of Ubuntu 17.04 that I just can't figure out. On my HP Pavilion 13b-220nd I have installed both Windows 10 and Ubuntu 17.04. My laptop boots in ...
  • 41
4 votes
1 answer
4k views

CentOS 7 won't start after recent update?

Last night I got some updates through yum on my CentOS virtual machine, which also updated the kernel. I tried booting it again about an hour ago, and I haven't been able to successfully start it. I'...
user avatar
4 votes
0 answers
1k views

Systemd mount with a condition

What I would like to do is mount my ntfs data partition during boot process with systemd only if laptop is on AC power. At the moment I am running this script as a startup application in cinnamon, but ...
4 votes
0 answers
1k views

Computer does not boot to Fedora but to Shim UEFI key management instead

When I turn on my computer, Fedora (which is the only OS installed on this computer does not boot). Instead, the following is printed to the screen: System BootOrder. Initializing defaults. Creating ...
4 votes
0 answers
804 views

RAID-1 / LVM server won't boot after power outage

Strange issue. After an extended power outage (transformer exploded!) which outlasted the UPS, a server running Slackware 13 crashed. This machine has been quietly serving accounting software and ...
4 votes
0 answers
283 views

Can't boot when moving Linux installation from one server to another - UEFI

Scenario I have two identical Lenovo (previously IBM) servers [xSeries 3250 M5 - model 5458EHM]. I've built Linux on server 1 and I want to be able to cold swap that hard drive to server 2. (This is ...
  • 41
4 votes
1 answer
1k views

boot of nfs mounting drive taking very long

When I upgraded to ubuntu 16.04 my boot time increased dramatically I did a systemd-analyze blame and as you can see the first two items take a very long time to load and this is on a SSD. 1min 30....
  • 337
4 votes
1 answer
3k views

How to debug systemd "init" freeze during boot?

I'm trying to get my own init script running on some ARM hardware and Debian Jessie with systemd. The overall boot concept and init script is almost identical to a x86 variant, which works fine. For ...
  • 1,093
4 votes
0 answers
560 views

Set up bluetooth keyboard to enter disk encryption password

How can I set up a bluetooth keyboard, so that I can use it to enter the disk encryption key, so that my encrypted linux system boots.
  • 1,763
4 votes
0 answers
646 views

ABRT report says "irq 19: nobody cared", but why?

Every couple weeks, I need to reboot my system. When I do, and enter as root in the terminal, the following message (in some variation) appears: ABRT has detected 3 problem(s). For more info run: ...
user avatar
4 votes
2 answers
5k views

Cannot boot into Linux off live USB

I am trying to dual boot Linux on my laptop (Dell XPS 15) which is running Windows 10 Pro. I did not have any problem dual booting the two operating systems on my desktop. I cannot boot up ANY Linux ...
  • 161
4 votes
0 answers
542 views

TPM passwordless boot

I'm trying to create device with CentOS6, encrypted disk (with LUKS), TPM module and TrustedGRUB to boot securely and without interaction. I'm following instructions from https://github.com/shpedoikal/...
4 votes
0 answers
751 views

Cannot Boot New Linux From USB

Recently, I got a new laptop, the MSI gx60. I grabbed a usb and loaded the Linux Mint 16 Cinnamon image onto it, tested it on my old laptop and desktop, where it worked. However, when I try it on my ...
  • 41
4 votes
2 answers
3k views

Updating kernel versions when booting from rEFInd

I'm booting from EFI using the awesome rEFInd bootloader. I've so far had to configure boot myself by manually copying over my EFI-compatible linux boot image to my EFI partition and writing a ...
  • 36.9k
4 votes
0 answers
5k views

System freezes upon executing any boot option in a live USB installation of Mint

Problem I'm trying to install Linux Mint 16, 64-bit, MATE using a live USB. The boot option menu itself is responsive and work as expected. However, when I execute any of said boot options, the ...
4 votes
1 answer
2k views

GRUB 2 scripting: convert device name in GRUB notation into a Linux device name

I'm trying to use partition labels (or UUIDs, that does not matter) to select root partition without use of an initrd/initramfs. With initramfs, this is fairly easy: root=LABEL=... or root=/dev/disk/...
  • 4,885
4 votes
1 answer
769 views

UEFI boot Fedora from USB 2.0 on 3.0 port (l75d-a7280)

I'm trying to make a bootable usb in ubuntu for fedora, but my settings are not working. I formatted the USB with FAT & Ext4, MBR, and Legacy BIOS bootable. My BIOS allows the USB 3.0 controller ...
user avatar
4 votes
0 answers
998 views

getting the message "out of partition" after installing GRUB 2. What is happening?

I recently moved a partition with a complete Linux install except /home to a new disk (with DD). Everything went fine, I can mount the partition, browse it... perfect. Next step: install GRUB to ...
  • 101
4 votes
2 answers
218 views

How to distinguish if a systemd unit is run by apt-get or during boot?

Can one somehow distinguish if, a) the daemon was started during boot or, b) (re)started by an apt-get install or upgrade? Can this be distinguished from within the daemon itself? The use case is ...
  • 1,628
3 votes
0 answers
1k views

Fail to start systemd-journal

i have upgraded my linux rescently (apt-get upgrade) and now it can not boot successfully. The booting process stop at a middle and ask for root authentification to resolve the issue the log said ...
  • 31
3 votes
3 answers
1k views

Loading a large Linux distribution such as Ubuntu into mapped partitions on RAM such as DDR4

Is there any way of booting from SSD/USB/NVMe/eMMC to have a Linux OS, such as Ubuntu, plus applications, services and containers load entirely into partitions created in RAM such as DDR3 or DDR4. ...
3 votes
0 answers
293 views

Booting from ISO suddenly stopped working

(Linux Mint 19.3 XFCE w/BTRFS; ISOs are on an EXT4 partition) I'm trying to get my system to boot from ISO images. I added the following entries to /etc/grub.d/40_custom: submenu "System ...
  • 2,808
3 votes
0 answers
955 views

Modifying login for an encrypted boot partition (GRUB)

I followed an tutorial on the archlinux wiki for an encrypted boot partition and I have some questions. Up to now everything is working (two partitions: efi + encrypted lvm), and when booting I come ...
  • 151
3 votes
0 answers
901 views

Stuck on /init with custom CPU

For a university project I was tasked with implementing privilege levels on an existing RISC-V (rv32i) processor with the end goal to have it run Linux. Due to complexity, my project ended with the ...
3 votes
1 answer
508 views

Why will this LVM RAID1 system not boot?

Context: while trying to install Arch Linux with an LVM setup including RAID1 for my root volume, I encountered the problem that I described here on the Arch Linux fora. I never found a solution to ...
  • 131
3 votes
0 answers
222 views

How to start at boot a service that lives within a user's schroot?

Due to legacy (aka corporate) reasons, I have a number of servers running recent Debian versions (Debian 9, Debian 10) that also need to run older services such as MySQL 5.5. This is done via a (pre-...
3 votes
0 answers
853 views

Alpine Linux Hangs During Boot at: " successfully initialized wpa_supplicant"

I installed Alpine Linux on Intel Compute Stick with 32 Bit Atom Processor. After installation I followed the procedure laid out here for connecting to internet via wlan0 port: Connecting to a ...
  • 191
3 votes
0 answers
617 views

Can't resume after suspend?

Recently (after a system update, I believe), my laptop stopped resuming after a suspend from closing my laptop lid. Usually, when I open my lid after suspending it, I'll see a black screen with my ...
3 votes
0 answers
9k views

can't boot Linux due to Login service failing to start

I am having a bit of trouble with my linux mint 18.3 (based on Ubuntu 16.04) since I can't manage to properly boot it on my computer. I have a dual-boot and windows launch properly, so there is that. ...
3 votes
0 answers
2k views

Ubuntu 18.04 is taking too long to boot

Clean Ubuntu Server 18.04 (not the live one) install (shell only). Software RAID 1 has been configured during the installation (swap and ext4 partitions). Boot up (time before login query) takes ...
  • 139
3 votes
0 answers
4k views

Why is initramfs dropping to a shell after installing Ubuntu next to a Windows 10 installation?

I have installed Ubuntu 18.04 LTS via Live USB on an ASUS Zenbook 13 UX331UN that is shipped with a preinstalled Windows 10. It is a UEFI system with secure boot enabled and fast boot disabled. I'm ...
3 votes
0 answers
793 views

Debian error logs on boot

I get the following error logs when booting Debian, but they do not seem to be causing any problems once booted into the system. Should I be concerned? ACPI Error : Namespace lookup failure AE not ...
3 votes
0 answers
951 views

rEFInd very slow to load initramfs

I'm trying to switch from grub to rEFInd, and I get much slower boot time. rEFInd itself it fast to load (I disabled auto detect) but when it comes to loading the kernel it hangs on "loading initramfs....
3 votes
0 answers
999 views

How to get video mode given by hwinfo when it doesn't work? And how to set login resolution?

I tried to follow the suggestion at this previous post: Use sudo hwinfo --framebuffer as described, choose a video mode you would like to see during boot in console, then add the option vga=nnn to ...
  • 31
3 votes
0 answers
5k views

systemd Journal Service takes two hours to start

I have a relatively fresh debian install on which I changed the hostname in /etc/hostname. It gives me the following message during boot: [ 7406.882872] systemd[1]: Starting Journal Service... [ 7406....
3 votes
0 answers
143 views

Can I use Grub on USB2.0 drive to boot a non-bootable USB 3.1 drive?

I've got a USB 3.1 (ASM1142) card that I'd like to boot from. The card doesn't supporting booting, on its own, but I'm wondering if I could boot Grub2 from a USB 2.0 device and 'hand off' booting of ...
  • 131

1
2 3 4 5
26