Questions tagged [beagleboneblack]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
1 answer
55 views

Qt statically linked application error: linuxfb plugin not found by the application

I have successfully developed a graphical Qt 5.15.2 application using Qt Creator with dynamically linked libraries. For various reasons I have determined static linking would be better for my ...
  • 21
0 votes
0 answers
62 views

How to run U-Boot Falcon mode from eMMC on BeagleBone Black

Warning: there is a bit of a long log in this reply. Here is what I'm attempting to accomplish: Store U-Boot environment variables in eMMC. Boot Falcon mode from eMMC. Keep my Debian version, custom ...
  • 21
0 votes
1 answer
105 views

Error when installing package "crontab" on Beaglebone Black (Debian Buster)

I am working on a project regarding autorunning a pythonscript on boot, on a Beaglebone Black Rev. C, running BeagleBoard.org Debian Buster IoT Image 2020-04-06. I am trying to follow the first part ...
1 vote
2 answers
57 views

U-Boot errors when trying to enable Falcon mode on BeagleBone Black

I have been having trouble enabling Falcon mode on the BeagleBone Black. I have a working U-Boot (v2019.04) and Linux (Debian 11.5, kernel v5.15.65-bone-rt-r30), but I have been unsuccessful thus far ...
  • 21
0 votes
0 answers
196 views

How to install Alpine Linux on a BeagleBone Black with u-boot and Rauc?

I have several embedded single-board computers (Pis, Odroids, BeagleBones, etc) and they all run a custom-compiled u-boot, custom-compiled kernel, and a redundant filesystem with a recovery partition ...
  • 101
0 votes
0 answers
272 views

I can't seem to get my serial ports working -- I get an input/output error. How do I fix this?

I'm working on a BeagleBone Black running 3.8.13-bone80. I'm trying to get UART2 working, but I can't seem to get it and I don't know the root of the problem. I'd like to configure ttyS2 as such: stty ...
0 votes
0 answers
293 views

iostat returns disk utilization greater than 100% while profiling a Beaglebone Black board

I need to profile the performance of software running on a BeagleBone Black (BBB). The BBB has an ARM Cortex-A8 up to 1GHz frequency, 512MB RAM, and 4GB eMMC onboard flash storage. You can find more ...
  • 1
0 votes
0 answers
36 views

How to reboot my linux multiple times and store my dmesg log at each boot?

I'm using beaglebone board, I just want to measure its boot time multiple times, so for that, I'm thinking to implement one script which reboots after every boot and stores dmesg data. Can anyone give ...
0 votes
0 answers
22 views

SARA-U201 modem on Beaglebone Black not starting automatically

I have SARA-U201 modem connected by USB to Beaglebone Black single-board computer. It is configured to run in ECM mode by AT+UUSBCONF=2 command. On boot, there are /dev/ttyACM[0-3] - 4 ports created ...
0 votes
1 answer
379 views

How to install gcc-5 on Debian 8.10?

I am trying to install gcc-5 on debian 8.10 on a beaglebone green. I have looked at many threads, of which the following was the most promising. How to install GCC 5 on debian jessie 8.1 When I try to ...
0 votes
0 answers
51 views

How to reflect the name of Beaglebone in the router panel?

For my BBB, my router displays the following: But I'd like it displays the hostname of my BBB. How to do that? So far, I have modified the hostname with $ sudo hostnamectl set-hostname myname And ...
0 votes
1 answer
114 views

Unable to bring up the CANbus interface on a Beaglebone black

To automatically bring up the interface on boot, I edited the /etc/network/interfaces file as follows: debian@beaglebone:~$ sudo nano /etc/network/interfaces And added the following at the end of the ...
0 votes
1 answer
644 views

I can't ping my linux VM from any machine other then the windows host

I can ping my BBB on 192.168.1.166, which is the address my router gave it, and which I have since made static. Windows host Ip address: 192.168.1.219 My linux VM (running on windows host): enp0s8: ...
0 votes
1 answer
68 views

Reading /dev/ttyS4 from a BeagleBone running Debian 10 not what is written

I am pulling my hears trying to make ttyS4 up and running on a Beaglebone black. I have set up UART4 in my /boot/uEnv.txt (see it at the bottom of my question). On the Beaglebone I have the comms cape ...
0 votes
0 answers
259 views

ssh (Putty) and X11 freezes/slows down with idle program

I am using Putty to ssh my server device, and to visualize I'm using Xming for the X11 forwarding. The Windows computer is being connected to a Debian-Machinekit framework on my BeagleBone to operate ...
1 vote
1 answer
200 views

Buildroot image missing /sys/bus/usb

I've tried to create a Beaglebone Black image with buildroot starting from beaglebone-defconfig. I discovered that /sys/bus/usb seems to be missing: # ls /sys/bus clockevents gpio mmc_rpmb ...
  • 121
1 vote
0 answers
202 views

Troubleshooting RS485 comm on Beaglebone black with cape comms2

TLDR: my serial comm (RS485) does not work on the BeagleBone Black. How to fix that? —— Following my previous question which didn't find any solution, I am now exploring the linux side of the ...
0 votes
0 answers
346 views

How to make Modbus RTU RS485 on cape comms2 works on the Beaglebone black?

I am scratching my head for days now, trying to make Modbus RTU RS 485 working on my Beaglebone black having the cape comms2 set and running Debian. I connect to /dev/ttyS0 at 9600 bauds, 8-bit data, ...
1 vote
0 answers
69 views

Compiling Beaglebone Black Linux image for QT and 4Dsystems LCD cape

I have researched a lot into buildroot and yocto compilation for BBB and understand qt configs / layers for both. However I can’t seem to get the 4.3” Touchscreen cape to work. I have tried comparing ...
0 votes
0 answers
410 views

BeagleBone Black UART 1 config

Recently I compiled my own linux system using kernel 5.10.23, and I made modifications to the device tree in order to activate UART 1 PIN (9-24) and (9-26). I have /dev/ttyS1 available for R/W ...
0 votes
1 answer
2k views

echo: write error: Operation not permitted issue

Hello i am trying to use the echo command to load firmware to the PRU on the Beaglebone black with the following command: root@beaglebone:~# echo 'am335x-pru1-fw' > /sys/class/remoteproc/...
0 votes
1 answer
177 views

Is there any way to change the I2C slave device address on a Linux board?

Aim: setAddress in i2c Slave Devices software side. example : 3 sensor with same address 0x29. through some method sensor1 to set 0x22, sensor2 to set 0x25, sersor3 to set 0x28. info: I have 3 similar ...
0 votes
0 answers
275 views

How to Change VL53L0X(TOF) sensor I2C address using c language on BeagleBone Black

Aim: To read Data from 4 VL53L0X(TOF) sensors using I2C communication in C language on BeagleBone Black Board (Debian OS). I have implement c code for a single VL53L0X(TOF) sensor which is: https://...
1 vote
1 answer
187 views

BeagleBone Black static IP retention

I am using BeagleBone Black device as an energy monitoring device in my IoT projects. The application reads data through USB (Modbus RTU) and sends it to remote cloud through MQTT. There are around 15–...
1 vote
1 answer
101 views

The host machine doesn't recognize BeagleBone device with SD card inserted

I am trying to boot BeagleBone Black (BBB) off the SD card that contains boot images and rootfs files, but when I have it inserted into the BBB, I don't see any device being detected by the host ...
  • 131
1 vote
1 answer
413 views

bind ltc2947-spi driver on BeagleBone Black

Having trouble binding a SPI driver on the BeagleBone Black. The driver in question, ltc2947-spi, is in the linux mainline, but not in the beaglebone kernel tree. When I get this working, I'll submit ...
0 votes
0 answers
128 views

How to enable bluetooth in beaglebone black

I bringup beaglebone black successfully with my own rootfs. After bringup beaglebone black how to enable peripherals like gpio,bluetooth and wifi from scratch please suggest me
  • 101
0 votes
1 answer
41 views

I can't specify a directory when creating a service on Beaglebone

I don't know where to post this question because it's half a programming question and half a Linux question, so forgive me. I'm working on a project using Beaglebone Black and I need to execute a ...
0 votes
1 answer
889 views

Installation of TurboVNC using Debian command line/Keyboard issue with LTQ Terminal Beagle Bone

It would be fantastic if someone could help. To give some history as to why; I had a problem with my keyboard mapping using TightVNC and so attempted to install tigerVNC and turboVNC on my ...
  • 11
0 votes
1 answer
484 views

** File not found /boot/uImage ** When using Angstrom Pre-built Images on BeagleBoneBlack Rev C

I'm trying to boot my BeagleBone Black into Angstrom using pre-built images found here. My SD card has two partitions BOOT & ROOTFS, and was formatted according to the procedures found here. ...
0 votes
1 answer
100 views

Problem with serial port, can't get the data if screen is not tun beforw

I am working with a Beagle Bone serial port. I made a C program to read some data sent by another board; However, something that I cannot understand is happening. When I run the program it does not ...
0 votes
1 answer
174 views

PocketBeagle enable com port on usb0

I'm attempting to configure a pocketbeagle running bone-debian9.9. Kernel version is 4.14.108-ti-r113. The board has a Micro USB port with the following functions: rndis, acm, ecm, and mass_storage. ...
  • 148
1 vote
1 answer
5k views

U-Boot "Wrong Ramdisk Image Format" with initramfs on BeagleBone black

I am following the book "Mastering Embedded Linux Programming - Second Edition" trying to boot up the Linux kernel mounting a ramdisk. I have U-boot 2020.01 working and the Linux kernel ...
  • 13
0 votes
1 answer
331 views

High load when Ethernet cable is unplugged

I'm building a system image with v4.19.106 kernel and BusyBox for BeagleBone Black using buildroot 2020.02. If I boot the board from the resulting SD card, I see a strange behaviour: system load stays ...
  • 61
1 vote
1 answer
663 views

Autostarting a python GUI application on startup as local user (beagle bone black)

I am trying to start a GUI application (python3 project) on application startup. I've created a script in /etc/xdg/autostart/. @lxpanel --profile LXDE @pcmanfm --desktop --profile LXDE @xscreensaver ...
  • 121
0 votes
1 answer
257 views

How can I use port 8080 on a BeagleBone Black with Debian Linux, kernel 4.14.x, when trying to use a web camera?

I have successfully compiled jacksonliam/mjpg-streamer. After compiling it, I ran into issues. The end result is that the source works, but I don't know how to resolve port conflicts under Debian ...
  • 103
2 votes
1 answer
722 views

Kernel throws error while writing to the character device file in 4.9.82-ti-r102 debian 9.3

I created the device file under /dev folder successfully, but writing to that device file makes kernel to throw following error messages. Message from syslogd@beaglebone at Feb 26 15:40:10 ... kernel:...
0 votes
0 answers
701 views

How to install apt packages to SD card

i have beaglebone black wireless which have 4gb of its memory , after flashing debian 9.9 os on it am left with 200 mb free space. so i wonder how can i change apt package installer path so that ...
0 votes
1 answer
145 views

Beaglebone pwm for non root user

The 4.9.78-ti-r94 distro comes with 81-pwm-nonroot.rules # /etc/udev/rules.d/81-pwm-noroot.rules # # Corrects sys PWM permissions on the BB so non-root users in the gpio group can manipulate bits # ...
1 vote
1 answer
2k views

Connman network configuration for default interface

I have a BeagleBone Green board running Debian. It uses Connman as the network manager. The configuration file should be /etc/connman/main.conf however this doesn't exist. I have two active network ...
  • 1,061
1 vote
0 answers
430 views

Beagle bone black - no boot text

I'm working with a beaglebone black with an image based off the base debian image for these boards. When I plug this into a monitor via the onboard HDMI and boot it, I get the linux penguine (Tux) in ...
0 votes
1 answer
689 views

Why can't / doesn't U-boot log messages for us to view later

I have a problem whereby a remote BeagleBone device is taking hours to boot up. When it does, I don't see any problems in the kernel boot logs such as journalctl -b or journalctl -b -1 Without ...
  • 1,061
1 vote
0 answers
532 views

reboot causes device to shutdown but doesn't start again for many hours after

I am using a BeagleBone running Debian. I have a cron entry in /etc/crontab which tells the device to reboot at 03:01 every night as follows 00 03 * * * root /sbin/shutdown -r +1 >> /...
  • 1,061
1 vote
1 answer
1k views

How to debug an SDIO configuration problem?

We are trying to get an SDIO-based 802.11 module to work on an SDIO port of the beaglebone. We adapted the device-tree overlay provided by manufacturer to our hardware, compiled the driver, the driver ...
  • 12.6k
3 votes
0 answers
533 views

Beaglebone Boot Fail with ALERT! PARTUUID does not exist

I have tried booting a Linux image in the eMMC through u-boot but it always drops to the busybox shell. As suggested by the busybox shell I double checked the PARTUUID (8fb410a9-01) using blkid, which ...
1 vote
1 answer
188 views

Why does plugging in a cellular modem create 8 different device files?

I am using a BeagleBone board running Debian. When I plug in a USB cellular modem, this creates the following files in the /dev folder: ttyACM0, ttyACM1, ttyACM2, ttyACM3, ttyModem0, ttyModem1, ...
  • 1,061
1 vote
0 answers
510 views

is there a way to disable/change kernel console from userspace

We have Beaglebone Black based custom board with 512MB RAM and 4GB eMMC. We have kernel console set as /dev/ttyS0 which is debug UART. After booting in user space, we want to disable(if possible, or ...
  • 1,071
2 votes
1 answer
639 views

How to install a few specific packages one time on Debian Wheezy (after EoL)

I'm using a fresh beaglebone debian 7.9 armhf image and need to do some additional setup. Despite EoL being May 2018, the apt sources have still been available until recently. They are no longer ...
  • 123
0 votes
2 answers
471 views

What is the difference between spidev2.0 and spidev2.1?

On my pocket beagle, which runs Debian, I have three spidev devices (spidev1.0, spidev2.0 and spidev2.1). I have a SPI temp sensor on spi1 (which is spidev2.0 and spidev2.1). Loopback tests on 2.0 (...
  • 113
0 votes
1 answer
982 views

Securing Beaglebone software from stealing [closed]

I have a BeagleBone Black which is programmed to start a NodeJS server on boot. The BeagleBone contains software that my company does not want to share. Is it possible to prevent any user from ...
  • 11