Questions tagged [aur]

The Arch User Repository (AUR) is a repository that contains PKGBUILDs which are created and maintained by the community.

Filter by
Sorted by
Tagged with
0
votes
1answer
38 views

How to install AUR package in home directory?

IntelliJ IDEA Ultimate is not available as an Arch Linux core package, and has a built-in upgrade mechanism. For these reasons it would be convenient to install it into my home directory, letting it ...
0
votes
0answers
20 views

Error when installing monodevelop-stable: error making: mono5

I am on Manjario 20.2.1 (on a real PC and Hard Drive and not in a VM) and I've been trying to install monodevelop-stable on Manjaro from the AUR but I get the same error every time: AOT [build-...
0
votes
1answer
17 views

how many types of orphan package are there

I clean orphan packages sometimes on Arch or Ubuntu based OS. But some of them not at pacman or yay list paru -Ss dfu-util community/dfu-util 0.10-1 [34.94KB 104.31KB] Tool intended to download ...
0
votes
0answers
16 views

How to run AUR helper from a pacman hook

Each time I update pulseaudio, the AUR replacement for pulseaudio-bluetooth pulseaudio-modules-bt-git needs to be rebuilt (source). I was wondering how could I do it automatically, straight after the ...
1
vote
0answers
21 views

How to locate which application downloaded files to my computer?

I was doing a routine system clean-up today and I noticed that in my Downloads folder there are 4 files(adult videos no less) that I did not download. How can I find out where they came from/what app ...
0
votes
0answers
16 views

How to solve this error on prepare() trying to build the zen-kernel?

I am trying to install the kernel: "linux-zen-vfio 5.9.13.zen1-1" from AUR. (http://aur.archlinux.org/packages/linux-zen-vfio) However it fails me on prepare() with this error: ==> ...
0
votes
1answer
79 views

Pacman: Target can be found for reinstall, but not for removal

I'm using the Manjaro i3 setup, which comes with the palemoon browser. I however really don't have any need for this, so I'd like to uninstall. When I run pacman -Rns palemoon, I get error: target not ...
0
votes
1answer
65 views

How to download and backup all pacman and pacaur packages?

I would like to have an backup of all pacaur and pacman packages. Example: https://www.archlinux.org/packages/ How to download it all?
2
votes
1answer
92 views

Should I worry about 'WARNING: Package contains reference to $srcdir'?

I was building font-manager package from AUR on my Arch system. It is throwing a warning while the process : ==> WARNING: Package contains reference to $srcdir usr/lib/font-manager/libfontmanager.so....
0
votes
1answer
85 views

Does Pacman's “-n” flag purge configuration files for AUR packages?

In Pacman's man page, there is a -n (nosave) flag that purges all the configuration files of the package being removed. Does this flag work for packages installed from AUR? Is manual cleanup ...
0
votes
0answers
68 views

Error when attempting to receive dropbox keyring

I picked the Git Clone URL from here, cloned the repo on my system, and the I run makepkg -si in the repo's directory, which resulted in dropbox-lnx.x86_64-102.4.431.tar.gz ... FAILED (unknown ...
0
votes
2answers
100 views

unable to install pi-hole from AUR on Arch ARM

I'm running Arch ARM on my RasPi and wanted to install pi-hole. I found https://aur.archlinux.org/packages/pi-hole-server/ in the AUR, cloned it requires a few dependecies it cannot install by itself. ...
0
votes
2answers
208 views

How to install multiple instances of an app in Arch linux [closed]

I've searched a lot but with no success. my problem is that I want to install multiple instances of an application in Arch Linux. to be more specific, I want 2-3 instances of latest Skype. one for my ...
1
vote
1answer
106 views

Install Package without dependencies from AUR in Manjaro

I'm trying to install CamlImages(http://gallium.inria.fr/camlimages/), I can't seem to get it to work by building it myself so I am trying to get it from the AUR. My problem is, it has omake listed ...
2
votes
2answers
1k views

unable to upgrade zoom on Arch Linux

I've got zoom installed on my Arch box. When I start it, it shows me a window which states on the bottom Version: 3.5.374815.0324. The problem is, I don't remember how I got this original version ...
2
votes
1answer
260 views

MongoDB installation size is huge

I need MongoDB to install on Arch Linux. It needs 180+GB free space for installation. However, I have 99GB partition where Arch Linux is installed and 107GB partition free. Can I installed MongoDB by ...
1
vote
1answer
272 views

How do I find binary installed from AUR package?

I installed balena-cli from AUR (https://aur.archlinux.org/packages/balena-cli/) using yay on my Arch box and all seemed to complete well but I can't find a balena-cli (or similar binary) on my system....
0
votes
1answer
362 views

Start forge server on arch linux?

I installed the latest version of minecraft forge server over the AUR. 1 aur/forge-server 1.15.2_31.1.0-1 (+2 0.11%) (Installed) Minecraft Forge server unit files, script and jar I can't seem to ...
0
votes
1answer
146 views

How to makepkg a git repository outside of the file

I'm trying to build a file called command.sh, which will just host a series of terminal commands that will install the software I need when I decide to buy a new computer. Its just the convenience of ...
1
vote
1answer
537 views

How to install gcc7 multilib on arch linux?

I've downloaded the gcc7 package with pacaur -S and that worked fine. Now I'm looking for the gcc7 multilib package but I can't find the pacman or aur package anywhere in the internet. Can someone ...
0
votes
1answer
602 views

How to install Amazon Corretto on Manjaro?

I'm trying to install Amazon Corretto on Manjaro Linux. As it's available on AUR, I installed it using Yay. However, whenever running any command, it's not found. How do I properly set it?
5
votes
2answers
2k views

What's the difference between pkg, pkg-bin and pkg-git on the AUR?

For example, there's https://aur.archlinux.org/packages/github-desktop/, https://aur.archlinux.org/packages/github-desktop-bin/, and https://aur.archlinux.org/packages/github-desktop-git/. I took ...
0
votes
1answer
1k views

I cannot install Yaourt: I do not have write permission for the directory

These are the instructions (https://manjaro.site/how-to-install-yaourt-on-arch-linux/) to install Yaourt: git clone https://aur.archlinux.org/package-query.git cd package-query makepkg -si cd .. ...
2
votes
1answer
590 views

NordVPN not working on Manjaro

I can't make NordVPN work on Manjaro. I git cloned the repo, run makepkg -d in order to build it and resolve dependencies and then run sudo pacman -U nordvpn-bin-3.3.1_3-1-x86_64.pkg.tar.xz But ...
2
votes
0answers
43 views

Arch/Hurd and the AUR

if i installed Arch/Hurd, Will I be able to use the AUR to install from source code since i will not be able to use the Arch/Linux binary packages ? have anyone tried to do that ?
0
votes
1answer
657 views

error: PKGBUILD contains CRLF characters and cannot be executed

When trying to install some (though not all) packages from AUR using yay or pacaur, such as rstudio-desktop or zotero, I get the following errors (translated from German): :: checking integrity of ...
0
votes
1answer
195 views

Manjaro AUR install: what is the difference between “makepkg -s” then “pacman -U *.tar.xz” vs “makepkg -si”

In Manjaro is there any functional difference between using makepkg -s followed by then running pacman -U <package_name>.tar.xz instead of just using makepkg -si ? I've seen them both used ...
0
votes
1answer
770 views

Collect2 error while installing yay for Arch Linux

OS: Arch Linux (64-bit) Kernel: 4.18.5-arch1-1-ARCH Shell: bash I tried to install yay for my Arch Linux, but faced with an error. Here is the log: ==> Making package: yay 9.1.0-1 (Mon 18 Feb ...
0
votes
1answer
3k views

How to install Bootstrap Studio on Manjaro-Linux

What do I have to do to install Bootstrap Studio on my Manjaro-Linux System? I downloaded the 64-bit Version for any linux distribution here, but I dont know what to do. There is a package in AUR, ...
0
votes
1answer
283 views

list dependencies of pkgbuild with shell script

How can I list dependencies of a PKGBUILD file with shell script? For example, in a google-chrome's PKGBUILD, I want the script to extract all dependencies (including makedependencies, dependencies ...
0
votes
2answers
344 views

List files installed with makepkg

I'm still fairly new to arch and I tried installing lemonbar while customizing my system. Now I've only ever installed AUR packages with makepkg -Si and it worked very well most of the time since all ...
0
votes
1answer
29 views

aura 2.0.0 without powerpill?

I recently updated my aura package to 2.0.0 (aur). While reading the changelog (here) i noticed the powerpill support was dropped. Can anyone tell my why this was done? Was it due to the overall "...
1
vote
1answer
1k views

How to update a package installed on Arch Linux using a PKGBUILD file?

I have edited my question for clarity. TL;DR Will yay update a package I initially installed from my own local PKGBUILD when I update my PKGBUILD file? In other words, can AUR helpers be used for ...
0
votes
3answers
1k views

Analogue of AUR for gentoo

Is there a portage extension with user installation scripts like the AUR for Archlinux. I’m curious about Gentoo, and so far every distribution I’ve come across, be it Debian or red hat based, has ...
4
votes
1answer
1k views

How to check an AUR package for malicious code?

Malicious code has been found and deleted later from 3 AUR packages acroread, blaz and minergate (e,g: acroread PKGBUILD detail). It was found in a commit released by a malicious user by changing the ...
-1
votes
1answer
962 views

How to fix the error `unrecognized option '--color never'`?

I was looking to try suplemon, so I run pacaur -S suplemon and face the following error: /usr/bin/pacman: unrecognized option '--color never' This error blocks the installation. How can I fix it?
2
votes
1answer
272 views

How am I supposed to inspect a PKGBUILD?

With AUR, you are expected to manually verify the PKGBUILD file and install scripts. What/how are you supposed to actually do this? What are some red flags to look for, what are common things done by ...
1
vote
1answer
2k views

Aurman: remove packages that are reported as neither in the repos nor AUR

I have installed aurman from the AUR, and every time I install a package, it says that packages are neither in the repos nor the AUR. Is there a way to remove them without removing them manually like ...
1
vote
1answer
298 views

Aurman asking for root privilege to install from AUR

I'm using Antergos. While installing an AUR package with aurman, it requires password. Why does it need root access to install package as by git clone and 'makepkg -si' I can install it with root ...
1
vote
1answer
2k views

Installing Computer Modern font on Arch Linux

I have tried installing Computer Modern Unicode fonts on Arch-linux using the following AUR repository here, but in vain. The installation goes smoothly and doesn't produce any errors but I still can'...
3
votes
2answers
889 views

Why is it sometimes necessary to manually import keys?

There are many packages on AUR which, when you attempt to install them, result in an error like: ==> ERROR: One or more PGP signatures could not be verified! This is resolved by importing the key ...
4
votes
0answers
900 views

How to update an Arch Linux PKGBUILD file for new version (printer driver)?

I want to install the CUPS driver for the Brother QL-1060N label printer on Arch Linux. Fortunately, there is an AUR package available. (Arch is amazing.) However, the AUR package is a bit out of ...
1
vote
1answer
513 views

Installing with packer: “sorry, you are not allowed to preserve the environment”

I'm on Arch Linux (4.11.9-1) trying to install a package from AUR using packer. During installation, after compressing the package, I'm asked for my sudo password which I enter. Then, installation ...
6
votes
3answers
24k views

VirtualBox is complaining that the kernel module is not loaded

I'm new to Manjaro and AUR, having an almost same problem like this one on Ubuntu: I have vagrant, virtualbox installed via pacman, then I try $ vagrant up VirtualBox is complaining that the ...
0
votes
1answer
30 views

Adding -DVLA to the make command of appstream

Situation: I am building Pantheon from AUR on Arch Linux. Problem: I have issues building appcenter-bzr. On appcenter-bzr's page, there is a comment saying to "You want to add the -DVLA flag to the ...
1
vote
1answer
921 views

Manjaro: enable edit in Shutter

To enable edit button in Shutter sometimes a new dependency is needed. In Ubuntu systems the neeeded package is libgoo-canvas-perl, but that is not present in Manjaro repositories, nor in AUR.
2
votes
0answers
411 views

Sublime Text 3 shows no menu bar on Arch Linux unless launched as root

I don't get a menu bar visible in Sublime Text 3, downloaded from the AUR using packer -S sublime-text-dev. This seems to be a fairly common issue, however none of the solutions around the Internet ...
2
votes
2answers
2k views

How to force yaourt to install all updates

I'm trying to update my system via yaourt, but I'm getting an error due to a python package installed with pip instead of yaourt. I'm not succeeding in forcing yaourt to install the update, and I'd ...
0
votes
1answer
361 views

Get version number of AUR package installed

I imagine there's some sort of generic command for getting the version number of a specific AUR package I have installed... ideally something I can grep for the specific name, perhaps offering the ...
2
votes
1answer
1k views

Arch Linux: Why people do not do “make install” in PKGBUILD?

I'm analyzing different PKGBUILDs to learn creating packages for Arch. I saw in a lot of them, that they do make on sources, and then manually copy files in the different places with the install ...