Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [audio]

Questions about audio hardware and software in Linux and other UNIX operating systems.

-2
votes
0answers
2 views

FreeBSD: no audio on Xfce on Youtube, VLC etc..Dell Optiplex455, Intel Pentium 64bit,2gig Ram

Audio works fine in Mint19. In FreeBSD v11.2 on Xfce4, I installed Pulseaudio but audio isn't there on Firefox or Chromium or VLC. I did #cat dev/random>dev/dsp0 and got a loud white static in my ...
1
vote
0answers
14 views

My audio stopped working suddenly in Debian/i3wm/alsa/pulseaudio

Once after i rebooted my laptop, my sound just stopped to work since then. I've already search a lot of solutions, the common solutions didn't suit my case. The auto-mute mode is disabled in ...
0
votes
0answers
8 views

Getting the audio-playtime of a folder from the command line

Is there a way/tool for the linux command-line (bash) to get the overall audio playtime of a certain directory? Something like: playtime --all --recursive /Music/DrumAndBass/ output: 1:35:06
1
vote
4answers
48 views

Find and remove audio files which has less than 3 minutes of play duration

Is there a way to find and delete all the audio files recursively (MP3 files) which have less than 3 minutes play duration time? Consider the situation that I have mixture of multiple format files (e....
0
votes
2answers
33 views

Is an audio equalizer available for Linux Mint 18.3?

I have Googled myself into near exhaustion trying to find an audio equalizer for Linux Mint 18.3. The only advice I've found is for older versions of LM or Ubuntu, none of which work for me. I ...
0
votes
0answers
20 views

Can't disable audio loopback in Ubuntu 18.04

I've got a Sony WH-H900N bluetooth headset that I'm having trouble to get to work properly on ubuntu 18.04. I get constant loopback from the microphone to the speakers, which really defeats the ...
3
votes
1answer
47 views
+100

How to make new ALSA control appear in amixer

On an embedded Linux system I am creating a custom ALSA "soft volume" control as described here. The control itself works as expected, except that upon boot it does not show up in amixer. It only ...
0
votes
0answers
20 views

Piano kbd connects to Qsynth but no sound

I'm running Mint 18.3 Mate on an Intel i5-8600K desktop. I do not have a sound card or speakers. I have a Sennheiser headset that works fine when I listen to something off the web like youtube. I ...
0
votes
0answers
15 views

bluez, pulseaudio, and ofono crashes and problems in iMX8 - Wayland

I have been trying to develop an application that has media playback, media control, and telephony with i.MX8 QuadMax MEK board. I use Yocto fsl-imx-wayland distro, which uses Wayland desktop with ...
1
vote
0answers
46 views

How to setup a virtual mic and pipe audio to it from node.js

Summary: I've already asked this question on StackOverflow, it got some attention, but unfortunately no one was able to help out. I figure this is because ALSA devices are a fairly specific topic and ...
0
votes
1answer
78 views

Sound doesn't work properly in root but does in normal user

I'm using debian 9 with gnome. When i use the root the volume control doesn' t work and doesn' t have the megaphone symbol (that is also missing in the gnome panel). I can move the bar but doesn` t ...
0
votes
1answer
68 views

PulseAudio not recognizing Intel HDA after upgrading to Debian testing (Buster)

I noticed a problem a over the summer after upgrading from Debian 9 stable to Debian 10 testing: PulseAudio no longer recognized my Intel HDA audio devices. At the time I was able to switch to my ...
0
votes
0answers
32 views

USB Audio interface makes terrible noises

As I have just recently switched to Debian, I have most things sorted out however, I cannot figure out this problem. I have a M-Audio MobilePre USB audio interface I've been using for years with no ...
0
votes
1answer
22 views

Splitting up a pcm file into minute using ffmpeg long chunks

I have a large pcm file with about an hour's worth of data. I want to split it up into minute long chunks. Is there a way to ffmpeg to do that pr some other utility? Basically going from 0 - 3600s I ...
0
votes
0answers
22 views

What is the proper package for “linux-modules-extra” in ubuntu 18.04 bionic?

I just installed Ubuntu 18.04, and had a heck of a time trying to get my simple embedded intel Series/C200 audio support to work. Turns out that I had the wrong version of linux-modules-extra- ...
1
vote
1answer
73 views

Is the cx2072x codec added to the Linux kernel 4.18?

I am using an E200HA laptop and I am having a problem with the CX2072X codec. Has this problem been fixed in the Linux kernel 4.18? If not, do you have any developers who participated in the official ...
1
vote
1answer
18 views

PulseAudio network stream not available on WiFi

I have PulseAudio streaming over my local Ethernet LAN. I play sound from my client (a laptop) to a PulseAudio "server" which is connected to speakers. Both run PulseAudio verion 12.2. When I switch ...
2
votes
1answer
40 views

KDE makes loud, startling noises

I have KDE as the window manager, and I cannot figure out how to stop it making ding-a-ling noises at extreme volume. Example: Open Konsole. Open a second tab. Close the whole window with its × ...
0
votes
0answers
12 views

No sound input or output after enabling snd_aloop

I was trying to get CAVA to work by adding a loopback for sound (sudo modprobe sound_aloop). I was unaware that this disabled any and all sound output and input. I promptly disabled it (sudo modprobe -...
1
vote
1answer
24 views

PulseAudio RTP unicast poor sound quality - frequent pops

I am doing multi-room audio in my house as described at posts like this one: Multi-room audio with multicast RTP http://www.danplanet.com/blog/2014/11/26/multi-room-audio-with-multicast-rtp/ My ...
1
vote
0answers
19 views

PulseAudio RTP Multicast - how to synchronize audio on all receivers?

I am streaming music from a single controlling PC ("sender") to multiple PCs (receivers) on my LAN as described here: https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Network/#...
1
vote
2answers
50 views

PulseAudio RTP Multicast - how to play sound on sender too?

I am streaming music from a single controlling PC ("sender") to multiple PCs (receivers) on my LAN as described here: https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Network/#...
1
vote
0answers
72 views

Connect external DAC / sound card in OpenBSD

I am trying to connect a Focusrite Scarlett 2i4 USB DAC to my OpenBSD system to use as an external sound card. From what I have figured out so far, it seems that I need to tell some program or other ...
2
votes
1answer
34 views

How to set up PulseAudio remote properly and securely?

I saw a forum post about someone who was using PulseAudio remote (client-server setup) and this interested me. PulseAudio has some very advanced features that I hope to use to be able to play music ...
2
votes
1answer
27 views

Share USB audio device over Ethernet [closed]

I connect my Linux laptop to an Onkyo P-3000R (a USB DAC) using a 10 meter USB cable. I would like to replace that long USB cable with a WiFi connection, if possible. I could connect my Onkyo USB ...
1
vote
0answers
26 views

Virtual audio device won't show up anymore (snd-aloop)

Archlinux on gnome 3.30. Until the most recent update (3.28 -> 3.30) I used snd-aloop constantly to create a virtual sound device. After the update and a system reboot however it doesn't seem to work ...
1
vote
1answer
83 views

How to adjust headphone gain in /sys/kernel/sound_control/headphone_gain?

I want to increase headphone gain. So I have found the file location at /sys/kernel/sound_control/headphone_gain. cat /sys/kernel/sound_control/headphone_gain shows 0 0 For writing some desired ...
3
votes
1answer
89 views

Crackling sound with ALSA from an USB sound card after resuming from suspend

I run Arch Linux using Systemd and ALSA on a Thinkpad X200 and I have an USB sound card connected, which I use for audio output. The audio is fine until I suspend my machine with $ systemctl suspend. ...
0
votes
2answers
100 views

No sound - 'Dummy Output' on Debian 9 fresh install

As the title says, I have had no sound out of my laptop since I installed Debian overtop of Windows 10. Sound worked just fine in Windows, but nothing I have done has been able to bring it back since ...
0
votes
0answers
12 views

Gnome Volume Applet Not Controlling Volume (Unbuntu 17.04)

I'm having a strange issue where I can't change the volume of my system's audio through gnome. The volume slider is visible, although it doesn't show the icon either in the tray or beside the slider. ...
0
votes
0answers
73 views

Sound not working - mint 19

Couple days ago, I installed linux mint 19 alongside windows 10, everything worked perfectly, until I plugged in headphones (while I was using win10). When I rebooted notebook, I was not able to hear ...
1
vote
0answers
19 views

Print Jack Audio and MIDI ports to the command line

How do I print jack-audio and midi ports to the command line, similar to aconnect -io for inputs and outputs of ALSA MIDI?
3
votes
0answers
17 views

What am I missing in my kernel patch for ALSA to get EAPD to properly turn off this internal speaker? [closed]

I'm working with a picture-frame-like device manufactured by the late OpenPeak Inc. known as the OpenFrame (or O2 Joggler in the UK). It has an internal speaker and a 3.5mm line out socket; none of ...
0
votes
0answers
18 views

Command line tool to playback audio at variable “turntable speed”

I’m looking for a command-line tool that can play audio from a file at a specified rate and pitch, preserving the rate-pitch ratio. That is, playback with a control analogous to the turntable speed on ...
2
votes
2answers
33 views

How to mute sound when xscreensaver locks screen

The goal is to mute sound whenever screen lock happens. Ideally restore sound after unlocking as well. Sound system is Pulseaudio.
1
vote
1answer
21 views

Rename USB Sound device

I have raspberry pi running raspbian that has 3 sound devices plugged in via USB. I successfully renamed the card ids for alsa based on the USB port with this rule: SUBSYSTEM!="sound", GOTO="...
0
votes
0answers
18 views

Partially replace video stream while preserving audio stream

Consider a video file with one video and one audio stream. I want to replace the video stream partially while preserving the original audio stream. With partially I mean to replace certain seconds ...
0
votes
1answer
47 views

How exactly USB Audio will be detected in Linux? [closed]

How will the Linux detect that I connected a USB Audio Peripheral? If I connect a USB Charger it will charge my mobile and it does not show any Headset icon on my status bar(Android). But when I ...
1
vote
1answer
98 views

Using a Bluetooth speaker as output for JACK audio connection kit [closed]

I want to know if it is possible, to use a Bluetooth Audio Device (mine is a AMP from SURE electronics) as a output for JACK. Currently i am only aware of the pulseaudio-bluetooth module and the ...
0
votes
0answers
11 views

Bluetooth speakers: sound buttons inefective

I'm new to Arch Linux, and even though my sound settings work normally for both normal output and jack output, I have a problem with Bluetooth: I connect without problem via bluethootctl to my ...
0
votes
0answers
34 views

change application specific volume from terminal without pulseaudio

I want to change the volume on a per-application basis, but without using pulseaudio. I'm on a raspberry-pi (resin.io image), and running pulseaudio on it is kind of a real pain. ( What I really ...
1
vote
0answers
26 views

No sound setting in settings panel manager

Sound settings is missed from settings panel. I try launch it from a terminal with command gnome-control-center: I already did install gnome-control-center: #sudo apt-get install gnome-control-...
0
votes
2answers
149 views

PulseAudio on Debian 9: How to adjust default sound volume level?

Every time I boot up my Debian machine the sound volume level is at 100 % (what is way too loud). I am using PulseAudio instead of Alsa. How can I adjust the default sound volume level to an ...
1
vote
1answer
103 views

Setting new default audio playback device for ALSA in .asoundrc

After looking for a solution for quite some time, I came here to ask. My problem is as follows. Most software can't play any sound. However, there are exceptions, Chrome and Discord can play audio for ...
0
votes
0answers
23 views

Can't control master volume

When starting my laptop this morning, I noticed that the volume control slider is missing on the top right panel, which is why I cannot control the master volume anymore and I have to use the volume ...
1
vote
0answers
28 views

How to initialize multiple I2C sound devices with one device tree overlay?

I am currently stuck in implementing a new device tree overlay to initialize two sound controller: PCM5142 and WM8804. The used board is the DACBerry ONE (https://www.osaelectronics.com/product/...
0
votes
0answers
75 views

Alarm Clock applet does not play sound

I recently installed the popular Alarm Clock software on Fedora 28. When I open it in a terminal I get the following message: ** (alarm-clock-applet:5286): WARNING **: 13:16:19.445: AlarmApplet: ...
0
votes
0answers
23 views

How do I add a sound notification to Signal Desktop message notifications in Kubuntu?

My problem is one which seems not have been addressed by others as of yet. At some point in its development Signal Desktop devs chose to remove audio notifications from its functions. However given ...
1
vote
2answers
53 views

Autorandr but for audio devices?

My ThinkPad T450s runs Manjaro. As a scrum master, I frequently move between my desk with two external displays, meeting rooms with no displays, and meeting rooms with one external display. I've ...
0
votes
0answers
16 views

How to set format/duration in asoundrc?

Here is my ~/.asoundrc file pcm.!default { type hw card 1 device 0 rate 44100 # format isnt recognized, channels breaks config file format S16_LE ...