Questions tagged [armbian]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
20 views

journalctl -b 0 and dmesg give infromation for previous boot but not current

I'm debugging armbian launching on mini-PC. I rebooted it at "6:36:01" and it failed to load. So, I turned on-off power at "6:43" and it loaded. But when I look into dmesg or ...
user avatar
  • 3
0 votes
1 answer
24 views

Sometimes can't reboot on arm-device

I have a little device on ARM with armbian on it. It automatically loads after turning power on or after shutdown. But sometimes it doesn't until I turn off-on power. I added a script to crontab. The ...
user avatar
  • 3
-1 votes
1 answer
89 views

My Linux mini server have infinite reboot loop

I made a daily reboot entry in crontab for 3 am, but it's always rebooting. I pulled out the power cable then put it in again to make the rebooting stop. Does anyone know the problem?
user avatar
0 votes
1 answer
115 views

Armbian logs for previous boots

I'm using armbian and have a problem with freezes on boot. I wanted to look into logs to understand why, but occasionaly I have only one log with current session: journalctl --list-boots returns only ...
user avatar
  • 3
1 vote
0 answers
78 views

How do I find out what is loading a given kernel module?

I an using Armbian on an orange pi zero SBC uname -a Linux orangepi 4.19.57-sunxi #5.90 SMP Fri Jul 5 17:58:43 CEST 2019 armv7l armv7l armv7l GNU/Linux This is in relation to displaying Armbian ...
user avatar
  • 169
0 votes
0 answers
836 views

nmtui "The device could not be readied for configuration"

I'm trying to connect my armbian device to internet through ethernet. I use nmtui for that. ifconfig -a showes me that there is "eth0" interface. I changed it. I put static IPv4 address, ...
user avatar
  • 3
0 votes
0 answers
63 views

Armbian tethering no connection

I have a problem with USB tethering on my Armbian device. It has static IP and I connect to it via ssh. My /etc/network/interfaces file is: auto usb0 auto eth0 allow-hotplug eth0 iface eth0 inet ...
user avatar
1 vote
0 answers
295 views

Connecting to open networks using nmcli Wi-Fi network could not be found

I have an an orange pi zero running armbian I am having problem connecting to open networks using nmcli. I can very well connect to my home "WPA1 WPA2" secured network with no issue at all. ...
user avatar
  • 593
0 votes
0 answers
82 views

Set console resolution on armbian buster / NanoPI M4

I have a NanoPI M4 hooked up to a 1024x600px HDMI screen, running Armbian Buster 5.10.43-rockchip64, booting to a console (no X). My issue is, that the console resolution is set to 1024x768px after ...
user avatar
1 vote
0 answers
27 views

Can I turn my existing Ubuntu installation to Ubuntu Core (ARM)

I'm using an Orange Pi Zero ARM board that uses the Allwinner H2+ SoC. I tried installing Alpine Linux because a want a really lightweight distro for my project. Sadly it didn't work. Hence, I had to ...
user avatar
0 votes
1 answer
25 views

An application keeps being called each time I log in to user

I've been using Armbian Buster v5.10 and configuring it for a project. I remember making some changes so that startx runs automatically at startup. Each time I log in via su myUser then startx gets ...
user avatar
  • 135
0 votes
1 answer
124 views

Remote SSH keys (ECDSA key) issue when accessing from client-side

I have a Rockpro64 single board computer that I am trying to access remotely via an eMMC flashed Ubuntu iso image from here: https://www.armbian.com/rockpro64/, but keep getting the error message ...
user avatar
0 votes
1 answer
421 views

script to log temperature on armbian

I am aware that there are other questions asking very similar questions, but none seems to answer my problem. I am running an odroid hc2 sbc with armbian for a nextcloud instance. Two days ago, it ...
user avatar
  • 13
1 vote
1 answer
62 views

What is minimal requirements for running simplest graphical application on Linux box

Having little Linux box running Armbian on Orange Pi, I want to develop on C++ small graphical application which will just read frame from remote IP camera and show it on screen connected to HDMI port....
user avatar
  • 133
0 votes
0 answers
173 views

USB3.0 connection problem with NanoPi M4

I have a single board computer NanoPi-M4 which has 4 USB3.0 ports and use Armbian OS which is "a Debian and Ubuntu based computer operating system for ARM development boards.". The problem is, when I ...
user avatar
  • 1
1 vote
1 answer
487 views

How to get TUI apps showing up properly with GNU screen?

I'm working with a derivative of Debian Buster called Armbian. It is a distribution for ARM-based devices and I am using it with a Nanopi Neo Air. Armbian has full screen curses-based TUI apps. When ...
user avatar
  • 405
1 vote
0 answers
43 views

Cannot run GameMaker Studio 2 .sh file on Banana Pi M1 board

I'm having problems running a game I made in GameMaker Studio 2 on a Banana Pi M1 board using Armbian. I've done: Installed Armbian Bionic 18.04.02 (Ubuntu-based) on a Banana Pi M1 board. Installed a ...
user avatar
1 vote
1 answer
942 views

How to check mdadm RAID5 integrity after power failure/random reboot

So I'm currently building an mdadm RAID5 array attached to my home server. The hardware is an Odroid N2 SBC with a Mediasonic Probox 4 bay enclosure attached. The array is currently rebuilding and ...
user avatar
  • 13
4 votes
1 answer
2k views

What's the process "sugov:0"

I have an Orange Pi installed Armbian. I find that when I use a CPU governor called schedutil a process called sugov:0 will exist in top. And the sugov:0 can spend about 13% CPU. When I use the ...
user avatar
1 vote
0 answers
281 views

Headless armbian device stopped responding to ssh

I have a headless device (Orange Pi Zero) running Armbian that I use to experiment with. Today it suddenly stopped responding to SSH (my only means of interacting with the device): mark@mark:~$ ssh ...
user avatar
-1 votes
1 answer
77 views

Fping not working on Armbian

Fping doesn't work with exit code 4. Given: $ fping 8.8.8.8 $ $ echo $? 4 $ fping -h $ echo $? 4 Then you comment some verbosity flags related if-s in the fping code, build it and see: ./build/usr/...
user avatar
1 vote
0 answers
131 views

"Mode not supported" on my Samsung tv

I'm using Banana Pi with Armbian, and when I connect my board to TV with HDMI cable, on TV's screen appears Mode not supported. My armbianEnv.txt looks like: verbosity=1 logo=disabled console=both ...
user avatar
5 votes
2 answers
6k views

How to enable SPI on Orange PI PC+ in Armbian?

I'm trying to get SPI working on my board. That's what I came up: SPI is not enabled by default in armbian, we need to enable it first (enable corresponding DT overlay) in linux SPI can only be ...
user avatar
2 votes
1 answer
3k views

NanoPi M4 - RK3399: Apache2 + SSL: Large download hangs

I've a brand new setup of Apache2 running under Debian 9 (armbian on NanoPi M4). Everything works fine until I try to download a large file over HTTPS. Small files download successfully however, ...
user avatar
  • 711
2 votes
1 answer
795 views

How do I create a bootable ISO image from a running ARM 7 based Debian 9 machine

I am running a system on a Banana Pi M2+ which I need to clone into a bootable working copy and I cannot find repos for tools like syslinux and clonezilla for the ARM processor. Is there another ...
user avatar
  • 21
0 votes
1 answer
848 views

Orange Pi Zero: Wrong Date and Time even given Internet Access

I am using Orange Pi Zero and running Armbian Stretch OS 5.59 on it. Problem is, it is giving wrong date and time even in the presence of the Internet. I have tried restarting "ntp" service but to no ...
user avatar
  • 9
1 vote
1 answer
461 views

Use OS in the flash card with VirtualBox

I'm not sure if it's possible or even if it is how practical would it be but this thought just popped up in my head as I was trying to set up my Armbian Ubuntu 18.04 for my Orange Pi PC. I have ...
user avatar
  • 1,044
1 vote
0 answers
170 views

Armbian: dm-raid module has gone missing

I'm running Armbian (stretch) on an OrangePi PC 2. This is how the OS identifies itself on SSH login: Welcome to ARMBIAN 5.58.180813 nightly Ubuntu 16.04.5 LTS 4.18.0-rc8-sunxi64 I just updated my ...
user avatar
2 votes
1 answer
3k views

Check Armbian version on the command line

I have an Orangepi+2e device with Armbian OS. How can I check Armbian version? I tried with these commands, but can not found Armbian type. $ sudo lsb_release -a Out: No LSB modules are ...
user avatar
0 votes
1 answer
117 views

Armbian [Orange PI] remote connection

I'm trying to connect to an Orange PI lite Armbian_5.38_Orangepilite_Debian_stretch_next_4.14.14.7z with a FTDI cable USB => serial using screen or putty and connection is fine. I can see the ...
user avatar
  • 111
0 votes
1 answer
113 views

Monitor interface not showing TX packets

I have set up a monitor interface using: iw dev wlan0 interface add mon0 type monitor ifconfig mon0 up And I am using libpcap to capture and inspect 802.11 frames and radiotap headers. I was ...
user avatar
2 votes
1 answer
272 views

Adapting Armbian to use a tablet-style interface

I'm building a home-brewed "tablet" using a 10" touchscreen hooked up to an Asus Tinkerboard. Ultimately I want it to function as much like an Android tablet as possible, but the Android distro ...
user avatar
  • 129
2 votes
1 answer
109 views

OPi Zero - update

I’ve been watching my Orange Pi Zero update since yesterday and I’m starting to worry there’s something wrong going on.. It doesn’t appear to be stuck, I can ssh into it and it seems to be working ...
user avatar
  • 182
2 votes
1 answer
573 views

HDMI audio stops working after setting drm_kms_helper.edid_firmware

I have the HDMI-to-VGA adapter with the bad EDID. The monitor says "unsupported mode" on the mode that should be supported. The 1600x900 mode don't work, only the 1280x720. The virtual console is ...
user avatar
0 votes
1 answer
325 views

Armbian update failing - Dec 2017 - unable to lock /var/lib/dpkg/lock

We'v got a strange problem. We have multiple bootable Armbian (including 5.25 and 5.30). These are of course not the newest, but we would update them immediately after installation with the usual apt-...
user avatar
  • 401
1 vote
0 answers
510 views

Adding wifi nfs boot to initramfs, under armbian and uboot

I'm trying to setup my an initramfs image to nfs boot from a WPA wifi access point. My image is working with armbian and uboot. so far I have NFS booting over ethernet just fine. But no real path to ...
user avatar
  • 11
2 votes
0 answers
4k views

Ralink MT7601U (148f:7601) Wi-Fi adapter installation

I am trying to install a Ralink wifi adapter in Armbian. I have look this here but it did not lsusb Bus 004 Device 003: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter OS Version: ...
user avatar
0 votes
1 answer
5k views

How to change display resolution for Armbian ?

I have a BananaPI M1 and I have installed the Armbian. The current resolution is 1920 x 1080 (px) which is very small. There is only 1920x1080 option in Settings> Display. How can I shrink this? ...
user avatar
6 votes
1 answer
20k views

How to use UART pins on Orange Pi zero?

I want to use UART1 or 2 (see picture) on the Orange Pi zero. But when I try to open the port with screen /dev/ttyS1 Screen terminates. I found here that I needed to add "overlays=sun8i-h3-uart1" in ...
user avatar
  • 473
2 votes
1 answer
898 views

How do I check if the system is currently suspended?

I want to use my orange pi power button to suspend and resume system and have some troubles with check state. So I wrote shell script for this but it won't work; it's only suspending. When I click ...
user avatar
0 votes
0 answers
318 views

Is armbian for bananapi pro lacking luks support?

I have a bananapi pro and run armbian on it. I tried stable, testing and experimental (in that order) all with the same result. When I try cryptsetup luksOpen /dev/sda1 ext_crypt I get Enter ...
user avatar
1 vote
1 answer
3k views

Orange Pi Armbian no network

I have installed armbian on SD card and I cannot get no network. Neither ethernet, neither wireless. Only thing I managed is to connect to it via serial port. Here is some information about my network ...
user avatar
  • 13
2 votes
1 answer
171 views

Make soundcard visible to new user

If it's relevant, I'm trying this on the Debian-derived Armbian 3.4, running on an Orange Pi Zero (Raspberry Pi "clone") board. As you will see below, the board can playback sound either through a "...
user avatar
  • 123
2 votes
1 answer
3k views

Send email with mailx/msmtp only works for root user

I'm struggling to find a solution. I installed heirloom-mailx and msmtp following this site. I can send emails (using gmail) as root user. The problem is with non-root user: the messages go to a queue ...
user avatar
2 votes
1 answer
1k views

Debian Jessie without systemd and with initramfs hangs at boot

I need to use Jessie without systemd and with initramfs. But there seems to be some incompatibilities. During boot, I get: Begin: Loading essential drivers ... done. Begin: Running /scripts/init-...
user avatar
  • 764