Skip to main content

Questions tagged [armbian]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
545 views

xrandr: can't open display

I am having trouble with my 7-inch type C LCD screen.  When I try to display an application on it, I get the error Missing X server or $DISPLAY.  I use the command xrandr and get the message can't ...
owl magician's user avatar
0 votes
0 answers
24 views

Armbian with KDE desktop reboots at KDE splash screen

I have Armbian running on a Pine A64 LTS V2 on an eMMC. All works on the headless part A-OK until the boot process gets to the KDE splash screen, then a power cycle occurs. Is there a way to stop the ...
BitBrigade's user avatar
0 votes
1 answer
172 views

Armbian enable UART2 for TX/RX

I'm trying to use the UART1 and UART2 of my device (a NanoPi NEO) to read serial data. So far, UART1 i fully functionnal and I can read and transmit data through /dev/ttyS1. I've enabled UART2 using ...
IArchi's user avatar
  • 11
1 vote
1 answer
598 views

Some binaries are extremely slow with qemu-user-static inside docker

I'm currently working with the armbian build system and it is using chroot inside docker to cross build armbian images (for aarch64 in my case on an amd64 host). However, for some reason, when the ...
theCalcaholic's user avatar
0 votes
0 answers
44 views

Truncate unallocated space from SD card

I have an Armbian system SD card that I want to copy to another device. The system was 16GB but was previously imaged to 64GB card and now it is to big to handle for me. Is it any way to truncate ...
user3742046's user avatar
0 votes
0 answers
157 views

High CPU usage from ffmpeg decoding rtsp to v4l2loopback

I got a orangepi5 that has hardware decoders for h264,hevc and other formats. I am using armibian Armbian 23.5.5 Jammy CLI kernel legacy 5.10.160. I've installed a custom ffmpeg that uses RockChip MPP ...
imbr's user avatar
  • 103
0 votes
0 answers
44 views

What is the source of this tty console output?

I'm making a kiosk system using Armbian on an orangepi zero 3. The kiosk is a on a local server that I connect to using chromium browser launched from my ~/.bash_profile. Before chromium-browser ...
soccermom420's user avatar
0 votes
0 answers
48 views

Fish shell can't change directory over a Webdav resource through Rclone

Fish can't cd into a folder on a Webdav remote directory through Rclone: Welcome to fish, the friendly interactive shell Type `help` for instructions on how to use fish drive ) ls Documents/ Music/ ...
freezr's user avatar
  • 11
0 votes
1 answer
466 views

PWM on BananaPi M2 0

"documentation" on Banana Pi Zero M2 is so chaotic it's even funny. goal: get PWM working. so I installed armbian, waited a week till my usb OTG cable came (because you'll just fail default ...
greengold's user avatar
  • 113
9 votes
1 answer
7k views

Remaining disk space on docker overlay filesystem

I'm new to linux. I installed armbian to an sd card and everything works fine. The sd card is 64GB. Then I installed docker.io, docker-compose and portainer, nothing else. When I check for disk space ...
Jimmy's user avatar
  • 93
1 vote
1 answer
583 views

Getting a Waveshare CAN HAT working on a Banana Pi BPI-M2 Zero

Waveshare makes a great CAN HAT for the Raspberry Pi (see here), but the instructions only work for Raspberry Pi OS, not for Armbian. The Banana Pi BPI-M2 Zero has the same pin header layout as the ...
johnnyb's user avatar
  • 101
0 votes
0 answers
84 views

100% packet loss banana pi m2 zero, using an armbian release

I've cracked my head on this for a while. I can't ssh into my banana pi m2 zero(I don't have a mini-usb cord, I'm trying to boot wirelessly for the first time). I get 100% packet loss every time I try ...
Itachi's user avatar
  • 1
0 votes
1 answer
543 views

NMCLI connection only works with 1 wifi adapter

I have 2 wifi adapters on my odroid, wlan0 and wlan1, I connected to my wifi using nmcli with wlan1 successfully, but would like to be able to connect with wlan0 instead. However it seems no matter ...
vph97's user avatar
  • 1
0 votes
1 answer
99 views

Sometimes can't reboot on arm-device

I have a little device on ARM with armbian on it. It automatically loads after turning power on or after shutdown. But sometimes it doesn't until I turn off-on power. I added a script to crontab. The ...
Dmitry's user avatar
  • 143
-1 votes
1 answer
303 views

My Linux mini server have infinite reboot loop

I made a daily reboot entry in crontab for 3 am, but it's always rebooting. I pulled out the power cable then put it in again to make the rebooting stop. Does anyone know the problem?
Wasesa Ahmad's user avatar
1 vote
1 answer
976 views

Armbian logs for previous boots

I'm using armbian and have a problem with freezes on boot. I wanted to look into logs to understand why, but occasionaly I have only one log with current session: journalctl --list-boots returns only ...
Dmitry's user avatar
  • 143
1 vote
0 answers
307 views

How do I find out what is loading a given kernel module?

I an using Armbian on an orange pi zero SBC uname -a Linux orangepi 4.19.57-sunxi #5.90 SMP Fri Jul 5 17:58:43 CEST 2019 armv7l armv7l armv7l GNU/Linux This is in relation to displaying Armbian ...
user13267's user avatar
  • 189
0 votes
0 answers
4k views

nmtui "The device could not be readied for configuration"

I'm trying to connect my armbian device to internet through ethernet. I use nmtui for that. ifconfig -a showes me that there is "eth0" interface. I changed it. I put static IPv4 address, ...
Dmitry's user avatar
  • 143
1 vote
1 answer
2k views

Connecting to open networks using nmcli Wi-Fi network could not be found

I have an an orange pi zero running armbian I am having problem connecting to open networks using nmcli. I can very well connect to my home "WPA1 WPA2" secured network with no issue at all. ...
DEKKER's user avatar
  • 968
1 vote
0 answers
75 views

Can I turn my existing Ubuntu installation to Ubuntu Core (ARM)

I'm using an Orange Pi Zero ARM board that uses the Allwinner H2+ SoC. I tried installing Alpine Linux because a want a really lightweight distro for my project. Sadly it didn't work. Hence, I had to ...
Jonathan Gerard Joseph J's user avatar
0 votes
1 answer
28 views

An application keeps being called each time I log in to user

I've been using Armbian Buster v5.10 and configuring it for a project. I remember making some changes so that startx runs automatically at startup. Each time I log in via su myUser then startx gets ...
JC123's user avatar
  • 145
0 votes
1 answer
912 views

Remote SSH keys (ECDSA key) issue when accessing from client-side

I have a Rockpro64 single board computer that I am trying to access remotely via an eMMC flashed Ubuntu iso image from here: https://www.armbian.com/rockpro64/, but keep getting the error message ...
KryptoKidz's user avatar
1 vote
2 answers
1k views

script to log temperature on armbian

I am aware that there are other questions asking very similar questions, but none seems to answer my problem. I am running an odroid hc2 sbc with armbian for a nextcloud instance. Two days ago, it ...
Beres's user avatar
  • 33
1 vote
1 answer
84 views

What is minimal requirements for running simplest graphical application on Linux box

Having little Linux box running Armbian on Orange Pi, I want to develop on C++ small graphical application which will just read frame from remote IP camera and show it on screen connected to HDMI port....
OlegG's user avatar
  • 133
0 votes
0 answers
211 views

USB3.0 connection problem with NanoPi M4

I have a single board computer NanoPi-M4 which has 4 USB3.0 ports and use Armbian OS which is "a Debian and Ubuntu based computer operating system for ARM development boards.". The problem is, when I ...
nanopi's user avatar
  • 1
1 vote
1 answer
840 views

How to get TUI apps showing up properly with GNU screen?

I'm working with a derivative of Debian Buster called Armbian. It is a distribution for ARM-based devices and I am using it with a Nanopi Neo Air. Armbian has full screen curses-based TUI apps. When ...
Roxy's user avatar
  • 385
1 vote
0 answers
54 views

Cannot run GameMaker Studio 2 .sh file on Banana Pi M1 board

I'm having problems running a game I made in GameMaker Studio 2 on a Banana Pi M1 board using Armbian. I've done: Installed Armbian Bionic 18.04.02 (Ubuntu-based) on a Banana Pi M1 board. Installed a ...
PeterOEM's user avatar
2 votes
1 answer
2k views

How to check mdadm RAID5 integrity after power failure/random reboot

So I'm currently building an mdadm RAID5 array attached to my home server. The hardware is an Odroid N2 SBC with a Mediasonic Probox 4 bay enclosure attached. The array is currently rebuilding and ...
Nick's user avatar
  • 23
6 votes
1 answer
3k views

What's the process "sugov:0"

I have an Orange Pi installed Armbian. I find that when I use a CPU governor called schedutil a process called sugov:0 will exist in top. And the sugov:0 can spend about 13% CPU. When I use the ...
lifansama's user avatar
1 vote
0 answers
562 views

Headless armbian device stopped responding to ssh

I have a headless device (Orange Pi Zero) running Armbian that I use to experiment with. Today it suddenly stopped responding to SSH (my only means of interacting with the device): mark@mark:~$ ssh ...
Mark Jeronimus's user avatar
-1 votes
1 answer
138 views

Fping not working on Armbian

Fping doesn't work with exit code 4. Given: $ fping 8.8.8.8 $ $ echo $? 4 $ fping -h $ echo $? 4 Then you comment some verbosity flags related if-s in the fping code, build it and see: ./build/usr/...
Dodger.elf's user avatar
1 vote
0 answers
194 views

"Mode not supported" on my Samsung tv

I'm using Banana Pi with Armbian, and when I connect my board to TV with HDMI cable, on TV's screen appears Mode not supported. My armbianEnv.txt looks like: verbosity=1 logo=disabled console=both ...
NikoKunx3's user avatar
4 votes
2 answers
13k views

How to enable SPI on Orange PI PC+ in Armbian?

I'm trying to get SPI working on my board. That's what I came up: SPI is not enabled by default in armbian, we need to enable it first (enable corresponding DT overlay) in linux SPI can only be ...
rattrapper's user avatar
2 votes
1 answer
4k views

NanoPi M4 - RK3399: Apache2 + SSL: Large download hangs

I've a brand new setup of Apache2 running under Debian 9 (armbian on NanoPi M4). Everything works fine until I try to download a large file over HTTPS. Small files download successfully however, ...
TCB13's user avatar
  • 741
2 votes
1 answer
1k views

How do I create a bootable ISO image from a running ARM 7 based Debian 9 machine

I am running a system on a Banana Pi M2+ which I need to clone into a bootable working copy and I cannot find repos for tools like syslinux and clonezilla for the ARM processor. Is there another ...
Rick's user avatar
  • 21
0 votes
1 answer
2k views

Orange Pi Zero: Wrong Date and Time even given Internet Access

I am using Orange Pi Zero and running Armbian Stretch OS 5.59 on it. Problem is, it is giving wrong date and time even in the presence of the Internet. I have tried restarting "ntp" service but to no ...
Saad's user avatar
  • 9
1 vote
1 answer
608 views

Use OS in the flash card with VirtualBox

I'm not sure if it's possible or even if it is how practical would it be but this thought just popped up in my head as I was trying to set up my Armbian Ubuntu 18.04 for my Orange Pi PC. I have ...
7_R3X's user avatar
  • 1,184
1 vote
0 answers
203 views

Armbian: dm-raid module has gone missing

I'm running Armbian (stretch) on an OrangePi PC 2. This is how the OS identifies itself on SSH login: Welcome to ARMBIAN 5.58.180813 nightly Ubuntu 16.04.5 LTS 4.18.0-rc8-sunxi64 I just updated my ...
Lukas Barth's user avatar
2 votes
1 answer
7k views

Check Armbian version on the command line

I have an Orangepi+2e device with Armbian OS. How can I check Armbian version? I tried with these commands, but can not found Armbian type. $ sudo lsb_release -a Out: No LSB modules are ...
Benyamin Jafari's user avatar
0 votes
1 answer
165 views

Armbian [Orange PI] remote connection

I'm trying to connect to an Orange PI lite Armbian_5.38_Orangepilite_Debian_stretch_next_4.14.14.7z with a FTDI cable USB => serial using screen or putty and connection is fine. I can see the ...
Daniele's user avatar
  • 111
0 votes
1 answer
269 views

Monitor interface not showing TX packets

I have set up a monitor interface using: iw dev wlan0 interface add mon0 type monitor ifconfig mon0 up And I am using libpcap to capture and inspect 802.11 frames and radiotap headers. I was ...
Ross MacArthur's user avatar
3 votes
1 answer
346 views

Adapting Armbian to use a tablet-style interface

I'm building a home-brewed "tablet" using a 10" touchscreen hooked up to an Asus Tinkerboard. Ultimately I want it to function as much like an Android tablet as possible, but the Android distro ...
thanby's user avatar
  • 139
2 votes
1 answer
139 views

OPi Zero - update

I’ve been watching my Orange Pi Zero update since yesterday and I’m starting to worry there’s something wrong going on.. It doesn’t appear to be stuck, I can ssh into it and it seems to be working ...
nxet's user avatar
  • 181
2 votes
1 answer
704 views

HDMI audio stops working after setting drm_kms_helper.edid_firmware

I have the HDMI-to-VGA adapter with the bad EDID. The monitor says "unsupported mode" on the mode that should be supported. The 1600x900 mode don't work, only the 1280x720. The virtual console is ...
user avatar
0 votes
1 answer
342 views

Armbian update failing - Dec 2017 - unable to lock /var/lib/dpkg/lock

We'v got a strange problem. We have multiple bootable Armbian (including 5.25 and 5.30). These are of course not the newest, but we would update them immediately after installation with the usual apt-...
MSalters's user avatar
  • 421
1 vote
0 answers
643 views

Adding wifi nfs boot to initramfs, under armbian and uboot

I'm trying to setup my an initramfs image to nfs boot from a WPA wifi access point. My image is working with armbian and uboot. so far I have NFS booting over ethernet just fine. But no real path to ...
Tasha's user avatar
  • 11
2 votes
0 answers
5k views

Ralink MT7601U (148f:7601) Wi-Fi adapter installation

I am trying to install a Ralink wifi adapter in Armbian. I have look this here but it did not lsusb Bus 004 Device 003: ID 148f:7601 Ralink Technology, Corp. MT7601U Wireless Adapter OS Version: ...
Alparslan Bagriyanik's user avatar
0 votes
1 answer
7k views

How to change display resolution for Armbian ?

I have a BananaPI M1 and I have installed the Armbian. The current resolution is 1920 x 1080 (px) which is very small. There is only 1920x1080 option in Settings> Display. How can I shrink this? ...
Alparslan Bagriyanik's user avatar
6 votes
1 answer
25k views

How to use UART pins on Orange Pi zero?

I want to use UART1 or 2 (see picture) on the Orange Pi zero. But when I try to open the port with screen /dev/ttyS1 Screen terminates. I found here that I needed to add "overlays=sun8i-h3-uart1" in ...
MatMis's user avatar
  • 523
2 votes
1 answer
1k views

How do I check if the system is currently suspended?

I want to use my orange pi power button to suspend and resume system and have some troubles with check state. So I wrote shell script for this but it won't work; it's only suspending. When I click ...
Evgeniy Russkikh's user avatar