Questions tagged [aptitude]

Alternative package manager for Debian and derivatives which offers an ncurses based text-mode user interface (TUI) and mighty search patterns besides a command-line interface similar to `apt-get`'s command-line interface.

Filter by
Sorted by
Tagged with
0
votes
1answer
2k views

debian: aptitude install sshfs > Couldn't find any package whose name [closed]

Why aptitude don’t found sshfs? And how can I install sshfs via aptitude? Pleas, without 3rd-Partys. https://packages.debian.org/en/wheezy/sshfs I typed this: root@s18:~# aptitude update Hit http://...
0
votes
3answers
1k views

How can I first download KDE files and then install them offline on Ubuntu?

How can I first download KDE files and then install them offline on Ubuntu?
0
votes
1answer
34 views

Error when apt update and removing ppa

I am trying to test PHP 7.0 installation on vagrant using Ansible and get this error: TASK [php-cli : Install php7.0-cli package] **********************************************************************...
0
votes
0answers
45 views

Unmet broken dependencies debian

I know there a lot of such question were asked, but no one answer helped me. Here is an error I beat with for few hours already. Here is my source.list I tried apt-get clean sudo apt --fix-broken ...
0
votes
0answers
40 views

i dont have Ettercap conf file when reinstall Ettercap

I don't have ettercap files, they don't generate when installing ettercap. I tried with apt-get install ettercap-graphical aptitude ettercap-graphical but it didn't generate ettercap files. ...
0
votes
0answers
21 views

How to download just one library from a newer version of debian using apt get?

My issue is this: I am using a library that changes versions across Jessie -> stretch, and I have dependencies based on the stretch version. Ideally, I can just this one time sudo apt-get from ...
0
votes
0answers
82 views

can't install libboost-python in debian

I think something is wrong the package manager I use this command to install libboost-python sudo aptitude install libboost-python1.62.0 I get the following error that later suggests removing ...
0
votes
1answer
30 views

how to view installation information for package to be installed by apt [duplicate]

For ubuntu or debian, for installed package, I can use dpkg -L package to view where files were installed by the package. For a package is going to be installed but yet installed, how can I foresee ...
0
votes
1answer
82 views

omitting icon files from downloading updates of Debian 9.5 amd64 package lists?

situation when I am updating Debian 9.5 amd64 (stable, backports, test, unstable) package lists using APT or APTITUDE, the download size of the update is, as of writing this post, cca 60 MB with half ...
0
votes
1answer
37 views

Cant start cutegram

I installed cutegram When I start it I get ./cutegram: error whiel loading shared libraries: libgstreamer-0.10.so.0: cannot open shared object file: No such file or directory I use Debian 9. I tried ...
0
votes
0answers
23 views

Aptitude reacts very slowly when fixing unresolved issues

When Aptitude's bottom status line permanently states [1(0)/...] Resolving dependencies (i.e. Aptitude can't find a solution given the current constraints), changing the status of any package (e.g. ...
0
votes
1answer
328 views

unresolved dependencies (held back packages) seemingly unfixable

I was having some problems with LibreOffice Draw, and since I couldn't find a solution for it I decided to uninstall and do a clean install. If I recall correctly This is what I've used: sudo apt-get ...
0
votes
1answer
42 views

Error whilst aptitude upgrade > error processing install-info

I've encountered a strange issue whilst updating my debian jessie system. I do a aptitude update, aptitude upgrade which then throws a error processing install-info. I managed to find the solution on ...
0
votes
1answer
676 views

insync messed up apt and I can't do apt-get update/upgrade

I had issues with 1.2.x version of insync, so I googled for its website and I downloaded the deb file of the newest version for my 64 bit debian. dpkg couldn't install it, even setting the --force-all ...
0
votes
0answers
39 views

Install Vlc 1.1 without building it from source

I am using Ubuntu 15.04. Is there any way to install VLC version 1.1 without having to build it from source? I tried these method but I was stuck in endless loop of unmet dependencies: sudo dpkg -i ...
0
votes
1answer
107 views

Debian system: install specific packages from source automatically to boost the performance

On Debian /Ubuntu systems, how to set a list of packages which can be installed from sources automatically by apt-get or aptitude? The server is mainly for scientific computing and I would like to ...
0
votes
1answer
154 views

Why does aptitude refrain from upgrading [UNAVAILABLE] packages?

Why does aptitude refrain from upgrading in the example below? Is it solely because existing package metadata is not in cache anymore? If package is marked as [UNAVAILABLE], does it mean the only ...
0
votes
1answer
218 views

Old Debian packages install sources

I'm trying to install make program using aptitude install make in my Debian. Unfortunately I have error : Err http://debian.balt.net lenny/main make 3.81-5 404 NotFound What I need to do to make ...
0
votes
0answers
499 views

apt-get or aptitude [duplicate]

Possible Duplicate: What is the real difference between “apt-get” and “aptitude”? (How about “wajig”?) I'm new in Linux (Ubuntu) world. When I need to install ...
-1
votes
1answer
143 views

Can’t install any software from old Debian

Looks like I can't install any software since I run Old Debian Lenny. Is it possible somehow change installation sources for system? UPD I have updated my sources, but still can't install software: ...
-2
votes
1answer
457 views

Dependency problems Linux Debian undetectable broken packages

I am just trying to do an upgrade (sudo apt upgrade), but it fails with error E: Broken Packages. Doing dpkg -l | grep broken and dpkg -l | grep held returned nothing. My sources.list looks as follows:...
-4
votes
1answer
7k views

Can able to install Linux Headers (Kali Linux)?

How to install Kali Linux header? I used this command apt-get update && apt-get install -y linux-headers-$(uname -r), but it was showing the below error E:unable to locate package linux-...