Questions tagged [aptitude]

Alternative package manager for Debian and derivatives which offers an ncurses based text-mode user interface (TUI) and mighty search patterns besides a command-line interface similar to `apt-get`'s command-line interface.

Filter by
Sorted by
Tagged with
1
vote
1answer
2k views

How to remove metapackage entirely in Debian

Is there any way to remove meta package and all its packages? Subset of metapackage is packages which don't depend on metapackage by all means. That's why if remove one metapackage only the package's ...
1
vote
3answers
962 views

How can I get an Ubuntu 12.04 box to do an aptitude update; aptitude upgrade?

I did an aptitude apt-get and then aptitude upgrade, on an Ubuntu 12.04 box, and got: root@li393-189:~# aptitude upgrade Resolving dependencies... The following packages will be ...
1
vote
1answer
404 views

Ubuntu Could not purge package

I've tried to install oracle-java7-installer package from custom repository onto Ubuntu 12. It was failed during executing some post-installation script. So. I want just to rollback it and proceed ...
1
vote
2answers
2k views

Replace yum with apt

I have used Ubuntu for like two years now. I am very comfortable with the aptitude package manager. I recently switched to Fedora(16)[I still have ubuntu on my other drive :) ] I am behind a ...
1
vote
0answers
31 views

libc6 (dependency of a package I'm trying to install) requires newer kernel, I can't upgrade though

There. It occured multiple times to me already, that packages I tried to install (e.g. ngircd or make) have a dependency called libc6, which required kernel version 3.2 however. I cannot upgrade my ...
1
vote
0answers
447 views

W: Failed to fetch http://deb.debian.org/debian/dists/jessie-updates/main/binary-amd64/Packages 404 Not Found [IP: 151.101.140.204 80] [duplicate]

I'm trying to get a project running locally on Deepin. The project relies on node 6.10, I understand that it's an old version but it works. When the Dockerfile tries to run the sudo apt-get update, it ...
1
vote
0answers
304 views

wine unmet dependencies:

I believe that at one point i uninstalled wine however when i try to install wine again i get this: ~$ sudo apt install --install-recommends winehq-stable Reading package lists... Done Building ...
1
vote
0answers
48 views

Configuring default output for Aptitude package search

In most flavors of Linux that I've used, the output for apt search does not include the current state display but in Linux Mint (Sylvia) it is displaying and I would like to remove it because it ...
1
vote
0answers
874 views

Cannot install libgstreamer-0.10 [duplicate]

I' using Debian 9 Cannot install libgstreamer-0.10.so I tried sudo apt-get install libgstreamer0.10-0 Reading package lists... Done Building dependency tree Reading state information... Done ...
1
vote
0answers
27 views

aptitude display current pkg repo and update pkg repo - default grouping method?

So trying a few things, mainly from here, https://aptitude.alioth.debian.org/doc/en/ch02s05s01.html#secDisplayFormat I wasn't able to get an error-free change to aptitude that displayed the repo of ...
1
vote
0answers
931 views

add key for repository

I've looked around a lot and can't seem to find what I need. I have a couple repositories I want to add, and avoid the "won't install from here because it is unsigned" error - so I'd like to download ...
1
vote
0answers
106 views

Linux Mint Debian: Apparently benign error message with aptitude

When I use aptitude or apt-get at the command line to update/install or upgrade (sudo aptitude update/sudo aptitude install) I get the following error message Error: GDBus.Error:org.freedesktop.DBus....
1
vote
3answers
151 views

Ubuntu software updates with apt-get

I had a basic question regarding Ubuntu's "apt-get update/dist-upgrade" behavior. I was unsure of which software packages were updated when "apt-get update/dist-upgrade" were run. I read on other SO ...
1
vote
0answers
32 views

what are the differences between package installers?

I have just started using Linux Mint and I have come across multiple ways to install packages from the command line: apt-get, aptitude, gdebi so far. Can someone explain what the major differences ...
1
vote
0answers
825 views

Installing Nvidia Drivers the Debian way would uninstall dozens of packages

I just set up a fresh Debian (Jessie/8), set the APT Sources to fetch testing packages (main, contrib, non-free). Now I wanted to install drivers for the installed Nvidia GeForce 9600 and I tried ...
1
vote
0answers
88 views

Completing a Debian installation

Here's what I did: I installed Debian by burning the first ISO from the repository to a USB. Booted from it, got Debian installed - except no desktop. I tried using aptitude to get it, but I need a ...
1
vote
0answers
88 views

Installing rgdal in Debian, with aptitude

I am installing rgdal in a docker container that also contains RShiny. I need some specific set of libraries for installing some packages, but also a downgraded version of the libraries for gdal. I ...
1
vote
1answer
169 views

aptitude unmarkauto trying to remove packages

aptitude unmarkauto seems to have behaved strangely for me. I had numerous packages that apt-get autoremove wanted to remove: # apt-get autoremove Reading package lists... Done Building dependency ...
1
vote
0answers
766 views

How can I install gcc-4.2 g++-4.2 on Linux Mint 17 with gcc-4.8 already installed?

I need an older version of gcc (specifically 4.2) alongside current gcc (4.8) on Linux Mint 17. Default Mint repositories can't find needed package: sudo aptitude install gcc-4.2 No candidate version ...
1
vote
1answer
96 views

How to make aptitude recognize Oracle Java as a valid java dependency

I have Oracle Java 7 on my Debian. I want to install tomcat server using aptitude, but it keeps trying to install icedtea, and unnecessary java related packages. Is it possible for aptitude to know ...
1
vote
1answer
670 views

aptitude search doesn't see deb, but it exist in repo: http://http.kali.org/pool/main/s/simplejson/

OS: Kali Linux 64 bit ISO 1.0.9 www.kali.org/downloads/ package: python3-simplejson Here is: http://http.kali.org/pool/main/s/simplejson/ python3-simplejson_3.6.3-1_amd64.deb 24-Aug-2014 01:57 ...
1
vote
2answers
2k views

dependency error when run apt-get -f install in debian squeeze

I can't install or remove packages in Debian. When I type apt-get -f install to fix the problem I get this error: Reading package lists... Done Building dependency tree Reading state ...
1
vote
0answers
444 views

Aptitude installing jre

I am trying to install jre on my debian 7 kali box, but I keep getting these faulty errors. I tried installing it through aptitude and it fails at the end. The result is: dpkg: error processing ...
1
vote
2answers
835 views

Aptitude - uninstalling autoinstalled packages that are recommended by other packages

I am running a Debian Wheezy install on a system where space is tight. Hence, I've turned off the "Automatically install recommended packages" option. The problem occurs if I install a package which ...
0
votes
1answer
2k views

An upgrade from 'zesty' to 'bionic' is not supported with this tool. Tried official links, no success

I tried following https://help.ubuntu.com/community/EOLUpgrades/Feisty link, but without success. I need to upgrade my system to 17.10(EOL) from 17.04. When running following command I am getting an ...
0
votes
1answer
1k views

How do I fix this “Permission denied” error I get every time I execute aptitude?

When I execute, for example, aptitude search ruby2.5, I get the following errors as first lines of the output. (It's the same error message repeated twice.) E: Error saving configuration file - ...
0
votes
2answers
4k views

Can't install software in Debian 6

I installed Debian 6 Squeez on my virtual machine and I can't install software using aptitude or apt-get. This is my sources.list file: root@debian:/etc/apt# cat sources.list # # deb cdrom:[Debian ...
0
votes
1answer
1k views

apt-get install wants remove everything

First thing is, when I try to install teamviewer (https://download.teamviewer.com/download/teamviewer_i386.deb) it wasnt install fully so i use apt-get install -f but -f delete all packages, after ...
0
votes
2answers
82 views

No bar at the bottom on Gnome after installing some Debian packages

A little bit back I tried to install a package with aptitude. One of its substitutions deleted gnome and many other packages. The bar at the bottom is gone basically, anyone know how to bring the bar ...
0
votes
1answer
363 views

32 bit aplications aren't installing properly on 64-bit

Ok, so I have been trying to get this to work for a while and i don't know exactly what is going on so I will just show what happens: aptitude install wine32 Note: selecting "wine32:i386" instead of ...
0
votes
2answers
4k views

Using apt-get in mac Terminal [closed]

I need to install tweaks' packages on an jailbroken iPhone via SSH. But apt-get is not included in mac command line tools. I've found that brew can be used, but it doesn't seem to work when ssh'ing ...
0
votes
1answer
2k views

Upgrading mysql caused broken packages

I have Debian Jessie, and MySQL 5.6 from the MySQL Debian repository. This installation installes an apt sources.list.d entry that after sudo apt-get install mysql-community-server, it asks whether I ...
0
votes
1answer
273 views

Why does 'aptitude markauto' uninstall my package?

From the aptitude help: aptitude 0.6.8.2 Usage: aptitude [-S fname] [-u|-i] .. snip .. markauto - Mark packages as having been automatically installed. unmarkauto - Mark packages as having ...
0
votes
1answer
13k views

Problem installing John the Ripper Jumbo on Kali - libssl-dev dependecy

I am trying to install John the Ripper Jumbo on my Kali box. For some reason the version of Kali I recently installed as the host OS on a spare laptop does not seem to have NTLM hash support (whereas ...
0
votes
2answers
3k views

How can I install Bastille on a recent version of Debian?

To the best of my ability, I have looked everywhere in order to find a .deb file however even on its own website (bastille-linux.org) it is recommended to use aptitude which no longer seem to contain ...
0
votes
1answer
120 views

apt ignores virtual package provided equivs-created package

I want to install pdftk on my development machine where I have installed (multiple versions of) Java with SDKMAN!. In order to fulfill the dependency on default-jre-headless of pdftk-java, I created a ...
0
votes
1answer
557 views

GPG error in Debian Lenny

I got error after aptitude update command: Err http://archive.debian.org lenny/non-fre Packages 404 Not Found [IP: 209.87....
0
votes
1answer
513 views

How to fix - Failed to fetch

Trying to install vim-gnome in Raspberry Pi3. Finally got error: E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/p/perl/libperl5.20_5.20.2-3+deb8u8_armhf.deb: 404 Not Found [...
0
votes
2answers
2k views

Broken package problem installing ring on Mint 18.1

I have a Linux Mint 18.1 Serena installed, and the apt-get install ring won't do the trick. it returns the following: Some packages could not be installed. This may mean that you have requested an ...
0
votes
1answer
63 views

Choose software from Debian repository

How can I choose which software I want to install from a Debian repository? I know that didn't make much sense, let me explain more detail. I want to install a «unstable» version of gnupg with (ECC ...
0
votes
1answer
651 views

Enable mouse support in the console for applications that feature it in GUI terminals [closed]

Is there some general mechanism missing in text mode consoles but present in GUI terminals that I can enable for mouse-supporting applications? By "general" I mean not per-application (not application-...
0
votes
1answer
62 views

Install latest version of number-versioned software like Tomcat using apt-get?

I'm not looking for some nightly releases, I just want the highest version of software available in apt's database. Although a beginner, I managed to pull just a list of basic tomcat installations: ...
0
votes
1answer
3k views

Install linux headers 3.7 on debian 8

I'm trying to install the amd64 radeon catalyst driver, but it needs kernel headers for 3.7 This is the output of uname -r: 3.16.0-4-amd64 I've already ran apt-get update, apt-cache search linux-...
0
votes
1answer
92 views

uninitialized constant XML::SaxParser / Error retrieving bug reports from the server

I use an old LMDE (Linux Mint Debian Edition) installation that went through several repository changes. I've originally tracked LMDE's repositories, then at one point switched to Debian Testing (...
0
votes
1answer
5k views

Debian: Can't Install Anything (Package Cannot Be Installed)

So, I have a brand new Debian install. My sources.list looks like this: deb http://http.debian.net/debian wheezy main contrib nonfree deb-src http://http.debian.net/debian wheezy main contrib ...
0
votes
1answer
168 views

Aptitude wants to remove tons of packages

I've used the search engine but do not manage to find a simple answer to this simple question: How to avoid aptitude wanting to deinstall tons of packages when a simple upgrade of a single package ...
0
votes
2answers
94 views

Why there is no automatic flag on automatically added libraries?

Under my Debian Jessie system, when I run aptitude I can see a lot of libraries not manually installed but without the automatic flag. So if I remove the main packages the dependent packages will stay....
0
votes
1answer
17k views

Unable to connect to source.repository.backtrack-linux.org

I have a BackTrack5 r3 installed on VMware. As you see below I have internet access in it : root@bt:~# ping www.google.com PING www.google.com (173.194.70.105) 56(84) bytes of data. 64 bytes from fa-...
0
votes
1answer
1k views

Why is my /etc/apt/sources.list set to squeeze when I have debian wheezy?

I have set up a few new debian boxes which were installed with debian wheezy (7.1). I set them up and upgraded to the current stable release: $ cat /etc/debian_version 7.6 If I look at my etc/apt/...
0
votes
1answer
23 views

Finding the latest version of package which doesn't require upgrading libc (on Debian)

When I try to upgrade packages using aptitude -t wheezy-backports, they often require newer libc than is installed. Proposed solutions remove hundreds of packages. Is there a way to request only the ...