Questions tagged [aptitude]

Alternative package manager for Debian and derivatives which offers an ncurses based text-mode user interface (TUI) and mighty search patterns besides a command-line interface similar to `apt-get`'s command-line interface.

Filter by
Sorted by
Tagged with
256
votes
10answers
107k views

What is the real difference between “apt-get” and “aptitude”? (How about “wajig”?)

I know that both apt-get and aptitude are command line package management interfaces on Debian derived Linux, with different options, but I'm still somewhat confused. Under the hood, aren't they ...
16
votes
3answers
29k views

What packages are installed by default in Debian? Is there a term for that set? Why some of those packages are `automatically installed` and some not?

Is there a term to refer to the subset of packages that is automatically installed by Debian distribution? I though that it had something to do with packages priorities, but it doesn't seem to be the ...
7
votes
2answers
829 views

Is there a command that outputs ONLY the packages explicitly installed by the user? (ubuntu/debian)

I have tried searching for this but there seems to be no command that can output a list of packages (ideally in Ubuntu) that I have installed, not including any dependencies.
11
votes
1answer
20k views

How to install some packages from “unstable” Debian on a computer running “stable” Debian?

On a computer running "stable" Debian, when trying to install a package which is in the unstable list on the Debian web site using the aptitude install <package>/unstable command, I get output ...
4
votes
1answer
1k views

relocation error using sudo apt

my system arch is amd64, i installed i386 as foreign arch and ran sudo apt dist-upgrade but after it finished, i keep getting this error while using apt: apt-get: relocation error: /usr/lib/...
50
votes
3answers
74k views

Can I rollback an apt-get upgrade if something goes wrong?

Is there a way, before starting an aptitude upgrade or apt-get upgrade, to set up something so that you can "easily" rollback your system to the "apt" state it was before the actual upgrade, if ...
33
votes
1answer
8k views

How does apt-get really work?

Okay, I understand how I may use apt-get {install|upgrade|remove} mypackages to install, upgrade, or remove binaries as well as their configuration data files and dependencies (actually, remove will ...
13
votes
3answers
4k views

How can I reliably “hold” a package in Debian?

I have a package in Debian that has been manually patched (not ideal, I know) that I must hold at its current version so upgrades don't overwrite the patched changes (I will manually inspect and apply ...
5
votes
1answer
700 views

Make debian “apt” (new apt-get / aptitude frontend) cache .deb files in '/var/cache/apt/archives/'

On a current (2018-06) Debian sid, installing .deb packages via apt-get or aptitude or synaptic caches the downloaded packages in /var/cache/apt/archives: # rm -f /var/cache/apt/archives/nano_* # ...
4
votes
1answer
356 views

How can I search for packages depending on a exact package?

I'm experimenting a bit with aptitude search terms and finally discovered how to do search on dependencies, which is: aptitude search '?depends("searchterm")' The only problem that I've found is... ...
1
vote
1answer
285 views

is there a way to use regexp with aptitude?

I use an alias to find new packages whenever I update the package index. [$] alias aptn aptn='aptitude search '\''~N'\' Now while this works, I also get a bunch of -dbgsym packages which come ...
1
vote
2answers
2k views

How to access local repository mirror?

I am trying to access a local apt mirror which is on a usb drive. The file tree on the drive is /apt-mirror /mirror /archive.ubuntu.com /dists /pool /skel ...
15
votes
2answers
660 views

Why do package names contain version numbers?

While working with Ubuntu and other Debian-based distros, I've noticed that packages in the software repos often contain the major version number. For example, Apache: apache2 Tomcat: tomcat7 PHP: ...
7
votes
2answers
4k views

How to run a command after apt-get upgrade

Recently I came across the nice checkrestart tool, that checks if running processes use an outdated version of a recently updated library and would need a restart to load them with the updated lib. At ...
9
votes
4answers
29k views

Removing broken packages

Recently in a bout of frustration with getting phpmyadmin setup, I decided to start from scratch. Unfortunately, during the uninstall phase, I was prompted with the root password for mysql which I ...
5
votes
1answer
7k views

How to remove a package on a debian-based system WITHOUT removing dependencies? [closed]

I'm running Linux Mint, a Debian-based distro, and I want to remove a package WITHOUT removing its reverse dependencies; or I want to target the removal of one package without removing anything else. ...
2
votes
3answers
5k views

How to download a package and its dependencies with aptitude?

I am trying to download some debian packages and their dependencies in a directory. I tried using the command aptitude download <package_name> it downloaded the package without its dependencies....
1
vote
1answer
210 views

Debian: The following packages have been kept back… odbcinst AND odbcinst1debian2

PROBLEM: I've had these two packages held back for weeks now and I can't get rid of them, The following packages have been kept back: odbcinst odbcinst1debian2 look here: [10:53:34][kristjan] ~ ...
1
vote
1answer
63 views

regexp with aptitude part 2

I had asked about regexp with aptitude here and that worked beautifully. Now have i386 packages also in the midst. How do I make sure that i386 packages do not come into the picture. I tried the ...
8
votes
1answer
1k views

Debian: How to delay configuration when installing/upgrading?

One of my Debian systems is rarely upgraded. So when it is time to upgrade, there are loads of packages. Right now I basically have to monitor the upgrade, because every 50 packages or so there is a ...
4
votes
1answer
847 views

Apt/Aptitude: how to filter packages that are impossible to install?

Especially when running Sid, there are many packages that become non-installable as the dependencies change ABI versions, or the dependencies themselves may have been dropped. It'd be good to know how ...
3
votes
1answer
4k views

Is there apt-get for windows?

If it was windows machine that had no internet connection, what I would do is downloading the installers/programs on another computer, putting them on a portable media, copying them on the ...
2
votes
1answer
790 views

Why does this apt-get remove have such deep consequences?

I wonder if someone can help me sort through my situation. So I'm keeping my system up-to-date today using the documented Debian process: sudo apt-get update sudo apt-get dist-upgrade The latter ...
2
votes
1answer
3k views

How to pull dependencies for package/testing from testing

Trying to install a newer version of libav-tools from testing to my otherwise debian-stable installation. I have testing in my sources.list and my preferences look like: Package: * Pin: release a=...
1
vote
0answers
818 views

Installing Nvidia Drivers the Debian way would uninstall dozens of packages

I just set up a fresh Debian (Jessie/8), set the APT Sources to fetch testing packages (main, contrib, non-free). Now I wanted to install drivers for the installed Nvidia GeForce 9600 and I tried ...
1
vote
1answer
816 views

Aptitude - uninstalling autoinstalled packages that are recommended by other packages

I am running a Debian Wheezy install on a system where space is tight. Hence, I've turned off the "Automatically install recommended packages" option. The problem occurs if I install a package which ...
0
votes
0answers
499 views

apt-get or aptitude [duplicate]

Possible Duplicate: What is the real difference between “apt-get” and “aptitude”? (How about “wajig”?) I'm new in Linux (Ubuntu) world. When I need to install ...
0
votes
0answers
45 views

Unmet broken dependencies debian

I know there a lot of such question were asked, but no one answer helped me. Here is an error I beat with for few hours already. Here is my source.list I tried apt-get clean sudo apt --fix-broken ...