Questions tagged [aptitude]

Alternative package manager for Debian and derivatives which offers an ncurses based text-mode user interface (TUI) and mighty search patterns besides a command-line interface similar to `apt-get`'s command-line interface.

Filter by
Sorted by
Tagged with
0
votes
1answer
20 views

What is the difference among apt-cache policy, apt-cache show, and apt-cache showpkg?

Note: I found this QnA addressing apt-cache show v/s apt-cache showpkg but couldn't find any QnA addressing the difference among all the three options i.e. policy, show, & showpkg. For example, ...
0
votes
1answer
14 views

Difference between apt(itude) (auto)clean, …

After understanding that apt is somehow an expansion of apt-get or an aggregation of several apt-… commands, I'm still confused how the different commands (especially apt, apt-get, aptitude and the ...
3
votes
1answer
37 views

How to explain apt dependencies that are not autoremoved?

The package libudev1:i386 is installed on my system. $ dpkg -l | grep libudev1:i386 ii libudev1:i386 245.4-4ubuntu3.2 i386 libudev shared library It won't get autoremoved. $ sudo apt autoremove ...
0
votes
0answers
17 views

could not install git via apt-get in debian 10 [duplicate]

/tried commands with sudo/ apt-get update & upgrade apt-get install git apt-get -f install git bash: aptitude: command not found
0
votes
0answers
57 views

aptitude update error: Fatal Python error: initfsencoding

This just happened, I was running Aptitude to check for updates when it gave me this error: sudo apt-get update Hit:1 http://us.archive.ubuntu.com/ubuntu eoan InRelease ...
1
vote
1answer
26 views

How to run Aptitude's TUI with limit pattern sent as an argument?

I want to have a command on Debian (Sid) that launches aptitude's TUI with a limit pattern defined within the command itself as an argument. Otherwise I have to write the pattern every time by ...
1
vote
0answers
66 views

Undo last operation in aptitude

While I was resolving some dependencies in aptitude, I miss-clicked and chose an option I didn't want. Quite a few packages were installed and even more were removed. I can see what happened in /var/...
1
vote
2answers
87 views

How to detect a Debian package that is no longer needed after an upgrade of its previously dependent package?

Let's say, there is a Debian package named Foo, whose version 1.1.1 depends on a package named Bar. Imagine that there is a newer version of Foo==1.1.2, which doesn't depend on Bar anymore. After an ...
0
votes
2answers
3k views

Error while installing or upgrading with apt

I was trying to upgrade debian 9 to 10 but when I tried to run sudo apt-get update, sudo apt-get upgrade and sudo apt-get full-upgrade, they all got this error message: optiplex@optiplex:~$ sudo ...
2
votes
2answers
72 views

Verbosity in aptitude command-line mode via its configuration file

This is related to a question I asked about 3 years ago. Since then things have changed a bit apparently. One of the obvious ones is that aptitude itself has changed from whatever version it was to ...
0
votes
1answer
235 views

Error when apt update and removing ppa

I am trying to test PHP 7.0 installation on vagrant using Ansible and get this error: TASK [php-cli : Install php7.0-cli package] **********************************************************************...
1
vote
0answers
82 views

libc6 (dependency of a package I'm trying to install) requires newer kernel, I can't upgrade though

There. It occured multiple times to me already, that packages I tried to install (e.g. ngircd or make) have a dependency called libc6, which required kernel version 3.2 however. I cannot upgrade my ...
3
votes
2answers
202 views

Having trouble successfully installing the DDD debugger from Debian Stable (Buster)

Having trouble successfully installing the DDD debugger from Debian Stable (Buster) When I try to install ddd, it fails to install with errors: robert@pip2:/tmp$ sudo -l [sudo] password for robert: ...
1
vote
1answer
62 views

How to prevent APT from keeping packages I didn't install?

When I install packages via apt-get install <package> or aptitude install <package> and remove them afterwards with apt-get purge <package>; apt-get autoremove --purge, my system is ...
2
votes
1answer
890 views

apt install: Note, selecting 'foo' instead of './foo_x.y.z_amd64.deb' - what it means?

I searched the web but could not find an answer to: why apt install ./*.deb writes Note, selecting x instead of './x_something.deb' e.g Note, selecting 'phantomjs' instead of './phantomjs_2.1.1+...
1
vote
1answer
975 views

How to Add Something Extra to a Busybox System?

So suppose that I have Busybox installed on an embedded device (e.g a router) and need to add something extra to it (a package). Now suppose that now I need to install a package to it besides using ...
0
votes
0answers
55 views

Unmet broken dependencies debian

I know there a lot of such question were asked, but no one answer helped me. Here is an error I beat with for few hours already. Here is my source.list I tried apt-get clean sudo apt --fix-broken ...
1
vote
1answer
817 views

Debian: The following packages have been kept back… odbcinst AND odbcinst1debian2

PROBLEM: I've had these two packages held back for weeks now and I can't get rid of them, The following packages have been kept back: odbcinst odbcinst1debian2 look here: [10:53:34][kristjan] ~ ...
1
vote
0answers
511 views

W: Failed to fetch http://deb.debian.org/debian/dists/jessie-updates/main/binary-amd64/Packages 404 Not Found [IP: 151.101.140.204 80] [duplicate]

I'm trying to get a project running locally on Deepin. The project relies on node 6.10, I understand that it's an old version but it works. When the Dockerfile tries to run the sudo apt-get update, it ...
0
votes
0answers
121 views

can't install libboost-python in debian

I think something is wrong the package manager I use this command to install libboost-python sudo aptitude install libboost-python1.62.0 I get the following error that later suggests removing ...
1
vote
0answers
503 views

wine unmet dependencies:

I believe that at one point i uninstalled wine however when i try to install wine again i get this: ~$ sudo apt install --install-recommends winehq-stable Reading package lists... Done Building ...
0
votes
1answer
32 views

how to view installation information for package to be installed by apt [duplicate]

For ubuntu or debian, for installed package, I can use dpkg -L package to view where files were installed by the package. For a package is going to be installed but yet installed, how can I foresee ...
0
votes
1answer
47 views

Debian Sid - Stay some weeks behind current roll

I'm currently on Debian Sid. Is there a way to only update packages that were released, e.g. at least one week ago? Could I schedule an update and then only upgrade two/four weeks later? The intent ...
1
vote
1answer
907 views

Failure to install aptitude using apt because of missing dependency even though dependency is installed

When trying to install aptitude with apt this error is thrown: Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may ...
2
votes
0answers
102 views

How to check If my PC was exploited after apt exploit? [closed]

I used sudo apt-get update sudo apt-get upgrade before I read https://www.debian.org/security/2019/dsa-4371 Is there a way to check if my PC got exploited/hacked/virused ?
0
votes
1answer
190 views

apt ignores virtual package provided equivs-created package

I want to install pdftk on my development machine where I have installed (multiple versions of) Java with SDKMAN!. In order to fulfill the dependency on default-jre-headless of pdftk-java, I created a ...
5
votes
1answer
645 views

How does apt/dpkg choose which real package is installed when a virtual package is specified as a dependency?

e.g. if package specifies Depends: www-browser How does apt/dpkg decide which real package will be installed?
0
votes
1answer
3k views

An upgrade from 'zesty' to 'bionic' is not supported with this tool. Tried official links, no success

I tried following https://help.ubuntu.com/community/EOLUpgrades/Feisty link, but without success. I need to upgrade my system to 17.10(EOL) from 17.04. When running following command I am getting an ...
0
votes
1answer
499 views

32 bit aplications aren't installing properly on 64-bit

Ok, so I have been trying to get this to work for a while and i don't know exactly what is going on so I will just show what happens: aptitude install wine32 Note: selecting "wine32:i386" instead of ...
0
votes
1answer
154 views

omitting icon files from downloading updates of Debian 9.5 amd64 package lists?

situation when I am updating Debian 9.5 amd64 (stable, backports, test, unstable) package lists using APT or APTITUDE, the download size of the update is, as of writing this post, cca 60 MB with half ...
2
votes
1answer
677 views

apt wants to autoremove automatically installed recommended packages despite settings in apt.conf.d

When I'm running apt upgrade, it suggests me to auto-remove several dozens of essential packages using apt autoremove. They include busybox, bluetooth and alsa-utils among other important packages ...
4
votes
1answer
2k views

relocation error using sudo apt

my system arch is amd64, i installed i386 as foreign arch and ran sudo apt dist-upgrade but after it finished, i keep getting this error while using apt: apt-get: relocation error: /usr/lib/...
1
vote
0answers
64 views

Configuring default output for Aptitude package search

In most flavors of Linux that I've used, the output for apt search does not include the current state display but in Linux Mint (Sylvia) it is displaying and I would like to remove it because it ...
1
vote
0answers
1k views

Cannot install libgstreamer-0.10 [duplicate]

I' using Debian 9 Cannot install libgstreamer-0.10.so I tried sudo apt-get install libgstreamer0.10-0 Reading package lists... Done Building dependency tree Reading state information... Done ...
1
vote
1answer
48 views

Cannot start Cutegram

I installed Cutegram When I start it I get ./cutegram: error whiel loading shared libraries: libgstreamer-0.10.so.0: cannot open shared object file: No such file or directory I use Debian 9. I tried ...
0
votes
1answer
2k views

How do I fix this “Permission denied” error I get every time I execute aptitude?

When I execute, for example, aptitude search ruby2.5, I get the following errors as first lines of the output. (It's the same error message repeated twice.) E: Error saving configuration file - ...
0
votes
0answers
25 views

Aptitude reacts very slowly when fixing unresolved issues

When Aptitude's bottom status line permanently states [1(0)/...] Resolving dependencies (i.e. Aptitude can't find a solution given the current constraints), changing the status of any package (e.g. ...
-2
votes
2answers
634 views

Dependency problems Linux Debian undetectable broken packages

I am just trying to do an upgrade (sudo apt upgrade), but it fails with error E: Broken Packages. Doing dpkg -l | grep broken and dpkg -l | grep held returned nothing. My sources.list looks as follows:...
0
votes
1answer
760 views

GPG error in Debian Lenny

I got error after aptitude update command: Err http://archive.debian.org lenny/non-fre Packages 404 Not Found [IP: 209.87....
-1
votes
1answer
169 views

Can’t install any software from old Debian

Looks like I can't install any software since I run Old Debian Lenny. Is it possible somehow change installation sources for system? UPD I have updated my sources, but still can't install software: ...
7
votes
1answer
1k views

Make debian “apt” (new apt-get / aptitude frontend) cache .deb files in '/var/cache/apt/archives/'

On a current (2018-06) Debian sid, installing .deb packages via apt-get or aptitude or synaptic caches the downloaded packages in /var/cache/apt/archives: # rm -f /var/cache/apt/archives/nano_* # ...
1
vote
0answers
29 views

aptitude display current pkg repo and update pkg repo - default grouping method?

So trying a few things, mainly from here, https://aptitude.alioth.debian.org/doc/en/ch02s05s01.html#secDisplayFormat I wasn't able to get an error-free change to aptitude that displayed the repo of ...
0
votes
1answer
1k views

How to fix - Failed to fetch

Trying to install vim-gnome in Raspberry Pi3. Finally got error: E: Failed to fetch http://mirrordirector.raspbian.org/raspbian/pool/main/p/perl/libperl5.20_5.20.2-3+deb8u8_armhf.deb: 404 Not Found [...
2
votes
1answer
501 views

How do I tell aptitude that a package was installed manually?

I installed a package (don't remember which one but that shouldn't be too important) and needed "the real" ffmpeg so I purged the debian package for ffmpeg and installed the other version manually. ...
0
votes
1answer
412 views

unresolved dependencies (held back packages) seemingly unfixable

I was having some problems with LibreOffice Draw, and since I couldn't find a solution for it I decided to uninstall and do a clean install. If I recall correctly This is what I've used: sudo apt-get ...
1
vote
1answer
189 views

Dependency issues when building software [closed]

When I build binaries from source provided by a third party, there is pretty much always an issue with the dependencies versions. I mostly use Debian (Sometimes Ubuntu) and the repositories only ...
1
vote
1answer
132 views

Essential packages and multiple architectures on Debian

I have a working OS that runs 64 bit kernel but I want to use 32 bit versions of most packages because of limited memory on the machine. I need to keep some 64 bit drivers though as there is no 32 bit ...
8
votes
5answers
39k views

How to install a specific version of GCC in Kali Linux?

This question appears to be addressed properly in several questions and other places easily found with Google, but I don't find the solution satisfactory for the reasons explained below. But just for ...
2
votes
1answer
67 views

aptitude, /etc/alternatives/aptitude, symbolic linking and aptitude-curses

Sometimes when I am running aptitude I run into problems (don't get me wrong, I love aptitude especially the CLI client, I have always wondered why /etc/alternatives/aptitude exist. I do know what /...
1
vote
1answer
34 views

Install partly downloaded updates in Debian

From time to time I update my Debian by running: aptitude update && aptitude full-upgrade but before running it I often forget or deliberately skip running aptitude clean which removes old ...

1
2 3 4 5