Questions tagged [apt]

For questions about the use, design, function etc. of APT (Advanced Packaging Tool), the standard software package management system for Debian and its derivatives.

Filter by
Sorted by
Tagged with
0
votes
0answers
6 views

How to ensure that a package is correctly installed/updated after “post-installation script: subprocess returned error exit status 1”

After upgrading to Debian 10.7 I got this error, possibly due to lack of storage space: Error while installing package: installed initramfs-tools package post installation script: subprocess returned ...
0
votes
0answers
12 views

The apt update in deepin 15.11 failed

I use the deepin 15.11 and change the /etc/apt/source.list to deb [by-hash=force] http://mirrors.aliyun.com/deepin lion main contrib non-free according to the alibaba's official guide,but when I use ...
1
vote
1answer
35 views

How to list dependent packages (reverse dependencies) for a system I don't have installed?

I know I can get a package's reverse dependency list with apt-cache rdepends <pkg> However, this shows dependencies on the system I run it on. How could I find out dependent packages for a ...
0
votes
1answer
21 views

What does the version string from dpkg/aptitude/apt-show-versions mean?

When I do apt-show-versions samba on my Debian machine, I get something like samba:amd64/buster 2:4.9.5+dfsg-5+deb10u1 uptodate Comparing this to the samba versions, which you can find at the ...
0
votes
0answers
29 views

Error when installing apt package

When I try to install any package using apt-get it gives this error: /usr/bin/chage: error while loading shared libraries: libaudit.so.1: cannot open shared object file: No such file or directory ...
0
votes
1answer
10 views

Install libmpfr-dev 4.10+ with apt

Heyo all, I've created a from-scratch linux distribution, or more specifically just the bootstrapper. This works flawlessly, but gcc wants MPFR 4.10+ on your system do download. Now this is fine for ...
0
votes
1answer
39 views

How to install libicui18n.so.58 on Ubuntu 18.04?

While running my application on Ubuntu 18.04, it fails. Using the trace command, I found that one library is missing on my machine: user@user-Box:~/Debug$ strace -o log -f ./test_project ./...
0
votes
1answer
51 views

pigz: abort: write error on <stdout> (No space left on device)

My system: toor@suey:~$ cat /etc/os-release PRETTY_NAME="Kali GNU/Linux Rolling" NAME="Kali GNU/Linux" ID=kali VERSION="2020.4" VERSION_ID="2020.4" ...
0
votes
2answers
46 views

How do you make a apt or .deb Package for debian? [closed]

So lately I've been trying to find a way to make an apt or a .deb package to make it easier for people to install and use packages without using the commander line but, to even start doing that I need ...
0
votes
1answer
25 views

Can't install deluge on Debian sid

Everytime I try to install Deluge on my system it throws this error Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed....
0
votes
3answers
49 views

How and where to find out details on which directories and files a package effects?

In the context of adding capabilities to BaseX,I can see some information about a package: nicholas@mordor:~$ nicholas@mordor:~$ apt show basex Package: basex Version: 9.0.1+ds-1 Priority: optional ...
0
votes
1answer
40 views

How can I publish a deb package?

I don't know much about packaging and it took me a a week to create a working deb for my software. Now I need a way for people to install it and I don't want to just create a download link for the deb....
0
votes
1answer
22 views

How to rename a local APT repository?

I follow the steps in this post to create a custom repository, but I want to rename it. I can't find any way to do it. Can you please help me?
0
votes
0answers
37 views

unmet dependencies error when I try to compile and install ffmpeg with apt-buid

I'm trying to use apt-build install ffmpeg to install a compiled from source version of ffmpeg rather than apt in order to have binaries optimized with machine specific instructions, rather than just ...
0
votes
2answers
30 views

Messed my apt repo list, probably linked to language packages

I am having trouble updating pop os because my apt repo list appear not to be working correctly. Probably linked to language package issues, but I don't know how to get rid of this errors. When I do #...
0
votes
0answers
29 views

debian downgrade nvidia driver?

I currently have version 450 installed, but I would need to downgrade to version 440. I have many (if not all) version 440 .deb files, but it gave me trouble even trying to remove all installed ...
1
vote
1answer
26 views

Why does a 400er pinning backports package get updated?

So this is my apt policy: apt policy Package files: 100 /var/lib/dpkg/status release a=now 400 http://deb.debian.org/debian bullseye/main amd64 Packages release o=Debian,a=testing,n=...
0
votes
1answer
61 views

Update Intel-microcode with amd CPU

Why does apt propose an update of Intel-microcode on my computer with an AMD cpu (Ryzen 7 2700X), and should I do this update?
-3
votes
1answer
72 views

Kali Linux update error with sources.list

How to fix this issue? Err:23 http://kali.cs.nctu.edu.tw/kali kali-rolling/main amd64 libglib2.0-dev amd64 2.66.1-2 Connection timed out [IP: 140.113.17.5 80] Fetched 9,463 kB in 19min 26s (8,118 B/s) ...
0
votes
1answer
30 views

Compiled program is replaced by repo version overnight

Vim version changes without opening a new terminal, without restarting the computer. Simply, the next day my computer takes the repo version, which has been removed by apt before. I've compiled vim ...
0
votes
1answer
26 views

Unable to Update R on Linux Mint 18

I originally posted this on the Stack Overflow site. I understand that it is inappropriate to ask the same question on multiple sites, but they were unable to help and I was told to come here. I am ...
0
votes
0answers
53 views

Pop OS 20.04 Unable to update and upgrade

For the past few days whenever I try to update I get the following output: user@pc-os:/etc/apt$ sudo apt-get -o Acquire::ForceIPv4=true update Get:1 http://ppa.launchpad.net/system76/pop/ubuntu ...
0
votes
1answer
13 views

Debian buster arm64 apt return error message, package installation works anyway

I'm running a debian linux on arm64 hardware, just did a dist-upgrade from stretch to buster and everything seems to be working except I'm systematically getting the following message: Error ...
0
votes
1answer
17 views

Muon is stuck on lubuntu cosmic. How do I get off this dead end?

Muon is using cosmic. http://security.ubuntu.com/ubuntu/dists/ does list cosmic. I do not see any reference to cosmic in the GUI but, I get an error saying it cannot find the file in the cosmic ...
0
votes
2answers
102 views

apt-get update failed?

Get:1 https://download.docker.com/linux/ubuntu focal InRelease [36.2 kB] Err:1 https://download.docker.com/linux/ubuntu focal InRelease The following signatures couldn't be verified because the ...
0
votes
1answer
16 views

Any HTTPs mirrors for ubuntu repos

Is there any reputable mirrors for archive.ubuntu.com and security.ubuntu.com that allow HTTPS? I want encryption for my updates.
0
votes
1answer
48 views

What's the difference between `+deb10u1` and `+deb10u2` packages returned in the output of `apt-cache show`?

Searching for libldap2-dev using apt-cache show, information for the following packages are returned in the output: 2.4.47+dfsg-3+deb10u1 and 2.4.47+dfsg-3+deb10u2 What's the difference between +...
0
votes
2answers
50 views

installed wrong libc6 package and broke system

Background I was attempting to upgrade my libc6 version in a "not" nice way. It all started with me trying to update my MariaDB from 10.1 to 10.2. I somehow then managed to find out that ...
0
votes
0answers
17 views

How can I install NPM and NodeJS correctly on iOS using cURL or apt-get

So I’m using NewTerm (Terminal for Jailbroken Devices) I’ve managed to install Git and Curl using apt-get, and I’ve successfully cloned a node.js project into my files (Which I also have access to) I’...
1
vote
2answers
58 views

how to downgrade apt packages to versions in archive?

I just noticed that the focal-proposed repository was included in my sources.list on ubuntu 20.04, although that doesn't seem to be recommended. After disabling it, the command apt-show-versions | ...
0
votes
1answer
30 views

Reinstalling all packages installed from an old repository that exist in a new repository (Apt)

My base system is Debian and came with ftp.debian.org in the sources.list file. I have since added the latest Ubuntu repositories to my sources.list file and taken out the original Debian one. ...
0
votes
0answers
26 views

Error while Installing Openrazer-meta and polychromatic in Xubuntu

I have an Razer mouse, I want to configure it using UBuntu , but I am not able to do that because of these errors. sudo apt install openrazer-meta Reading package lists... Done Building dependency ...
1
vote
1answer
37 views

Cron job doesn't run

I have a cron job which should run once a week to update, upgrade and autoclean apt, but it never seems to work, at least not as far as I can tell. This is apparent because running sudo apt-get ...
3
votes
2answers
527 views

0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded. How can I upgrade that 1 package, or at least know which is?

I have tried many different solutions found around this and other websites, such as sudo apt update && sudo apt upgrade sudo apt list --upgradeable sudo apt full-upgrade sudo apt dist-upgrade ...
0
votes
1answer
45 views

Apt is attempting to remove sudo package [closed]

My machine: Distributor ID: Ubuntu Description: Ubuntu 20.04.1 LTS Release: 20.04 Codename: focal Hello, I'm just trying to run sudo apt-get install qemu-kvm libvirt-daemon-system libvirt-...
0
votes
1answer
58 views

Kali Linux not Updating

I am trying to update my kali linux version, but whenever I try to execute sudo apt update command, it gives me the following output: Ign:1 http://ppa.launchpad.net/micahflee/ppa/ubuntu groovy ...
0
votes
2answers
56 views

Error: Unable to correct dependencies

OS and version : Debian 8 Arch : 64 bit I am trying to update packages but I get the following error: # apt-get upgrade Reading package lists... Done Building dependency tree Reading state information....
0
votes
1answer
51 views

No binary after python3-pygments

I need pygmentize for my Latex document. Since minted seems to work only with the python3 version, I want to install python3-pygments. (I'm using Ubuntu 16.04.7 LTS) Now that seems to work at first, ...
0
votes
1answer
20 views

NPi i.MX6ULL Linux SBC - Difficulty Finding Linux Headers

I am currently using a NPi i.MX6ULL Dev Board Linux SBC. I am trying to get SPI functionality up and running by following the tutorials that are on: https://wiki.seeedstudio.com/NPi-i.MX6ULL-Dev-Board-...
0
votes
1answer
61 views

How do install the Debian package manager (dpk and apt) in my custom Linux distribution? [closed]

I've been already made a bootable Linux-based OS using the kernel, busybox only, and testing it in the QEMU emulator is successful. The next step I need is to install dpkg and APT (Debian package ...
0
votes
1answer
103 views

apt doesn't work on kali linux 2020.3 [duplicate]

kali@kali:~$ sudo apt update Get:1 http://kali.download/kali kali-rolling InRelease [30.5 kB] Get:2 http://kali.download/kali kali-rolling/main amd64 Packages [16.6 MB] Err:2 http://kali.download/kali ...
-1
votes
1answer
209 views

I'm not able install deluge on my Kali

Greetings! I'm trying to install a torrent client to my Kali Linux. The deluge apt isn't included in Kali's official repositories. So, I tried: add-apt-repository ppa:deluge-team/stable Deluge 2.0 ...
0
votes
0answers
62 views

Samba Won't Install Apt Unmet Dependencies — Ubuntu 20.04

Please help. I am receiving the following error when I try to install samba on my Ubuntu 20.04 server. Here is the error: The following packages have unmet dependencies: samba : Depends: python-...
0
votes
1answer
84 views

phpmyadmin : Depends: php-phpmyadmin-sql-parser (< 5~~) but 5.4.0-1 is to be installed

After dist-upgrade of my debian, from 10.5 to 10.6 I have this small problem I cannot upgrade this package The following packages have been kept back: php-phpmyadmin-sql-parser I thought to install ...
0
votes
0answers
62 views

apt install broken held packages; no broken packages found

I recently installed new Debian (10.6.0) on my pc. After installing the OS I naturally wanted to download few packages. However whenever I try to run apt install <package name> it ends with E: ...
0
votes
1answer
35 views

Debian Stable upgrade to Debian Testing

Ive followed the instructions here (https://wiki.debian.org/DebianTesting) now i have the testing branch active and i pulled a lot of new stuff, so far so good. Unfortunatelly, i somewhat now lost ...
1
vote
0answers
23 views

unattended-upgrades is not running

I have a Debian 10 server on which unattended upgrades do not work. The system timers are overwritten as follows: /etc/systemd/system/apt-daily.timer.d/override.conf: [Timer] OnCalendar= OnCalendar=*-*...
0
votes
1answer
39 views

How to search for a file from the list of installed files of each package installed in the system

Synaptic has the option to search from different sources (Package name, description, name and description, etc)... But if you have a package installed in your system, Synaptic can show you what files ...
3
votes
1answer
166 views

Syntax error /etc/apt/apt.conf.d/listchanges.conf:7: Extra junk at end of file

My server is hosted at OVH, and runs debian Buster. I ran apt-get update and apt-get upgrade last week without visible issue. But now I get an error message when I try to run it again: sudo apt-get ...
3
votes
1answer
86 views

Update version of Kali Linux to 2020.3 from 2020.1

I am trying to update my Kali version to 2020.3 from 2020.1 as I have many important files and tools installed, but I was not able to do it. I consulted this site https://www.kali.org/docs/general-use/...

1
2 3 4 5
51