Stack Exchange Network

Stack Exchange network consists of 175 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [apt]

APT (Advanced Packaging Tool) is the standard software package management system for Debian and its derivatives.

4
votes
0answers
83 views

cannot install in linux mint rebecca

I have a problem to install new packages/software in linux mint rebecca. My OS: > userubuntu@Oracle ~ $ uname -a Linux Oracle 3.13.0-37-generic #64-Ubuntu SMP Mon Sep 22 21:30:01 UTC 2014 i686 ...
3
votes
0answers
57 views

Why did apt not prompt me to confirm installing dependencies?

Usually, installing a package with dependencies that aren't currently installed will make apt confirm whether this is desired before proceeding to install: $ sudo apt install gnome-terminal Reading ...
3
votes
0answers
2k views

How to install Gnome Shell Extension “Night light slider” & “Pause night light” with apt

If i type "night..." into my global search window, software recommends the 2 packages: Night light slider and Pause night light. How do I install this packages with apt? I have done some apt search ....
3
votes
0answers
146 views

add an apt repository only for few packages (or mirror them)

I'd like to install a couple of packages available from an unofficial repository, problem is the repository share many packages and an apt upgrade would replace many of the official. I know about ...
3
votes
0answers
755 views

Use local (on disk) mirror for debootstrap

I'm trying to debootstrap from local files. I followed this guide. My host machine runs debian that I installed with : debootstrap stable /mnt http://httpredir.debian.org/debian/ What I did: mkdir ...
3
votes
0answers
37 views

Is it possible to pin a local package-repo?

I bound the folder /var/cache/apt/archives as a local package-source in my system. Is it possible to pin them? $ apt-cache policy | grep archive 500 file:/var/cache/apt/archives/ ./ Packages I ...
3
votes
0answers
324 views

How to set up keyserver and port permanently

I have corporate firewall which blocks default port for apt-key. So each time I add PPA, I have to interrupt gpg (which hangs) and receive missed keys manually setting port 80. I created script which ...
3
votes
0answers
31 views

Why do the outputs of those apt invocations differ?

When running apt-get dist-upgrade it shows, that there are zero packages that are not upgraded. When I run apt-get autoremove it informs me that there are two packages that can be upgraded. To me this ...
3
votes
0answers
741 views

How to remove the entire ubuntu-desktop package?

I use linux Mint 18 cinnamon. While I am working I always have a lot of different softwares running and I wanted to try Unity to see if the left-side bar would be more confortable. So, as I found ...
3
votes
0answers
214 views

rdepends stops on virtual packages

I am working to create an offline repository for a system that does not have internet access. One of the first packages I am downloading for this system is the apt-offline package. I am using the ...
3
votes
0answers
3k views

dpkg-query listing package that is not installed

I installed Chrome via dpkg by downloading the deb file and installing it. I later uninstalled and removed it. However I'm now seeing this: $ dpkg-query -W google-chrome google-chrome $ dpkg-query -...
3
votes
0answers
144 views

Generate apt-offline bundle for use across many machines

I'm trying to use apt-offline to install packages on many machines (using ansible), so I need to avoid generating a machine-specific signature file (e.g. sudo apt-offline set debian-update.sig --...
3
votes
0answers
735 views

apt repository not showing in apt-cache policy, why?

I have a private mini-dinstall based repository. sources.list.d has an entry for it, like https://user:pass@my.host/repos/ tools/ I have installed apt-transport-https and I can happily install ...
2
votes
0answers
42 views

Renaming trusted.gpg to trusted.gpg-broken

I ran a fresh install of Debian stretch 9.8.0 and all was well. I then ran sudo apt update and I get an output which hits the ftp.debian.stretch server for the update thing is it tells me unable ...
2
votes
0answers
282 views

Debian Stretch apt-get update failure resolving 'ftp.de.debian.org'

Since I have updated debian from jessie to stretch apt-get update fails. Error Message: Err:1 http://ftp.de.debian.org/debian stretch InRelease Temporary failure resolving 'ftp.de.debian.org' ...
2
votes
0answers
85 views

Getting exit code 139 while running UCF (during dpkg postinstall)

I got stuck while trying to update two specific packages (e.g. "samba-common" and "openssh-server", for completion's sake), throwing the following error on the terminal: subprocess installed post-...
2
votes
0answers
109 views

apt-get says apparmor is installed, but the Docker kernel compatibility check says it's not

I'm in the process of installing Docker for the first time. In the official documentation, at this point, it says I should download and run a script (check-config.sh) to test whether my system has ...
2
votes
0answers
464 views

Xfce broked / network not working

Well. Some days ago i made an 'apt-get install virtualbox' on my kali linux 2.0. I use xfce. apt-get downloaded like 300mb of files and installed about 1gb. Everything ok. Then i restarted my ...
2
votes
0answers
1k views

Debian package `vlc-data` causes `error: subprocess paste was killed by signal (Broken pipe)`

I am running Debian 9.1. There is a package that isn't upgrading correctly on my system: vlc-data version 2.2.7-1~deb8u1. This is apparently required by libvlccore8. This may well be a continuation of ...
2
votes
0answers
1k views

APT commands stall on `update-initramfs: Generating /boot/initrd.img-4.8.0-58-generic`

Whenever I try to use apt to install or upgrade and also when I try to launch Synaptic Package Manager I get an error that says: E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -...
2
votes
0answers
2k views

“You have held broken packages” when trying to update mysql

I'm tryng to update my mysql (currently at version 5.6) to 5.7 on my Debian 8, however I get this error when I'm reaching the last step. cat /etc/apt/sources.list gives the following: deb http://...
2
votes
0answers
816 views

E: Package 'gstreamer0.10-plugins-bad' has no installation candidate

I turned on the "Video Capture" option in VirtualBox, recorded a video in webm format, shut down the virtual machine and tried to play this video, but I got this error in the Totem video player: An ...
2
votes
0answers
196 views

How can I undo the effects of reprepro update?

On a private Debian package server, I accidentally did a reprepro update without the --restrict option, which updated all packages. Not realizing this, I then created a new distribution and populated ...
2
votes
0answers
2k views

Debian jessie to stretch upgrade problem - “systemd breaks udev'”

I've been trying to upgrade my current Debian Jessie to Stretch. Unfortunately, at apt-get dist-upgrade failed, it returns: Reading package lists... Done Building dependency tree Reading ...
2
votes
0answers
1k views

apt-get: Almost all packages “have no installation candidate”

Note: I am aware that this question appears to be a duplicate of "E: Package '' has no installation candidate", but the only posted answer in that question did not help me at all. I've attempted to ...
2
votes
0answers
54 views

apt-get commands won't return

I am working on a Raspberry Pi running Raspbian, and I think I'm having a problem with my apt-get. The problem originated with a MySQL server I was running. The server stopped seemingly at random, ...
2
votes
0answers
78 views

Automatic deployment of software to Debian

I have been reading about creating my own Debian packages for my own software and deploying them to a apt-get repository that I also can create on my own. The source code for my software is in a Git ...
2
votes
0answers
3k views

pkgProblemResolver::Resolve generated breaks

I am trying to run an apt-get dist-upgrade, but it comes with the following error Reading package lists... Done Building dependency tree Reading state information... Done Calculating upgrade... ...
2
votes
0answers
159 views

Debian Jessie removing leafpad

I have installed Debian Jessie, in short: graphical Installation mostly options set to default software selected to install: Debian desktop LXDE SSH server standard system utilities Then execute ...
2
votes
0answers
726 views

No candidate version found for sudo

When I tried to install sudo in Debian 8.2 via aptitude install sudo I got an error: No candidate version found for sudo. The source list is standart. Here is the Source list: deb http://httpredir....
2
votes
0answers
2k views

Debian 8 apt-get upgrade fails with Failed to fetch … Connection failed

Debian 8 "Jessie". CLI-only home-use server. "apt-get upgrade" always fails with "E: Failed to fetch ... Connection failed ..." errors. "apt-get update" appears to always succeed. Problem has been ...
2
votes
0answers
45 views

Debian jessie mounted pendrive not trusted by apt

I have installed debian jessie from unetbootin pendrive and without network drivers. After booting from HDD, I have added mounted pendrive to apt sources (with file:// prefix). I have two problems. ...
2
votes
0answers
1k views

Including pending update list in motd

How would you include the list and / or count of pending updates in the welcome banner? Eg. username: User password: ***** Hi 'User', welcome on 'localhost' There are 8 pending updates, you need to ...
2
votes
0answers
207 views

What does apt need to be healed of a bad setup?

I made a couple of earlier posts regarding a libssl-dev that, it seemed, was not removable. Some of the replies touched on that there was a problem with apt, and now that someone posted the command to ...
2
votes
0answers
112 views

Can sources.list only be updated by hand?

I'm currently running Linux Mint. I remember that under Ubuntu, whenever a new release comes out, it prompts you with a choice of whether to upgrade or not. It seems like this is not happening in Mint,...
1
vote
0answers
45 views

apt-get update shows after upgrade to stretch still jessie

I upgraded from Jessie to Debian Stretch: cat /etc/issue Debian GNU/Linux 9 \n \l When I run apt-get update it still checks jessie sources: example: Ign:5 http://ftp.debian.org/debian jessie-...
1
vote
0answers
43 views

How can i fix Linux Mint 19.1's GNOME terminal not TAB-autocompleting file names in apt?

I have a .deb package downloaded that i want to install using apt. When i wanted to TAB-autocomplete the following command nothing happened. $ sudo apt install ./pa[TAB] However, when i tried $ ./...
1
vote
0answers
168 views

`apt update` results in consistent “Failed to Fetch” errors for different apt sources

After a recent update from Bionic-based Pop OS! 18.04 to Cosmic-based Pop OS! 18.10, executing apt update always results in Failed to Fetch .... Temporary failure resolving errors for few sites. ...
1
vote
0answers
137 views

Why does apt-file report “The cache is empty” even after running “apt-file update”?

Does anybody know why apt-file reports that the cache is empty even after running apt-file update and apt update? [pop-os ~][I]% apt-file search /usr/lib/android-sdk/tools/bin/sdkmanager E: The cache ...
1
vote
0answers
158 views

wine unmet dependencies:

I believe that at one point i uninstalled wine however when i try to install wine again i get this: ~$ sudo apt install --install-recommends winehq-stable Reading package lists... Done Building ...
1
vote
0answers
242 views

Error when installing GNOME desktop environment on Debian

I was attempting to install virt-manager on my computer. I didn't pay attention and i went ahead with the install. Apparently one of my repositories was down at the time- So almost all of my core ...
1
vote
0answers
54 views

why doesn't appstream have apt pdiff like structure?

Whenever I run apt update especially for those which have DEP 11 and are metadata never have pdiffs. Is this something which needs a feature in appstream (upstream) or it's a feature needed to be done ...
1
vote
0answers
39 views

DEB822 style /etc/apt/sources.list?

I'm trying to upgrade my apt configuration to use the newer DEB822-style format. man sources.list says: It is intended to make this format gradually the default format, deprecating the previously ...
1
vote
0answers
90 views

Install virtual package of specified version

There is a VCS repo that has 2 branches - master and release. There are also 2 Debian packages that are built from these branches - let's say foo for the release branch and foo-master for the master ...
1
vote
0answers
150 views

why is yum's tab completion slow while apt-get's tab completion is fast?

Why is yum's tab completion slow while apt-get's tab completion is fast? I'm not sure but I believe that this may have to do with the fact that for autocomplete yum looks over the internet and apt-get ...
1
vote
0answers
36 views

apt-get ignores --assume-no

I want to upgrade the package base-files without overwriting /etc/issue. So I used --assume-no to disable the modification of config-files, but this is ignored and apt-get asked for input while ...
1
vote
0answers
359 views

Debian : E: Command line option --allow-releaseinfo-change is not understood

Since several days i'm getting the following error on a Debian 8 system from cron: /etc/cron.daily/distupgrade: E: Command line option --allow-releaseinfo-change is not understood I never touched ...
1
vote
0answers
128 views

Debian with “APT::Install-Recommends ”false“;” wants to autoremove packages installed with --install-recommends

right after my system installation, I add "APT::Install-Recommends "false";" to APT settings. Recently I installed "nvidia-driver" package with # apt install --install-recommends nvidia-driver ...
1
vote
0answers
19 views

Are there any downsides of having a 99default_release in /etc/apt/apt.conf.d

Instead of having /etc/apt/preferences file. I made the following - $ cat 99default_release APT::Default-Release "testing"; The following is the /etc/apt/sources.list - $ cat /etc/apt/sources....
1
vote
0answers
30 views

Configuring default output for Aptitude package search

In most flavors of Linux that I've used, the output for apt search does not include the current state display but in Linux Mint (Sylvia) it is displaying and I would like to remove it because it ...