Skip to main content

Questions tagged [amd]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0 votes
0 answers
228 views

Driver problem with 780M (Ryzen 7 7840HS iGPU)

I have HP Victus 16 with configuration Ryzen 7 7840HS(780M iGPU) and RTX3050. There is issues with my 780M iGPU. It gives black screen on Linux 6.9.1 when using iGPU. Using dGPU (which is RTX3050) ...
erenalyoruk's user avatar
0 votes
0 answers
84 views

lm-sensors, CPU sensors not detected

I have a fresh install of Manjaro running on a server i have built. I have an AMD Genoa 9334 ES. On windows I can detect the correct core temperature (see attached images). On the linux OS (Ubuntu 24....
Nan Rait's user avatar
0 votes
1 answer
30 views

Lags, artefacts and LOW fps in game if i open youtube or anything in full screen in another monitor

Lags, artifacts and LOW fps in game if I open youtube or anything in full screen in another monitor. Two monitors full HD 1 60HZ and Primary 75. I tried changing the refresh rate, but it made no ...
BrunoGuillou's user avatar
0 votes
1 answer
35 views

Pop!_OS 22.04 LTS tearing and not working properly with AMD RX 6600 XT

I'm having this issue when trying to install Pop!_OS on my system. I have tried Pop!_OS 22.04 LTS before on another computer with an Nvidia GPU, but in my current one with an AMD RX 6600 XT it just ...
JustASimp38's user avatar
0 votes
1 answer
216 views

Arch linux: bash: rocminfo: command not found

I have fresh and updated arch linux install. I have AMD Radeon 7900 XTX. I am trying to run stable diffusion and I installed these packages: local/comgr 6.0.0-1 Compiler support library for ROCm ...
Jan Černý's user avatar
  • 1,441
0 votes
0 answers
70 views

Ubuntu 22.04 install.iso and other VMs won't start in VirtualBox

I have not had this problem before with VirtualBox so I thought I would share and hope for some answers. UPDATE: The VMs are working fine on QEMU/KVM. When loading Ubuntuy 22.04 install .iso or the ...
I'm Root James's user avatar
0 votes
0 answers
38 views

Frozen on BIOS logo after the GRUB selection

I have the following packages avaliable to update: lib32-lcms2-2.16-1 lib32-libdrm-2.4.118-1 linux510-5.10.204-1 linux510-nvidia-545.29.06-4 linux510-virtualbox-host-modules-7.0.12-7 ...
vfbsilva's user avatar
  • 3,717
0 votes
1 answer
60 views

Unable to install any overlay packages on FS39 with glibc depsolve errors

Fedora Silverblue 39 Trying to install and upgrade packages in rpm-ostree results in dependency errors with unresolvable glibc version conflicts. I don't know if it may be related to this issue. My ...
tsilvs's user avatar
  • 99
2 votes
1 answer
1k views

Arch linux: AMD ryzen + AMD radeon experiencing freezes and crashes of browsers

I moved my install from intel i7 + intel iris to AMD ryzen 5 + AMD radeon, by swaping SSDs. I experience these issues: Symptoms Everything works fine except randomly load of CPU explodes to 30+ and ...
Jan Černý's user avatar
  • 1,441
0 votes
1 answer
149 views

Failing to install cvxpy.py on Ubuntu 22.04.3 LTS, on Zynq UltraScale+ MPSoC based SOM ARM Cortex-A53 4 core processor

I was barely able after much effort to get this to install 9 or so months ago, now it doesn't install on the same platform with a new update/upgrade. Here's the software version info: ubuntu@BDv4-...
Charlie's user avatar
  • 11
0 votes
0 answers
70 views

Migrated from AMD to Intel and grub doesn't boot Linux

I have Linux Mint 21.2 installed on an NVMe M.2 SSD. I migrated from a Ryzen 5 3600X to an Intel Core i9-14900K CPU and motherboard, and now grub welcomes me with the following screen: GNU GRUB ...
László Monda's user avatar
0 votes
1 answer
37 views

Vulcan detecting GPU on TTY but not on gnome

I am on Debian 11 I have a program that works by overriding tty1. So when starting my computer, the program runs right away. This works fine, but I use Gnome as my GUI to develop and test the program. ...
fwan's user avatar
  • 11
0 votes
1 answer
318 views

issue EFI USB Device (....) boot failed. in framework pc with specific OS (tuxedo OS 2)

I have created a bootable usb using balenaEtcher of the tuxedo OS 2 iso file to setup my new framework 13 pc (amd ryzen processor). the thing is, when I turn on the pc, I get the error: EFI USB Device ...
otaolafr's user avatar
2 votes
1 answer
177 views

OpenBSD boot hangs after “256 targets”

I'm trying to boot OpenBSD 7.4 on my desktop with ASUS B650E-i motherboard, but after scsibus3 at softraid0: 256 targets, it hangs. Is OpenBSD incompatible with hardware this recent?
jobukkit's user avatar
  • 411
0 votes
0 answers
706 views

Frequent segmentation faults causing browser and/or system to freeze

I have been having issues for awhile with a new PC I built. I decided to go with Pop!_OS (didn't see a dedicated Pop!_OS forum so here I am) since it is supposed to support a lot engineering and data ...
AKA_Tom's user avatar
0 votes
0 answers
116 views

My Laptops internal mic is not Detected

I have tried the gnome version of both Fedora 38 and ubuntu 23.04 on my Acer Aspire 315-24p laptop with AMD Ryzen 5 7520u processor. Non of the OSes detect my laptops internal mic. My mic is nowhere ...
Zeesan's user avatar
  • 1
0 votes
0 answers
855 views

Random Freezes on pop!_os based on ubuntu 22.04

I've experiencing random freezes on Pop!_os distro (based on Ubuntu 22.04), where the whole system freeze and won't do any thing so I have to force restart. The frequency of freezes is really random. ...
Heba Fareed's user avatar
3 votes
1 answer
1k views

Lenovo V15 g4 AMN mouse and keyboard is not working under linux

I have a Lenovo V15 g4 AMN with AMD Ryzen 5 7520U Tried to install multiple distros (Fedora, Ubuntu), but internal touchpad and keyboard are not working. Usb mouse and keyboard work perfectly, also ...
dre-hh's user avatar
  • 185
0 votes
1 answer
3k views

How can enable iommu in AMD CPU during boot?

Motherboard info: sudo dmidecode -t baseboard | grep -B 1 Product Manufacturer: Colorful Technology And Development Co.,LTD Product Name: BATTLE-AX B450M-HD CPU info: sudo dmidecode -t ...
showkey's user avatar
  • 395
0 votes
1 answer
276 views

Linux not working with Radeon Vega 8 GPU

I have a laptop, an Acer Aspire 3 A315-41G-R6KL with an integrated Radeon Vega 8 graphics card on a Ryzen 5 2500U CPU and a discrete Radeon R535. This laptop was running Windows 10 before me. But ...
Aleksander's user avatar
-1 votes
1 answer
136 views

Critical error on Linux installed in AMD computer after deleting /boot/intel-ucode.img

It is puzzling to me that deleting /boot/intel-ucode.img could cause a critical error on a Linux installation in an AMD computer. Could you please clarify how this works? The operating system is Arch ...
user avatar
0 votes
0 answers
214 views

How do you determine if a PCIe device supports "ID-based ordering (IDO)" or "Relaxed ordering (RO)" in Linux

According to AMD, a device can be prioritized on the PCIe bus if it supports IDO or RO (which are further defined here). For example, an Infiniband card. Can you use tools like lspci to determine if ...
KJ7LNW's user avatar
  • 495
1 vote
0 answers
132 views

scaling_cur_freq is low (lower than scaling_min_freq) when battery is low

I have a chinese noname laptop with AMD Ryzen 3 3250U. Here is lshw, lscpu, cpupower frequency-info When the battery is less than 25%, the processor frequency is about 400000 kHZ (according to /sys/...
Timur's user avatar
  • 31
0 votes
0 answers
240 views

Vulkan issue on AMD 5700G CPU onboard Radeon....'amdgpu'?

I have an AMD Ryzen 5700G and I tried installing Wine, however when I launch it I get "0074:err:vulkan:wine_vk_init Failed to load vulkan library". I'm running Debian 10 with an updated ...
1toneboy's user avatar
  • 441
1 vote
0 answers
442 views

GUI Video transcoder with VA-API (Handbrake alternative)

I'm looking for an alternative to Handbrake. Sadly, it doesn't support VA-API, so you have to install separate support for QSV/VCN/NVENC. While I don't know how bad the situation with Intel and NVIDIA ...
Richard Rosner's user avatar
1 vote
0 answers
40 views

North Bridge stuck in P1 state

I have AMD E-350 processor stuck in NBP1 (north bridge P1) state in Linux (Debian 11) and doesn't transit into NBP0 state under CPU/GPU load. The problem doesn't take place in Windows. Let's follow ...
Trudy's user avatar
  • 924
0 votes
0 answers
162 views

Enable ATI GPU work on debian 11

I'm on an old laptop with AMD ATI Radeon 6490 M. With default kernel parameters any Linux freezes on booting, which I fixed by disabling the discrete AMD gpu completely: radeon.modeset=0 amdgpu.runpm=...
WhiteBlackGoose's user avatar
0 votes
0 answers
78 views

Linux cannot recognise my RAID0 array drives

OS: 64bit Debian 11 Bullseye with KDE Plasma Desktop environment PC Specs: AMD FX-4300 Quad Core Processor, nVidia Geforce GTX 970 Graphics card, ASUS M5A97 LE R2.0 Motherboard, 16GB unknown brand ...
Pepe Wightmore's user avatar
1 vote
0 answers
114 views

How to determine cause of poor CPU performance - AMD 75F3?

I have 2 identical machines with pretty identical configurations, however one machine is performing much worse than the other. After some digging it appears the CPUs on one machine is simply slower ...
GCPuser's user avatar
  • 53
1 vote
0 answers
545 views

NVMe hotswap / hotplug with linux and amd working?

Has someone got nvme hostwap/hotplug working on linux with amd? We use RS500A-E10-RS12U (ASUS) and hotplug / hotswap is not working. If I remove devices it wont disappear in lsblk and If I add devices ...
jsterr's user avatar
  • 1,341
0 votes
1 answer
291 views

amdgpu drivers broke debian APT

Each time I try to use APT I get this error: The following packages have unmet dependencies: clinfo-amdgpu-pro : Depends: ocl-icd-libopencl1-amdgpu-pro but it is not going to be installed E: Unmet ...
IdotMaster1's user avatar
1 vote
1 answer
718 views

Enabling KVM without BIOS setup

I'm running Debian 11 LXDE in an old notebook and during the boot I'm receiving the following message: root@debian:~# dmesg | grep -i kvm [ 20.501228] kvm: disabled by bios [ 20.541824] kvm: ...
Jeron Baffom's user avatar
0 votes
1 answer
5k views

installing 32-bit architecture in amd64 linux

I'm trying to install 32-bit libraries so I can do stack smashing in a amd64 kalios.` The instruction for installation on a x86 linux would be: sudo dpkg --add-architecture i386 && sudo apt-...
Joel Russo's user avatar
0 votes
0 answers
546 views

Determining the number of threads per EPYC AMD 7601 cpu

I'm trying to confirm that my AMD EPYC 7601 CPUs are set up with dual threading. I have 2 X 32 CPUs and ​should have 2 threads per CPU. When I run: lscpu | grep -E '^Thread|^Core|^Socket|^CPU\(' I ...
dtx1's user avatar
  • 21
0 votes
0 answers
124 views

Installing new GPU with drivers

I am currently upgrading my PC from an AMD 5700XT to an RTX 3070 which use different drivers (duh). The drivers i currently have installed are the xf86-video-amdgpu Packages from arch as well as ...
rafe's user avatar
  • 13
0 votes
1 answer
13 views

Can APIC LVTERR on AMD be configured as NMI message type?

In fact, the message type / delivery mode of LVTERR on Intel is unconfigured. However, on AMD, it is presented as below. The problem is, when I configure the MT of LVTERR on AMD as NMI, it will keep ...
konguu's user avatar
  • 1
1 vote
1 answer
568 views

KDE Neon Display-setup-script Nvidia Driver alternative

I'm using KDE Neon based on Ubuntu 20.04 latest release version with last KDE on a Asus laptop with AMD Ryzen 4800H and Nvidia RTX 2060. I'm trying to install Nvidia drivers using ubuntu-drivers ...
addictedtohaskell's user avatar
0 votes
1 answer
830 views

AMD Epyc 7452 having CPU base clock as max clock speed & not boosting to boost clock?

I have an AMD Epyc 7452 CPU on an ASRock Rack ROMED6U-2L2T board running Proxmox 7 a linux system and running cpupower frequency-info reveals the following: analyzing CPU 0: driver: acpi-cpufreq ...
user avatar
8 votes
1 answer
5k views

No temperature reading on Ryzen 5700G?

I've built a new computer with a AMD Ryzen 5700G and to my surprise, no sensor information is picked up whatsoever. I thought perhaps the new AMD chips would not yet be recognized by Linux, but the ...
kasimir's user avatar
  • 445
1 vote
1 answer
3k views

dpkg-deb treats my architecture as amd64 instead of x86-64

I just created a simple .deb package (using this tutorial). This is my control file: Package: bla Version: 1.0 Architecture: x86_64 Maintainer: bla Description: bla The Architecture I got from uname -...
CIsForCookies's user avatar
1 vote
2 answers
802 views

Configuring AMD RX 580 on Fedora 34

I have ASUS AMD RX 580 on Fedora 34 system. This series of video cards have problems with very high default core frequency and power limits. Video core has normal temperature, but some small ...
Elusha's user avatar
  • 111
2 votes
2 answers
2k views

Disable GTT on amdgpu?

How can I disable GTT on amdgpu? According to https://www.kernel.org/doc/html/v4.20/gpu/amdgpu.html, adding amdgpu.gttsize=0 should work but that has no effect. The reason why I am asking is, that my ...
InvisibleShadowGhost's user avatar
0 votes
1 answer
762 views

16GB installed but only 12GB available

I have a ThinkPad P14s Gen 2 AMD which has a AMD Ryzen 7 PRO 5850U with Vega 8 Graphics running Fedora 34. It has one 16GB DIMM installed, which the bios as well as dmideocde report correctly Getting ...
InvisibleShadowGhost's user avatar
4 votes
0 answers
859 views

Any way to fix chromium hang that eats up all mouse clicks?

So I have been running into this weird issue where Chromium would hang, and pretty much lock out mouse clicks. The mouse can still move, I can navigate using my keyboard all non-chromium windows like ...
user16551018's user avatar
2 votes
0 answers
64 views

Are there any desktops (intel or amd) or pci-e cards that can support more than 16 USB devices per port?

I have a custom device from a manufacture that creates 32 ttyUSB devices. But this doesn't work with pc usb's controller because this generates error "not enough host controller resources for new ...
knodi's user avatar
  • 21
0 votes
1 answer
598 views

Linux Mint showing 1 thread per core in a 4 thread/core cpu

I have a Ryzen 3 3200g and, when I do lscpu in a Linux Mint 20.1 Cinnamon OS terminal, the output says that I only have 1 thread per core. The Windows system's info accurately recognizes that my CPU ...
Vitor_figm's user avatar
1 vote
1 answer
637 views

How to get sensors-detect to detect an AMD Phenom II temtperature sensor

Yes, I know that is an old chip. Running a sensors-detect with all the optional tests yields nothing. My sensors refuse to read the temperature of the CPU. I know there is a working temperature sensor ...
Betta George's user avatar
1 vote
1 answer
3k views

AMD GPU not being used by Debian

I'm running Debian 10 with kernel 5.10 via buster backports. The installed driver for amd is amdgpu and the output of dmesg from my understanding tells me the driver is being recognized, [ 2.774224]...
PC-02's user avatar
  • 11
0 votes
1 answer
848 views

GCC and AMD Ryzen

https://wiki.gentoo.org/wiki/Ryzen#GCC says, neither GCC 6.x nor GCC 7 is Ryzen optimized. But, when doing man gcc-7 I clearly see march=znver1 is available in GCC-7. Or is this just a dummy option ...
flyingpenguin's user avatar
0 votes
1 answer
151 views

Linux not resuming from s2ram (X570, Zen3)

I have a fresh install of Gentoo Linux on a MSI X570 Tomahawk, AMD 5900X machine with the latest BIOS (7C84v163). 5.10.27-gentoo-x86_64 kernel fails to resume from Suspend-to-RAM. First, s2ram ...
eprst's user avatar
  • 101