Stack Exchange Network

Stack Exchange network consists of 174 Q&A communities including Stack Overflow, the largest, most trusted online community for developers to learn, share their knowledge, and build their careers.

Visit Stack Exchange

Questions tagged [amazon-linux]

The tag has no usage guidance.

1
vote
2answers
93 views

How do I configure my Amazon Linux service to auto-restart if it fails?

I'm using Amazon Linux. I have a script to start and stop a service, written in bash, located at /etc/init.d/wildfly At the various run levels, I have symlinks to ensure the script starts and stops,...
1
vote
1answer
35 views

Permission denied when accessing a file with acls on xfs file system

I'm trying to use ACLs with the xfs file system on Amazon Linux (RHEL-ish distribution). However, when I configure acls and try to access a file with a test user, my access is denied. I currently ...
0
votes
3answers
74 views

How can we generate the session token in aws

i have aws access key and secret key with me. i wanted session token to be updated in aws credential file (~/.aws/credentials), how will i get it? I want them to be generated in command line.
0
votes
0answers
76 views

face error in installing mysql on AMI linux centos 2017-09

how to fix "Error: Package: mysql-community-server-5.6.42-2.el7.x86_64 (mysql56-community) Requires: systemd You could try using --skip-broken to work around the problem You could try running: rpm -Va ...
1
vote
0answers
42 views

/etc/timezone on Amazon Linux

Usually /etc/timezone is a text file containing the timezone, at least that's how it works on most non-embedded linux distros. However, on Amazon Linux(4.14.72-68.55.amzn1.x86_64) it's actually an ...
0
votes
1answer
26 views

Rebuild from src.rpm using new version

This is a follow up to my previous question regarding Building QuantLib on Amazon Linux. I followed the instructions in the answer posted by MLu: Download the source RPM (QuantLib-1.4-7.el7.src.rpm) ...
1
vote
1answer
50 views

Building QuantLib on Amazon Linux

I am trying to get QuantLib version 1.13 running on Amazon Linux. I found some .rpm files at https://pkgs.org/download/QuantLib, although there is an up to date .rpm for Fedora, there isn't one for ...
0
votes
0answers
35 views

Accessing Amazon Linux 2 repository from Ubuntu EC2 Instance

I am trying to mirror Amazon Linux 2 repository on one of my local Update server which is running Ubuntu 1604 as EC2 Instance in AWS. While mirroring the repo using reposync utility, i am getting ...
0
votes
0answers
39 views

Missing cc1 executable on Amazon Linux

I've been trying to build Tensorflow on Amazon Linux (2016.09). I'm struggling with not being able to get cc1 to install with GCC. Here's what I've tried: Installing gcc Installing gcc-c++ Installing ...
0
votes
1answer
27 views

Allow a group to su to a user without a password in Amazon Linux

In Amazon linux on my ec2 server, how do I allow a group of restricted users to su to a specific user. Also I would like for them not to be prompted for password. I have a group called 'my-users' ...
0
votes
2answers
789 views

pip says it is out of date but updating says it is the latest version!

If I try and do the following: pip --version I get this: Traceback (most recent call last): File "/usr/bin/pip", line 6, in <module> from pkg_resources import load_entry_point File "/...
1
vote
1answer
173 views

Installing Fedora packages on Amazon Linux AMI

I'm trying to install a Fedora package, specifically the package poppler-utils versions 0.5x or later, but that currently only for Fedora. I don't have a lot of knowledge on Amazon Linux AMI, but from ...
2
votes
1answer
431 views

SUDO requiring tty

On Amazon Linux 2018.03, I have a process running as an unprivileged user and calls sudo to run a command. I'm getting the message: sudo: sorry, you must have a tty to run sudo The unprivileged ...
0
votes
1answer
209 views

How to install open connect client on Amazon linux

sudo yum list all | grep openconnect NetworkManager-openconnect.x86_64 0.8.6.0-3.el6 epel openconnect.i686 7.07-2.el6 ...
1
vote
1answer
1k views

sudo: unable to mkdir /var/log/sudo-io/00/2A: No space left on device

A script began throwing errors related to not being able to init an I/O plugin sudoers_io: (amazon linux). I can't get into delete some logs since each time I use the sudo command, it fails to log ...
1
vote
0answers
63 views

Is this the right way to generate a wildcard CSR?

I generated my CSR on an Amazon Linux system using this command openssl req -new -sha256 -key ~/mymaindomain.com.ssl/mymaindomain.com.key -out ~/mymaindomain.com.ssl/mymaindomain.com.csr I verified ...
-1
votes
1answer
25 views

Mistakenly moved the server files to a directory and the server wont work now [duplicate]

I screwed up my AWS instance. I created a new directory demo inside my /var/www/html Then in navigated to the html directory and ran this command: sudo mv /* demo And all the files and folders ...
0
votes
0answers
625 views

Unable to install PHPMyAdmin with PHP 7.1

I previously installed php56 in aws but i had to update to 7.1. When I do, I couldn't install phpmyadmin anymore. I tried to search on the net but all are said to remove php5.6 then to install 7.1. It ...
2
votes
1answer
61 views

How can I tell if a command is available on the $PATH for sudo?

I installed a utility on a server recently and discovered that it wasn't available when running from sudo. That is, foo executed as expected buy sudo foo resulted in sudo: foo: command not found. I ...
0
votes
0answers
73 views

Questions about restricting SFTP users to specific directories but giving one admin user access to all

I've read a great number of posts about restricting SFTP users but I still have questions about some specifics (I just started using Linux on Friday). I built a server on AWS using Amazon Linux 4.9....
0
votes
1answer
396 views

Upgrade PCRE lib on AWS EC2 Linux AMI

I would like to update the default PCRE library of my AWS EC2 Linux instance. Current version is 8.21 2011-12-12. I tried with the following guides: https://forums.aws.amazon.com/thread.jspa?...
1
vote
3answers
384 views

ZFS on Amazon linux ami

I am trying to install ZFS on my amazon linux ami. Since the package is by default not available in their repository, I downloaded it from http://zfsonlinux.org/ . I also managed to install spl and ...
0
votes
1answer
265 views

How can I prevent running “Xvfb :10 -ac” if it has already been run before?

I'm using Amazon Linux. I'm running an automated script through Jenkins with this command Xvfb :10 -ac However, if this command has already been run before, I get the error ... (EE) Fatal server ...
1
vote
1answer
56 views

Why isn't my Apache server starting automatically wnen I reboot my server?

I'm using Amazon Linux. I just Apache via yum, however, I can't get it to automatically start when I reboot my server, despite the fact it starts on the command line ... [myuser@mymachine ~]$ sudo ...
0
votes
3answers
368 views

How do I figure out when swap space will be used on our Linux machine?

We are trying to tune our application servers, which are Amazon Linux machines ... [myuser@mymachine ~]$ uname -a Linux mymachine.myco.org 4.3.17-14.25.amzn1.x86_64 #1 SMP Wed May 10 01:58:40 UTC ...
0
votes
1answer
151 views

How do I install an RPM key on my Amazon Linux system?

I'm using Amazon Linux. Here's the uname info [myuser@mymachine3 ~]$ uname -a Linux mymachine3 4.8.18-12.31.amzn1.x86_64 #1 SMP Thu Jun 22 06:20:54 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux I'm ...
4
votes
1answer
7k views

How do I figure out what CentOS version my AMazon Linux distribution is based on?

I was told we recently created a new Amazon Linux instance with the latest and greatest (Version 2017.3–01) . I'm trying to find out if it is based on CentOS 7 (because that is the only version that ...
1
vote
0answers
89 views

Compiling g++ from source results in broken standard library. error: ‘::realloc’ has not been declared

I need to run on Amazon Linux but I need a recent g++. I compiled g++ 5.3.0 from source following the instructions here. The compilation ran for 13 hours on an EC2 instance and finished successfully. ...
1
vote
0answers
64 views

Openssl.Cnf impact on sshd services amazon linux

I have Openssl V.1.0.1k-fips on my Amazon Linux machine and a few days ago I have added following parameter in my openssl.cnf [ san_env ] subjectAltName=${ENV::SAN} and exported variable export SAN=...
0
votes
1answer
410 views

How do I upgrade Amazon Linux?

Is Amazon Linux based on CentOS 6? I want to upgrade my Amazon Linux instance [myuser@mymachine ~]$ uname -a Linux sandbox2.evo-text.com 4.9.38-16.33.amzn1.x86_64 #1 SMP Thu Jul 20 01:31:29 UTC ...
3
votes
1answer
6k views

Where do I find “libgtk-3.so.0()(64bit)” for Amazon Linux? [duplicate]

I'm using Amazon Linux. When I run "sudo yum install" it eventually errors out with the following [myuser@mydomain ~]$ sudo yum update [sudo] password for myuser: Loaded plugins: fastestmirror, ...
2
votes
3answers
3k views

How do I install Google Chrome on Amazon Linux with all its dependencies?

I'm using Amazon Linux. I want to update the version of Google Chrome that I have installed on my machine so I got this script #!/bin/sh sudo touch /etc/yum.repos.d/google-chrome.repo echo -e "[...
0
votes
2answers
333 views

/usr/bin/find is needed but I can't locate the package to install it

I am trying to set up a Docker container that runs from the base amazonlinux and install the Oracle version of the jdk but it keep failing on with the error: error: Failed dependencies: /usr/bin/...
1
vote
0answers
2k views

/usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21 not found in amazon linux ami

I am trying to run one of my node.js project in amazone linux ami (AWS cloud) but i got the following error to while running the project. /usr/lib64/libstdc++.so.6: version `GLIBCXX_3.4.21 not found ...
1
vote
1answer
380 views

Making swapfile for t1.micro Amazon EC2 instance with Amazon Linux

I'm using t1.micro EC2 instance with Amazon Linux. Since the micro instance has limited RAM (589MB RAM in total), it is insufficient for many operations such as installing & compiling Python ...
2
votes
1answer
5k views

How do I get the output of a cron script run from my home directory?

I'm using Amazon Linux and trying to run a cron job from my home directory (I don't have sudo permissions on the machine). I'm setting a cron job by executing crontab -e and adding this line 30 18 * ...
0
votes
0answers
657 views

Yum [Errno 28] No space left on device

I am at a situation that I want to install some packages with yum on an Amazon EMR Master Node which has the root volume limited to 10GB At some point, I constantly end up getting this error because ...
1
vote
3answers
627 views

How do I create a file name for my email attachment?

I'm using Amazon Linux and am creating a bash script. I'm tryhing to email an attachment and am having success with (cat $TFILE1; uuencode $output_file $output_file) | mailx -s "$subject" "$to_email"...
0
votes
1answer
227 views

Adding SSL to my Amazon AMI EC2 instance

I was following this how-to: https://nouveauframework.org/blog/installing-letsencrypts-free-ssl-amazon-linux/ and it leverages LetsEncrypt so i was happy to use it. I was entering this command and ...
2
votes
1answer
884 views

Where are my nginx modules?

I'm running the latest Amazon AMI (amzn-ami-hvm-2016.09.1.20170119-x86_64-gp2). If I run nginx -V, I can see it's been configured with many modules: $ nginx -V nginx version: nginx/1.10.1 built by ...
1
vote
1answer
79 views

How to enable Disk Merge in fio in AWS Ubuntu 1604?

I am running Ubuntu 1604, with fio-2.1.10, libaio engine, on a VM on AWS. Its IO scheduler is "none". (I guess it will use "noop"). And, the disk's nomerge is 0, that means merge is enabled. But, ...
2
votes
0answers
67 views

Proper way of installing puttygen on Amazon Linux [duplicate]

I'm trying to install puttygen on an Amazon Linux server. puttygen is provided by the putty package available in EPEL, but installation fails with it unable to find several required C libraries: ...
5
votes
3answers
9k views

Is it possible to install mysql 5.7 on Amazon Linux AMI?

I tried installing and I am seeing the error Error: Package: mysql-community-server-5.7.17-1.el7.x86_64 (mysql57-community) Requires: systemd You could try using --skip-broken to work around ...
3
votes
2answers
939 views

Docker on Amazon EC2

I am running several Docker containers on AWS (EC2, T2 medium) and I constantly run out of diskspace. It has something to do with the underlying filesystem. I run Docker on Ubuntu and it works fine (...