Questions tagged [alsamixer]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1
vote
0answers
34 views

Merging two USB microphones into one stream using ALSA or PulseAudio

This is all very new too me and the question might be simple/stupid. I have 2 USB microphones (with speakers) connected to a PC. Card 2 and 3 below. arecord -l **** List of CAPTURE Hardware Devices ***...
1
vote
1answer
20 views

5.1 sound with external USB soundcard (Soundblaster HD)

I'm trying to make 5.1 sound work on my old Soundblaster HD. This through the toslink digital output of the card. I set those values in the pulseaudio daemon: remixing-produce-lfe = yes remixing-...
0
votes
0answers
18 views

Volume control, max limit issue on MX Linux 19.3 XFCE 4.14 (See text)

I have the following issues: Sound at 100% is too low for me, so I have to move it to 150% from Pulse Audio Volume Control - but it's not permanent. If I use keyboard to change volume, it again sets ...
0
votes
0answers
20 views

Audio coming from headphone and speaker simultaneously

I have just installed and finished the necessary configuration but I have found that my headphones are not working. I have got a strange behavior. I have implemented some fixes and they fixed my ...
0
votes
0answers
32 views

How can I have alsa (specifically: as controlled by alsaequal) control ALL my sound across my system (firefox, youtube etc.)?

Debian Buster. I use alsa, (as configured by the system, which I believe uses pulseaudio too?) mpd and alsaequal ad my setting at the moment are just the defaults to get all that working. /etc/asound....
0
votes
0answers
10 views

My headphones are detected even when they are unplugged

I run debian buster on my Laptop. I recently get a issue that my headphones are detected even when they are unplugged. Because of this my speaker doesn't work. Sometimes it corrects itself but ...
5
votes
1answer
302 views

How can I get my unsupported sound card to work with ALSA?

I get no sound via the speakers of my Lenovo Legion 7i laptop, which alsamixer tells me is using a Realtek ALC287. I have tried various Linux distros and kernel combinations, including Ubuntu 16.04, ...
0
votes
0answers
128 views

How can I force ALSA to recognize my sound card as a different model?

I have a Lenovo Legion 7i laptop, and the sound does not work in Linux at all, but does work in Windows. Alsamixer identifies the laptop as having an ALC287, but several websites indicate that the ...
0
votes
1answer
113 views

headphone not working elementary os hera

My Problem When I start up Elementary, the audio through the computer speakers work as expected. When I plug headphones into the audio jack, the audio doesn't come through the headphones. Sometimes ...
0
votes
1answer
40 views

Unable to use speakers when the headphone is plugged

I want to be able to use my internal speaker without unplugging the jack headphone so I set the Speaker Playback Switch to on: $ amixer -c1 cset numid=4 on numid=4,iface=MIXER,name='Speaker Playback ...
1
vote
1answer
1k views

How to switch between headphones and speakers without disconnecting

When I connect my headphones into the front jack, my speakers (line-out) get muted. I would like to switch to speakers without disconnecting my headphones. I see two possible options in gnome-control-...
0
votes
0answers
100 views

Chromium recognizes headset mic only when pulseaudio is uninstalled

Running Debian Buster XFCE on Asus ImagineBook. Installed 4 days ago. Neither Firefox or Chromium recognises the plugged-in Headset Microphone. Pulse Audio sees it and hears it (I checked). I read ...
0
votes
0answers
159 views

CentOS is not detecting my Microphone, I can't save alsamixer settings

I can't record and I was reviewing my Microphone. Checking [joseluisbz@centos ~]$ uname -r 5.7.8-1.el8.elrepo.x86_64 [joseluisbz@centos ~]$ [joseluisbz@centos ~]$ arecord -l **** List of CAPTURE ...
0
votes
1answer
54 views

Microphone issues on debian 10

I'm trying to set up discord chat with debian 10 installed on macbook pro. there are two input devices listed in discord. Default, and Built-in Audio Analog Stereo. I was using Default, and it worked ...
1
vote
1answer
41 views

Alsa doesn't detect soundcards anymore

Until today audio was working under Debian bullseye/sid, now it just doesn't anymore and I don't know why. ~ $ sudo alsactl init alsactl: init:1759: No soundcards found... ~ $ lsmod | grep snd ~ $ # ...
1
vote
0answers
25 views

Microphone Problems

I can't get a webcam microphone to work; it appears grayed out in Linux Mint 19.3 Cinnamon: > System: Host: me-Peppy Kernel: 5.3.0-46-generic x86_64 bits: 64 > compiler: gcc v: 7.5.0 Desktop: ...
0
votes
0answers
1k views

How do I switch between my audio output devices? (Pop!_os)

I am using Pop!_OS, installed it a few days ago. I have two audio output devices (correction: read #1 under the post) connected to my PC, one to the 3.5mm audio jack in the front panel and one to the ...
1
vote
1answer
97 views

Parsing audio format rates from USB Audio Interface fails, causing disconnect/rediscover loop

When I connect my PreSonus USB AudioBox 96 to my Ubuntu 18.04LTS desktop via USB2.0 port, dmesg shows the following errors in a loop: [ 8764.468004] usb 1-11: new high-speed USB device number 61 ...
0
votes
0answers
23 views

alsamixer: changing the Line capture output channel

I'm trying to use brutefir for my HiFi. The only way I can get it to work is by enabling the capture of the input channel (in brutefir) I'm trying to use in alsamixer. The problem is the output from ...
1
vote
0answers
294 views

Internal microphone not working on any distro, any kernel

This is a problem that I have been trying to solve for a while. I've tried a lot of distros and versions (Ubuntu, Mint, MX, Elementary, Deepin). My problem is, basically, that Linux is not capturing ...
0
votes
1answer
229 views

Lineout shows plugged but no sound in Ununtu 18.04

If I connect my logitech speaker to rear jack of my desktop, it does not make sound but detected as a lineout (Built in). However, if I connect through the front jack, it makes sound and detected as ...
0
votes
0answers
36 views

How to get sound through phones in Ubuntu?

I have JBL T450BT phones. Is it possible to set Ubuntu 18.04 such that if those are plugged in to USB port, the sound will go through the phones? How one can do it?
0
votes
1answer
2k views

Alsa doesn't recognize soundcards but kernel does

I've an issue with alsa which seems not to recognize my soundcards. Before I didn't have that issue... !!################################ !!ALSA Information Script v 0.4.64 !!#############...
1
vote
0answers
272 views

ALSA: mixing input source to output and vice-versa

I'm looking forward to have Linux system with GPU-passthrough Windows VM. Since the emulated sound device from QEMU/KVM is not very good, Windows VM will have USB-passthrough sound device and send ...
1
vote
1answer
422 views

how to add support for libasound2-plugin-equal to ASLA config raspnerry pi MAX98357 I2S amp

I've followed this tutorial (https://learn.adafruit.com/adafruit-max98357-i2s-class-d-mono-amp/raspberry-pi-usage) to add MAX98357 I2S amp to raspberry pi. It works fantastic, but i would like to have ...
0
votes
0answers
136 views

No sound in every linux distribution,in aslamixer only one bar(master)

Now i am using Void Linux,sound don't work,but when i type $beep Sound work,so i don't know where the problem. Help please. aplay -L [bixbow@localhost ~]$ aplay -l **** List of PLAYBACK Hardware ...
3
votes
2answers
182 views

I need to know how to get sound in Linux to do something specific

What I want is to separate two different applications' sound output from each other, and pipe that into a sound editing program. What I need is a way to add an entry in record that outputs into the ...
0
votes
1answer
385 views

Asterisks locks ALSA device if chan_alsa is loaded

I am implementing an extension 900 which routes the audio to ALSA device.  I am also using mpd, which plays music through ALSA. Asterisk 15, OpenWrt 18.06 mpd.conf: log_file "syslog" ...
0
votes
1answer
130 views

Alsamixer not identifying audio output

I've map a keyboard combination to execute the command amixer sset Master 4%+ and it does nothing. I plug my headset via the jack 3.5 port and in pavucontrol/Pulseaudio I can control de volume but ...
0
votes
0answers
201 views

Alsa - dmix, softvol config?

I want to acheive the following: A USB DAC is connected to a linux box. So far no issue... card 1: Device [USB Audio Device], device 0: USB Audio [USB Audio] Subdevices: 1/1 Subdevice #0: ...
0
votes
0answers
655 views

PopOS - Headphones making Heart Beat sound while plugged in

Since this morning my headphones have been making a "Heart Beat" thumping noise while plugged in. No sound plays through them. Sound plays normally through laptop speakers. I am running Pop!_OS ...
1
vote
2answers
1k views

Multiple problems with alsamixer after opening up laptop (no problems in other OSs)

This randomly started happening today. Yesterday I opened up my laptop to clean it out. I also disconnected the CMOS battery cable by mistake. When I open alsamixer in a terminal, the following things ...
1
vote
3answers
2k views

Sound stopped working all of a sudden

I have antergos and gnome as DE dual booted with windows 10. Everything was ok until I powered on the laptop and played a movie, there was no sound.(Also no sound when headphones plugged) There is ...
0
votes
1answer
1k views

No sound on Fedora 28 XFCE

After installing Fedora 28 XFCE I had sound (everything worked). I run dnf update and after reboot I have lost sound. PulseAudio plugin for panel says in tooltip "Not connected to the PulseAudio ...
1
vote
1answer
399 views

synchronizing alsa volume to all pulse audio sinks

I control my computer's audio using key bindings linking XF86 audio key presses to amixer commands. This works well, unless I am listening through a non-alsa sink such as bluetooth-connected ...
1
vote
0answers
32 views

How to prevent xfce from increasing the sound level when playing a warning sound?

Consider following case I am listening to music on xfce 4.12. The sound level is on 25% of the maximum in ALSA Mixer. Suddenly, an application [I reproduced it using two different applications] ...
4
votes
2answers
4k views

Find out whether sound output is muted (ALSA with Pulseaudio)

I'm trying to look for a command that outputs 1 or 0 depending on whether I have my output muted. I was trying this: amixer sget Master This is the output I get: Simple mixer control 'Master',0 ...
1
vote
1answer
2k views

ALSA — remarkably horrible sound output on headphones

OS: Arch Linux (4.13.12-1-ARCH) First of all, I'm not using pulseadio. I know it causes a lot of problems, but I'm just with alsa Situation I have a 2.1 speaker system, plugged into the back panel ...
3
votes
4answers
24k views

Ubuntu: No sound from speakers, headphones jack detected even when no headphones are connected

I have a problem with the audio in Ubuntu 17.10. No sound from speakers unless auto-mute from alsamixer is disabled. In that case sound goes to both speakers and headphones. All sound cards are ...
0
votes
1answer
713 views

Speakers and headphones have different independent volume levels

Linux Mint 18.2 MATE. I tried to increase the volume in headphones via alsamixer, but thereafter I have different volume levels for speakers and headphones. How can I make the only one level for ...
0
votes
1answer
1k views

Is ALSA's asym plugin deprecated?

I have a Logitech Webcam C310 and the built-in microphone of the webcam works really well, that's why I use at as my default microphone. My ~/.asoundrc looks like this: pcm.usb { type hw ...
0
votes
1answer
2k views

Horrible input sound on any distro

I've been toying around with several distros in my endless effort to ditch windows and stick to linux but I haven't been able to work this out. I used to have a desktop where everything just worked ...
1
vote
1answer
7k views

How to disable loopback with alsamixer?

A column "loopback" appeared on my alsamixer panel, so that I don't have any sound even when properly set. Which module should be removed